• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Want to unlock your OMC / Skate? Tutorial here!

720 posts in this topic

Posted

You are correct that if you flash an orange image.bin by TPT you will need to root your phone and install Clockmod again.

Since your OMC is able to connect to another network, I think your OMC is just all right and TPT is not necessary any more. The problem is clear - your OMC could not work with your home router.

Thank you very much for your help xiaoyaoswim. The other phone which works with my home router is a ZTE Skate unbranded - GB_BP_P743V1.0.0B01. Maybe it handles the router differently.

0

Share this post


Link to post
Share on other sites

Posted

I don't particularly want to TPT - not only because I don't know how to but also because I am afraid I will have to go back and start all over with everything again...

I don't know if this is relevant, I am just trying to compare things between a phone which is connected to my router(another ZTE) and the OMC.

The one connected, under WiFi settings, has three sections showing. Turn on WiFi, Network notification, Add WiFi network.

On the OMC, there is an extra section "Add WPS network"

Regarding trying another network, I have just connected to an 'open' (without the lock over its WiFi icon) network. However, I can't connect to my home router.

Does your router have Mac filtering if it Is turned on you will have yo add your phones mac address to the allowed to connect list. Have you also told your phone to forget the network so you have to re-enter your password, or you could turn of protection just to see if you can connect.
0

Share this post


Link to post
Share on other sites

Posted

Thank you very much for your help xiaoyaoswim. The other phone which works with my home router is a ZTE Skate unbranded - GB_BP_P743V1.0.0B01. Maybe it handles the router differently.

Oh, that is really interesting now.rolleyes.gif There is no difference in the hardware between you OMC and ZTE Skate, the reason why your OMC could not work with your router but your Skate could must be that, there is something wrong with the ROM of you OMC. So again I would suggest you TPT your phone. It's very easy to do actually. You just need to download the Orange image.bin from this topic, copy it into the folder of /image of your MicroSD card (You may need to create the image folder ). Switch on your OMC by pressing Volume up + Menu + power at the same time. Once the TPT finishes, you will found everything back to Orange stock - just like a new one out of package, but still unlocked.

0

Share this post


Link to post
Share on other sites

Posted

Oh, that is really interesting now.rolleyes.gif There is no difference in the hardware between you OMC and ZTE Skate, the reason why your OMC could not work with your router but your Skate could must be that, there is something wrong with the ROM of you OMC. So again I would suggest you TPT your phone. It's very easy to do actually. You just need to download the Orange image.bin from this topic, copy it into the folder of /image of your MicroSD card (You may need to create the image folder ). Switch on your OMC by pressing Volume up + Menu + power at the same time. Once the TPT finishes, you will found everything back to Orange stock - just like a new one out of package, but still unlocked.

Thanks again for your help, xiaoyaoswim! I will bookmark your advice and will try this method should I need it because... in the meantime, my WiFi suddenly started to work! :rolleyes: I was trying to look up my location in maps, and got a message that it could not be determined so I opened up Latitude and was prompted to switch on WiFi and for some reason, this time it worked. Should I lose connection again, I will definitely try your suggestion. Thank you for your support.

0

Share this post


Link to post
Share on other sites

Posted

@Itted: Afaik Skate can't work with N protocol. Also you should check the channel(s) your router is working and the channel(s) your Skate is working in.

0

Share this post


Link to post
Share on other sites

Posted

Thanks again for your help, xiaoyaoswim! I will bookmark your advice and will try this method should I need it because... in the meantime, my WiFi suddenly started to work! :rolleyes: I was trying to look up my location in maps, and got a message that it could not be determined so I opened up Latitude and was prompted to switch on WiFi and for some reason, this time it worked. Should I lose connection again, I will definitely try your suggestion. Thank you for your support.

You are welcome. It's a surprise that your wifi suddenly started to workblink.gif but a lovely surprise isn't it?

0

Share this post


Link to post
Share on other sites

Posted

This is Very Helpful Thanx very much indeed :)

XV132 hex editor can be downloaded here.

My link

If you want to try QPST again try this as it was giving me lots of errors and failed to back up until I tried this method.

1 Stock recovery on phone.

2 Boot into FTM and once in that mode put battery back in.

3 Start QPST configuration - in ports tab click add new port and pick the usb one that is your phone - in IP Server tab tick (accept client connections) go to top and select start clients - software download.

4 on new window got to backup tab then browse in line with the drop down list, in new window at bottom filename just type in there backup and at the top were it says save in select somewhere you can find it then click start, once finished.

5 open saved "backup" file with xv132 - file - open (locate file) then click search - find and in hex string type 11 22 33 44 55 66 then ok then search - replace and 11 22 33 44 55 66 should be in the top hex box and put your mac in bottom hex box and click replace all - save.

6 Back with QPST click restore tab browse to file you just edited -select - ok then start.

7 once finished pull out usb cable boot phone.

All the files you need for stock recovery and clockwork mod are in the first post follow every step down to and including 7 then do above then

15 Power on the phone and turn on USB Debugging.

16 OPTIONAL – go to “POST-UNLOCK FOLDER” and run the bat file again – this installs ClockworkMod

0

Share this post


Link to post
Share on other sites

Posted

I unlocked my phone before the mac address fix, and I subsequently went through the tutorial on how to fix this. I had previously changed the MAC address back through ES File Explorer, but as I was experimenting with ROMs, I kept having to use 3G to download ES File Explorer in order to fix the wi-fi, so I decided to follow the tutorial. The trouble is, that although my wi-fi now works (mostly) without problems (except for a very weak signal), whenever I connect to it, it comes up with this message 'your phone doesn't write MAC address, please confirm'.

I have no idea what this means, or what I have to do to fix it, but when I go into ES File Explorer, the MAC address seems fine.

0

Share this post


Link to post
Share on other sites

Posted

I unlocked my phone before the mac address fix, and I subsequently went through the tutorial on how to fix this. I had previously changed the MAC address back through ES File Explorer, but as I was experimenting with ROMs, I kept having to use 3G to download ES File Explorer in order to fix the wi-fi, so I decided to follow the tutorial. The trouble is, that although my wi-fi now works (mostly) without problems (except for a very weak signal), whenever I connect to it, it comes up with this message 'your phone doesn't write MAC address, please confirm'.

I have no idea what this means, or what I have to do to fix it, but when I go into ES File Explorer, the MAC address seems fine.

Do you mean the tutorial on how to fix mac address? If so - wrong thread.

0

Share this post


Link to post
Share on other sites

Posted

Do you mean the tutorial on how to fix mac address? If so - wrong thread.

yes, I do, but it doesn't make that much difference, its basically the same process in a slightly different order. I'll post it in the other thread though.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Just unlocked only one small mistake or was it?? did all the steps as stated when it came to step 13 the phone was not recognized so I just disconnected and it all seemed to work so I thought must have been me however although the phone was unlocked it would not do certain things ie go into recovery to flashing new rom and other things. So I went through the whole procedure again this time when i got to step 13 again said the phone was not recognized so I unplugged it re connected and put it into FTM mode and hey presto away it went. ALL done now new rom on it (bluemonte) so thanks go out to all who put this guide together and the rom maker cheers. Donated cheers

Edited by weaversbrook
0

Share this post


Link to post
Share on other sites

Posted

@D3abL3: My WiFi has suddenly repaired itself but I wanted to thank you also for your input.

0

Share this post


Link to post
Share on other sites

Posted

Just unlocked only one small mistake or was it?? did all the steps as stated when it came to step 13 the phone was not recognized so I just disconnected and it all seemed to work so I thought must have been me however although the phone was unlocked it would not do certain things ie go into recovery to flashing new rom and other things. So I went through the whole procedure again this time when i got to step 13 again said the phone was not recognized so I unplugged it re connected and put it into FTM mode and hey presto away it went. ALL done now new rom on it (bluemonte) so thanks go out to all who put this guide together and the rom maker cheers. Donated cheers

Enjoy your OMC & many thanks for the donation.

0

Share this post


Link to post
Share on other sites

Posted (edited)

fixed

Edited by Reaskawallah
0

Share this post


Link to post
Share on other sites

Posted

Hi i unlocked the OMC but messed up at the qpst backup stage now i have no backup of qcp and now the phone is unlocked but the Widi mac address is wrong and it wont let me connect phone to qpst so i can change it please can you help me. thanks

0

Share this post


Link to post
Share on other sites

Posted

we all make mistakes ,so its our time and effort to sort it.start again.

0

Share this post


Link to post
Share on other sites

Posted

Thanks xiaoyaoswim and tilal6991, successfully unlocked my sister's Monte Carlo tonight following your guide. Went nice and smoothly, and now running BlueMonte.

0

Share this post


Link to post
Share on other sites

Posted

when i try qpst backup my phone just loops comes of ftm

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, thanks for the hard work of all the guys on this unlock.

I've run into a problem. Got all the way to memory restore after the unlock. The download software shows the phone connected on COM5 but when i click restore the phone dissapears (COM5 No phone connected message is displayed) and I get a Memory restore failed message with the error: Could not Communicate in Diagnostic Mode.

The phone goes into an infinite loop of buzzing for a second turning on to the android logo then resetting.

Any help would be really appreciated.

edit: I should add the first time I ran the flash it failed randomly. I ran the flash a second time and it came back successful.

Edited by wadexenon
0

Share this post


Link to post
Share on other sites

Posted

The phone goes into an infinite loop of buzzing for a second turning on to the android logo then resetting.

That indicate you didn't put the phone in FTM mode. Do it, and try to restore qcn file afterwards.

0

Share this post


Link to post
Share on other sites

Posted

That indicate you didn't put the phone in FTM mode. Do it, and try to restore qcn file afterwards.

Thanks for the feedback. I made sure FTM was turned on when i first tried and just tried again to make sure. Getting the same problem still.

Oddly I just threw the battery in and powered up out of interest and the phone is unlocked without the backup restore- I would have thought that was a required element?

I did try to post-unlock clockwork mod install and though it seemed to run smoothly it is nowhere to be seen on the phone.

Should I just try downloading it from the market? Should I expect any problems re not restoring?

Thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted

I did try to post-unlock clockwork mod install and though it seemed to run smoothly it is nowhere to be seen on the phone.

Should I just try downloading it from the market? Should I expect any problems re not restoring?

Clockwork Mod is on the recovery partition you boot into it to backup/restore or install a new ROM.

Best read the Pinned Clockwork Mod thread.

You may have lost you're Wifi Mac address if you didn't get your qcn backed up or restored but there is Pinned Thread on recovering that too.

0

Share this post


Link to post
Share on other sites

Posted

when i try qpst backup my phone just loops comes of ftm

Once in FTM you need to put the Battery back in before you can backup or restore with qpst.

0

Share this post


Link to post
Share on other sites

Posted

Once in FTM you need to put the Battery back in before you can backup or restore with qpst.

Worked unlocked thanks alot rolleyes.gif

0

Share this post


Link to post
Share on other sites

Posted

GREAT JOB. its unlocked to German O2.

But 3G is not working. any ideas??

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.