• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Android 4.0.x on ZTE Racer

269 posts in this topic

Posted (edited) · Report post

ICS on Racer

File deleted because no sense in it, we will wait more than a normal assembly for blade, or who may decide to collect from the source.

For the time being we can discuss their ideas and news, if that appears more or less worthy, let me know, I secured in the first message, that would not create a new topic.

Edited by LordCrash
5

Share this post


Link to post
Share on other sites

Posted · Report post

thnks a lot downloading it atm.....will post complete review tomorrow :rolleyes:

0

Share this post


Link to post
Share on other sites

Posted · Report post

could you give screenshots or a link for screenshots

I can not make a screenshot, as one of the problems - it does not work yet USB flash drive, if the current is on camera ...

0

Share this post


Link to post
Share on other sites

Posted · Report post

guys this is not a completely finished ROM as yet, some work needs to be done LordCrash has kindly uploaded the main ported ROM which does boot with vamshi kernal and deadlinks too...........if anybody would like to help in correcting any problems or identifying problems please feel free to post with feedback

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ill flash and report back any problems (i will make backup first)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

looks like someone beat me to it :P

Edited by equiliym
0

Share this post


Link to post
Share on other sites

Posted · Report post

ahh found you all:D on a mish.

0

Share this post


Link to post
Share on other sites

Posted · Report post

well i can atleast say calibration is waaaaaaaaay off so i cant really get to home screen :D

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

with the calibration of all right, there's just an interesting control - the cursor

Edited by LordCrash
0

Share this post


Link to post
Share on other sites

Posted · Report post

well i can atleast say calibration is waaaaaaaaay off so i cant really get to home screen :D

press on the circle and its fine

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

OK, reporting back :)

I flashed it successfully with deadlink's #186 GEN1 kernel.

Here's a pic:

FiSXN.jpg

The first thing I noticed is that the touchscreen is working as a pointer/cursor, but nevertheless, touchscreen works.

Also the other thing I noticed that does work is vibration.

Also, the whole UI feels really smooth, there is no lag.

Things that don't work: RIL (Phone,3G,Data,SMS...), Wi-Fi, Bluetooth, SDCard, Sound.

Also, many thing such as the dialer, keyboard, settings, locksreen will need resizing, as they don't fit the screen.

LordCrash Thank you for bringing this excellent port, now I'm sure ICS will work perfectly on the Racer very soon :)

EDIT: I got logcat working, if you need anything just ask.

Edited by Krste
1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

press on the circle and its fine

when i press the circle nothing happens, i have to tap all around it for it to go white and do something

edit: nvm

inb4 touch_to_keys make softkeys work, i added it here

this cursor circle thing is really annoying

Edited by equiliym
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for your report, I'll try that tomorrow night, or to correct, today is just a lot of time and sleepy)

1

Share this post


Link to post
Share on other sites

Posted · Report post

OK, reporting back :)

I flashed it successfully with deadlink's #186 GEN1 kernel.

Here's a pic:

FiSXN.jpg

The first thing I noticed is that the touchscreen is working as a pointer/cursor, but nevertheless, touchscreen works.

Also the other thing I noticed that does work is vibration.

Also, the whole UI feels really smooth, there is no lag.

Things that don't work: RIL (Phone,3G,Data,SMS...), Wi-Fi, Bluetooth, SDCard, Sound.

Also, many thing such as the dialer, keyboard, settings, locksreen will need resizing, as they don't fit the screen.

LordCrash Thank you for bringing this excellent port, now I'm sure ICS will work perfectly on the Racer very soon :)

do you know what kernel this comes with please ?:)

0

Share this post


Link to post
Share on other sites

Posted · Report post

do you know what kernel this comes with please ?:)

I doesn't come with any kernel, I took deadlink's kernel from another ROM, renamed to boot.img and put it to the update.zip.

0

Share this post


Link to post
Share on other sites

Posted · Report post

do you know what kernel this comes with please ?:)

without kernel, will boot with vamshi/deadlink

ok so far, i have no signal, didnt try call, with touch_to_key softkeys seems to respond and only button that works is back, red/green button doesnt work but glow and cursor is rather annoying when scrolling left/right D:

0

Share this post


Link to post
Share on other sites

Posted · Report post

I doesn't come with any kernel, I took deadlink's kernel from another ROM, renamed to boot.img and put it to the update.zip.

vamshi`s works too

0

Share this post


Link to post
Share on other sites

Posted · Report post

I doesn't come with any kernel, I took deadlink's kernel from another ROM, renamed to boot.img and put it to the update.zip.

thank you:D, take it, I can just flash as normal and without leaving cwm flash vamshri kernel then boot?

0

Share this post


Link to post
Share on other sites

Posted · Report post

thank you:D, take it, I can just flash as normal and without leaving cwm flash vamshri kernel then boot?

should be ok, if not just place the boot.img file in the root of the isc.zip

0

Share this post


Link to post
Share on other sites

Posted · Report post

im really confused with this, i noticed this is a htc hero port, there are hero libs and other files that should be replaced with racer files and also if possible, a lower res, proper qvga should be more recommended but anything is fine atm i guess

ill try doing stuff to make anything work here and also next week my system and vm should be reinstalled and up for some aosp stuff :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

should be ok, if not just place the boot.img file in the root of the isc.zip

thank you:D

0

Share this post


Link to post
Share on other sites

Posted · Report post

ok checked build.prop, set dencity to 120, now my screen brightnes doesnt work but everything else is fine, speaker doesnt work when playing mp3 from sdcard >.<

fixed sdcard mount on phone, edit /system/etc/vold.fstab

dev_mount sdcard /mnt/sdcard auto /devices/platform/msm_sdcc.1/mmc_host/mmc0

i hope someone besides me is actually doing something to get anything to work on this and will benefit from my replies..

0

Share this post


Link to post
Share on other sites

Posted · Report post

ok checked build.prop, set dencity to 120, now my screen brightnes doesnt work but everything else is fine, speaker doesnt work when playing mp3 from sdcard >.<

fixed sdcard mount on phone, edit /system/etc/vold.fstab

dev_mount sdcard /mnt/sdcard auto /devices/platform/msm_sdcc.1/mmc_host/mmc0

i hope someone besides me is actually doing something to get anything to work on this and will benefit from my replies..

if I could I would , but your ninja master to my wax on wax off. just way beyond my capabilitys...:)

0

Share this post


Link to post
Share on other sites

Posted · Report post

if I could I would , but your ninja master to my wax on wax off. just way beyond my capabilitys...:)

lol dont worry :P im trying my best tho, i might actually get something to work atleast :D

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.