• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[RECOVERY] : ClockworkMod Recovery for ZTE Blade 2

40 posts in this topic

Posted

*MY* build of Koush's ClockworkMod Recovery for the Orange San Francisco II/T-Mobile Vivacity/ZTE Blade2.

I have tested it as much as I can, but I'm always open to any more constructive feedback.

It is not officially supported by Koush, please do not bother him with support questions for this build.

Koush seems not to publish a traditional change log, however you can see the project's commit history for details

[RECOVERY] : ClockworkMod Recovery for ZTE Blade 2

NOTE: Currently the only way to install ClockworkMod Recovery is via the fastboot method, instructions can be found by following the above link.

1

Share this post


Link to post
Share on other sites

Posted

before anyone asks, yes its works on both the San Francisco 2 & the Vivacity.

0

Share this post


Link to post
Share on other sites

Posted

Wow! Well done @Sebastian404! That was mega fast!

0

Share this post


Link to post
Share on other sites

Posted

Outstanding!

0

Share this post


Link to post
Share on other sites

Posted

How do we install this? and root the device? thankyou

0

Share this post


Link to post
Share on other sites

Posted

How do we install this? and root the device? thankyou

I gather its through adb and fastboot.

0

Share this post


Link to post
Share on other sites

Posted (edited)

after running reboot bootloader command the device is aparently not connected :S

"fastboot is not a recognised command" even tho i have fastboot ready in icon tray :S

Edited by raverrr
0

Share this post


Link to post
Share on other sites

Posted

after running reboot bootloader command the device is aparently not connected :S

"fastboot is not a recognised command" even tho i have fastboot ready in icon tray :S

This might be a stupid point, but don't different devices have different fastboots? So if you are trying to use the blade's one it might not work.

But I'm probably wrong.

Got the Zte drivers installed?

Trying to remember the last time I used fastboot...

0

Share this post


Link to post
Share on other sites

Posted

the command is fastboot-windows.exe just thought id add have u read through the rest in sebastians guide thx ian.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I need some help with this -.-

Edited by Bouncer5
0

Share this post


Link to post
Share on other sites

Posted

Seb any chance to increase the screen brightness and enable the capacitive button lights please?

0

Share this post


Link to post
Share on other sites

Posted

Seb any chance to increase the screen brightness and enable the capacitive button lights please?

what's-a-matter? your eyes not working :)

yeah, good point, I'll look into that one :)

EDIT:

LCD Backlight is fixed.. keypad is tricky, seem the kernel source is missing part of the keypad drivers....

0

Share this post


Link to post
Share on other sites

Posted

what's-a-matter? your eyes not working :)

yeah, good point, I'll look into that one :)

EDIT:

LCD Backlight is fixed.. keypad is tricky, seem the kernel source is missing part of the keypad drivers....

Another thing ZTE missed from the source release? They are on a roll! :lol:

0

Share this post


Link to post
Share on other sites

Posted

ok, I've added a couple of fixes, so the screen and keypad are now at maximum brightness..

0

Share this post


Link to post
Share on other sites

Posted

LOL, cheat menu worked - thanks Seb.

Buttons now light up but capacitive keys still dont work, my only guess is myabe my TMV has different firmware or source? (Since I've only had it 2 days).

Cheers

0

Share this post


Link to post
Share on other sites

Posted

Might be better to use a stock Vivacity kernel for recovery as this supports both devices without any issues. The ZTE source is really buggy for blade2 devices :(

I have replaced the kernel with stock vivacity but the volume rocker doesn't work. Everything else does though.. easy fix?

0

Share this post


Link to post
Share on other sites

Posted

LOL, cheat menu worked - thanks Seb.

Buttons now light up but capacitive keys still dont work, my only guess is myabe my TMV has different firmware or source? (Since I've only had it 2 days).

Cheers

Im testing it on my Vivacity primarily over the San Francisco II.... it works fine for me, and others here....

I wonder if they have done the old Blade trick of changing parts, if you dial *983*24474636# what does it say under LCD Information?

San Francisco II

post-764508-0-20540900-1322921774_thumb.

Vivacity

post-764508-0-14494100-1322921763_thumb.

0

Share this post


Link to post
Share on other sites

Posted

Info was...

Truly yorys

Sypnaptics

3000 series

0x22

Synaptic+ tpk

Cheers

0

Share this post


Link to post
Share on other sites

Posted

My Vivacity is Truly screen with atmel touch controller.

Looks like some may have truly screen with synaptics, or even LEAD with atmel controller.

Damn you ZTE.. stop using different parts!

0

Share this post


Link to post
Share on other sites

Posted

Yup, I was reading about zte and Samsung said the only company that bothers them are zte due to fact they make phones so damn cheap, so it's no surprise they fit what they have in stock or what is cheapest at the time.

0

Share this post


Link to post
Share on other sites

Posted (edited)

*MY* build of Koush's ClockworkMod Recovery for the Orange San Francisco II/T-Mobile Vivacity/ZTE Blade2.

I have tested it as much as I can, but I'm always open to any more constructive feedback.

It is not officially supported by Koush, please do not bother him with support questions for this build.

Koush seems not to publish a traditional change log, however you can see the project's commit history for details

[RECOVERY] : ClockworkMod Recovery for ZTE Blade 2

NOTE: Currently the only way to install ClockworkMod Recovery is via the fastboot method, instructions can be found by following the above link.

I have flashed my Vivacity with your CWM recovery however I can't select anything due to only my volume and power button keys working. The cheat menu doesn't make things any better, it just disables the power button.

So I was thinking a solution might be for me to modify the CWM recovery source code so that perhaps the volume down key moves through the menus and the volume up key selects items. I know I can get the sourcecode from koush's Github page and I'm happy to have a go at compiling it myself. I was just wondering what modifications you made to the code to get it to work with the ZTE Crescent? Also do you think this is a crazy idea just to get my phone to work?

Hope you don't mind me asking this, just really keen to get my phone working and at first glance CWM recovery source doesn't look too bad... maybe....

EDIT

I just found your source including the device_handle_key method in recovery_ui.c. I guess I should just be able to change the case KEY_VOLUMEUP to return SELECT_ITEM rather than HIGHLIGHT_UP and it'll do what I'm after? Another question I have is regarding your KEY_SLEEP case, why does the first if statement have {} around the returning function but the second if statement doesn't? I have to say my C is pretty rusty (or non existent) being more of a python / vb.net / fortran (at a push) coder at times.

Anyway, any comment would be great!

Edited by BrideOfTheAtom
0

Share this post


Link to post
Share on other sites

Posted (edited)

Ah I got it working. Think I must have clockwork mod installed in two places, although they look the same. If I let the phone boot normally its the old version that doesn't work. If I hold down the volume down on power on I got into the updated version with bright screen, capacitive buttons and most of all actually working. Hopefully installing rom will work...

It did, everything working nicely and unlocked. Thank you so much for your work on this phone.

Edited by BrideOfTheAtom
0

Share this post


Link to post
Share on other sites

Posted

after running reboot bootloader command the device is aparently not connected :S

"fastboot is not a recognised command" even tho i have fastboot ready in icon tray :S

I'm getting the same message as this ??

Anyone help ?

0

Share this post


Link to post
Share on other sites

Posted

Ah I got it working. Think I must have clockwork mod installed in two places, although they look the same. If I let the phone boot normally its the old version that doesn't work. If I hold down the volume down on power on I got into the updated version with bright screen, capacitive buttons and most of all actually working. Hopefully installing rom will work...

It did, everything working nicely and unlocked. Thank you so much for your work on this phone.

Hi can you still get to clockwork after you have installed your rom by holding down the volume - key? , once my rom was installed i cant get back to clockwork is it possible to have clockwork installed permanently and be able to boot to it on the phone by holding down the volume- after the rom is installed. ?. If this is possible to do can you tell me how it is done.

Thanks.

0

Share this post


Link to post
Share on other sites

Posted

I'm getting the same message as this ??

Anyone help ?

Anyone ???

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.