• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Android 4 on ZTE Racer discussion page

93 posts in this topic

Posted · Report post

It works but the touchscreen driver needs updating since u cant really use the touchscreen with the damn cursor thingy..

no it doesnt lol, it just boots.. no touchscreen, no wifi, no bt, no audio, no ril/phone signal, cant send messages/call, half apk missing.. it doesnt work :P and also is a 4.0.1 alpha

0

Share this post


Link to post
Share on other sites

Posted · Report post

i thought audio was working? or maybe i just confused it with the blade..

0

Share this post


Link to post
Share on other sites

Posted · Report post

so what's the issue actually regarding the cursor thing? we need a new kernel or touchscreen drivers? i tried google and there are many threads about this problem but the dev's did'nt post how they fixed it :( I m praying for a working ics within this year lol.

0

Share this post


Link to post
Share on other sites

Posted · Report post

well i really dont know.. it might be msm_ts issue in kernel.. but then again it might be related to libinput or something.. not even sure if input is related to touchscreen anymore, long time since i checked the sources and i dont have them anymore

0

Share this post


Link to post
Share on other sites

Posted · Report post

well i really dont know.. it might be msm_ts issue in kernel.. but then again it might be related to libinput or something.. not even sure if input is related to touchscreen anymore, long time since i checked the sources and i dont have them anymore

---------------------------

thanks for you! need you pay more time on it,,加油~

0

Share this post


Link to post
Share on other sites

Posted · Report post

well i really dont know.. it might be msm_ts issue in kernel.. but then again it might be related to libinput or something.. not even sure if input is related to touchscreen anymore, long time since i checked the sources and i dont have them anymore

I do know it's got an option to turn off, from within developer options in system settings while in cm9, if that helps .:)

0

Share this post


Link to post
Share on other sites

Posted · Report post

I do know it's got an option to turn off, from within developer options in system settings while in cm9, if that helps .:)

systemui?

0

Share this post


Link to post
Share on other sites

Posted · Report post

systemui?

im currently having a diff project that i will post today/tomorrow but i will check this.. or if anyone have that bootable ics, you can decompile systemui with apktool and check bools

0

Share this post


Link to post
Share on other sites

Posted · Report post

im currently having a diff project that i will post today/tomorrow but i will check this.. or if anyone have that bootable ics, you can decompile systemui with apktool and check bools

me thinking, it comes with a off switch in settings, if pre set to an off value pre flash, it just would not be there.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

i do have a bootable ics :lol: but its way too old i l try to check the systemui..

EDIT : Pls ignore this it's the hero port damn :( just a bit too much eager to help

Edited by massacre^
0

Share this post


Link to post
Share on other sites

Posted · Report post

i do have a bootable ics :lol: but its way too old i l try to check the systemui..

EDIT : Pls ignore this it's the hero port damn :( just a bit too much eager to help

well, racerboy ported something from blade, i dont have that, you could ask him to check it if he isnt busy :P

1

Share this post


Link to post
Share on other sites

Posted · Report post

Hey franzzz i want to install 4.0 on my dell xcd28 is it possible???? if yes then tell me how??

thnxxxx

0

Share this post


Link to post
Share on other sites

Posted · Report post

Pls kindly scroll through the whole thread before asking this questions

No offense but its really very annoying :(

1

Share this post


Link to post
Share on other sites

Posted · Report post

Hi guys,any updates for ics4.0 os on our racer??

0

Share this post


Link to post
Share on other sites

Posted · Report post

may be devs who work on ICS look at codeaurora forum?) many libs,souces and etc. u may find theresmile.gif

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hey developers, can someone please give me the ROM .zip? I know it is unstable and stuff, but i am just experimenting...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Developers, I am sorry to trouble you, but I'd be happy if you would assist me with this issue, I am trying to port a ROM for Racer (ICS) from a Blade one, during bootup i do adb logcat to see how its going, but all i get is Netd 1.0 starting and that continues forever, why?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Developers, I am sorry to trouble you, but I'd be happy if you would assist me with this issue, I am trying to port a ROM for Racer (ICS) from a Blade one, during bootup i do adb logcat to see how its going, but all i get is Netd 1.0 starting and that continues forever, why?

obviously you need a different /bin/netd binary file, try using prebuilt one from different rom /racer/

2

Share this post


Link to post
Share on other sites

Posted · Report post

obviously you need a different /bin/netd binary file, try using prebuilt one from different rom /racer/

Nope, that didnt help too :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Nope, that didnt help too

try this one i attached, i use that one with my 4.0.3 build i was testing, at least it boots but nothing else works lol

netd.zip

1

Share this post


Link to post
Share on other sites

Posted · Report post

What ROM do you guys use as a base, stock one? With all the others i tried, it didnt get past the android logo, now with stock it is just stuck at splash image. Even adb doesn't see it.

0

Share this post


Link to post
Share on other sites

Posted · Report post

i use aosp 4.0.3 and cm9 4.0.4 for my dev tryouts

1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

equiliym, can you push your current device tree to github or upload it somewhere? I don't have much time for the moment, but I'll see what I can do.

As far as I know, we definitely need a more recent kernel. I'd sync CM9, lots more performance options than AOSP 4.0.4.

Edited by FezzFest
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

equiliym, can you push your current device tree to github or upload it somewhere? I don't have much time for the moment, but I'll see what I can do.

As far as I know, we definitely need a more recent kernel. I'd sync CM9, lots more performance options than AOSP 4.0.4.

i dont think thats really needed, i downloaded ics4blade from tom's github so you can download it straight from there since the files are similar somewhat.. as for needed files for building i used cm7 from deadlinks github since he has racer files, i tried to compare and edit so i can properly build ics files based on gb from deadlink but failed badly.. as for kernel, we also have deadlinks source that he edited from tom giordano with added racer /msm7627 mooncake/ files.. vamshi never released his for some odd reason which im favoring but thats just me..

edit: also sorry for not uploading what i already made everyone, i think wooly deleted my account or just raceroms is glitching again so i cant login :( but the rom doesnt work anyway so you aren't missing much

Edited by equiliym
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

i dont think thats really needed, i downloaded ics4blade from tom's github so you can download it straight from there since the files are similar somewhat.. as for needed files for building i used cm7 from deadlinks github since he has racer files, i tried to compare and edit so i can properly build ics files based on gb from deadlink but failed badly.. as for kernel, we also have deadlinks source that he edited from tom giordano with added racer /msm7627 mooncake/ files.. vamshi never released his for some odd reason which im favoring but thats just me..

edit: also sorry for not uploading what i already made everyone, i think wooly deleted my account or just raceroms is glitching again so i cant login but the rom doesnt work anyway so you aren't missing much

I already checked both TomG's and deadlinks github. The Qualcomm MSM GPU drivers require genlock, which is not available in the 2.6.32.9 kernel. If we ever want hardware acceleration in ICS to work, we'll have to port the 2.6.35.7 kernel.

Edited by FezzFest
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.