• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[Recovery] ClockworkMod Recovery 5.0.2.7

18 posts in this topic

Posted · Report post

Hi guys,

I compiled the latest ClockworkMod Recovery 5.0.2.7 for the Blade2. I've tested it and it works fine for me but your mileage may vary.

Download: recovery-clockwork-5.0.2.7-blade2.img 3.54 MB

This was built during my CM7 development so I thought I'd share it with people since it does work.

One very important note! Backups created with the older recovery won't work with the new version and vis-versa since the developer has switched to a tar based recovery. This should result in a better & safer backup and restore with smaller sizes than before.

Flash this exactly the same way Sebastian404 mentions using fastboot.

Changelog:

5.0.0.1 through 5.0.1.0



  • Backups now use tar over yaffs for everything except mtd partitions. Backup speed improved.
  • Backups now preserve the filesystem type at time of backup. Restores will restore the appropriate filesystem type.
  • New color scheme
  • Status bar when backing up working again
  • Backing up of .android_secure working again

    5.0.2.0


    • Bug-fix: root no longer lost on rom restore
    • Unable to find a changelog for 5.0.2.7 right now

      (Sebastian404: If you want me to remove this let me know)

1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

got it done thx! l.

Hi guys,

I compiled the latest ClockworkMod Recovery 5.0.2.7 for the Blade2. I've tested it and it works fine for me but your mileage may vary.

Download: recovery-clockwork-5.0.2.7-blade2.img 3.54 MB

This was built during my CM7 development so I thought I'd share it with people since it does work.

One very important note! Backups created with the older recovery won't work with the new version and vis-versa since the developer has switched to a tar based recovery. This should result in a better & safer backup and restore with smaller sizes than before.

Flash this exactly the same way Sebastian404 mentions using fastboot.

Changelog:

5.0.0.1 through 5.0.1.0

  • Backups now use tar over yaffs for everything except mtd partitions. Backup speed improved.
  • Backups now preserve the filesystem type at time of backup. Restores will restore the appropriate filesystem type.
  • New color scheme
  • Status bar when backing up working again
  • Backing up of .android_secure working again
    5.0.2.0
    • Bug-fix: root no longer lost on rom restore

Unable to find a changelog for 5.0.2.7 right now

(Sebastian404: If you want me to remove this let me know)

Edited by ROMZERO
1

Share this post


Link to post
Share on other sites

Posted · Report post

Nice,

I have avoided going past 4.0.1.5 since I have some issues with the direction Koush has taken with clockwork mod's development.. withholding the source for a number of weeks was one of them.

I sometimes feel the need to write a blog post about it, but then I remember I'm not an emo teenager on live journal ;)

2

Share this post


Link to post
Share on other sites

Posted · Report post

As long as these conditions are met any recovery is ok :

a) base address set properly (i.e so you can do fastboot boot recovery.img)

B) usb storage working from the menu's (pita to work out how to it manually each time).

c) adb working (first time whether from adb reboot recovery or cold boot - all circumstances).

Really given the choice of only one of a recovery or fastboot (Without the limits on size i.e SE's fastboot) I would take fastboot every time.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi guys,

I compiled the latest ClockworkMod Recovery 5.0.2.7 for the Blade2. I've tested it and it works fine for me but your mileage may vary.

Hi flibblesan,

Does this backup the ext partition okay? I think some that Sebastian404 didn't have a hand in wouldn't work.

cheers

0

Share this post


Link to post
Share on other sites

Posted · Report post

waht does mileage may vary mean?

I don't understand...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

waht does mileage may vary mean?

I don't understand...

Roughly speaking its like you want the same car as him, he gets 50mpg and all works well just for him. But you might not because you drive differently. In this case we're talking about phones so it works well for him but you might use it differently so it might not work so well for you. So using the cars example your milage may vary, it may work for some and probably will for others but its not guaranteed. Then again nothing in this life is.....

Edited by Reider59
0

Share this post


Link to post
Share on other sites

Posted · Report post

It basically means it worked fine for him but he's not guaranteeing you'll have the same experience.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Any word on CWM Touch recovery? that would be pretty cool

0

Share this post


Link to post
Share on other sites

Posted · Report post

Just thought id add that using this CWM means that USB mounting or adb/fastboot stops working for me. Using the version provided in most rom guides (v4) i do not have this problem

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi guys,

As a few people have recently had issues in manually installing CWM after installing TWRP recovery etc., I thought it'd be easier if I upload the automated files and link them here. All credits go to flibblesan, Sebastian404, Koush, Google, ZTE and sanfranciscoandroid,co,uk for the files. This is only for Windows.

Two versions are there, first if you're able to boot into Android and enable USB Debugging.

1. Download and extract http://www.mediafire...8rlo4u9eeb1dp6v

2. Check whether USB debug is enabled on phone and drivers installed in Windows

3. Double click clockinstall.bat

4. Phone will reboot into green andy, and CWM will be flashed

5. Phone will reboot back to Android as usual

Second version, if you're not able to boot the phone in any way but can access the bootloader.

1. Download and extract http://www.mediafire...t5pnne4cqxb5gsn

2. Connect the USB cable while in bootloader

3. Let Windows search in Update and locate proper drivers for "Android" (Should be installed then as Google Fastboot Interface or similar in Device Manager)

4. Double click clockinstall-bootloader.bat

5. CWM will be flashed and phone will reboot normally.

Sometimes ADB will not work with the driver that Windows downloads automatically, therefore to be sure it would work, this is the OEM driver from ZTE - http://www.mediafire...6bv2zidmbm26qam

Hope this helps someone! :)

Warning - Do NOT attempt to flash any of the zip files listed above, they are compressed for convenience of packaging the files together only

Edited by BLu3HaZe
1

Share this post


Link to post
Share on other sites

Posted · Report post

Hi guys,

As a few people have recently had issues in manually installing CWM after installing TWRP recovery etc., I thought it'd be easier if I upload the automated files and link them here. All credits go to flibblesan, Sebastian404, Koush, Google, ZTE and sanfranciscoandroid,co,uk for the files. This is only for Windows.

Two versions are there, first if you're able to boot into Android and enable USB Debugging.

1. Download and extract http://www.mediafire...8rlo4u9eeb1dp6v

2. Check whether USB debug is enabled on phone and drivers installed in Windows

3. Double click clockinstall.bat

4. Phone will reboot into green andy, and CWM will be flashed

5. Phone will reboot back to Android as usual

Second version, if you're not able to boot the phone in any way but can access the bootloader.

1. Download and extract http://www.mediafire...t5pnne4cqxb5gsn

2. Connect the USB cable while in bootloader

3. Let Windows search in Update and locate proper drivers for "Android" (Should be installed then as Google Fastboot Interface or similar in Device Manager)

4. Double click clockinstall-bootloader.bat

5. CWM will be flashed and phone will reboot normally.

Sometimes ADB will not work with the driver that Windows downloads automatically, therefore to be sure it would work, this is the OEM driver from ZTE - http://www.mediafire...6bv2zidmbm26qam

Hope this helps someone!

Warning - Do NOT attempt to flash any of the zip files listed above, they are compressed for convenience of packaging the files together only

When I last installed CWM 5, when trying to mount the SD card the application gave an error and did not work. I doubt this is related to the driver used on the computer since it also errors when you mount the SD card when not connected to the USB cable.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is there a way of remotely restoring a nandroid backup (without using CWM)? If so, how? If not, can you completely wipe the internal mem. of the phone remotely?

(Cryptic, I know)

0

Share this post


Link to post
Share on other sites

Posted · Report post

what is the latest version of clockworkmod recovery available for the crescent?

0

Share this post


Link to post
Share on other sites

Posted · Report post

This is the newest version which someone's made into a flashable zip on this forum. Don't really know why you'd want a more recent version, it's CWM, it does what it needs to do.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

This is the newest version which someone's made into a flashable zip on this forum. Don't really know why you'd want a more recent version, it's CWM, it does what it needs to do.

I was just looking at Dazzozo's Cwm for the G300 and these are the fixes that come with the latest 6.0.1.8 Cmw over the other CWM builds

  • Better backup options
  • ADB sideload
  • Charge mode
  • Mass storage (mounts both cards)
  • Symlink errors and issues with system mounts fixed (hard to prove something is truly gone, but not seen since a potential fix)

Edited by reedo_17
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Works for me, and thanks fibblesan. Many thanks indeed.

I had been struggling for three days to get CWM back into my system, it got lost somehow when I flashed CM9.

Following the guide here (in WindowsXP!):

http://forum.xda-dev...=1608042&page=1

I came to the command

su

and got the response

permission denied

Well, the penny dropped then. I am running CyanogenMod9 IceCreamSandwich. Under Settings: Developer options: there is an entry "Root access". This was set to "Apps only" and that was the cause of my problems. I didn't have su rights to the system. Simply changed in there to "Apps and ADB" and suddenly everything works. smile.gif

Maybe this feature was added in ICS, and wasn't there in Gingerbread? Could be the reason others using CM9 have been having trouble.

One other observation. My first attempt at a backup, I selected the backup/restore and then pressed the power button (as in the earlier CWM) This just brought me to the RomManager logo. I later discovered that the software button DO work, and menu brought me back, Home selects the option. Maybe I need a user guide?

Thanks again!

Edited by momist
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hello!

 

Is it just me, or this recovery doesn't partition the SD Card?

 

I've tried to do it, it says it's done, but it's not.

 

Can anyone confirm me this, please?

 

----EDIT----

 

Forget it. It works.

Edited by Typhus_
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.