goatee

CM7 "Sleep of Death" Fixed??

7 posts in this topic

So, taking a look at the changes since Nightly 204 (http://cm-nightlies.appspot.com/?device=p990), I see that one of the changes is to "Prevent sleep of death caused by framework NPE" (http://review.cyanogenmod.com/10364) - I don't get lots of BSODs with CM7, but it will be good to see if this fixes it - just installed Temasek's kang build (http://www.mediafire.com/temasek), which should include this. I guess I'll find out at some point!

0

Share this post


Link to post
Share on other sites

Yeah, this is fixed quite a while ago, but sensor usage by some apps in standby which drains battery fast(er) is sadly not fixed yet.

0

Share this post


Link to post
Share on other sites

Yeah, last night was really odd - when I went to bed, my phone had gone down 15% after 4.5 hours of normal usage, which was fine, but then this morning when I woke up (9 hours later), the battery was totally dead, and as you can see - the battery usage shows me something was keeping it awake - even though it had behaved normally up to that point.

Yeah, this is fixed quite a while ago, but sensor usage by some apps in standby which drains battery fast(er) is sadly not fixed yet.

post-120880-0-92823900-1324469454_thumb.

0

Share this post


Link to post
Share on other sites

Yep, caused by some Apps hogging g-sensor in standby. It is such a shame! CM7.2 is perfect if only they could fix this bug! But most likely they don't, because only a few peoples left for developing on CM7, others are on CM9.

Edited by Macheath
0

Share this post


Link to post
Share on other sites

Yay, the fix seems to work - see my new screenshot from last night :). The phone wasn't awake all night, and the battery life is excellent :D.

post-120880-0-14007400-1324547375_thumb.

0

Share this post


Link to post
Share on other sites

I have already answered you in xda forum. :P

There is no commit regarding this issue till now. So this is a placebo and/or random.

To prove that, you should post screenshots from spare parts category 'sensor usage '. These here are useless

Edited by Macheath
0

Share this post


Link to post
Share on other sites

lol, appears issue still exists, but much kinder on my battery, so I'm happy :D.

I have already answered you in xda forum. :P

There is no commit regarding this issue till now. So this is a placebo and/or random.

To prove that, you should post screenshots from spare parts category 'sensor usage '. These here are useless

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.