• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

read only file system for internal memory

6 posts in this topic

Posted (edited)

So I'm trying to get ssh keys to work on this thing, and I've installed BTEP as my ssh client, but unfortunately when I run ssh it looks for keys in the folder ./.ssh whereas my keys are saved in the folder /data/data/com.magicandroidapps.bettertermpro/home/.ssh/, since ~ on the terminal points to that folder

The folder ./.ssh doesn't exist, and when I try to create it and copy my keys over, I just get a read only file system error.

How do you go about removing the read only file system thing on this device?

Edited by feuxfollets
0

Share this post


Link to post
Share on other sites

Posted (edited)

Well you could dick about with mount commands but personally I prefer to just use Root Explorer which has a couple of little toggle buttons for R/O & R/W

Edited by Andy_E
0

Share this post


Link to post
Share on other sites

Posted

Well you could dick about with mount commands but personally I prefer to just use Root Explorer which has a couple of little toggle buttons for R/O & R/W

I also use Root Explorer to mount system as r/w but it isn't free. A free alternative is to install Busybox and then use a terminal to do a sudo mount.

0

Share this post


Link to post
Share on other sites

Posted

A free alternative is to install Busybox and then use a terminal to do a sudo mount.

That was the dicking about with mount commands I was referring to..... :)

0

Share this post


Link to post
Share on other sites

Posted

So I'm trying to get ssh keys to work on this thing, and I've installed BTEP as my ssh client, but unfortunately when I run ssh it looks for keys in the folder ./.ssh whereas my keys are saved in the folder /data/data/com.magicandroidapps.bettertermpro/home/.ssh/, since ~ on the terminal points to that folder

The folder ./.ssh doesn't exist, and when I try to create it and copy my keys over, I just get a read only file system error.

How do you go about removing the read only file system thing on this device?

You need to extract the boot.img from whatever rom you are using, make the changes, create a new ramdisk, make a new boot.img then update the rom again with it ... / lives on the ro boot partition.

Not possible to relocate the location of the .ssh directory ?

0

Share this post


Link to post
Share on other sites

Posted (edited)

You need to extract the boot.img from whatever rom you are using, make the changes, create a new ramdisk, make a new boot.img then update the rom again with it ... / lives on the ro boot partition.

Not possible to relocate the location of the .ssh directory ?

So I got the root file manager since it seemed useful, and made a .ssh folder in /

Unfortunately that didn't solve the problem.

On linux you can change the .ssh folder by editing a setting in the /etc/ssh/ssh_config or something like that, but such a file does not exist on my android device. The /etc/ssh folder doesn't even exist.

Edited by feuxfollets
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.