jm888

Does compass function work for anyone?

34 posts in this topic

maybe those "mountains" of burnt out cars where you live give magnetic interfearance or the sky aint clear enough :lol: ( i joke) sry m8 had too

BUT Seriously I`m baffled aswell, another one of lifes little mysteries

:lol: no offence taken :D

0

Share this post


Link to post
Share on other sites

for me it works good for all roms really...

but worked best with equilym's sense like 2.2

its about 50 degree or less off the mark...

0

Share this post


Link to post
Share on other sites

ok i compared some older 2.3 roms and my 2.2 rom for sensors and stuff, i dont have latest cm7 nightly but there appears to be missing permissions xmls like:

android.hardware.sensor.accelerometer.xml < missing in 2.3

android.hardware.sensor.compass.xml < missing in 2.3

android.hardware.sensor.light.xml.xml < dunno if this should be like this but was the same in 2.2

also missing sensors.mooncake.so here and there, dunno whats the thing with this..

0

Share this post


Link to post
Share on other sites

After having read this topic, I tried my phone and...s***!!! My phone has the same problem!!! The compass points east/west instead of north/south lol

0

Share this post


Link to post
Share on other sites

is it possible to use these missing files from 2.2, to a 2.3 rom? or would 2.3 equivalent files need to be sourced? that is if 2.3 would still require them. we've learnt with ics the way Google move things about and in a different way :)

0

Share this post


Link to post
Share on other sites

i think those xml's can be used from 2.2 since they are very simple things, see example:


<permissions>

	<feature name="android.hardware.sensor.light" />

</permissions>

etc etc, i dont think it has THAT much difference with 2.3 :P however on mostly all 2.3 roms, even the stable ones and all, in ddms there are sensor errors, im currently using an older nightly of 2.3.4 but even this rom has some sensor errors
01-15 00:20:17.516: E/Sensors(215): sensors_control_activate active=00000000 sensor=00000002 new_sensors=2 changed=2

so my guess it that racer sensors for 2.3 were never coded properly :o doesnt mean im right tho (and my error is totally unrelated since im using i think #113 cm7 rom)

0

Share this post


Link to post
Share on other sites

we will have to offset by 90° :lol:

let's hope we never get lost on a desert island with no phone charger :D

0

Share this post


Link to post
Share on other sites

sorry guys im just really busy nowadays.. i checked deadlinks github since i used some of his sources for my newest stable cm7 rom and saw that even his sensor libs arent perfect, you can see his commit: initial commit: Maybe something not good, but rom booted

0

Share this post


Link to post
Share on other sites

sorry guys im just really busy nowadays.. i checked deadlinks github since i used some of his sources for my newest stable cm7 rom and saw that even his sensor libs arent perfect, you can see his commit: initial commit: Maybe something not good, but rom booted

thanks for trying :) :P

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.