• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ROM][beta]CyanogenMod 9

682 posts in this topic

Posted · Report post

New MT is in the mail, I'm compiling a vanilla kernel as we speak. Will begin trying to fix issues when it's done.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm compiling a vanilla kernel

why not to just pick the one we achieved?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Alright, so after getting lens kernel to compile properly, i began looking into the IOCTL issues and realized how in over my head I am. I've never done kernel work on this scale before and am entirely sure that I need more experience before I can attempt something like this. Sorry everyone.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sad to hear, but this is not a big surprise as this community is dying.

Metal devs are at their maximum of their capabilities, or did the unrepairable for us. I think that the only things to do now are to be happy with the pretty roms we have, thanks everybody for their work, stop metal losses, and thinking about finding a replacement for this little but strong Liquid Metal that i've been using for nearly two years now, and will continue to serve me for months.

Thank you all

0

Share this post


Link to post
Share on other sites

Posted · Report post

any news !?! everything is already died !?!?

0

Share this post


Link to post
Share on other sites

Posted · Report post

any news !?! everything is already died !?!?
Well, lens bricked his phone, soundemonchan was well over his head and unbr8ckable left without a trace (from what I can tell)
0

Share this post


Link to post
Share on other sites

Posted · Report post

Well, need buy a china-smartphone :D Medium THL W3+ or big Zopo Leader ZP900, for ex. ;) (220-240$, ICS, 2 core, 1Gb RAM, 5,3" IPS qHD). If it is broken -> then trash it and buy new, with 4.1 JB. :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm sorry everyone, I realize I was kind of the last hope for the community.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

omg, I'm costricted to resell my unpowered phone :(

Edited by met4ller87
0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm now using the CM9. (I'm impressed: D)

I reflected on a test that you could do:

for the mobile data and the camera the problem is poprietarie libs. Why not try to use the libraries (camera and rild) of GLOW? (The camera is the same!).

It seems silly, but in the end it is a method that has worked for many porting.

I remember that someone had posted the link to the ZIP of ICS for GLOW. Who help me? :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

for the mobile data and the camera the problem is poprietarie libs. Why not try to use the libraries (camera and rild) of GLOW? (The camera is the same!).

not agree about rild. It is common for all devices using ics. It would be better to try libril-acer-1.so(if it's still there). anyway they require baseband from glow too.

About camera, do whatever you want but least error you will see is "couldn't connect to camera", near no chance there.

It seems silly, but in the end it is a method that has worked for many porting.

yeap, to port sense from desire HD to desire Z both with msm7x30 onboard..

trust me, there should be REALLY NEAR hardware like iconia smart - liquid MT(eheehe if first got official ics...).

You'd better seen on kernel to fix native_start_video ioctl.

0

Share this post


Link to post
Share on other sites

Posted · Report post

The hardware of Metal camera is this:


config S5K4E1GX

bool "Sensor s5k4e1gx (Samsung 5M)"

depends on MSM_CAMERA

default n

---help---

   Samsung 5M with Autofocus

Now if the kernel driver is correct now search a ICS version when camera work fine and with same hardware. (now I try with ICS for Desire Z).

if this method don't works, the problem may be S5K4E1GX.c or S5K4E1GX.h on kernel.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Now if the kernel driver is correct now search a ICS version when camera work fine and with same hardware. (now I try with ICS for Desire Z).

tried desire z version already, it has the same bug with native_start_video, so most likely it's a kernel bug.

if this method don't works, the problem may be S5K4E1GX.c or S5K4E1GX.h on kernel.

all that ever touched camera in kernel modified VFE source in the same folder.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm happy that mabye lens' work won't be "useless"

0

Share this post


Link to post
Share on other sites

Posted · Report post

tried desire z version already, it has the same bug with native_start_video, so most likely it's a kernel bug.

all that ever touched camera in kernel modified VFE source in the same folder.

...mmm ok. I replace the libs (camera.msm7x30 camera.glod... libcamera and liboemcamera) from http://forum.xda-developers.com/showthread.php?t=1349864 and now in logCat :


08-19 13:10:05.857: E/HAL(112): load: module=/system/lib/hw/camera.msm7x30.so

08-19 13:10:05.857: E/HAL(112): Cannot load library: link_image[1965]:   112 could not load needed library 'libcamera.so' for 'camera.msm7x30.so' (reloc_library[1314]:   112 cannot locate '_ZN7android7Overlay5setFdEi'...

08-19 13:10:05.857: E/HAL(112): )

ps

more phone with CM9/ICS use the media_profile.xml..

0

Share this post


Link to post
Share on other sites

Posted · Report post

I replace the libs (camera.msm7x30 camera.glod... libcamera and liboemcamera) from http://forum.xda-dev...d.php?t=1349864 and now in logCat :

08-19 13:10:05.857: E/HAL(112): load: module=/system/lib/hw/camera.msm7x30.so

08-19 13:10:05.857: E/HAL(112): Cannot load library: link_image[1965]: 112 could not load needed library 'libcamera.so' for 'camera.msm7x30.so' (reloc_library[1314]: 112 cannot locate '_ZN7android7Overlay5setFdEi'...

08-19 13:10:05.857: E/HAL(112): )

you need compiled overlay module to make it work.

more phone with CM9/ICS use the media_profile.xml..

so? My cm too..

0

Share this post


Link to post
Share on other sites

Posted · Report post

so? My cm too..

lol, I had not seen :D .

Changing also all libs reach the same error (native_start_video: ioctl failed. ioctl return value is -1). I think the problem are the drivers of the camera or worse video driver... Now I keep CM9 a few days and I continue to do tests.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

lol, I had not seen :D .

Changing also all libs reach the same error (native_start_video: ioctl failed. ioctl return value is -1). I think the problem are the drivers of the camera or worse video driver... Now I keep CM9 a few days and I continue to do tests.

Could you use the Acer Glow camera driver?

Try it, maybe could work…

…and same for Data…

Edited by Don Tsnm
0

Share this post


Link to post
Share on other sites

Posted · Report post

Don Tsnm

Acer Glow is a completely different device. driver in any way can not come up.

Sorry for my bad English.

0

Share this post


Link to post
Share on other sites

Posted · Report post

there are some little hopes for our metal, now that you are looking for this rom??

0

Share this post


Link to post
Share on other sites

Posted · Report post

Don Tsnm

Acer Glow is a completely different device. driver in any way can not come up.

Sorry for my bad English.

true, but camera and probably RILD is the same.

0

Share this post


Link to post
Share on other sites

Posted · Report post

true, but camera and probably RILD is the same.

If we use these drivers, maybe could revive our phone on ICS!

I will continue dreaming… :P

0

Share this post


Link to post
Share on other sites

Posted · Report post

RILD is the same.

you know, even chinese phone (iphone clones ones) have the same rild :D

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, I'm new in this forum (even if it is a long time since I follow it)!

In the last month or so I tried this fantastic ROM, and I have to do all my compliments to Lens for his great work!

I posted mainly to show the things I've seen not working (besides the camera and data connectionit) to be helpful to those who will continue the work! Mainly, for me, is serious the lack of a complete support of flash! To explain, when I play a video with the flash player, you can only hear the are, but not see! plus the sound crackles a little both with flash and with HTML5! Last thing a little more revealing is that sometimes the letters in the font are replaced by symbols (with a reboot but you can easily fix )!

Last little issue I've seen is concerning the speed of read / write the SD, that I change to 2048kb and each time you reboot back to 4096kb even if I tick "apply on boot"!

That's it, I hope I have not done anything inappropriate! I renew my congratulations to Lens and all those who have tried and will try to finish the job!

0

Share this post


Link to post
Share on other sites

Posted · Report post

lack of a complete support of flash!

install normal flash player then.

when I play a video with the flash player, you can only hear the are, but not see

sure that site also works on stock?

plus the sound crackles a little both with flash and with HTML5!

feel the speaker native power :D

Last thing a little more revealing is that sometimes the letters in the font are replaced by symbols

are you using RTL? For me nothing to do with symbols, they worked.

2048kb and each time you reboot back to 4096kb even if I tick "apply on boot"!

have you ever heared about compatibility?

4096 worte in ramdisk(boot script) and might affect your program which in some cases work only before my script.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.