• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ROM][beta]CyanogenMod 9

682 posts in this topic

Posted

Please somebody may post working gapps. I like this rom and don't care about mobile data and camera

0

Share this post


Link to post
Share on other sites

Posted

hi all, I wanna try this rom but when I tap the pin code it appears the message "incorrect pin" (obviously I tap the correct numbers)......how can I solve this? Is this a cm9 bug?

0

Share this post


Link to post
Share on other sites

Posted

when I tap the pin code it appears the message "incorrect pin" (obviously I tap the correct numbers)......how can I solve this? Is this a cm9 bug?

common cm bug for our device, not solved still, and won't be seems. Just disable pin code on stock rom.

0

Share this post


Link to post
Share on other sites

Posted

Thanks for your reply Lens

0

Share this post


Link to post
Share on other sites

Posted (edited)

CM9 ROM for the Acer Liquid Metal, here it is: http://www.mediafire...jkzcabc0j1sa8fk

And here is the flashable GAPPS (modified so it will install everything, even Google Play): http://www.mediafire...yad55f22n530pq5

I installed GAPPS but still no playstore.

Please anyone can help me?

I don't use mobile data and the camera so this rom is perfect for me!

thanks

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted (edited)

I installed GAPPS but still no playstore.

Please anyone can help me?

I don't use mobile data and the camera so this rom is perfect for me!

thanks

First the problem is caused due insufficient space in the system partition ,

Solution

first install only rom and reboot then install root explorer or any root file manager of your choice open /system/media delete the videos folder also delete any ringtones which you don't use. Then open /system/app delete all the unneeded apps like rom manager, email ,exchange ,camera etc

now extract the gapps and compare their size with the free space in /system partition

The free space in the system partition must be greater than that of gapps (you can also delete some gapps if you want)

If you have deleted some gapps create a new zip

Now reboot into recovery and flash the gapps

Edited by liquid metal newbie
0

Share this post


Link to post
Share on other sites

Posted

First the problem is caused due insufficient space in the system partition ,

Solution

first install only rom and reboot then install root explorer or any root file manager of your choice open /system/media delete the videos folder also delete any ringtones which you don't use. Then open /system/app delete all the unneeded apps like rom manager, email ,exchange ,camera etc

now extract the gapps and compare their size with the free space in /system partition

The free space in the system partition must be greater than that of gapps (you can also delete some gapps if you want)

If you have deleted some gapps create a new zip

Now reboot into recovery and flash the gapps

Thanks for the info!

I don't think it's a problem with space because I installed all gapps found in this thread (10mb, 23 mb, 27 mb) but still no playstore (only youtube gets installed).

How can I install root explorer without a file manager?

0

Share this post


Link to post
Share on other sites

Posted

I don't think it's a problem with space because I installed all gapps found in this thread (10mb, 23 mb, 27 mb) but still no playstore (only youtube gets installed).

definitely insufficient storage space. it should be lesser than 200mb.

0

Share this post


Link to post
Share on other sites

Posted (edited)

definitely insufficient storage space. it should be lesser than 200mb.

So neither the 10mb GAPPS is enough?

I need only playstore, if I add "MarketUpdater.apk" in the cm9 zip (system/app) and I install rom again should it work?

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted

So neither the 10mb GAPPS is enough?

I need only playstore, if I add "MarketUpdater.apk" in the cm9 zip (system/app) and I install rom again should it work?

market is now named phonesky.apk. Also, it has dependencies like google services framework etc.
0

Share this post


Link to post
Share on other sites

Posted (edited)

So any pratical advice to make it working?

It's a shame you made such hard work to port cm9 and neither the ones that are happy with no data connection can use it :)

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted

any pratical advice to make it working?

there already said you need to cleanup system folder and set full gapps. You should have less than 200mb in system. Also cache storage should be enough to host all that apps.
0

Share this post


Link to post
Share on other sites

Posted (edited)

there already said you need to cleanup system folder and set full gapps. You should have less than 200mb in system. Also cache storage should be enough to host all that apps.

thanks, but can I do it directly from the cm9 zip and then install rom and full gapps?

I haven't found a file manager already installed in cm9 so I don't know how to install root explorer.

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted

can I do it directly in the cm9 zip and then install rom and gapps?

yeap, system/app folder is right in your zip. But don't merge gapps and main zip, it usually causes more bugs.
0

Share this post


Link to post
Share on other sites

Posted

Thanks a lot, now it works! :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

"-untick mobile data at first boot and reboot!(if you don't want to control it anytime, flash that zip, it will kill also a SIM card support)"

I have to do it only the first time I install cm9, right?

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted

I have to do it only the first time I install cm9, right?
sure. And each wipe of course.
0

Share this post


Link to post
Share on other sites

Posted (edited)

I tried this rom for a few hours and it's awesome! speed and boot time are great compared to stock.

But I found my phone shut down 2 times when it was inactive, there must be some bugs.

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted

But I found my phone shut down 2 times when it was inactive, there must be some bugs.
you have unique phone seems.. try to remember what have you done just before sending it to sleep?
0

Share this post


Link to post
Share on other sites

Posted

Does I use data using this rom???

0

Share this post


Link to post
Share on other sites

Posted

Does I use data using this rom???
no it is still not working.
0

Share this post


Link to post
Share on other sites

Posted (edited)

you have unique phone seems.. try to remember what have you done just before sending it to sleep?

I rememeber I was downloading dead trigger from play store with screen off.

In the last 2 days however I'm not having random shut down. :)

Maybe it was a problem with battery because after the first charge don't have it anymore.

Edited by Carter07
0

Share this post


Link to post
Share on other sites

Posted

I rememeber I was downloading dead trigger from play store with screen off.
uhm looks like wifi deep sleep issue, which is common for some chips those drivers were upgraded to ics without changing kernel driver. For sure I can't fix such behaviour..
0

Share this post


Link to post
Share on other sites

Posted

Latest source for CM9 just got uploaded to my tree (for now only device tree, not kernel which has some little corrections).

Now everybody could compile latest source and get flashable archive as well as the newest cwm recovery(well, for ics, we're not talking about jb ones which are for sure newer).

I rejected my fixes on camera part (were totally wrong :P), and managed to get netmgrd to run.

So, camera and data STILL NOT WORKING, the only issue seems remained in kernel part.

That source should have been uploaded last summer, but something went totally wrong so I haven't released them until now.

Let me also update issues list somebody needs to fix up:

  • couldn't mmap handle on the client[/CODE]

    - actually the last thing I got from huawei library which points to kernel/system allocator - pmem device; it might be little wrong, incomplete or so, so that somebody need a way to debug it first.

  • netmgrd is actually running, framework gives to libril right parameters, it passes them to netmgrd - then boom - and netmgrd hungs on waiting answer, so whole telephony chain got ruined on that point; I bet netmgrd awaits something from kernel, but kernel can't answer back; If one could find what's actually wrong here - he will get data to work.

Also I could offer one deal with gingerbread CM7 source. If somebody could get one of the bunch opensource libraries on CM7 to work (at the same time getting rid of the acer proprietary crap) we could wrap it then to CM9 routines and finally get camera to work. It seems easier than trying to find trouble in kernel (which has perfect camera driver, thx acer!).

PS:

I'm not going to back, but I'm still here to help anybody that could take this project over.

1

Share this post


Link to post
Share on other sites

Posted

kernel changes are also commited now.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.