• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Viber from Speakers

45 posts in this topic

Posted (edited)

A part of our presence in forums (especially tech forums like MoDaCo) is not only to hear compliments, but also hear complaints and criticism. So - don't worry, we fully understand and appreciate your anticipation to use Viber normally, and we are always glad to hear or users.

I encourage all the users with the ZTE Blade speaker problem to open a support ticket through the direct link I provided in one of my last posts.

One last quick note to our users who already opened a support ticket - we tried replicating the problem in our labs, and for now we didn't manage to do so. The more information you give to our support team, the faster they will be able find the source of the problem. They might also ask for your help by sending a debug version, but that's only in advanced stages.

Thank you in advance :)

Edited by Viber
0

Share this post


Link to post
Share on other sites

Posted

I´ve open a ticket with Viber since Viber was still in Beta.

Still no good news!

Abraço

Pedro

0

Share this post


Link to post
Share on other sites

Posted (edited)

One last quick note to our users who already opened a support ticket - we tried replicating the problem in our labs, and for now we didn't manage to do so. The more information you give to our support team, the faster they will be able find the source of the problem. They might also ask for your help by sending a debug version, but that's only in advanced stages.

If you have a Blade, then you'll surely experience the problem in any case. Audio seems to work correctly only with CyanogenMod7 ROM.

Edited by fox2000
0

Share this post


Link to post
Share on other sites

Posted

As I'm writing to you these very words, I am testing ZTE Blade ("ZTE U V880") and all is working fine.

For those of you with the speaker problem and also without it (so we can compare) - please specify the *exact* device type and model that you have, and also the exact version of Android and/or Custom ROM that you're running.

Thank you in advance.

0

Share this post


Link to post
Share on other sites

Posted

As I'm writing to you these very words, I am testing ZTE Blade ("ZTE U V880") and all is working fine.

For those of you with the speaker problem and also without it (so we can compare) - please specify the *exact* device type and model that you have, and also the exact version of Android and/or Custom ROM that you're running.

Thank you in advance.

I´m using ZTE Libra, running Swidish Snow RLS5 (2.3.5)

If you need any more specific information, please tell me, no problem.

Abraço

Pedro

0

Share this post


Link to post
Share on other sites

Posted

Please note that:

1. What we have here in our labs and tested on was ZTE Blade, not Libra. There could be a totally different problem on Libra :(

2. Since you're also running a Custom ROM, this could be another source of the problem.

In other words - we need both that specific device and the Custom ROM in order to find the source of the problem, and that may take a while :(

0

Share this post


Link to post
Share on other sites

Posted

Please note that:

1. What we have here in our labs and tested on was ZTE Blade, not Libra. There could be a totally different problem on Libra :(

2. Since you're also running a Custom ROM, this could be another source of the problem.

In other words - we need both that specific device and the Custom ROM in order to find the source of the problem, and that may take a while :(

ZTE Blade or Libra share de sama hardware. The diference is the camera and cosmetics.

I´ve tried Viber with de original ROM (the one that came with the device and the update (2.1 and 2.2, from TMN - Mobile operator in Portugal) and the problem with Viber was the same.

I´ve tried also the Blade version (Optimus San Francisco, from mobile operator Optimus, from Portugal) and the problem was the same.

If you haven't noticed, everybody's got a problem with Viber, except the ones running CM7 based Roms. So, even the original Rom, for the ones who don't want to change to a custom rom have the same problem.

Abraço

Pedro

0

Share this post


Link to post
Share on other sites

Posted

Thank you for the info.

With this elaborate information that you've just given me, please open a new support ticket using the link I gave previously in this thread. All this information could be valuable for our testings and will hopefully help us find the source of the problem.

0

Share this post


Link to post
Share on other sites

Posted

not all cm7 based roms work. I am using Lewa and it has this problem.

Can anyone point out the cm7 commit which fixed this problem as I would imagine this would be the ultimate solution for Viber.

here is a large discussion about it with logs and solutions.

code.google.com/p/cyanogenmod/issues/detail?id=2858

0

Share this post


Link to post
Share on other sites

Posted

I'm Now using cm9 coldfusionx, and Viber works like it should.

Abraço

Pedro

0

Share this post


Link to post
Share on other sites

Posted

I'm Now using cm9 coldfusionx, and Viber works like it should.

Abraço

Pedro

That's great news!

Are you using the same device, only a different version of ROM?

Have other users (who had the same problems as you) tried it and had success as well?

0

Share this post


Link to post
Share on other sites

Posted

That's great news!

Are you using the same device, only a different version of ROM?

Yes, same device (ZTE Libra aka Sapo A5 in Portugal).

Abraço

Pedro

0

Share this post


Link to post
Share on other sites

Posted

This IS real support. Thumbs up Viber!

0

Share this post


Link to post
Share on other sites

Posted

That's great news!

Are you using the same device, only a different version of ROM?

Have other users (who had the same problems as you) tried it and had success as well?

Someone already pointed out that CyanogenMod (7 or 9 doesn't matter) changed the audio routing to make VoIP softwares usable. BUT if you are using the stock ROM (or a modified one based on the stock one like Swedish Snow), well...

In some countries if you've changed the software on your Blade you've also lost your warranty. So you are forced to stay with it. Changing ROM is not an option for these users.

I promised that I will inform you about any changes with Viber on my phone. Well, nothing changed.

0

Share this post


Link to post
Share on other sites

Posted

Someone already pointed out that CyanogenMod (7 or 9 doesn't matter) changed the audio routing to make VoIP softwares usable. BUT if you are using the stock ROM (or a modified one based on the stock one like Swedish Snow), well...

In some countries if you've changed the software on your Blade you've also lost your warranty. So you are forced to stay with it. Changing ROM is not an option for these users.

I promised that I will inform you about any changes with Viber on my phone. Well, nothing changed.

As I explained before, note that Viber does not officially support ZTE Blade yet. I imagine you already opened a support ticket, as I instructed previously, and if that is the case then our support team will take a look at the problems and try to investigate its source.

0

Share this post


Link to post
Share on other sites

Posted

i just wanted to say that on your second point about download data what you need to take in to concideration is that on a lot of the custom roms what the market thinks the phone is and what the phone is are 2 very diffrent things cuz if i remember most of the roms make the market think its a htc if i remember correctly and the zte blade has a massive following on custom roms so most of the data collected would be untrue and inacurate im not digging at anyone im just saying

its a good app its a shame it dont work properly on our blades

OK, my responses to your above posts:

1. First and foremost - we have real representatives of our development team here on MoDaCo (like me, for example). If you think this is an automated message (for some reason) - I invite you to visit other, very technical forums and see our representation there as well - like XDA, Android.com, etc.

Moreover - we believe that we are one of the only app developing companies in the world today (if not the only one) who actually proactively searches for forums and users discussing Viber and offers support, and cares enough to hear the users and make changes to the app accordingly.

2. Information about ZTE Blade that's published could be biased in order to achieve certain goals. Let's assume that's not even the case in the article you linked to - we can tell you for sure that in both Market's statistics and our own statistics, the percentage of ZTE Blade users who downloaded and installed Viber is tiny, compared to other devices. As a company, we cannot ignore those stats, and we must prioritize our limited resources by the commonness based on statistics.

3. Let's try to be constructive here. Here is a link to a form dedicated to forum users who are having technical issues: SMRT ticket

Please report your problem so we have the information logged and our lab team can test it hopefully soon. Again - we can't promise it would be solved immediately (nor are problems with Galaxy S, for that matter) - but we will do our best, as explained above.

Regards,

the Viber Team.

1

Share this post


Link to post
Share on other sites

Posted

i just wanted to say that on your second point about download data what you need to take in to concideration is that on a lot of the custom roms what the market thinks the phone is and what the phone is are 2 very diffrent things cuz if i remember most of the roms make the market think its a htc if i remember correctly and the zte blade has a massive following on custom roms so most of the data collected would be untrue and inacurate im not digging at anyone im just saying

its a good app its a shame it dont work properly on our blades

Most people don't know about costum roms. You'd need to ask Paul about viewers but I'd say no more than 100K use them. And not all roms alter the device name. I certainly haven't used one that does.

0

Share this post


Link to post
Share on other sites

Posted

Viber Developers, check it please: https://jira.skype.com/browse/JSA-81

Sykpe has similar problem and there is a fix for that. Probably you can easily implement the solution.

0

Share this post


Link to post
Share on other sites

Posted

Can't believe Viber's replies Vs. Dev's replies...

It seems that the Viber technical team is a team of Unprofessional users :S

0

Share this post


Link to post
Share on other sites

Posted

Hi,

I am using zte blade gen2 with a CM 7.2 custom rom. I do have the problem of audio coming through the speaker. In the first page, the fix ( a apk for FM radio) could not be installed on my phone. Any help in this regard would be appreciated even if it is not instant.

Cheers

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.