• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[Development][ROM] cm9

226 posts in this topic

Posted · Report post

Well "no buttons backlight" looks more like a powersaving feature :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

That helped to build Mms.apk (was not a case before). Will check later if "Messaging" application will appear if I add the apk. I think it should...

I think so too.

This is great progress happening here.... I've no idea yet about the boot animation. Does it make sense to revisit ICS ports for msm7200a devices htc dream or that openeve lg? Perhaps they included different framework-res.apk?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Well "no buttons backlight" looks more like a powersaving feature :)

Yes, and "no mobile data" is another feature, i do not have any traffic plan for data, with this feature i do not have to worry about accidentally connecting data access :lol:

Amazing how this development is going fast. Great job!

1

Share this post


Link to post
Share on other sites

Posted · Report post

Does hardware acceleration in ICS make UI faster than gingerbread at the moment on pulse? like on ZTE blade?

As I wrote, if remove ICS boot animation (which can be played just fine (but on a slower side) if no hardware acceleration enabled),

then "ANDROID" boot animation will be revealed. It will be animated, but colors will be weird and scaling gonna be completely off. (you can try to add hardware acceleration into the rom from first page to see what I refer to...)

boot animation issues are wrong colors and scaling (making overall experience wrong and unpleasant), but it animates.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Does hardware acceleration in ICS make UI faster than gingerbread at the moment on pulse? like on ZTE blade?

Not in the moment at least. (well it helps to degree) That is distant potential. As ICS (and Honeycomb) add more hardware acceleration into UI compared to previous editions, like gingerbread.

People (tilal?) found a solution for msm2727 based devices with Adreno 200. And they really comment that ICS if smoother than gingerbread on their devices. ZTE Skate, Blade, some Samsung with msm7227.

I saw nothing for us yet around. Keep looking around too!

I know good ICS development goes on for HTC HeroC (msm7201a) device. But they don't have proper hardware acceleration in the moment.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

openeve people (just one guy in fact) applied a patch for graphics and saying it made very positive difference.

http://forum.openetn...g33626#msg33626

the patch itself is very rough, nearly as is from gingerbread, submitted to CM just to grab attention, but anyway...

"Change I271fd87c: libagl: Allow use of copybit to accelerate 2D rendering"

http://review.cyanog...m/#change,11167

EDIT:

some also suggested this patch in addition:

http://r.cyanogenmod.com/#change,12727

EDIT2:

from the same guy. May be this will help native screenshots:

http://review.cyanogenmod.com/#change,12089

Edited by pier11
0

Share this post


Link to post
Share on other sites

Posted · Report post

Some tips from turl on Moto Cliq XT (msm7200a) forum:

http://modmymobile.com/forums/558-motorola-cliq-xt-development/564337-ics-booted-cliq-xt-2.html#post4113596

"And these too on your BoardConfig.mk to get a more or less working EGL

COMMON_GLOBAL_CFLAGS += -DMISSING_EGL_EXTERNAL_IMAGE -DMISSING_EGL_PIXEL_FORMAT_YV12 -DMISSING_GRALLOC_BUFFERS

BOARD_NO_ALLOW_DEQUEUE_CURRENT_BUFFER := true

"

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

total used free shared buffers

Mem: 107064 100164 6900 0 84

-/+ buffers: 100080 6984

Swap: 62456 60644 1812

This is not good. With Google Maps.

Edited by pier11
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Our own build of cm9 compiled from source available on the first page of this thread:

cm9-u8220-20120309.zip

Features (compared to previous rom):

- wifi

- radio (sometimes reload)

- jogball fix

Hardware accelerated boot animation is broken in this release. Don't be scared - it will boot into Android fine.

Post your feedback.

Edited by pier11
3

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

After entering the PIN get this message.

"SIM network unlock PIN". But my phone is unlocked. I try enter my old unlock-code, but this window is not responding. I can see message "Requesting network unlock" only.

If i press "Dismiss", network didn't work.

One more bug: after turning on "Airplane mode" phone is rebooting.

Edited by superdeman
0

Share this post


Link to post
Share on other sites

Posted · Report post

UPD: I restore my backup CM7.2 and flash this rom one more time. This message appears all the same, but after pressing "Dismiss" mobile network did work

0

Share this post


Link to post
Share on other sites

Posted · Report post

UPD: I restore my backup CM7.2 and flash this rom one more time. This message appears all the same, but after pressing "Dismiss" mobile network did work

I have the same result.

WiFi works smile.gif

0

Share this post


Link to post
Share on other sites

Posted · Report post

I want to ask for a patch that will return the mouse to jogball.

We do not have a large screen and use the cursor will be very helpful.

Especially for the Internet. Thank you!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Give me please link to gapps for this ROM.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Perhaps I should say please feel free to start. By the way google apps may work on other firmware like on cm 2.3.7 check will tell.

0

Share this post


Link to post
Share on other sites

Posted · Report post

OK, due to popular demand added gapps on the first page.

Unfortunately installing big memory consumers like Maps effectively render u8220 unusable. u8230 should feel better - twice more memory.

1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Small gapps work! Thank you B)

I tried flash "big" gapps from cyanogenmod.com - it didn't work.

g-sensor (accelerometer) needs to be calibrated. I noticed this in the game "Doodle Jump". See for yourself

Edited by superdeman
0

Share this post


Link to post
Share on other sites

Posted · Report post

Спасибо за gapps +)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

if you do that scann is working as it is not is original rom

replaced libril.so from cm7.2 and now i can search network manually.

somebody can confirm?

edit: i notice that the following libs where missing comparing to cm9-20120303

invoke-mock-media-player.so

libcamera.so

libdll.so

libOmx-core.so

libstagefrighthw.so

for the moment i did replace a few file from first cm9 to last cm9 :all *Omx*.so files/add *Omx-core.so/libstagefrighthw.so

replace libril.so from cm7.2 to last cm9

what i could notice:network scan is working...but it seem to me that cm9 is smoother...somebody can confirm?

in fact i think it is smoother cos i oc to 710 and mini 245

Edited by desalesouche
0

Share this post


Link to post
Share on other sites

Posted · Report post

Спасибо за gapps +)

it's thank for gapps =)

DSPManager in this ROM don't work =(

And try change volume in voice call - this is one more bug

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

ok video playback is back doing this:adding/replacing from cm7.2 libaudio.so/libaudiopolicy.so/*Omxcore.so/*Omxh264.so/*Omxmpeg4dec.so/*Omxvidenc.so/

*OmxWmvDec.so

and replacing from cm9-20120303 libstagefright.so to cm9-20120309

i also add libstagefrighthw.so from cm9-20120303 to cm9-20120309

laugh.gifwooooooooo

edit:video playback is not very smooth...youtube with HQ and normal video.

ps:i am using quickpic

Edited by desalesouche
1

Share this post


Link to post
Share on other sites

Posted · Report post

desalesouche, can you make flashable zip for CWM?

sorry will let pier11 confirm and do itsmile.gif

0

Share this post


Link to post
Share on other sites

Posted · Report post

ok video playback is back doing this:adding/replacing from cm7.2 libaudio.so/libaudiopolicy.so/*Omxcore.so/*Omxh264.so/*Omxmpeg4dec.so/*Omxvidenc.so/

*OmxWmvDec.so

and replacing from cm9-20120303 libstagefright.so to cm9-20120309

i also add libstagefrighthw.so from cm9-20120303 to cm9-20120309

laugh.gifwooooooooo

edit:video playback is not very smooth...youtube with HQ and normal video.

ps:i am using quickpic

EDIT: video play back is repared with 2 files(libstagefright.so and libstagefrighthw.so from cm9-20120303)

1

Share this post


Link to post
Share on other sites

Posted · Report post

EDIT: video play back is repared with 2 files(libstagefright.so and libstagefrighthw.so from cm9-20120303)

desalesouche,

Do i correctly understand you, that if take the following files and replace, video playback will restore?

Will it be smooth in both normal and HQ modes?

Or should we NOT use cm7.2 files at all as you said in your second post? I'm confused a bit.

cm7.2:

libaudio.so

libaudiopolicy.so

*Omxcore.so

*Omxh264.so

*Omxmpeg4dec.so

*Omxvidenc.so

*OmxWmvDec.so
cm9-20120303:
libstagefright.so

libstagefrighthw.so

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.