twrock

[ROM] Styx (CM6; updated 2012 05 25)

244 posts in this topic

Firstly well done for producing another great ROM with excellent battery life!

I tried something experimental which seemed to work if anyone else is interested in testing this setup: I installed the 2.6.32 kernel version ROM and applied the ext4 support kernel patch from um840 ROM. My ext partition was formatted as ext4 before doing this. It seemed to come up and work fine without any problems or FCs.

Then I came across 2 issues - one of them mentioned here. At this point I have completely reformatted as ext2, wiped, cleared cache partition and formatted /system before proceeding with more testing. Now I see exactly the same 2 issues with a clean flash of the ROM with ext2 partition:

1. I am unable to find Whatsapp in Play search. I transferred the whatsapp.apk to the phone and tried to install, but it does not give me any error messages (at least in the Play interface). It just tells me eventually 'Whatsapp has not been installed.'

2. I go to terminal and try running the following a2sd commands but its having issues with the a2sd program. I tried these commands from su prompt:


a2sd check

a2sd reinstall

a2sd lowmem-aggressive

a2sd swappy10

a2sd cachesd

Everytime I get this output:

/system/bin/a2sd: line 18: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 19: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 21: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 22: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 23: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 24: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 31: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 35: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 36: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 37: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 38: /system/bin/busybox.a2sd: no such file or directory

/system/bin/a2sd: line 39: /system/bin/busybox.a2sd: no such file or directory

/system/bin/bash: /system/bin/launcha2sd: no such file or directory

 /system/bin/a2sd: line 41: /system/bin/busybox.a2sd: no such file or directory

I then tried:

#find / -name a2sd

/system/bin/a2sd

find: /proc/1336/task/1543/fdinfo/103: No such file or directory

find: /proc/1710: No such file or directory

find: /proc/1728: No such file or directory


Could it be I need to completely wipe the sd card (delete ALL partitions and reformat as fat32 + ext2 + swap) and try again to get a2sd to install itself correctly? When flashing dt_a2sd.zip from Clockwork recovery 2.5.0.7 it appears to install fine without any errors. Does anyone else see this problem? My card is a class 10 8gb with 1st partition fat32, 2nd sd-ext ext2 512Mb and 3rd 64Mb linux-swap. All created using gparted on Linux box.

thanks,

Peter

EDIT: It turns out a full format of the SD card AND phone did not help either of these two issues. This ROM works great and i can move apps to the SD card but these commands just do not work at all and whatsapp or OS Monitor will not install at all..

Edited by pedrojaime
0

Share this post


Link to post
Share on other sites

I tried:


# a2sd repair

today but that did nothing (without reboot - maybe with reboot it could have worked..?) Then I went into recovery and replashed dt_a2sd...zip version that came with Styx ROM. Reobboted, went into Terminal and not note that A2sd is back and working again. Hope it helps others with this same issue. The unable to install certain apps issue with this ROM still persists though if anyone has more ideas on how to fix that one..? cheers, Peter EDIT: I ran yesterday:

#a2sd zipalign

then rebooted into recovery and cleared the cache. I am not sure what fixed it but I am now able to install Whatsapp! I still cannot install 'OS Monitor' though. trying to run it from terminal as normal user and su tells me: 'Permission denied' I have yet to try to install using via ADB and look at logcat errors..

Edited by pedrojaime
0

Share this post


Link to post
Share on other sites

So after testing CM7.2 over the last two days, and being driven crazy by the camera/video recorder trouble, I'm coming back to work on this rom for a while. At least this camera works flawlessly for me. (And I still think the system is quicker with CM6 than CM7 at the same settings.)

So I went back to dr.flo's final version of CM6.1.1 and reinstalled with very little modification. I then install a minimal gapps and then updated to the .32 kernel. (Note, the Market app in that gapps was not the latest version of Google Play that is available at the moment.) I could see Tweetdeck and Tweakdeck in the Market. So the problems some of us are having seem to have been introduced by something I did in modifying the rom. I have no idea what it is. It might be a combination of the newest Google Play app I added to /system along with some other changes I made. But in any case, it seems it is not a problem inherent to the original build of the base rom that dr.flo did.

However, the Simplified Chinese problem is something inherent to the original rom he ported, and I don't think I'll ever be able to correct that bug. Sorry to all the PRC people, but I don't know what to do.

0

Share this post


Link to post
Share on other sites

Styx-620 20120401d has been released. See the first post for the link.

This version is based on dr.flo's CM6.2.0-RC0 port, and has more up-to-date Google apps and support files. This has solved my problem of missing Market apps. YMMV, but it works for me.

Enjoy.

1

Share this post


Link to post
Share on other sites

Styx updated to 2012 04 02a. This is a very minor update: updated GoogleSearch, added VoiceSearch, and changed default network to WCDMA.

Note: there is no need to update if you just installed 2012 04 01. Just update GoogleSearch and add VoiceSearch from the Market yourself and you will have the changes in this latest version.

0

Share this post


Link to post
Share on other sites

twrock, your rom is too fast, but i have some problem i can't install some apps. In google play I do not see them, not through google play during the installation there is an error. For example there is a problem with the google maps.

0

Share this post


Link to post
Share on other sites

twrock, your rom is too fast, but i have some problem i can't install some apps. In google play I do not see them, not through google play during the installation there is an error. For example there is a problem with the google maps.

What?!! :huh:

I was so excited that my newest version based on CM6.2.0 did not have any problem for me with the Market/Google Play. Are you using the latest version that I just uploaded today? I downloaded Maps, Tweetdeck, Tweakdeck, Whatsapp, etc. without any problems. I did have problems with the previous version (based on 6.1.1), but this newest version solved all my problems.

Did you do a full wipe before installing the latest version?

It is fast, isn't it. B) Fast (even at 528mhz) and good battery life. I really like this rom. I'm working on Arabic support this afternoon. I hope to get that working soon.

0

Share this post


Link to post
Share on other sites

very very hard work thank you and waiting for Arabic patch .

0

Share this post


Link to post
Share on other sites

very very hard work thank you and waiting for Arabic patch .

Try it. :) (the new Arabic patch)

http://android.modac...ost__p__1927304

And please let us know if it works.

Edited by twrock
0

Share this post


Link to post
Share on other sites

I did not notice that there is a new version :)

0

Share this post


Link to post
Share on other sites

twrock,

I would like to use the wallpaper of your TXG ROM but can't get it out from the phone. Can you advise how to do it?

Thanks.

0

Share this post


Link to post
Share on other sites

twrock,

I would like to use the wallpaper of your TXG ROM but can't get it out from the phone. Can you advise how to do it?

Thanks.

Here is the small version for our phone screen.

post-596158-0-35248600-1333443446_thumb.

If you want the large version for some reason, let me know and I'll try to find it. I took that picture on the Pacific beach down on the southern beach in Taiwan with my phone, using my sunglasses as a filter. :lol: I like it a lot too. Maybe I'll make it the default wallpaper in this rom for the next update.

For future reference, that graphic is /system/framework/framework-res.apk/res/drawable/default_wallpaper.jpg.

Edited by twrock
0

Share this post


Link to post
Share on other sites

Here is the small version for our phone screen.

post-596158-0-35248600-1333443446_thumb.

If you want the large version for some reason, let me know and I'll try to find it. I took that picture on the Pacific beach down on the southern beach in Taiwan with my phone, using my sunglasses as a filter. :lol: I like it a lot too. Maybe I'll make it the default wallpaper in this rom for the next update.

For future reference, that graphic is /system/framework/framework-res.apk/res/drawable/default_wallpaper.jpg.

twrock,

Thanks a lot.

I have been in Kenting 墾丁 once (in 2009 or 2010) and it is beautiful and I enjoyed the holiday much there. That why you wallpaper attracted me.

Thanks again.

0

Share this post


Link to post
Share on other sites

Simplified Chinese or can not use

0

Share this post


Link to post
Share on other sites

Simplified Chinese or can not use

This is a known bug. The first post already says that this problem has no solution at this time. You will have to use a different rom. Sorry, but there is nothing I can do.

0

Share this post


Link to post
Share on other sites

Great ROM!

But Estonian language support is missing ;)

Well, when you have fixed it, please post the solution. ;)

I don't have any idea what can be done about that. Sorry.

0

Share this post


Link to post
Share on other sites

have been following this thread for quite some time now...

Thanks for this excellent ROM.. I think nothing cud've been better than this one.. the speed is awesome.. and the market issue has been resolved..

TWROCK: have u noticed any resolution problem? i feel that the standard cygnmod had better graphical resolution ..

Edited by Rizwan Sheikh
0

Share this post


Link to post
Share on other sites

TWROCK: have u noticed any resolution problem? i feel that the standard cygnmod had better graphical resolution ..

I can't imagine that this rom is any different than the standard CM (no different than the rom dr.flo ported). Our screen are 320x480. I know of nothing I can do to change the resolution.

However, you can easily change the "apparent" resolution in build.prop. This changes the "density" of the screen. Look for this line or add it: ro.sf.lcd_density=160. If memory serves me correctly, I think you will want to try 140.

Some people prefer that look, but it is far too small for my liking. But unless there is some magic I don't know about, our screens have the resolution that they have.

0

Share this post


Link to post
Share on other sites

for that, i wud have to install the rom again after changing it's value.. is there a way to do it from some settings or from terminal emulator, so that i wud not have to re-install the rom.. ?

0

Share this post


Link to post
Share on other sites

for that, i wud have to install the rom again after changing it's value.. is there a way to do it from some settings or from terminal emulator, so that i wud not have to re-install the rom.. ?

you can do it with root explorer :)
0

Share this post


Link to post
Share on other sites

When flashing TRE 2.1 ROM it says Update Failed. Any ideas why?

Edited by zYn!x
0

Share this post


Link to post
Share on other sites

Just installed Google Goggles. When I try to use it I get the error "Unsupported system configuration - Goggles won't work in your non standard system configuration (kernel is missin ipv6 support)".

I don't think this is the case. Any ideas how to fix it?

0

Share this post


Link to post
Share on other sites

Just installed Google Goggles. When I try to use it I get the error "Unsupported system configuration - Goggles won't work in your non standard system configuration (kernel is missin ipv6 support)".

I don't think this is the case. Any ideas how to fix it?

Unfortunately, I think this is the case. "Someone" needs to replace the boot.img in this rom with the newest .32 kernel version Pier compile which has ipv6 support. I don't see why it wouldn't be possible. I will look into it and see if it is easy enough for me to do.

(Of course anyone is very welcome to do it before I have a chance to.) :rolleyes:

0

Share this post


Link to post
Share on other sites

I flashed Pier's latest boot.img from the um840 rom. Rebooted without any problem. I will add that to the next update, but for now, you can do what I did.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.