Site Notice - We are currently investigating an issue with missing download links. Apologies for any inconvenience caused. PaulOBrien

  • Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[HOW-TO] A2SD for Coldfusion ICS

102 posts in this topic

Posted (edited) · Report post

pff...i want s2e. It works for me first time i flashed but then i decided to format my card and phone to keep all things clean, but after that...the app didnt work. Still need to install Link2SD? But how do i do that ?

EDIT:I solved my problem. Just went in CWM ->Advanced->Partiton SD and that's all!

Edited by stanvladut
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

pff...i want s2e. It works for me first time i flashed but then i decided to format my card and phone to keep all things clean, but after that...the app didnt work. Still need to install Link2SD? But how do i do that ?

EDIT:I solved my problem. Just went in CWM ->Advanced->Partiton SD and that's all!

Lol, i did that too, and it nuked my FAT32 partition! should have shrunk it with gparted and inserted the partition, which i assumed CWM would do (luckily i had an rsync backup).

also i had to format the partition afterwards before it would work, and CWM formatted it ext3 not ext4, although that's fine as it can backup ext3.

anyway Links2SD is working nicely now, I've got 4 screens full in app drawer now, with half of /data free, and finally can move my massive GPS app to sdcard, saving about 40mb!

oddly enough, Links2SD says when you turn on usb mass storage with the phone connected to a computer, it doesn't unmount /sd-ext, well on linux you get both partitions showing up, although it seems /data/sdext2 is still mounted, so probably a bad idea to write to it!

i really don't like the thought of s2e making the whole of /data on /sd-ext, you've got no way to install onto nand other than gapps in /system!

Edited by sej7278
0

Share this post


Link to post
Share on other sites

Posted · Report post

支持支持,我是中国网友。

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Here's the problem.

I'v got ZTE Blade with Coldfusion ICS 29/05.

Got s2e installed.

The phone has plenty of space free:

post-915025-0-60559000-1338545788_thumb. post-915025-0-38414000-1338545803_thumb.

Despite this, OS thinks that it has less internal storage than it uses.

post-915025-0-81884400-1338545818_thumb.

Some apps install seamlessly, but some other don't install saying "Insufficient storage available"

post-915025-0-16640600-1338545825_thumb. post-915025-0-11077400-1338545830_thumb.

The problem has already been mentioned here, so it's not just me.

Looks to me like the space available is calculated ignoring the fact that /data/app is on another file system.

Dunno who is to blame: core ics or cm or s2e...

Any suggestions?

post-915025-0-60559000-1338545788_thumb.

post-915025-0-38414000-1338545803_thumb.

post-915025-0-81884400-1338545818_thumb.

post-915025-0-16640600-1338545825_thumb.

post-915025-0-11077400-1338545830_thumb.

Edited by yell
0

Share this post


Link to post
Share on other sites

Posted · Report post

so, exactly which zip to use?

<_<

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

No matter which zip I use (from this or that post), I get "Root is required" all the time. I have 29/05 CFX. Is there zip working with this one?

Edited by jukooz
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi guys,

Great thread.

Been using SS RLS7 for a few months now. Planning to move to CFX this weekend. Just wanted to summarize (for noobs like me) how CFX is installed with A2SD - S2E. Please comment if I have got it right:

Edit: My card already has a 2 GB ext3 partition.

1. Get GAPPs and CFX ROM from CFX OP and put them on the SD

2. Put A2SD - S2E zip on the SD from this post:

Here you go:

Attached Files

simple2ext-v4.zip 820.61K

3. Now FORMAT SYSTEM

4. Flash the ROM and A2SD - S2E zip

5. After this wipe data

6. Reboot

7. Flash Gapps

8. Reboot

And this post from the king himself:

Use Link2SD.

What is that about?

Edit: Read the FAQ thread. Tilal recommends using Link2SD. I assume this step is after step 6 above. Am I right?

Anyways, would prefer S2E myself (if all is ok) sind L2SD uses a b/g service and doesn't move app data. So, if anyone can tell me if S2E works perfectly and can confirm the steps above, that'll be great!

Will appreciate your responses. Thanks in advance.

P

Edited by probals
0

Share this post


Link to post
Share on other sites

Posted · Report post

I don't know where to find this script!... Could you kindly provide us with a link or upload it to us, so that we may have a look at what this script is doing to create a sd-ext mount for S2E v2 please?

Sorry! haven't visited this thread for a while. I took my s2e-v4 script from here.

@ probals: Though I would deem myself still being a noob, I can tell you that I did it like you described and it worked for me. Remember that you have to flash the s2e-script everytime you carry out a ROM update.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Use Link2SD.

i'm getting all sorts of problems with links2sd - from mount warnings every time i reboot from recovery (seems to require reinstalling startup scripts and rebooting a couple of times) to "not enough free space" when updating apps from play store (fixed by unlinking and relinking then updating!)

0

Share this post


Link to post
Share on other sites

Posted · Report post

@ probals: Though I would deem myself still being a noob, I can tell you that I did it like you described and it worked for me.

Thanks Staud. After facing all sorts of problems with Link2SD over the last 2-3 days, I'm going to try S2E. Let's see how it goes.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Staud. After facing all sorts of problems with Link2SD over the last 2-3 days, I'm going to try S2E. Let's see how it goes.

simple2ext-v4.zip works like a charm. You only have to flash it again after each update like you have to do with the gapps.

0

Share this post


Link to post
Share on other sites

Posted · Report post

simple2ext-v4.zip works like a charm. You only have to flash it again after each update like you have to do with the gapps.

But, I think one should keep in mind that a full wipe includes formatting the ext-partition, or am I mistaken? Or, in your experience, can one keep the ext partition and just reflash s2e without any problems when updating the ROM? Is this even cleaner than formatting the ext and restore apps via Titanium Backup?

0

Share this post


Link to post
Share on other sites

Posted · Report post

But, I think one should keep in mind that a full wipe includes formatting the ext-partition, or am I mistaken? Or, in your experience, can one keep the ext partition and just reflash s2e without any problems when updating the ROM? Is this even cleaner than formatting the ext and restore apps via Titanium Backup?

You don't have to wipe your data partition on each update. I've made this flashable zip to be flashed after each update. So you don't have to worry about anything.

1.Flash udpate zip

2.Flash Gapps

3.Flash s2e

4.wipe dalvik

5.reboot

It can't be compared with Titanium Backup. Because you simply don't uninstall or remove the apps during the flash progress.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

simple2ext-v4.zip works like a charm. You only have to flash it again after each update like you have to do with the gapps.

Thanks XeS0r... It does work like a charm. No complaints at all. I have over a 100 apps, all working smoothly!

edit: I think it's important the S2E app is downloaded from play store to activate all options, like moving davlik cache to sd, etc.. This was not done by default for me, but after using the app, it's all a-ok!

Is this even cleaner than formatting the ext and restore apps via Titanium Backup?

I normally format all data (including ext) and use MyBackup Root to get back apk + data. No issues faced till date. I prefer it to TB.

edit: Best part of MyBackup Root is that apps are relinked to the market automatically. Not sure if TB does that.

Edited by probals
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks XeS0r... It does work like a charm. No complaints at all. I have over a 100 apps, all working smoothly!

edit: I think it's important the S2E app is downloaded from play store to activate all options, like moving davlik cache to sd, etc.. This was not done by default for me, but after using the app, it's all a-ok!

I normally format all data (including ext) and use MyBackup Root to get back apk + data. No issues faced till date. I prefer it to TB.

edit: Best part of MyBackup Root is that apps are relinked to the market automatically. Not sure if TB does that.

You don't need to download it from google play store. It's signed with the market signature and can be updated on updates too. But it don't reside on your ext partition and isn't affected if something goes wrong and you need to start your s2e application. I can move my Dalvik Cache (Option isn't greyed out). As i wrote during the flash process -> Start your s2e app to configure what you want to store on the ext partition. If you got any problems let me know and i will take a look at it.

And you only need to wipe data on major releases like from 7 to 9 or after the first flash of cyanogenmod. That's what they said. But in the end you can do what you want.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

You don't have to wipe your data partition on each update. I've made this flashable zip to be flashed after each update. So you don't have to worry about anything.

Okay, maybe next time I'll give it a try. But I'm always a bit anxious and paranoid that there might be incompatibilities, that's why I mostly wipe everything. If there are problems with the ROM the first thing they'll ask you is if you did a full wipe... But of course, like you already said, everybody is free to decide that by theirselves. Haha, maybe it's my German attitude to do things thoroughly :D

Edited by staud
0

Share this post


Link to post
Share on other sites

Posted · Report post

You don't have to wipe your data partition on each update. I've made this flashable zip to be flashed after each update. So you don't have to worry about anything.

1.Flash udpate zip

2.Flash Gapps

3.Flash s2e

4.wipe dalvik

5.reboot

you don't have to flash gapps after every update either.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

you don't have to flash gapps after every update either.

I'm not sure how you did that but it won't work on my blade with the 31/05 Update from tilal.

1.Flashing Update again for testing purpose

2.Restart

3.Google Apps disappear.

Correct me if i'm wrong but the updater-script formats the system? It may work for those whose gapps didn't reside in the system/apps folder.

Btw.: updated to simple2ext-v5-zip which includes s2e v2.2.1

Edited by XeS0r
1

Share this post


Link to post
Share on other sites

Posted · Report post

I have been using CFX for a couple of weeks now along with the simple2ext-v4 add-on.

One issue I'm facing is that the data in apps takes sometime to load. When I press on an app.. the apps loads ok, but the data takes 2-3 secs to come.

May or may not be an issue with simple2ext. Just sharing

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

does anyone knows why i cant open A2SD in the 15/06 build? it get allways the error of missing the scripts or the ext...

i allready tryed to use the apps2ext-cm9.zip and the 31032012-a2sd-ext3.zip and it didnt work with both...

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

I'm using Coldfusion Alpha 3 and I was fighting for two whole days to get A2SD working. Link2SD wasn't satissfiy me. Here's my receipe:

Create file 05sdcard with content:


#!/system/bin/sh

/system/bin/mount -o remount,rw /

/system/bin/mkdir /sd-ext

/system/bin/mount -o remount,ro /

if [ -e /dev/block/mmcblk0p2 ];

then

	/system/bin/mount -t ext4 /dev/block/mmcblk0p2 /sd-ext

fi;

then adb remount adb push 05sdcard /etc/init.d/ adb shell chmod 0755 /etc/init.d/05sdcard Then download ICS_simple2ext.zip, unzip it to /sdcard with preserving directory structure (META-INF in .zip is /sdcard/META-INF etc) Next: adb shell And copy-paste into adb shell window:

mount -o remount,rw /system

rm /system/etc/init.d/10apps2sd

cp /sdcard/system/app/s2e.apk /system/app/

cp /sdcard/system/etc/init.d/20userinit /system/etc/init.d/

chmod 0644 /system/app/s2e.apk

chmod 0755 /system/etc/init.d/20userinit

mount -o remount,ro /system

reboot, setup s2e according to Your preferences, reboot (watch adb logcat, this boot should take longer)

If everything works go to fridge and open Cold Beer of Winner biggrin.gif

Credits: uosiu (myself → this how-to), (tlexul → inspiration from THIS POST/XDA-Developers) and OlegKrikun/XDA-Developers for S2E application.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm not sure how you did that but it won't work on my blade with the 31/05 Update from tilal.

1.Flashing Update again for testing purpose

2.Restart

3.Google Apps disappear.

Correct me if i'm wrong but the updater-script formats the system? It may work for those whose gapps didn't reside in the system/apps folder.

Btw.: updated to simple2ext-v5-zip which includes s2e v2.2.1

Can you please share a link for "simple2ext-v5-zip" ?

Thank you.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I have been using CFX for a couple of weeks now along with the simple2ext-v4 add-on.

One issue I'm facing is that the data in apps takes sometime to load. When I press on an app.. the apps loads ok, but the data takes 2-3 secs to come.

May or may not be an issue with simple2ext. Just sharing

P

That's because you've moved everything to your ext partition. Moving the Application data directory and the dalvik-cache to your ext partition will eventually slow down the system due to concurrent file access.

does anyone knows why i cant open A2SD in the 15/06 build? it get allways the error of missing the scripts or the ext...

i allready tryed to use the apps2ext-cm9.zip and the 31032012-a2sd-ext3.zip and it didnt work with both...

You can't open the a2sd? Did you mean the s2e app?

Check your /system parition free space. Open Terminal and enter "df". Maybe your system partition is to small. In my case it was to small and after the flashing process my gapps and s2e won't flash. You can check the Clockworkmod Log, too. Just restart into clockworkmod and flash s2e zip again. Goto main menu where you can reboot system and choose Advanced -> Logs.

Can you please share a link for "simple2ext-v5-zip" ?

Thank you.

Here you will find it:

https://docs.google....m4tejhQaFU/edit

Edited by XeS0r
1

Share this post


Link to post
Share on other sites

Posted · Report post

thank you

0

Share this post


Link to post
Share on other sites

Posted · Report post

hello i just instal simple2ext-v5-zip but i cant see any difference out of the s2e app all my apps are like before!!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.