• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Auto-LiMPoT -- A tool for automatic MIUI porting

47 posts in this topic

Posted

My 2.3.30, made with the tool. Been using it two weeks now... let's see if it works.

http://mir.cr/0CH8GLSP

I've decided to try for the fun and... this MIUI rom is a great, great rom ! Probably one of the best i've tried !

0

Share this post


Link to post
Share on other sites

Posted

I've decided to try for the fun and... this MIUI rom is a great, great rom ! Probably one of the best i've tried !

That's nice to hear, but one thing confuses me.

You said after installing java you managed to make Auto-LiMPoT work... so why didn't you just build this very rom yourself with the tool? What I mean is: I made this tool so that people wouldn't be constantly waiting for others to make ports and upload them, if I start uploading the roms myself it kinda defeats the purpose, doesn't it?

An to be clear: I'm not attacking you, I'm just trying to understand how people think... everyone is always asking for the latest MIUI version, but now that it can be built automatically people still wait for someone to upload roms for them. Is it that the tool doesn't work for you too? Some other reason?? If it doesn't work, let's get together and find out how to fix it, but I need some input on your (I mean everyone that uses the program, not you in particular) part.

0

Share this post


Link to post
Share on other sites

Posted (edited)

wow, I thought it is impossible to automate :D

anyway, if something goes wrong, you could always see a log and quickfix rom you are trying to boot.

hi i tried you port and it working perfectly and its i gess the most smoth miui i tested !

that's what I call LF magic bro :D

Edited by Lens_flare
0

Share this post


Link to post
Share on other sites

Posted

That's nice to hear, but one thing confuses me.

You said after installing java you managed to make Auto-LiMPoT work... so why didn't you just build this very rom yourself with the tool? What I mean is: I made this tool so that people wouldn't be constantly waiting for others to make ports and upload them, if I start uploading the roms myself it kinda defeats the purpose, doesn't it?

An to be clear: I'm not attacking you, I'm just trying to understand how people think... everyone is always asking for the latest MIUI version, but now that it can be built automatically people still wait for someone to upload roms for them. Is it that the tool doesn't work for you too? Some other reason?? If it doesn't work, let's get together and find out how to fix it, but I need some input on your (I mean everyone that uses the program, not you in particular) part.

Easy answer : the time my friend, the time ! :)

Last time, after the java problem, i've tried to made my rom, from the phoenix stable version. It doesn't work. I've had no time to do more so i rest with my 2.3.7c.

Today, i've got some time, so i try your rom.

And just now, with this wonderful rom, i'll try to make a 2.4.6

;)

0

Share this post


Link to post
Share on other sites

Posted

Could we use only N1 rom for port or desire rom could work too ?

(Because i don't find new N1 GB version since N1 have MIUI ics).

0

Share this post


Link to post
Share on other sites

Posted (edited)

Could we use only N1 rom for port or desire rom could work too ?

(Because i don't find new N1 GB version since N1 have MIUI ics).

only N1

But if they don't release N1 rom it means the new version only introduces fixes for other devices that do not make any differences on N1, so there would probably be no difference between my 2.3.30 and a supposed 2.4.6 if it existed.

PS: yes the tool is designed to use roms by either Lens, iKrautDroid or me as base. Phoenix is untested and probably not working.

Edited by Master_T
0

Share this post


Link to post
Share on other sites

Posted

ok so the 2.3.30 is the last version for Liquid.

I confirm, with the phoenix version the build crash ;)

0

Share this post


Link to post
Share on other sites

Posted

Mister t yes i ll wend you my failed port very soon when i 'll have some time to check whats going wrong

anyway thanks to you mister t and all devs like Lens flare who totally converted me to miui mania since this one ;-) http://miuiandroid.com/community/threads/1-12-30-miui-light-force.11653/

0

Share this post


Link to post
Share on other sites

Posted

hello i tried to compare the 2 os with win merge it seems to have 3 differents files the torsh and fm that i ve forgotten to remove and the service.jar file

0

Share this post


Link to post
Share on other sites

Posted

its indeed the service.jar the problem i took yours and i put into the rom i converted it work fine !

0

Share this post


Link to post
Share on other sites

Posted

Really great Master_T ^_^ It's very nice to see someone still working for the old liquid :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

i have found a guide on XDA on how to port MIUIv4 to any phone>>http://forum.xda-dev...d.php?t=1499411..i tried to combine a rom and i'm getting installation aborted error status 7..i dont know what to ..i took cm9 beta 2 as base and miuiv4 2.4.13 (nexus one rom from miui.us).can anyone help me in solving that error..its my first try to compile a rom!

Edited by elixir.amrit
0

Share this post


Link to post
Share on other sites

Posted

my rom helped you to find the solution master t ?

0

Share this post


Link to post
Share on other sites

Posted

my rom helped you to find the solution master t ?

Sorry, very busy at the moment, haven't had time to analyze it yet...

0

Share this post


Link to post
Share on other sites

Posted

Hi, i try the 2.3.23 rom but the camcorder don't work. While recording the screen is white. I would try the last rom, 2.3.30, but i need the italian language pack.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, i try the 2.3.23 rom but the camcorder don't work. While recording the screen is white. I would try the last rom, 2.3.30, but i need the italian language pack.

I've flashed the language pack of 2.3.23 from miui downloader app and it works.

Edited by siggey
0

Share this post


Link to post
Share on other sites

Posted

I noticed the white screen when recording as well (on .30 also). If anyone has any clue on how to fix it, please share it and I'll re-up a fixed .30 (since it appears .30 will be the last rom for our Liquid, might as well try to have it working as good as possible).

0

Share this post


Link to post
Share on other sites

Posted

Don't know if it's link, but camera 360 don't want to work due to a hardware problem.

Wich is the last miui rom with a full working camera ? Maybe we could take the camera lib file and try.

(as i know the phoenix one doesn't have problem but i'm pretty sure that the phoenix and the lens one are not fully compatible)

0

Share this post


Link to post
Share on other sites

Posted

Here is a logcat of what happens when the camera starts recording, hope someone can figure out what's going wrong:

06052012183058.jpg

0

Share this post


Link to post
Share on other sites

Posted (edited)

sorry Master_T, i've tried all i can the last week, decompile many files, compare with working on (2.3.16) and so... but no result on this :(

So i've made final optimisation with the last fully working on base the 2.3.16 :

http://www.modaco.co...cs-theme-fr-en/

Hope you enjoy it (change between 2.3.30 and 2.3.16 are very very tiny ;) )

Edited by youpi666
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.