• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[GEN2/European] AOSP GB 2.3.7 / t0mm13bROM

537 posts in this topic

Posted

I was having bad battery drain issues with the CM7 eco rom by JVentura. It wasn't probably the roms fault as it had been working just fine for a year or so.

 

I gave this a try as the author seems to still care, wiped cache and data, installed gapps.

 

For some reason now I have a bigger issue - using GPS by Google Maps or any other app reboots the phone almost instantly. I tried rebooting with or without GPS on and toggling it, no change. As said on this thread GPS will not work if you toggle it off so using it on-demand and being always enabled is how it's supposed to work. Even if I reboot with GPS on and then try Google Maps or c:geo, they both will reboot the phone in a matter of seconds when it tries to fix GPS location.

 

I have a Gen2 Blade with 'B' TPT of 128MB system partition from this forum. GPS was working fine with other roms. Any ideas? I'd love to get back to AOSP for a change.

0

Share this post


Link to post
Share on other sites

Posted

I was having bad battery drain issues with the CM7 eco rom by JVentura. It wasn't probably the roms fault as it had been working just fine for a year or so.

 

I gave this a try as the author seems to still care, wiped cache and data, installed gapps.

 

For some reason now I have a bigger issue - using GPS by Google Maps or any other app reboots the phone almost instantly. I tried rebooting with or without GPS on and toggling it, no change. As said on this thread GPS will not work if you toggle it off so using it on-demand and being always enabled is how it's supposed to work. Even if I reboot with GPS on and then try Google Maps or c:geo, they both will reboot the phone in a matter of seconds when it tries to fix GPS location.

 

I have a Gen2 Blade with 'B' TPT of 128MB system partition from this forum. GPS was working fine with other roms. Any ideas? I'd love to get back to AOSP for a change.

I think that Your system folder is a bit smaller for this rom.... I use a costum tpt of 185mb to system and it works great.

0

Share this post


Link to post
Share on other sites

Posted

I think that Your system folder is a bit smaller for this rom.... I use a costum tpt of 185mb to system and it works great.

 

df shows 16MB free after unpacking the rom and gapps, I didn't see any out of space errors when I unpacked them with CWM. As far as I know, the system partition is ro (as indicated by mount) so it shouldn't cause any issues as long as all the rom data (including gapps) fits in and even gapps upgrades are installed in the /data partition, not /system. This would make sense as then "factory reset" means wiping /data and /cache and you have a pristine /system to start from again. Correct me if I'm wrong.

 

I use 128Mb system because of how tight the internal storage is and how easy it is to fill with essential apps that can't be moved to SD card. Also if I'm correct above any unused free space in /system is just eating usable storage for internal storage apps and configuration. This isn't that big of an issue with 2GB+ internal storage but with this older model it gets tight really fast.

 

I can try a larger TPT but given what I see here it shouldn't make any difference.

0

Share this post


Link to post
Share on other sites

Posted

I think that Your system folder is a bit smaller for this rom.... I use a costum tpt of 185mb to system and it works great.

Hi.

I also think that the system folder is a little small.

I found for some reason - a programmer may know why - but you need to keep about 20mb of free space in both ROM  and RAM or things start falling over!.

 

I have 160mb reserved for the ROM and use Ludovic Renault's most excellent "Apps2ROM" app (from the Store) to fill up the spare space in the ROM - works for me :-)

 

Also use 3c's "System Tuner" - to tweak your phone - their newer "Android Tuner" I find can easily crash this ROM.

 

You'll find it's worth sorting out the phone  to run this most excellent ROM - and just add any bell's and whistles that you need from the "store".

 

Enjoy.

Bill.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi.

I also think that the system folder is a little small.

I found for some reason - a programmer may know why - but you need to keep about 20mb of free space in both ROM  and RAM or things start falling over!.

 

I have 160mb reserved for the ROM and use Ludovic Renault's most excellent "Apps2ROM" app (from the Store) to fill up the spare space in the ROM - works for me :-)

 

Also use 3c's "System Tuner" - to tweak your phone - their newer "Android Tuner" I find can easily crash this ROM.

 

You'll find it's worth sorting out the phone  to run this most excellent ROM - and just add any bell's and whistles that you need from the "store".

 

Enjoy.

Bill.

 

I've taken the advice from both of you and wiped the phone clean once again, but as I'm a developer myself I was intrigued to find out if the problem was persistent so I didn't repartition the phone yet.

 

Installed just c:geo first from Play, on first run no issues. After I upgraded it from the Play Store it crashed the phone once. After that I reinstalled all my apps but have no crashing. I'll try wiping once again and reinstall some test apps. If I can at least have one crash per reinstall consistently then I'll add more space and see if it can be reproduced. "Required" free space on ROM sounds silly but at least with consistent enough test case I could prove to myself it really helps.

 

Thanks to both of you, will keep digging.

 

EDIT:

 

Did a few more wipes with 128MB /system, I almost always got one crash with Google Maps on first run. After that it worked fine, so did c:geo. Finally I repartitioned with 160MB /system and for good measure also the SD card to avoid having any config/cache for any apps. After installing everything and running Google Maps it once again crashed the phone on first run. Again that was the only crash so far, both c:geo and Google Maps work now.

 

I'm fairly sure at this point 128MB /system was not the real issue but rather something went horribly wrong in /data permanently until wipe (maybe 128MB /system made it more likely/frequent). Removing Google Maps own cached data didn't make any difference as c:geo also inhibited the same behaviour.

 

Anyway, at least it works now. Aside from low fps in UI animations my battery life rocks again. Thanks.

Edited by hif1
0

Share this post


Link to post
Share on other sites

Posted

 

I almost always got one crash with Google Maps on first run.

 

Hi.

Funny thing is "Google Maps" has always caused issues on my OSF even when it was stock Orange 2.1

Some updates worked better than others.

0

Share this post


Link to post
Share on other sites

Posted

I've taken the advice from both of you and wiped the phone clean once again, but as I'm a developer myself I was intrigued to find out if the problem was persistent so I didn't repartition the phone yet.

 

Installed just c:geo first from Play, on first run no issues. After I upgraded it from the Play Store it crashed the phone once. After that I reinstalled all my apps but have no crashing. I'll try wiping once again and reinstall some test apps. If I can at least have one crash per reinstall consistently then I'll add more space and see if it can be reproduced. "Required" free space on ROM sounds silly but at least with consistent enough test case I could prove to myself it really helps.

 

Thanks to both of you, will keep digging.

 

EDIT:

 

Did a few more wipes with 128MB /system, I almost always got one crash with Google Maps on first run. After that it worked fine, so did c:geo. Finally I repartitioned with 160MB /system and for good measure also the SD card to avoid having any config/cache for any apps. After installing everything and running Google Maps it once again crashed the phone on first run. Again that was the only crash so far, both c:geo and Google Maps work now.

 

I'm fairly sure at this point 128MB /system was not the real issue but rather something went horribly wrong in /data permanently until wipe (maybe 128MB /system made it more likely/frequent). Removing Google Maps own cached data didn't make any difference as c:geo also inhibited the same behaviour.

 

Anyway, at least it works now. Aside from low fps in UI animations my battery life rocks again. Thanks.

Always here to help you ;)

A question , do you use Android 4.4.2? 

0

Share this post


Link to post
Share on other sites

Posted

Always here to help you ;)

A question , do you use Android 4.4.2? 

 

At most I've used 4.1 on the Blade and it's the only Android phone I have.

 

So far this AOSP rom has been very nice!

0

Share this post


Link to post
Share on other sites

Posted

At most I've used 4.1 on the Blade and it's the only Android phone I have.

 

So far this AOSP rom has been very nice!

You should try it , is not as fast as GB but it´s preatty snappy for our old buddy :D

0

Share this post


Link to post
Share on other sites

Posted

You should try it , is not as fast as GB but it´s preatty snappy for our old buddy :D

 

I think I need to try something else anyway. While this rom seems to be the best one yet, today when I went out to do some geocaching the phone rebooted 5 times when gps was activating. Very unfortunate.

0

Share this post


Link to post
Share on other sites

Posted

I still use Swedish Snow, which is the best ROM for Blade. I used it during my last 3 weeks trip in Cuba. Without any problem for recording my GPS tracks.

0

Share this post


Link to post
Share on other sites

Posted

Hello! Is this rom full estonian language support? if not, how to add estonian language?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.