• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

How to root your Huawei Ascend G300 (for Windows, Mac and Linux)

329 posts in this topic

Posted (edited)

Edit: Now to figure out why the Launcher has lots of gaps where the unstalled apps used to be ..

On your apps page press the settings cog at the bottom then all the downloaded apps get a cross on them.

You can drag them to one of the dots at the bottom to indicate which page you want them on.

When you've finished, if you have empty apps pages left over just press the tick and empty pages will be removed.

Edited by goodfella123
0

Share this post


Link to post
Share on other sites

Posted (edited)

I rooted then accidentally removed the stock calendar thinking it was a vodafone one.

Can i do a factory reset to bring it back?

If so, should i do that via the settings menu or do it via the recovery menu (volume up when powering on)? Does it matter if rooted?

I have backed-up all my downloaded apps via titanium so will just get that from the market when reset is done to reinstall them.

Will i need to re-root?

Edited by goodfella123
0

Share this post


Link to post
Share on other sites

Posted

I did a factory reset and the stock calendar is still f***ed, looks like i'll have to wait a long time for a new rom.

0

Share this post


Link to post
Share on other sites

Posted

I did a factory reset and the stock calendar is still f***ed, looks like i'll have to wait a long time for a new rom.

Download the system folder that Paul uploaded. Extract the calendar related apks and adb push them to system. Job done.

0

Share this post


Link to post
Share on other sites

Posted

Sorry for being a bit slow but i'm not 100% sure how to do that.

0

Share this post


Link to post
Share on other sites

Posted

Anyone able to tell me how to extract calendar and related apk's and push them to my phone.

I have the superrecovery folder and see the 5mb rom .img file and the adb-windows.exe.

I'm on win xp sp3 does that matter?

0

Share this post


Link to post
Share on other sites

Posted

just extract them using winrar or 7zip, then transfer them over to the microsd card on your phone

install root explorer and copy them over to the relevant place

reboot phone and it should then work :)

0

Share this post


Link to post
Share on other sites

Posted (edited)

Anyone able to tell me how to extract calendar and related apk's and push them to my phone.

I have the superrecovery folder and see the 5mb rom .img file and the adb-windows.exe.

I'm on win xp sp3 does that matter?

You shouldn't need to do that. just copy the file to the sdcard by mounting it in Windows like you would if you were copying music and pictures to and from the phone. Then use the normal inbuilt file explorer to open the APK file. You will just need to turn on the option in the settings to allow the installation of packages from unknown locations.

Edited by zerosignull
0

Share this post


Link to post
Share on other sites

Posted

I can't open the recovery img using winrar or 7-zip.

I have browsed to the img file on my phone using es explorer but it still won't open.

It also won't open using WUNYAFFS.

0

Share this post


Link to post
Share on other sites

Posted

I can't open the recovery img using winrar or 7-zip.

I have browsed to the img file on my phone using es explorer but it still won't open.

It also won't open using WUNYAFFS.

1-Download the extracted ROM from here:

http://files.podtwo.com/roms/stock/huawei/u8815/

2-Open the zip in windows.

3-Navigate to \system\app

4-Copy the calendar apk to your phones SDCard

5-Follow previous post of mine

0

Share this post


Link to post
Share on other sites

Posted

Managed to do all that, but when i select the apk to install, it just says 'app not installed'.

The only option i get then is 'done'.

I have the 'allow installation of unknown sources' box ticked.

0

Share this post


Link to post
Share on other sites

Posted

Copy them to the system app folder using root explorer and make sure the permissions are set the same as the rest of the apks in that folder. Job done. They wont install normally.

0

Share this post


Link to post
Share on other sites

Posted

Root explorer was £2.50 so i tried with root browser lite and copied the files to system/app but they wouldn't install.

0

Share this post


Link to post
Share on other sites

Posted

I'm a bit new to this- I've managed to start it up with the volume down held and it gets stuck on the huawei screen (bootloader mode?) but when I try to connect it to my computer, I get that USB failed noise and it doesn't come up. The cable and USB ports definitely work because I've transferred music onto the phone. What obvious step have I missed?

0

Share this post


Link to post
Share on other sites

Posted

Root explorer was £2.50 so i tried with root browser lite and copied the files to system/app but they wouldn't install.

In ES file explorer go to settings

tick - Root Explorer

tick - Mount File System

Then try pasting the file.

0

Share this post


Link to post
Share on other sites

Posted

I'm a bit new to this- I've managed to start it up with the volume down held and it gets stuck on the huawei screen (bootloader mode?) but when I try to connect it to my computer, I get that USB failed noise and it doesn't come up. The cable and USB ports definitely work because I've transferred music onto the phone. What obvious step have I missed?

Reboot phone and connect USB, under my computer one of the items should have drivers for your phone. Copy this to desktop. Then go back to bootloader, open up devices under my computer and look for the failed one. Update drivers and point it to that folder. I did that.

0

Share this post


Link to post
Share on other sites

Posted

Hi

I think I may have turned on fastboot. I cannot get into bootloader mode.

How do I turn off fastboot?

Thanks

0

Share this post


Link to post
Share on other sites

Posted

pull the batt and usb cable out

0

Share this post


Link to post
Share on other sites

Posted

Reboot phone and connect USB, under my computer one of the items should have drivers for your phone. Copy this to desktop. Then go back to bootloader, open up devices under my computer and look for the failed one. Update drivers and point it to that folder. I did that.

Cheers! I saw the driver in the non-storage android thingy and installed that and it worked! Finally got rid of the Vodafone crud.

0

Share this post


Link to post
Share on other sites

Posted

What Vodafone apps or stuff did you get rid off, Taan? I'd be curious to know as I've heard that removing some can affect the system...

0

Share this post


Link to post
Share on other sites

Posted

Hi

I think I may have turned on fastboot. I cannot get into bootloader mode.

How do I turn off fastboot?

Thanks

Found it. Fastboot option is under application settings

0

Share this post


Link to post
Share on other sites

Posted (edited)

HELP

Think I screwed this up or the instructions are a little lacking. It flashed across from W7 and I put it into recovery mode but nothing intuitive presented itself.

So i'm at a G300 screen which doesn't inspire confidence.

It says - Android system recovery <3e>

Choose a package to install:

/sdcard

../

.PocketCloud/

.android_secure/

Android/

DCIM/

Download/

LOST.DIR/

PocketCloud/

SmsContactsBackup/

media/

I can go up & down the list, using the volume control, but not to the previous screen ?

What am I missing ? Waiting patiently.

M&C

Edited by muppet&chums
0

Share this post


Link to post
Share on other sites

Posted (edited)

press the back button then pick reboot

Edited by bumps
0

Share this post


Link to post
Share on other sites

Posted (edited)

press the back button then pick reboot

Errrr. What back button ?

We go up the directory list = Volume UP

We go down the directory list = Volume DOWN

We have the on off button ( possibly 'the brick' button).

No ' Back Button ' anywhere that I can see, hardware or software.

Do you mean . . / and press the power on/off switch ?

Do I panic now ?

M&C

Edited by muppet&chums
0

Share this post


Link to post
Share on other sites

Posted

on the list of stuff you see

Choose a package to install:

/sdcard

../

.PocketCloud/

.android_secure/

Android/

DCIM/

Download/

LOST.DIR/

PocketCloud/

SmsContactsBackup/

media/

highlight ../ and press the power button

then highlight reboot system now, press power button

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.