• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Huawei loudspeaker issue DEFINITELY software related.

266 posts in this topic

Posted

Mine is B882 and the sound is now working, i downloaded the demo file and placed it on sd card, but when i installed and let it reboot, the power widget and lockscreen were missing so i went to put vendor on but only got a pink screen, so i went into sd card and removed the vendor file and demo, and went back to clockwork to restore to my nandroid backup, but clockwork had reverted back to Paul's stock, so i fixed it back to Sebs and installed my nandroid backup, then when i rebooted the phone my sound seems to be all fixed but i'm on B882

So, install b886 then revert to clockworkmod backup? :)

P

0

Share this post


Link to post
Share on other sites

Posted

So, install b886 then revert to clockworkmod backup? :)

P

Hi guys

I've been waiting ages for a break through like this one, it seems really promising already with the sound/volume fix. Although I have a few quick questions:

1. Do I need to install Clockwork to get this running. I'm currently using Pauls root method.

2. Please can someone pin a user guide for doing this...?

Thank you in advance guys!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi guys

I've been waiting ages for a break through like this one, it seems really promising already with the sound/volume fix. Although I have a few quick questions:

1. Do I need to install Clockwork to get this running. I'm currently using Pauls root method.

2. Please can someone pin a user guide for doing this...?

Thank you in advance guys!

You don't need clockwork to do this, when you download the B886 file there is info and pictures in there that show you what to do.

Edited by feckineejit
0

Share this post


Link to post
Share on other sites

Posted (edited)

With B886 i'm not getting the three buttons to light up even after a reboot

EDIT: yes they are realized i had to be in a dark place to get them to come on ;)

Edited by feckineejit
0

Share this post


Link to post
Share on other sites

Posted

You don't need clockwork to do this, when you download the B886 file there is info and pictures in there that show you what to do.

Hi feckin,

Just a quick one... In your post you mentioned something about "removing the vendor file" I'm totally confused with these terms... ☺

0

Share this post


Link to post
Share on other sites

Posted

With B886 i'm not getting the three buttons to light up even after a reboot

Maybe a bug...?!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi feckin,

Just a quick one... In your post you mentioned something about "removing the vendor file" I'm totally confused with these terms... ☺

I done it wrong first time thats all.

what i done was download "demo U8815 V100R001C185B886" extract it to desktop,

inside that folder there is 4 files, if you open the dload folder you will notice there is another dload folder, i copied that folder along with the file onto my sd card,

then power off phone,

Start phone up holding vol+ and volume - at the same time then power on, (hold for a few seconds)

it will go through the process of installing the file,

let it reboot itself,

when phone is fully rebooted install the vendor folder onto your sdcard naming the folder "dload"

Power off again, hold the Vol+ and vol- at the same time and power button, let it do what it has to do and that should be it sorted.

That's how i done it, if my info is a bit hard to follow, the info in the file is much better,

Good luck

Edited by feckineejit
0

Share this post


Link to post
Share on other sites

Posted (edited)

I done it wrong first time thats all.

what i done was download "demo U8815 V100R001C185B886" extract it to desktop,

inside that folder there is 4 files, if you open the dload folder you will notice there is another dload folder, i copied that folder along with the file onto my sd card,

then power off phone,

Start phone up holding vol+ and volume - at the same time then power on, (hold for a few seconds)

it will go through the process of installing the file,

let it reboot itself,

when phone is fully rebooted install the vendor folder onto your sdcard naming the folder "dload"

Power off again, hold the Vol+ and vol- at the same time and power button, let it do what it has to do and that should be it sorted.

That's how i done it, if my info is a bit hard to follow, the info in the file is much better,

Good luck

Dumb question... if you do it this way, will you lose all the installed apps and data? Or is this just flashing changing the ROM, leaving everything else at it was?

Another question, if we first install the clockwork recovery, will this affect somehow the handset if we flash it using the method mentioned here for B886 or the recovery will be "always there"?

Thanks and sorry for such a basic questions..

Cheers!

Edited by dancg
0

Share this post


Link to post
Share on other sites

Posted

My buttons weren't lighting up on stock rom so its not a bug and I'm sure it doesn't matter what background lighting is like

0

Share this post


Link to post
Share on other sites

Posted

Not sure if its just me but the signal strength is degraded substantialy. Going back to orginal vodafone rom until volume fix is released.

0

Share this post


Link to post
Share on other sites

Posted

Not sure if its just me but the signal strength is degraded substantialy. Going back to orginal vodafone rom until volume fix is released.

Yes!. I restored my cwm backed up vodafone rom and the speaker is still loud!

0

Share this post


Link to post
Share on other sites

Posted

Dumb question... if you do it this way, will you lose all the installed apps and data? Or is this just flashing changing the ROM, leaving everything else at it was?

Another question, if we first install the clockwork recovery, will this affect somehow the handset if we flash it using the method mentioned here for B886 or the recovery will be "always there"?

Thanks and sorry for such a basic questions..

Cheers!

Yes, the Huawei demo one will wipe all data, so you will lose everything. Best bet to keep them is follow the route above and make a backup with clockwordmod.

0

Share this post


Link to post
Share on other sites

Posted

Interesting, I intsalled the B884 update, which fixed the voume, and then I restored my debranded ROM (based on B882) and the volume fix still seems in place, so it seems the fix has something to do with something thats outside the scope of the normal system (AudioFilter.csv is identical)..

still, job done

0

Share this post


Link to post
Share on other sites

Posted

Not sure if its just me but the signal strength is degraded substantialy. Going back to orginal vodafone rom until volume fix is released.

If I am not mistaken the bars on the screen bear no resemblence to actual signal strength they are simply a visual representation of it and if the code is to show 3 bars at a certain strength you can also have code that shows 4 bars at the same strength so although you see less bars the strength may be the same. The code might just be different in this rom.

0

Share this post


Link to post
Share on other sites

Posted

If I am not mistaken the bars on the screen bear no resemblence to actual signal strength they are simply a visual representation of it and if the code is to show 3 bars at a certain strength you can also have code that shows 4 bars at the same strength so although you see less bars the strength may be the same. The code might just be different in this rom.

Yeah i'm pretty sure this is accurate. Only real way to tell is check actual signal strength in phones about part.

0

Share this post


Link to post
Share on other sites

Posted

Not sure if its just me but the signal strength is degraded substantialy. Going back to orginal vodafone rom until volume fix is released.

today at work i noticed it to be improved over voda rom was still getting a signal in places i would normaly not since having this phone

0

Share this post


Link to post
Share on other sites

Posted

If I am not mistaken the bars on the screen bear no resemblence to actual signal strength they are simply a visual representation of it and if the code is to show 3 bars at a certain strength you can also have code that shows 4 bars at the same strength so although you see less bars the strength may be the same. The code might just be different in this rom.

well I went to the pub for a pint (as you do) and sat in my usual place and i had no signal at all. The same for the 3g signal, no data connection.

but now i've gone back to the original rom and the volume is still loud so i'm not worried now.

0

Share this post


Link to post
Share on other sites

Posted

Hi guys

Not wanting to take over the thread or anything, but shouldn't this thread be marked as "Fixed" now. Just so everyone else is aware...?

Thanks

0

Share this post


Link to post
Share on other sites

Posted

Well it's not fixed as such .... Huwaei or Vodafone have not issued a firmware update for normal users.

It's only fixed if you are willing to root your device, install CWM and install different firmware.

Keith

0

Share this post


Link to post
Share on other sites

Posted (edited)

Well it's not fixed as such .... Huwaei or Vodafone have not issued a firmware update for normal users.

It's only fixed if you are willing to root your device, install CWM and install different firmware.

Keith

Well you don't need any of that really, the update can be done on a completely new and untouched device.

The big issue is what if something goes wrong? Without CWM you won't have a backup so if something bad does happen you can't revert back and even if everything goes well you would still be left with the newer (de branded) firmware.

Saying that I agree with you though that the thread should not be changed to fixed just yet as neither vodafone not huawei have issued a fix and until we get that I think the pressure should stay on them.

Edited by FlatPackPete
0

Share this post


Link to post
Share on other sites

Posted

Ah OK, what if I have everything backed up to the SD card with Titanium backup, can I flash the new FW then recover with that?

Keith

0

Share this post


Link to post
Share on other sites

Posted

Ah OK, what if I have everything backed up to the SD card with Titanium backup, can I flash the new FW then recover with that?

Keith

Yeah no problem :)

0

Share this post


Link to post
Share on other sites

Posted

was told by vodafone store today that all stock had been returned to Huawei to fix the sound issue so can't buy.

0

Share this post


Link to post
Share on other sites

Posted

was told by vodafone store today that all stock had been returned to Huawei to fix the sound issue so can't buy.

That's ridiculous. But at least they are doing something I suppose. But why not just a software update ota?

0

Share this post


Link to post
Share on other sites

Posted (edited)

That's ridiculous. But at least they are doing something I suppose. But why not just a software update ota?

I cant understand them doing it but they need to get the back in the stores quick as people will still want/ask for them & if they dont get them they'll more than likely leave cost Vodafone money.

never know...if they have they might put ICS on them ;) lol...yeah right lol

Edited by FrankieADZ
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.