Sign in to follow this  
Followers 0
timbeam

Wifi randomly disconnects...

18 posts in this topic

Hi Guys,

My brand new G300 just arrived this morning and first impressions are very good indeed - massive upgrade on the San Francisco!

Only problem I am experiencing at the minute is that the wifi randomly disconnects and then instantly reconnects every couple of minutes. This rather annoyingly causes a prompt to appear onscreen warning about data charges and obviously disrupts anything you may be streaming at the time.

Has anyone got any suggestions as to how to fix this issue or has anyone else experienced a similar problem?

Thanks!

0

Share this post


Link to post
Share on other sites

Hi Guys,

My brand new G300 just arrived this morning and first impressions are very good indeed - massive upgrade on the San Francisco!

Only problem I am experiencing at the minute is that the wifi randomly disconnects and then instantly reconnects every couple of minutes. This rather annoyingly causes a prompt to appear onscreen warning about data charges and obviously disrupts anything you may be streaming at the time.

Has anyone got any suggestions as to how to fix this issue or has anyone else experienced a similar problem?

Thanks!

I think mine done this right at the start after I first tried to connect to wifi, I told it to forget connection rebooted phone and imputed wifi key again and it's not done it since. Also on a plus not it seems to shut of wifi once the screen has been closed for a while and then turns it back on when you unlock phone which should save a lot of battery. Maybe it mentions it in the instructions I think i should read them at some point.

0

Share this post


Link to post
Share on other sites

That solution worked for me on a ZTE CrescentTMV/SFII....

just forget the wifi in settings, and let it find again, re-enter encryption key

0

Share this post


Link to post
Share on other sites

Thanks for the suggestion but unfortunately that hasn't worked! :(

Told it to forget the network, rebooted the phone, set it back up again - worked fine for about 5 mins then it dropped the connection and instantly reconnected!

It's a really annoying problem, everything else is working a treat.

Thanks for your help!

0

Share this post


Link to post
Share on other sites

I had a few problems with mine, I did a factory wipe and that sorted mine out. just do it under the privacy in settings

0

Share this post


Link to post
Share on other sites

I also have this issue. Thought it was the tethering to the blade that was the issue. Will try the factory reset. Could this be fixed in software if its a widespread issue?

0

Share this post


Link to post
Share on other sites

Factory reset made no difference whatsoever :(

The only thing I have had any success with is setting my phone to connect with a static ip address. Thankfully, this seems to have solved the problem! At the very least it has greatly improved it. Will just have to see how I get on over the next few days.

I am reluctant to pay for an unlock until I'm confident that this is working correctly. A stable wifi connection is essential for me and if I continue to have problems I'm afraid it will have to go back! :(

0

Share this post


Link to post
Share on other sites

it might be your router have you tried it at different places?

0

Share this post


Link to post
Share on other sites

it does it. when right next to my phone when tethering so it's not distance based.

0

Share this post


Link to post
Share on other sites

You can see the WiFi signal on the phone jumping. it goes from full to one bar to full to one bar. I think it's more a bug than hardware.

0

Share this post


Link to post
Share on other sites

Is this a Netgear router?

I've got an old Netgear WGR614 v6 and the wireless works fine with mine.

I would have thought if it was an inherent software problem then it would be a bit more widespread, like the sound problem.

It might sound a bit obvious but you could try changing the channel in the router's wireless settings in case there's a bit of interferance on the one you're using.

0

Share this post


Link to post
Share on other sites

I have not noticed this. As someone said though it does turn wifi off of the phone is on standby for a while.

0

Share this post


Link to post
Share on other sites

I have a very old Belkin router - maybe that could be an issue???

I'll try changing the channel as suggested but I've never had a problem with anything else before and I have several devices connected to it.

Thanks for the continued suggestions ;)

EDIT:

Changing the channel made no difference. However, I have it working with a static ip address and was able to stream a 10 minute clip without and dropped connection. That will have to do for now as a fix I guess. I will try it with my brother's router when I get a chance ;)

Cheers for the suggestions!

Edited by timbeam
0

Share this post


Link to post
Share on other sites

The problem does sound like it may be router-based.

If I were you I'd check to see if there is a more up-to-date firmware for your router. I had severe problems with my old router at home with one or two devices until I checked and discovered there were firmware updates available which resolved the problems.

It can be a little bit of a hassle to update your router's firmware (it can require you to set up your network and password once again), but in the long run, it is probably worth it.

0

Share this post


Link to post
Share on other sites

I had issues like this on a Huawei U8800 which I resolved by changing my routers DHCP lease time from 'Forever' to 'Two Weeks'. I have a Belkin router.

I'm not entirely sure how this made a difference but since changing this I've not had any wifi issues with any phone.

0

Share this post


Link to post
Share on other sites

I had issues like this on a Huawei U8800 which I resolved by changing my routers DHCP lease time from 'Forever' to 'Two Weeks'. I have a Belkin router.

I'm not entirely sure how this made a difference but since changing this I've not had any wifi issues with any phone.

I've no idea why it works either but it does!

Thanks a lot for that, works a charm!

0

Share this post


Link to post
Share on other sites

Just to say this very same issue has arisen on my G300 too, again with a 2 year old Belkin router. Changing the router settings to 2 weeks also seems to have worked for me. Strange, as all of my other (numerous) wi fi phones have all been rock steady on wi fi. Definitely a G300 issue of some description.

Thanks for the tip.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.