• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

ClockworkMod Recovery for Huawei U8815/Ascend G 300

269 posts in this topic

Posted · Report post

Is anyone getting any lag or freezing on the lock screen. I am rooted and have the clockworkmod recovery image installed. The lag seems to have appeared after the cwm recovery image was installed.

It can happen on the lock screen, and in the rom itself and when this happens, the capacitive touch buttons usually don't light up or work.

A reboot fixes it sometimes but mostly it doesn't and it can lag after a battery pull also.

Could the clockworkmod recovery image have caused this.

I did a full wipe and installed the debranded rom by sebastian and installed no apps, just set up my account and its lagging again.

I tried posting a log before but uploads appear broken on the new modaco layout.

Any advice to offer me and will flashing the stock rom on Sebastian's page break the rooting that was done so it will have to be rooted again?

Contemplating a return of the phone as its only a week old.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Phone now frozen at lockscreen. Reboot or battery pull doesn't fix. I can reboot into clockworkmod recovery but I can't select anything. Volume moves selection up and down but home does not select.

Lockscreen icon doesn't budge at all.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It sounds like you have some hardware problems there, I'd take it back and see if you can get it swapped

1

Share this post


Link to post
Share on other sites

Posted · Report post

Cheers for that Sebastian, will return it tomorrow. Will have to pay for unlock again is a bit of a bummer

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've successfully installed the "super recovery" but on trying to install Clockworkmod I get:

# fastboot-linux flash recover recovery-clockwork-4.0.1.5s-hwu8815.img

sending 'recover' (5212 KB)... OKAY

writing 'recover'... FAILED (remote: partition table doesn't exist)

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've successfully installed the "super recovery" but on trying to install Clockworkmod I get:

# fastboot-linux flash recover recovery-clockwork-4.0.1.5s-hwu8815.img

sending 'recover' (5212 KB)... OKAY

writing 'recover'... FAILED (remote: partition table doesn't exist)

fastboot-linux flash recovery recovery-clockwork-4.0.1.5s-hwu8815.img

0

Share this post


Link to post
Share on other sites

Posted · Report post

fastboot-linux flash recovery recovery-clockwork-4.0.1.5s-hwu8815.img

*Sigh*. Sorry. And thank you.

Where's your tip jar?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've rooted my G300 and installed ClockworkMod and also installed ROM Manager.

If i try and use the ROM Manager 'Backup current ROM' option it tells me i don't have ClockworkMod installed and offers to install it.

I click no - if i clicked yes would it install a version of ClockworkMod that is incompatible with the G300?

Is there any way to tell ROM Manager that i DO have a working version of ClockworkMod already installed?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I've rooted my G300 and installed ClockworkMod and also installed ROM Manager.

If i try and use the ROM Manager 'Backup current ROM' option it tells me i don't have ClockworkMod installed and offers to install it.

I click no - if i clicked yes would it install a version of ClockworkMod that is incompatible with the G300?

Yes it would attempt to install an incompatible recovery that may brick your device.

Is there any way to tell ROM Manager that i DO have a working version of ClockworkMod already installed?

No. ROM manager only functions with officially supported recovery images that have been built by the developer of ROM manager (Koush). The G300 recovery image is unofficial.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I always thought there was an option to tell it, actually i do have some form of recovery installed thanks.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I always thought there was an option to tell it, actually i do have some form of recovery installed thanks.

Yes there is but if I remember right it doesn't let you access recovery or make backups if you use this option.. unless it changed? Sebastian404 may sort his own recovery manager out soon.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

anyone got a problem of when you power the phone off with usb plugged in CWM automatically comes on

Edited by bumps
0

Share this post


Link to post
Share on other sites

Posted · Report post

anyone got a problem of when you power the phone off with usb plugged in CWM automatically comes on

Thats a 'common' problem with all the Huawei devices I've seen, I have a feeling its something to do with the broken implmentation of a charging animation when powered off.

0

Share this post


Link to post
Share on other sites

Posted · Report post

yup you are right, did a little research on google. common bug when any phone has a charging animation with its original recovery.img

0

Share this post


Link to post
Share on other sites

Posted · Report post

OK having spent the last 3 hours going round in circles im am about to give up. I have never atempted anything like this.

I have managed to root the phone which i think went OK i can see SU installed.

So now i want to ClockworkMod it.

I followed the link and have installed Android SDK. and downloaded the file "Recovery image"

Where i am getting stuck is the Command Prompt run 'fastboot flash recovery <filename>.img.

Where does the fastboot bit come in, is this a seperate download?

Then What, run that and then type "Recovery"?

I am a noob, be gentle!

Carl..

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

sorry wrong post

Edited by feckineejit
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I think i've got the clockwork installed now, when i go into it, it says CWM -based recovery v4.0.1.5 but when i try to accept any of the options like backup etc, it just sits on the picture of the hat, if i go down the list and click an option etc: "install zip from sdcard" it just pops up the hat and sits there doesnt go into sdcard, if i push power button it goes back to the options. i need to pull battery as well for "reboot system now" as the power button does not restart it. anyone know what ive done wrong

some clockworks mod use power button, this one use the the 3 buttons @ bottom of screen (and volume rockers) namely the home (house symbol) to execute your choice

Edited by Gary_J_Wright
0

Share this post


Link to post
Share on other sites

Posted · Report post

Here we go, this is *MY* customized build of Koush's ClockworkMod Recovery .Ascend G 300....

Just a note to say thanks for this installed no problems. Hardest part was 1) remembering the home key not power 2) Vol up not vol down like the upside down ZTE blade!

Another great release from Seb thanks so much noticed your touch based recovery tool might try that tomorrow! You are an asset to the Modaco and Android communities.

Many Thanks Seb!

0

Share this post


Link to post
Share on other sites

Posted · Report post

sorry 4 my noobness now,

can i do a back up of my rom in CMR?.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes you can Frankie.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes you can Frankie.

Cheers for that :D

part of me in kinda hoping CMR gets official support tbf..just for the fact I paid for the premium version lol

0

Share this post


Link to post
Share on other sites

Posted · Report post

<p>

part of me in kinda hoping CMR gets official support tbf..just for the fact I paid for the premium version lol

the only way devices seem to get into RomManager is if there's is an 'offical' build of CyanMod or someone send Koush a device directly.

0

Share this post


Link to post
Share on other sites

Posted · Report post

<p>

the only way devices seem to get into RomManager is if there's is an 'offical' build of CyanMod or someone send Koush a device directly.

if i find a spare couple a hundred quid i might well do that ;) :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

Will ADB made easy work to fastboot recovery ? It works on my skate,and I am just lazy and want to push one button,rather than type out some commands,which I am a little rusty on.I think,going off memory from my blade days here,the commands where: cd C:\fastboot fastboot flash recovery recovery.img

Does that sound about right ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm not entirely sure but I think Paul said the fastboot method didn't work hence the super recovery method. I may be well off here.

I quote from Paul

Strangely, 'fastboot boot' doesn't work on the

G300 so the usual superboot approach won't

work, so i've created a 'SuperRecovery'. This is

a stock recovery image with 2 changes - firstly

the ADB access is upgraded to root, secondly

the recovery will automatically install

Superuser / SU on start (in the same way as a

superboot). This means it will give you root

while maintaining compatability with stock

upgrades applied via the stock recovery.

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.