• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

ClockworkMod Recovery for Huawei U8815/Ascend G 300

269 posts in this topic

Posted · Report post

It is possible to flash CWM recovery on a brand new phone without rooting it first.

Start in bootloader mode (Vol Down + Power) and use the "fastboot flash recovery <filename>.img" command, to install CWM.

Now you can use CWM recovery to load up your pre-rooted ROM of choice.

1

Share this post


Link to post
Share on other sites

Posted · Report post

t bon, I doubt it. If you think about it, phones are released so as the average customer won't flash something and break their phone. Rooting opens an exploit so as you gain greater access to the phone. Its a good question but someone with more knowledge can confirm.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

Can anyone offer any advice please? .. whenever I try to install CMW I get the following message?

fastboot-windows.exe flash recovery recovery.img

sending 'recovery' (5212 KB)... OKAY

writing 'recovery'... FAILED (remote: Command not allowed)

Help?!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Are you trying to install CWM after upgrading to ICS? If so then that error normally means that your bootloader is still locked and needs to be unlocked before you can flash the recovery.

0

Share this post


Link to post
Share on other sites

Posted · Report post

t bon, I doubt it. If you think about it, phones are released so as the average customer won't flash something and break their phone. Rooting opens an exploit so as you gain greater access to the phone. Its a good question but someone with more knowledge can confirm.

It works. In fact that's how I've rooted every (2) Android devices I've owned.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for clarifying Dazzozo

0

Share this post


Link to post
Share on other sites

Posted · Report post

Note this is a Customized version, that will handle the 2 extra partitions Huawei use this means backups made with this version will only be partly compatible with vanilla versions of Clockwork Mod Recovery.

I have the 'Rom Manager' app installed. (I've upgraded to stock ICS, rooted and installed ClockworkMod Recovery.) When I start the Rom Manager app, it does not recognise Seb's version of Clockwork Mod and offers to install it. Would this be the vanilla version, and therefore not fully compatible?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have the 'Rom Manager' app installed. (I've upgraded to stock ICS, rooted and installed ClockworkMod Recovery.) When I start the Rom Manager app, it does not recognise Seb's version of Clockwork Mod and offers to install it. Would this be the vanilla version, and therefore not fully compatible?

Rom Manager doesnt isnt support this Phone...by that i mean not official support for thing like ROMs and all that.

you'll have to do stuff like back ups and stuff like that by the old button press way.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Thanks - as Seb had to make his own version of ClockworkMod Recovery to work with the G300, I'd assumed that Rom Manager wasn't going to work. However, I'm just curious as to what would happen if I let Rom Manager install the version of CWM Recovery it's currently offering me.

Edited by Geoff2
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks - as Seb had to make his own version of ClockworkMod Recovery to work with the G300, I'd assumed that Rom Manager wasn't going to work. However, I'm just curious as to what would happen if I let Rom Manager install the version of CWM Recovery it's currently offering me.

if the app maker would give it official support...it certainly would be nice. :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Geoff, as its not Supported, your phone type g300 won't appear so you would be installing a recovery from the wrong phone with unknown results or consequences.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Something I have noticed about CWM on the G300 is that the backups fail the md5 check if you rename the backup folders. I'm sure I used to rename my folders to something more memorable than a time and a date on my Blade and they'd restored fine. Am I misremembering that? I know ROM Manager let you chose a name for the folder if you initiated the backup from within the app, but I'm sure I've just renamed the folders in the past.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Something I have noticed about CWM on the G300 is that the backups fail the md5 check if you rename the backup folders. I'm sure I used to rename my folders to something more memorable than a time and a date on my Blade and they'd restored fine. Am I misremembering that? I know ROM Manager let you chose a name for the folder if you initiated the backup from within the app, but I'm sure I've just renamed the folders in the past.

remember that too, but i think thats cos the Blade was supported by ROM Manager.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

i see theres a ClockworkMod Recovery V6 then....

also I see someone has gone and done a Huawwei u8815 version too,(in the recovery builder thingy; here: http://builder.clockworkmod.com/ )

Edited by FrankieADZ
0

Share this post


Link to post
Share on other sites

Posted · Report post

i see theres a ClockworkMod Recovery V6 then....

also I see someone has gone and done a Huawwei u8815 version too,(in the recovery builder thingy; here: http://builder.clockworkmod.com/ )

anyone tried it yet? ;)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Something I have noticed about CWM on the G300 is that the backups fail the md5 check if you rename the backup folders. I'm sure I used to rename my folders to something more memorable than a time and a date on my Blade and they'd restored fine. Am I misremembering that? I know ROM Manager let you chose a name for the folder if you initiated the backup from within the app, but I'm sure I've just renamed the folders in the past.

The same happened to my when I changed names but it was changed from Windows with the SD mounted. I have changed the names directly inside android system using File Manager or Root Explorer, and it works.

Regards.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

The same happened to my when I changed names but it was changed from Windows with the SD mounted. I have changed the names directly inside android system using File Manager or Root Explorer, and it works.

Regards.

That's interesting to know thanks

edit: hmm tried that with a couple of different root explorers and still getting md5 mismatch

Edited by Hans Gruber
0

Share this post


Link to post
Share on other sites

Posted · Report post

I do this every time and it works.

Maybe is a problem that this Cwm has when wipe/format. Try to "restart recovery" once you have made the wipe/format, then restore.

Regards.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is anyone got "waiting for device" when press enter in cmd?

0

Share this post


Link to post
Share on other sites

Posted · Report post

If i use TWRP it works fine but certain roms wont install like the 'HTCMania' one this made me try clockworkmod recovery but this just stays on a loading screen when i try and do something?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is anyone got "waiting for device" when press enter in cmd?

If this happens, is because the phone is not detected.

Make sure you are in fastboot mode (power on the phone using power and vol- at the same time), and you have installed the ADB drivers.

Regards.

0

Share this post


Link to post
Share on other sites

Posted · Report post

If i use TWRP it works fine but certain roms wont install like the 'HTCMania' one this made me try clockworkmod recovery but this just stays on a loading screen when i try and do something?

I don´t know if the loading screen you are talking about is the one you get when you use the power button to "select" an option. The HOME button must be used to select the options.

Regards.

0

Share this post


Link to post
Share on other sites

Posted · Report post

oh ok thanks i will try this now but any reason why these roms wont install with TWRP?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

That's interesting to know thanks

edit: hmm tried that with a couple of different root explorers and still getting md5 mismatch

I've just tried and It worked for me, I made the backup, changed its name and restored. What you get if don't reboot recovery after wipe/format, is "systema can't be format" when tried to restore.

Regards

Edited by elperroderoke
0

Share this post


Link to post
Share on other sites

Posted · Report post

I've just tried and It worked for me, I made the backup, changed its name and restored. What you get if don't reboot recovery after wipe/format, is "systema can't be format" when tried to restore.

Regards

For me it doesn't even get that far. It fails when checking the md5 at the start. From memory my old phone had version 5.x or CWM. Maybe that had some option to skip the md5 check or something

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.