• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ROM] VegaCream for Advent Vega / PoV Mobii Tegra

230 posts in this topic

Posted · Report post

I have a humble request.

We now have /system/app and /system/framework and others on .sfs files.

This make it almost impossible to flash a .zip from CWM that changes anything on that files (or folders after the mount).

Given that SD card prices as comming down pretty fast, and that a 32gb can be had for about 20€, would it be too much to implement /system on NAND and cache/data on a SD partition ?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I have a humble request.

We now have /system/app and /system/framework and others on .sfs files.

This make it almost impossible to flash a .zip from CWM that changes anything on that files (or folders after the mount).

Given that SD card prices as comming down pretty fast, and that a 32gb can be had for about 20€, would it be too much to implement /system on NAND and cache/data on a SD partition ?

Putting /system on a sdcard is not really possible. This has to do with the boot loader. The boot loader is looking for the kernel on a fixed position, so that cannot be changed. Besides putting /system on a sdcard means that you cannot take out the sdcard anymore. Also you cannot use nvflash anymore (I think). The nvflash mode on the tablet is closed and I do not know if the sdcard can be accessed from nvflash. I think /data can be put on sdcard, but it will need some adjusting in the kernel, the recovery (the recovery needs to know where /data is when flashing a zip file and that is defined in a partition layout at compile time). I do not know if it needs changes in the android sources.

Edited by Scanno
0

Share this post


Link to post
Share on other sites

Posted · Report post

Putting /system on a sdcard is not really possible. This has to do with the boot loader. The boot loader is looking for the kernel on a fixed position, so that cannot be changed. Besides putting /system on a sdcard means that you cannot take out the sdcard anymore. Also you cannot use nvflash anymore (I think). The nvflash mode on the tablet is closed and I do not know if the sdcard can be accessed from nvflash. I think /data can be put on sdcard, but it will need some adjusting in the kernel, the recovery (the recovery needs to know where /data is when flashing a zip file and that is defined in a partition layout at compile time). I do not know if it needs changes in the android sources.

Scanno:

would it be too much to implement /system on NAND and cache/data on a SD partition

System on NAND is possible, but not easy. Remember that Ubuntu for Vega, everything was on SD, and there are those "boot from SD" using Haret/Special Loaders.

But that's not what i meant, /System can remain on NAND, perhaps also /cache, it will always be faster than any sdcard.

Data on SDCARD has 2 advantages IMHO:

- Space... we decide the size of the partition and

- /system get much cleaner, more AOSP without yaffs hacks to gain precious MB.

The disadvantage is:

- We cannot remove the SDCARD (while running), and

- Speed. But we are already moving as much as we can to /sdcard (via normal android methods), so i don't belive we would feel such speed loss.

Of course i'm highly ignorant, perhaps i'm missing something. Also, if we're partitioning the SDcard, we could create another 512mb (or similar) partition for SWAP.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Another quick one : Wifi Hotspot is not working right ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Another quick one : Wifi Hotspot is not working right ?

Did you try?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, i did. It stays on "Switching Wifi" or whatever it is in English (i'm on Portuguese language).

And that's it. The SSID never shows up on searches... i just asked to be sure if i was the only one :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Have updated to beta 2.1 and link2sd is working again :D did have a problem with touchscreen on first boot but powered off and on and all was ok :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Initial tests with my PoV Mobii seems to be going great! 3G working without a hitch it seems, I'll just have to test it a bit more. Wifi connected nicely at first start, even with hidden SSID.

Great work Scanno and everyone else involved in bringing this to the masses!

Looking forward to future releases...

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Same here, this ROM gave PoV Mobii new life, very pleasant surprise to see GPS actually working, previously I thought it was failing because of bad antenna. Only disappointment after couple hours testing was that bluetooth seems not to pair, starts ok but does not find any device and vice versa, other decives are not seeing the tablet.

Any idea would it be possible to replace only the bt-module(s) from some other ROM where it has been proven functional?

Edited by Crawlerr
0

Share this post


Link to post
Share on other sites

Posted · Report post

Same here, this ROM gave PoV Mobii new life, very pleasant surprise to see GPS actually working, previously I thought it was failing because of bad antenna. Only disappointment after couple hours testing was that bluetooth seems not to pair, starts ok but does not find any device and vice versa, other decives are not seeing the tablet.

Any idea would it be possible to replace only the bt-module(s) from some other ROM where it has been proven functional?

My Viewpad 10S paired with my shitty BeeWi BBH100 and i played music via A2DP (with the expected WiFi VS BT problem).

Check you setup, it might be PoV dependent, but i doubt it.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Seems that the planets are aligned better today since after fresh boot bluetooth worked as it should, repeated same test yesterday probably 20 times without success. All good now.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi All!

I seem to be having some trouble with my Wi-Fi connection on this rom. I just installed it now and it doesn't connect to my BT Home Hub 3 at all. It finds it and I can type in the code but it then disappears and another with the same SSID shows up in the list but it doesn't think it has the password for it. I couldn't connect on VegaICS either, so I'm not really sure what the problem is. I'll try the stock rom or ModdedStockv2 and report back but in he mean time does anyone have any ideas? I'm thoroughly stumped :huh:

Will :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi All!

I seem to be having some trouble with my Wi-Fi connection on this rom. I just installed it now and it doesn't connect to my BT Home Hub 3 at all. It finds it and I can type in the code but it then disappears and another with the same SSID shows up in the list but it doesn't think it has the password for it. I couldn't connect on VegaICS either, so I'm not really sure what the problem is. I'll try the stock rom or ModdedStockv2 and report back but in he mean time does anyone have any ideas? I'm thoroughly stumped :huh:

Will :)

I have this problem as well with my BT Homehub (though its not vega related issue as I have had the same issue with my phone), what I normally do is give it a restart, after that it works fine

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have this problem as well with my BT Homehub (though its not vega related issue as I have had the same issue with my phone), what I normally do is give it a restart, after that it works fine

Thanks for your response. After hours of fiddling with all sorts of settings I finally found that changing the channel my router was using to 11, or it may have been 1 I can't remember, managed to get me connected consistently and it hasn't failed yet. Also, if yours has this you can try connecting the Vega to the BT OpenZone thing, that worked fine for me also.

Will

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have VegaCream Beta 2.1 running in my Advent Vega. It runs incredibly fast. Wifi is Ok. I haven't tested BT yet. The only problem I have is that I cannot mount my USB pendrive. I have searched through Internet but none of the solutions were valid for me.

I hope someone can give me some advice to solve this, provided that mounting USB pen drives can be done in ICS.

Thank you very much.

0

Share this post


Link to post
Share on other sites

Posted · Report post

hi,

i'm on bet1.

it's a very beatiful and stable rom, but skype doesn't work :(

i'm 2 other problems:

1) stop rotate button (not on the screen) doesn't work;

2) when i put on standby (screen off) the vega; if i don't turn on vega after 1 hour (i think) vega put automatically totaly off. then i can only re-turn on completely the vega.

excuse e for my english.

bye

db

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Scanno et all:

Now that aparently you reached not only stability but a mostly complete rom, where to next ? :D

CM9/AOKP ?

Since we have a front facing camera, how hard would it be to enable face unlock ? How about video call?

How difficult/cumbersome would it be to release a rom with all NAND occupied with /system and recovery etc, and data + cache on the SD - Card ?

Edited by Daedric1383
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Can someone with the Huawei em770w modem confirm if GPS is working for them. I have read somewhere that it should be but I have got hold of a few of them and I cant get GPS working on any of them. Does android send the AT command to switch on gps on the modem? If it dosen't maybe the gps needs to be switched on this way. Can anyone advise me of how to send AT commands to the modem in android?

Cheers

Richard

Also,

The integrated Voice search and most voice/microphone apps like skype and soundhound dont work

This is what logcat has to say when trying voice seach from the voice widget. Beta 2.1

I/ActivityManager( 167): START {act=android.speech.action.WEB_SEARCH flg=0x1080

0000 cmp=com.google.android.voicesearch/.RecognitionActivity} from pid 446

D/audio_hw_primary( 104): Using HDMI audio

D/audio_hw_primary( 104): start_output_stream: card:0, port:2, rate:48000

I/ActivityManager( 167): Start proc com.google.android.voicesearch for activity

com.google.android.voicesearch/.RecognitionActivity: pid=7066 uid=10051 gids={3

002, 3003, 1015}

I/ActivityThread( 7066): Pub com.google.android.voicesearch: com.google.android.

voicesearch.AudioProvider

D/dalvikvm( 7066): GC_CONCURRENT freed 332K, 8% free 5799K/6279K, paused 2ms+1ms

D/dalvikvm( 7066): GC_FOR_ALLOC freed 244K, 10% free 5877K/6471K, paused 14ms

D/dalvikvm( 7066): GC_FOR_ALLOC freed 157K, 9% free 5900K/6471K, paused 21ms

D/dalvikvm( 7066): GC_FOR_ALLOC freed 156K, 10% free 5923K/6535K, paused 15ms

D/dalvikvm( 7066): GC_FOR_ALLOC freed 158K, 9% free 5947K/6535K, paused 13ms

D/dalvikvm( 7066): GC_FOR_ALLOC freed 198K, 10% free 5997K/6599K, paused 14ms

D/dalvikvm( 167): GC_EXPLICIT freed 527K, 33% free 11364K/16903K, paused 2ms+5m

s

D/androidNetworkLocationListeners( 5244): Still have listener com.google.android

.location.internal.client.NetworkLocationClient$1@41041e30

E/WifiStateMachine( 167): set suspend optimizations failed!

D/androidNetworkLocationListeners( 5244): Still have listener com.google.android

.location.internal.client.NetworkLocationClient$1@41041e30

D/NetworkLocator( 5244): null cell state delivered

D/NetworkLocator( 5244): null cell state delivered

D/dalvikvm( 7066): GC_CONCURRENT freed 343K, 8% free 6138K/6663K, paused 2ms+2ms

I/RecognitionControllerImpl( 7066): startRecognition(RecognitionParameters{sessi

on=null,request=0})

I/RecognitionControllerImpl( 7066): State change: STARTING -> STARTING

I/RecognitionControllerImpl( 7066): New mic stream.

D/audio_hw_primary( 104): adev_get_input_buffer_size: sample_rate: 8000, format

: 1, channel_count:1

D/audio_hw_primary( 104): check_input_parameters: rate:8000, format:1, count:1

D/audio_hw_primary( 104): get_input_buffer_size: rate:8000, format:1, count:1

D/audio_hw_primary( 104): check_input_parameters: rate:8000, format:1, count:1

D/audio_hw_primary( 104): adev_get_supported_devices

D/audio_hw_primary( 104): adev_open_input_stream: channel_count:1

D/audio_hw_primary( 104): check_input_parameters: rate:8000, format:1, count:1

D/audio_hw_primary( 104): get_input_buffer_size: rate:8000, format:1, count:1

D/audio_hw_primary( 104): check_input_parameters: rate:8000, format:1, count:1

I/MicrophoneInputStream( 7066): #new 1

F/libc ( 7066): Fatal signal 4 (SIGILL) at 0x50f4a084 (code=1)

I/ActivityManager( 167): Start proc com.google.android.gsf.login for service co

m.google.android.gsf.login/com.google.android.gsf.loginservice.GoogleLoginServic

e: pid=7087 uid=10010 gids={3003, 1015, 1007, 2001, 3006}

D/libEGL ( 7066): loaded /system/lib/egl/libGLES_android.so

D/libEGL ( 7066): loaded /system/lib/egl/libEGL_tegra.so

D/libEGL ( 7066): loaded /system/lib/egl/libGLESv1_CM_tegra.so

I/Process ( 167): Sending signal. PID: 7066 SIG: 3

I/dalvikvm( 7066): threadid=3: reacting to signal 3

I/dalvikvm( 7066): Wrote stack traces to '/data/anr/traces.txt'

D/libEGL ( 7066): loaded /system/lib/egl/libGLESv2_tegra.so

I/ActivityManager( 167): No longer want com.google.android.gsf.login (pid 7087)

: hidden #1

D/OpenGLRenderer( 7066): Enabling debug mode 0

I/ActivityManager( 167): Displayed com.google.android.voicesearch/.RecognitionA

ctivity: +626ms

I/DEBUG ( 6197): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *

**

I/DEBUG ( 6197): Build fingerprint: 'Android/full_shuttle/shuttle:4.0.4/IMM76I

/eng.menno.20120526.201350:userdebug/test-keys'

I/DEBUG ( 6197): pid: 7066, tid: 7084 >>> com.google.android.voicesearch <<<

I/DEBUG ( 6197): signal 4 (SIGILL), code 1 (ILL_ILLOPC), fault addr 50f4a098

I/DEBUG ( 6197): r0 00236a00 r1 0000000a r2 00000000 r3 000400d5

I/DEBUG ( 6197): r4 00236a00 r5 00001f40 r6 00236a48 r7 ffffffff

I/DEBUG ( 6197): r8 ffffffff r9 00000000 10 000002ee fp ffffffff

I/DEBUG ( 6197): ip 400d5474 sp 5b796b70 lr 50f4a2cb pc 50f4a098 cpsr 400

00030

I/DEBUG ( 6197): d0 4264926f43c80000 d1 3e4ccccd45fa0000

I/DEBUG ( 6197): d2 3df5c28f43160000 d3 3d99999a3dcccccd

I/DEBUG ( 6197): d4 3e19999a3db851ec d5 3fe999993c23d70a

I/DEBUG ( 6197): d6 3ecccccd00000000 d7 3e80000042480000

I/DEBUG ( 6197): d8 0000000000000000 d9 ffffffffffffffff

I/DEBUG ( 6197): d10 0000000000000000 d11 0000000000000000

I/DEBUG ( 6197): d12 0000000000000000 d13 0000000000000000

I/DEBUG ( 6197): d14 0000000000000000 d15 0000000000000000

I/DEBUG ( 6197): scr 60000012

I/DEBUG ( 6197):

I/DEBUG ( 6197): #00 pc 00001098 /system/lib/libvoicesearch.so (_ZN

12speech_input10Endpointer5ResetEv)

I/DEBUG ( 6197): #01 pc 000012c6 /system/lib/libvoicesearch.so (_ZN

12speech_input10EndpointerC2Ei)

I/DEBUG ( 6197):

I/DEBUG ( 6197): code around pc:

I/DEBUG ( 6197): 50f4a078 43c80000 00000000 eddf2300 210a0b0b ...C.....#.....

!

I/DEBUG ( 6197): 50f4a088 3044f880 3045f880 f8802200 edc03046 ..D0..E0."..F0.

.

I/DEBUG ( 6197): 50f4a098 f8800b0c edc03047 23000b0a e9c06401 ....G0.....#.d.

.

I/DEBUG ( 6197): 50f4a0a8 4770230e 8000f3af ffffffff ffffffff .#pG...........

.

I/DEBUG ( 6197): 50f4a0b8 4604b510 ffe0f7ff 0048f104 f0002100 ...F......H..!.

.

I/DEBUG ( 6197):

I/DEBUG ( 6197): code around lr:

I/DEBUG ( 6197): 50f4a2a8 e9c09b02 ed80230e 46309b04 f000460d .....#....0F.F.

.

I/DEBUG ( 6197): 50f4a2b8 2300f9bd 50e0f8c4 30e4f8c4 f7ff4620 ...#...P...0 F.

.

I/DEBUG ( 6197): 50f4a2c8 ee05fedb eef85a10 ed9f8ac5 4a318a31 .....Z......1.1

J

I/DEBUG ( 6197): 50f4a2d8 ad012300 9b06ed84 9b08ed84 e9c44628 .#..........(F.

.

I/DEBUG ( 6197): 50f4a2e8 23002300 eec84a2c e9c47a88 23002304 .#.#,J...z...#.

#

I/DEBUG ( 6197):

I/DEBUG ( 6197): memory map around addr 50f4a098:

I/DEBUG ( 6197): 50f48000-50f49000 /system/framework/android.policy.jar

I/DEBUG ( 6197): 50f49000-50f4c000 /system/lib/libvoicesearch.so

I/DEBUG ( 6197): 50f4c000-50f4d000 /system/lib/libvoicesearch.so

I/DEBUG ( 6197):

I/DEBUG ( 6197): stack:

I/DEBUG ( 6197): 5b796b30 4086db01 /system/lib/libdvm.so

I/DEBUG ( 6197): 5b796b34 00236a48 [heap]

I/DEBUG ( 6197): 5b796b38 00001f40

I/DEBUG ( 6197): 5b796b3c 00236a48 [heap]

I/DEBUG ( 6197): 5b796b40 ffffffff

I/DEBUG ( 6197): 5b796b44 ffffffff

I/DEBUG ( 6197): 5b796b48 00000000

I/DEBUG ( 6197): 5b796b4c 000002ee

I/DEBUG ( 6197): 5b796b50 ffffffff

I/DEBUG ( 6197): 5b796b54 400a3117 /system/lib/libc.so

I/DEBUG ( 6197): 5b796b58 00236a48 [heap]

I/DEBUG ( 6197): 5b796b5c 401529cf /system/lib/libstdc++.so

I/DEBUG ( 6197): 5b796b60 00236a48 [heap]

I/DEBUG ( 6197): 5b796b64 50f4a64f /system/lib/libvoicesearch.so

I/DEBUG ( 6197): 5b796b68 df0027ad

I/DEBUG ( 6197): 5b796b6c 00000000

I/DEBUG ( 6197): #01 5b796b70 00236a00 [heap]

I/DEBUG ( 6197): 5b796b74 00000000

I/DEBUG ( 6197): 5b796b78 ffffffff

I/DEBUG ( 6197): 5b796b7c 400d5474

I/DEBUG ( 6197): 5b796b80 000002ee

I/DEBUG ( 6197): 5b796b84 400a1c65 /system/lib/libc.so

I/DEBUG ( 6197): 5b796b88 00000000

I/DEBUG ( 6197): 5b796b8c 000009af

I/DEBUG ( 6197): 5b796b90 5b796bd0

I/DEBUG ( 6197): 5b796b94 00236ab0 [heap]

I/DEBUG ( 6197): 5b796b98 5b796bbc

I/DEBUG ( 6197): 5b796b9c 5b796bcc

I/DEBUG ( 6197): 5b796ba0 001e54c0 [heap]

I/DEBUG ( 6197): 5b796ba4 00273860 [heap]

I/DEBUG ( 6197): 5b796ba8 ffffffff

I/DEBUG ( 6197): 5b796bac 00000004

I/DEBUG ( 6197): 5b796bb0 ffffffff

I/DEBUG ( 6197): 5b796bb4 ffffffff

D/NetlinkEvent( 98): Unexpected netlink message. type=0xf250

I/BootReceiver( 167): Copying /data/tombstones/tombstone_08 to DropBox (SYSTEM_

TOMBSTONE)

W/InputDispatcher( 167): channel '41214c88 com.google.android.voicesearch/com.g

oogle.android.voicesearch.RecognitionActivity (server)' ~ Consumer closed input

channel or an error occurred. events=0x8

E/InputDispatcher( 167): channel '41214c88 com.google.android.voicesearch/com.g

oogle.android.voicesearch.RecognitionActivity (server)' ~ Channel is unrecoverab

ly broken and will be disposed!

D/Zygote ( 102): Process 7066 terminated by signal (4)

I/WindowManager( 167): WIN DEATH: Window{41214c88 com.google.android.voicesearc

h/com.google.android.voicesearch.RecognitionActivity paused=false}

W/InputDispatcher( 167): Attempted to unregister already unregistered input cha

nnel '41214c88 com.google.android.voicesearch/com.google.android.voicesearch.Rec

ognitionActivity (server)'

D/audio_hw_primary( 104): adev_close_input_stream

I/ActivityManager( 167): Process com.google.android.voicesearch (pid 7066) has

died.

W/ActivityManager( 167): Scheduling restart of crashed service com.google.andro

id.voicesearch/.logging.LoggingService in 5000ms

W/ActivityManager( 167): Force removing ActivityRecord{4129c020 com.google.andr

oid.voicesearch/.RecognitionActivity}: app died, no saved state

I/WindowManager( 167): WINDOW DIED Window{41214c88 com.google.android.voicesear

ch/com.google.android.voicesearch.RecognitionActivity paused=false}

D/androidNetworkLocationListeners( 5244): Still have listener com.google.android

.location.internal.client.NetworkLocationClient$1@41041e30

W/InputManagerService( 167): Got RemoteException sending setActive(false) notif

ication to pid 7066 uid 10051

D/NetworkLocator( 5244): null cell state delivered

D/dalvikvm( 167): GC_CONCURRENT freed 1125K, 32% free 11585K/16903K, paused 3ms

+7ms

Edited by richardmlea
0

Share this post


Link to post
Share on other sites

Posted · Report post

richardmlea,

re. voicesearch not working and soundhound.

Now just to say on my own rom these work without issue, voicesearch picks up audio and gives list of items to search for and soundhound picked up both songs I tested with over my PC speakers correctly.

Having a quick look I think it has something to do with the voicesearch.apk Scanno is using in his rom (1.8mb mine is ,only 962kb) I opened the apk and it only has drawable-xhdpi where as mine has drawable-mdpi so maybe unable to draw graphics (maybe libs also but they look the same).

Scanno has the apk I use as it was in the test rom I sent him a while ago so hopefully he can test and include it in his next release.

0

Share this post


Link to post
Share on other sites

Posted · Report post

GPS seems to work, it switches on and finds satellites, but looses them as fast also. I haven't looked into any logs yet.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I seem to have similar results on my Viewpad10S. Signal is REALLY weak.

Question, do you have any case ? If true, did you try without it?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm having a dumb moment.. i cannot for the love of God pass the 1st lock screen on 2.1

I flashed VegaICS1, then VegaCream 2.1 with build prop adultered to have the disabled wizard... and nothing! :D

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I'm having a dumb moment.. i cannot for the love of God pass the 1st lock screen on 2.1

I flashed VegaICS1, then VegaCream 2.1 with build prop adultered to have the disabled wizard... and nothing! :D

I just took the back off and unplugged the sim module, booted up, setup the Rom, powered down and then plugged the sim module back in.

On the GPS subject, I don't get any signal and I am not using a case. I have tried one in my Vega which is very busy inside (usb hub, mylar heat shield) and I have also tried one in another vega but same thing.

Anyone know how to send at commands to the modem in android? I know the command I need to send and I know connectbot will do it but I don't know exactly how to use connectbot to do it. If someone knows how I could do with a heads up.

Cheers

P.S. great work on the Rom scanno et al.

Edited by richardmlea
0

Share this post


Link to post
Share on other sites

Posted · Report post

echo -e "command" > /dev/ttyUSB?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.