• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Windows 7, G300 USB drivers after ADK install

14 posts in this topic

Posted

I have downloaded the updates through the android DK, however when I go to device manger to install USB drivers for debug mode.

The generic drivers in the 'Extras' folder aren't recognised.

Is there another location for the G300 USB drivers?

0

Share this post


Link to post
Share on other sites

Posted

did you find the 2 .DLL files in platform-tools it did you get to that step yet. Sorry not at PC and am new to this myself.If no one else gives advice, I will go through the steps tomorrow Eve and see can I find the issue.

0

Share this post


Link to post
Share on other sites

Posted

I see the 2 .dll file in that folder.

As to installing the USB driver. I have uninstalled the devices driver as a 'mass storage', then tried again to right click on the 'Android adapter' and install driver from the required location. However it still produces the same result... 'windows could not find the drivers for this device'.

Thanks for the help, its appreciated.

0

Share this post


Link to post
Share on other sites

Posted

you have to copy and paste those 2 DLL files to the tools folder then it may work.

If it doesn't, just plug phone in normally to.PC and let it download the drivers automatically. It can take a while but eventually gets them. Then go back to the sdk after that and see where you are at.

0

Share this post


Link to post
Share on other sites

Posted

Balls!

I have tried both of the above and am no further on.

When I plug the phone in again windows installs it as a mass storage device, with or without SD card in place.

It bound to be something simple Im missing, but for the life of me....

0

Share this post


Link to post
Share on other sites

Posted

I'd copy the drivers iso file from the system partition. Mount it with daemon tools. Remove device from my computer devices. Boot into fastboot mode, install drivers from mounted iso file.

0

Share this post


Link to post
Share on other sites

Posted (edited)

think you are confusing the 'modes' of phone? 1) phone booted as normal has standard usb mass storage and 2) phone in BOOTLOADER mode it will show as a adb interface, bootloader mode is what you need to install pauls root mod and/or sebastions404 clockworkmod

1)windows usb mass storage

try it with usb debugging ( menu>settings>aplications>development - tick box usb debugging) ticked and unticked with phone booted as normal, let it install drivers automatically when you plug in usb cable

2) BOOTLOADER MODE

NOW take battery out, hold volume down and keep holding, insert battery, press power till it vibrates- release power only (holding volume down still) after say 10 seconds release volume down and phone should be stuck on start up logo, now plug in usb and it should install a different set of drivers along line of adb interface.

hopefully this is all the drivers installed

you are now in bootloader mode and should be able to flash super recovery or Clockworkmod

ANYTHING you flash is AT YOUR OWN RISK, not sure read up, ask people to double check 1st!

Im running win7 64 bit and its finds phone fine.

Edited by Gary_J_Wright
1

Share this post


Link to post
Share on other sites

Posted

Many thanks Gary.

I wasn't connecting it in bootloader mode.

However I'M LEARNING!!!

0

Share this post


Link to post
Share on other sites

Posted

Ok I have uninstalled the mass storage drivers.

Put the phone into bootloader mode.

Then plugged in the USB.

It now doesn't register in Device Manager, there is no drivers auto installed on insertion of USB.

Do I need to put it into debugging mode before bootloader mode?

When I get this sorted I think Ill write a guide for the next noob!!

Ahhhhh!

0

Share this post


Link to post
Share on other sites

Posted

Hold on sec! It now says ADB interface in device manager, with Fastboot interface (google USB ID) underneath.

Am i onto something?!?!

0

Share this post


Link to post
Share on other sites

Posted

Ok, Think I have got it now... In Debugging Mode I can see 'Android Composite ADB interface' in device manager.

In Bootloader mode it shows 'fastboot' in device manager.

The question is, now I have that sorted where do I go from there? Thanks for your help guy!

0

Share this post


Link to post
Share on other sites

Posted

What are you trying to do? are you putting on Sebastian's rom. If so download it to your pc. Then paste it into the tools folder I think it is. Then you will need to search.for instructions on how to push it to the phone. I am having to do this myself later as I am suffering from severe phone lag for some unknown reason which requires constant battery pulls. If you not sorted by then, I will post the instructions that I find.

0

Share this post


Link to post
Share on other sites

Posted

Yea, Sebs ROM. Well at least as a starting point. Until plenty more reading is done!

Again thanks for the heads up!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.