• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Vodafone 945 - 2.2 - 2.3 - MIUI and 4.0.4 ROMS


90 posts in this topic

Posted

No biggie... I had a backup made after installing Google Apps, it was just a matter of restoring and install a couple apps...

I don't know if it had something to do with the file permissions, i may have skipped that step... I was really hungry!

I haven't used ADB, the file went straight through Google Drive...

I remember connecting to my cell phone via SSH after that... Don't remember if i actually changed the file permissions...

It allowed the execution of the apk though, so i guess downloading via GD + executing made that step unnecessary.

Will try again, maybe later, probably tomorrow.

0

Share this post


Link to post
Share on other sites

Posted (edited)

using 2.3.7 by wosisa and Curious Mind for a few days and a very positive feedback.

I installed the rom already knowing the camera is with some problems but since i dont use the camera very much i dont mind, still for taking a photo from time to time is no problem, the camera just crash's sometimes and you are stil able to take photos if you want.

Besides the camera i dont have any problems, no force close problems, no restarts (happened to me with the original rom sometimes lol) everything i use in my daily is working fine, everything in the phone is much more fast and smooth, games run better and without breaks, angry birds crash no more, it doesn't get slow and laggy after some time of use, is like a new phone.

Great work really :D

Edited by picanha
0

Share this post


Link to post
Share on other sites

Posted

No biggie... I had a backup made after installing Google Apps, it was just a matter of restoring and install a couple apps...

I don't know if it had something to do with the file permissions, i may have skipped that step... I was really hungry!

I haven't used ADB, the file went straight through Google Drive...

I remember connecting to my cell phone via SSH after that... Don't remember if i actually changed the file permissions...

It allowed the execution of the apk though, so i guess downloading via GD + executing made that step unnecessary.

Will try again, maybe later, probably tomorrow.

You shouldn't mess with your phone on an empty stomach heheh :) I'll try something different, I'll see if I can transfer the dictionaries from that apk to the original one, that way those white borders should not appear and it should work properly.

Well, I'm not really sure if the permissions are necessary, but I did it and no problems here. You shouldn't install the app, it's a system app and it is running when you tried to install the other, so maybe that made some difference. If you can, try through adb and then let me know ;) I'll try to do my little experiment today but after work diablo III is waiting for me hehe :)

CyanogenMod 7

For GAPPS need to install:

http://cmw.22aaf3.co...0828-signed.zip

google account and sync available

Thanks man. I vote link to OP when cuttysark has a chance;)

0

Share this post


Link to post
Share on other sites

Posted

Any news of the camera fix for CyanogenMod?

I would love to use the 2.3.7 version, but I can't without the camera. I use it a lot... :/

Thank you

0

Share this post


Link to post
Share on other sites

Posted (edited)

I could not run 2G/3G Network (APN).

Set the same as Android 2.1, but not functional.

Telefonica O2 CZ

Name: O2 Internet

APN: internet

Proxy: Not set

Port: Not set

Username: Not set

Password: Not set

Server: Not set

MMSC: Not set

Proxy MMS: Not set

Port MMS: Not set

MCC: 230

MNC: 02

Typ ověření: PAP or CHAP

Type APN: default

APN protocol: IPV4V6 (tested all - IPV4 or IPV6)

(CyanogenMod7 by Curious Mind)

Edited by StaryMuz
0

Share this post


Link to post
Share on other sites

Posted

m usng 3g - 2g there s no problem on vodafone turkey

0

Share this post


Link to post
Share on other sites

Posted (edited)

Sry,

i 2G/3G network already running, it was a mistake in my settings (blocked connection).

Hardly versed in the English setting. :blink:

Edited by StaryMuz
0

Share this post


Link to post
Share on other sites

Posted (edited)

I try 2.2 ROM, but compass, automatic brightness and automatic screen off when calling do not work. Then mobile stuck (after 2 minutes rest) and I must remove battery :(..

It is solve in 2.3., do you know ?

Edited by vodafonek
0

Share this post


Link to post
Share on other sites

Posted (edited)

The magnetic field sensor is not perfect... but I don't have any of those problems you have mentioned...

I'm using Vodafone 945 2.3.7 Cyanogenmod 7.2.0 By wosisa Rom By Curious Mind...

I use it daily.

4/5 days standby (with 3G disabled)

1 or 2 days with Wi-Fi enabled

Flash Support

Faster web browsing

No game lag

It's a new phone...

no Camera though

When you install a new ROM be sure to wipe everything. It's mandatory.

Edited by cuttysark76
0

Share this post


Link to post
Share on other sites

Posted

any 1 working on sensors ??

0

Share this post


Link to post
Share on other sites

Posted

ics zte joe ıt s bdivrik works ported frm u8120

Works

-Touchscreen

-Mound unmount sd card

-Play music

-Not works

-Gsm services like edge-3g-call -sms

-Bluetooth

-Wifi

-Camera

And all ics application doesnt work its say stopped

download just change boot.img here http://www.mediafire.com/?tr54oiy5h2whm97

http://www.mediafire.com/?bue4bn04njz4xv6

0

Share this post


Link to post
Share on other sites

Posted (edited)

.

Edited by harock
0

Share this post


Link to post
Share on other sites

Posted

Sorry i had too much work and could not be around for a while (Now my workload has increased i have even less chance to do so).

I see that pretty good developement has been made while i wasn't around. Especially that multitouch fix, since i didn't develop the rom (i just modified and compiled the kernel) i didn't know it was a permission problem. Congrats on MIUI rom. Thanks cuttysark and harock.

Before anything else i should remind that everything here is here is experimental and might damage your phone (although it should damage mine first, since i try everything before, but this is no guarantee).

Here is what i did. I was so immersed in camera problem i didn't actually looked at anything else. Camera freezing after just 3 shots really annoyed me. Bad news is: sorry i couldn't find a solution to stock camera app yet. Good news is: it seems we have a workaround: "Camera 360" which is a free app that could be downloaded from Google Play Store doesn't seem to be affected from camera freeze problem. I took 10 consequtive shots without any trouble. But i must warn you, flash must be off while taking photos (default setting) otherwise Camera 360 also freeze (Yes there is a flash option now but it is not completely working yet). If you set autosave to 1 sec and use no effect it is really similar to stock camera app and camera button works, it also support other resolutions.

Other than that i corrected abnormal preview size (preview was looking zoomed before). And overclock is now possible (it was really easy actually: just a few changes in Kconfig files). But i must warn you again, it doesn't seem stable over 690 mhz.

Although flash doesn't work as it should if you want to just test it you can use flash_test (this file is from original vdf 945 rom, i had to modify -hexedit- 1 byte to make it work on this kernel), here is how:

After downloding attached flash_test;

adb push flash_test /system/bin

adb push em_flash_test.sh /system/bin

adb shell chmod +x /system/bin/em_flash_test.sh

adb shell chmod +x /system/bin/flash_test

adb shell /sytem/bin/em_flash_test.sh -> this script turn on (flash_test 1) then turn off (flash_test 0) the camera flash.

if you manually turn on flash (flash_test 1) flash led lights for a short time then goes off. But even it goes off don't forget to turn off flash (flash_test 0) otherwise camera flash might get damaged (might be ?). After turning off and waiting a few seconds it works again.

And lastly sensors: Yes there is light and proximity sensor support in kernel (taos driver) but somehow rom cant use it. I read http://code.google.c.../detail?id=3955 and downloaded "ztesensortest" and tried. Proximity sensor works and reads values, but rom still doesn't use the sensor (may be it is a permission problem).

Here is the kernel (inside boot image for gingerbread) http://www.mediafire...6233z2i2mlqia4r

Since i do not have much time, if you don't want waiting you can develop kernel yourself, all my modifications to blade kernel is at https://github.com/r...kernel-msm7x27# But please share your code so others can develop it further.

flash_test.zip

0

Share this post


Link to post
Share on other sites

Posted

thanx for all efforts

0

Share this post


Link to post
Share on other sites

Posted (edited)

@Curious Mind thnks all but help us for the problem of sensor

Edited by cingibi
0

Share this post


Link to post
Share on other sites

Posted

And lastly sensors: Yes there is light and proximity sensor support in kernel (taos driver) but somehow rom cant use it. I read http://code.google.c.../detail?id=3955 and downloaded "ztesensortest" and tried. Proximity sensor works and reads values, but rom still doesn't use the sensor (may be it is a permission problem).

At the end of that page, they claim to have solved it with http://review.cyanogenmod.com/#change,13045. Since you only mention testing ztesensortest (something mention in the middle of the issue discussion, it would be good to know if your kernel build used that final patch, or even if the solution is usable in your build.

0

Share this post


Link to post
Share on other sites

Posted

Yes there were sensors issue so i packed new kernel and sensor lib from cm blade into an update.zip here: http://www.mediafire.com/?2d38ltck5e3j3zw after installing this update, reboot then connect usb cable and run: "adb shell ztesensortest -c" to calibrate the sensor. You should probably move your finger over the sensor (near - far) while calibrating.

After the procedure explained above "androidsensorbox" (an adware-free app that could be found on market) shows both lightsensor and proximity sensor values correctly (hopefully). This is not a permanent solution but i hope this workaround is enough for now.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Other than that i corrected abnormal preview size (preview was looking zoomed before). And overclock is now possible (it was really easy actually: just a few changes in Kconfig files). But i must warn you again, it doesn't seem stable over 690 mhz.

The camera hang-ups aren't consistent... Sometimes i can take 10, 15, sometimes it hangs on the second.

It can be just a feeling, but i think it doesn't hang that much when camera settings is set to 3MP.

Can you please elaborate on the fix for the camera preview zoomed issue?

Also, any clue on the screen dislocated and cut when rotated to 180º / 270º ?

Edited by HLopes
0

Share this post


Link to post
Share on other sites

Posted (edited)

Yes there were sensors issue so i packed new kernel and sensor lib from cm blade into an update.zip here: http://www.mediafire...2d38ltck5e3j3zw after installing this update, reboot then connect usb cable and run: "adb shell ztesensortest -c" to calibrate the sensor. You should probably move your finger over the sensor (near - far) while calibrating.

Light sensor, but (in my case) proximity still does not. Although in hindsight, I remember that even in stock ROM I had issues with accidental "put call on hold". I gained the habit of turning of the screen after dialing because of it. So could be that my sensor is malfunctioning from the start... I might just do a quick check this afternoon with a stock ROM. (Edit: Confirmed my proximity sensor never worked a day in its life... LOL Like I said, light is working as expected after patching)

Also, after applying the patch I get some splitseconds of green screen when rotating. (Edit: Seems to be a small lottery when booting. Sometimes I'll always get the green frames, in others no green frames at all)

Edited by marklangdon
0

Share this post


Link to post
Share on other sites

Posted (edited)

New İcs Rom 4.0.4

working

-Sounds

-Google apps

-App installing

-Multilang

-Overlock

-Gsm services

Doesnt work

-Camera

-Sleeping Mode, power does not work

-All sensor

-Bluetooth

-Gps (m not sure)

-MultiTouch

Rom download: http://www.mediafire...3qo8fvw4h6cu8tp

Edited by fatih312
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.