• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

lib/modules read-only

6 posts in this topic

Posted (edited) · Report post

So I'm on HoneyIce (latest version 3.2.7 I think) trying to get USB ethernet working. I have an ASIX AX88772 based adapter. I've found instructions on this page:

http://www.modaco.co...t-for-the-vega/

...but I need to move the downloaded "asix.ko" to to /system/lib/modules

I've spent an entire day trying to do this and have not been able to figure it out. I tried Root Explorer, and though the /system/ directory is writable, system/lib/modules isn't. Within "modules" nothing happens when I click "Mount R/W".

When I try and change permissions of the modules folder it says "modules permissions cannot be changed because the file system is read-only". If I try and change the owner it says "modules owner cannot be changed because the file system is read-only"

"adb push" is also giving me the same problem. ie "cannot copy ... to ... : Read-only file system"

I've tried a million other things, but nothing has made it possible to write to this directory. Can someone help here? How can I write to the lib/modules dir?

Many thanks

Edited by Muji12
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

So I'm on HoneyIce (latest version 3.2.7 I think) trying to get USB ethernet working. I have an ASIX AX88772 based adapter. I've found instructions on this page:

http://www.modaco.co...t-for-the-vega/

...but I need to move the downloaded "asix.ko" to to /system/lib/modules

I've spent an entire day trying to do this and have not been able to figure it out. I tried Root Explorer, and though the /system/ directory is writable, system/lib/modules isn't. Within "modules" nothing happens when I click "Mount R/W".

When I try and change permissions of the modules folder it says "modules permissions cannot be changed because the file system is read-only". If I try and change the owner it says "modules owner cannot be changed because the file system is read-only"

"adb push" is also giving me the same problem. ie "cannot copy ... to ... : Read-only file system"

I've tried a million other things, but nothing has made it possible to write to this directory. Can someone help here? How can I write to the lib/modules dir?

Many thanks

Hi, Muji12...

HoneyIce 3.2.7 RC3 (Chimera) uses SquashFS ( http://en.wikipedia.org/wiki/SquashFS )... meaning that all the files in /system/lib are actually stored in a single SquashFS file called lib.sfs - (loosely analagous to a .ZIP archive.)

To add asix.ko, would require a new updated lib.sfs (incorporating asix.ko) to be copied into /system - which I think can only be "built" on a Linux system...

...or at least, this is my understanding.

GED.

Edited by GedBlake
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

So I'm on HoneyIce (latest version 3.2.7 I think) trying to get USB ethernet working. I have an ASIX AX88772 based adapter. I've found instructions on this page:

http://www.modaco.co...t-for-the-vega/

...but I need to move the downloaded "asix.ko" to to /system/lib/modules

I've spent an entire day trying to do this and have not been able to figure it out. I tried Root Explorer, and though the /system/ directory is writable, system/lib/modules isn't. Within "modules" nothing happens when I click "Mount R/W".

When I try and change permissions of the modules folder it says "modules permissions cannot be changed because the file system is read-only". If I try and change the owner it says "modules owner cannot be changed because the file system is read-only"

"adb push" is also giving me the same problem. ie "cannot copy ... to ... : Read-only file system"

I've tried a million other things, but nothing has made it possible to write to this directory. Can someone help here? How can I write to the lib/modules dir?

Many thanks

Try putting it in /vendor/lib/modules

Edited by Scanno
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Thanks guys. Scanno, unfortunately I can't seem to install the driver when it is there. insmod returns "can't insert... invalid module format'.

Can I ask - does your VegaCream support USB ethernet? Is it possible to get it working in it?

Edited by Muji12
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks guys. Scanno, unfortunately I can't seem to install the driver when it is there. insmod returns "can't insert... invalid module format'.

Can I ask - does your VegaCream support USB ethernet? Is it possible to get it working in it?

I guess that will need a kernel recompile with the driver enabled, if it is part of the linux kernel.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ah, that's a little over my head I'm afraid. Thanks anyhow. Do you think we can look forward to USB ethernet support in any upcoming releases of VegaCream or any of the ICS ROMs? Or looking unlikely?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.