• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Kernel Experiment - 4.0 updated 2012.05.28

199 posts in this topic

Posted · Report post

I tryed:

-- 4 trials snipped --

I applaud your persistence. But you still must have typed something wrong. Typing serious commands in terminal is really a challenge and a PITA, I know. I attach the script so that you don't have to type.

1. Download the ke.txt

2. Rename it to ke (without the extension)

3. Put it in say /ke of your phone

4. Do a "chmod +x /ke"

5. Run "su"

6. Disconnect USB

7. Run "/ke"

See if this works.

ke.txt

0

Share this post


Link to post
Share on other sites

Posted · Report post

Wifi don't work for me, and also I can't seem to lock the screen.

Again, see the first 2 points in the Troubleshooting post (2nd post of this thread).

ipaq3870.I reinstalled the assembly with the kernel 4.0 with 160 MB of memory. WiFi has started) cheers! thank you.

Good to know! What exactly you have done to make Wifi work? Did you reinstall the whole OS via the beta2 installer, or just the kernel part? What other things you have done? Perhaps these are useful info for others.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I reinstalled just the kernel part (modules and kernel replace again) on your instructions (manual) )) only white squares in the games

Edited by DimonAK
0

Share this post


Link to post
Share on other sites

Posted · Report post

I have now some issues with angry birds rio textures. Any idea?

0

Share this post


Link to post
Share on other sites

Posted · Report post

it worked thanks, foremerly i didn't reboot :-p

0

Share this post


Link to post
Share on other sites

Posted · Report post

I applaud your persistence. But you still must have typed something wrong. Typing serious commands in terminal is really a challenge and a PITA, I know. I attach the script so that you don't have to type.

1. Download the ke.txt

2. Rename it to ke (without the extension)

3. Put it in say /ke of your phone

4. Do a "chmod +x /ke"

5. Run "su"

6. Disconnect USB

7. Run "/ke"

See if this works.

I used a .sh file to test the 4 situation ;-)

I executed exactly your instruction and the result is:

Cannot open `': No such file or directory

Nothing has been loaded!

Ready for further testing :-)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ver 4.0 667-166 Mhz 24 bpp 160 MB. It is working. Thanks ipaq. (But first try didn't work. I copied 4.0 kernel and modules over 3.0. No signal and wifi. So I reinstalled android and copied ver 4.0 now working. )

0

Share this post


Link to post
Share on other sites

Posted · Report post

I reinstalled just the kernel part (modules and kernel replace again) on your instructions (manual) )) only white squares in the games

I have now some issues with angry birds rio textures. Any idea?

See Caveat section - it's by design : sacrifice your video memory for something else. :D Choose a build with less free memory (mean more memory for video) helps.

Cannot open `': No such file or directory

Nothing has been loaded!

That means the command "getprop haret.kernel" return nothing. Check step 2 again. Note the setprop line must be placed before the line that reads "class_start default".

Ver 4.0 667-166 Mhz 24 bpp 160 MB. It is working. Thanks ipaq. (But first try didn't work. I copied 4.0 kernel and modules over 3.0. No signal and wifi. So I reinstalled android and copied ver 4.0 now working. )

It still baffles me as to why an Andriod reinstallation would work. It's not uncommon for me to switch kernels and modules 20-30 times a day if I am doing development, and still yet to encounter any gsm/wifi problems like you guys described. Anyway, good to know it works for you.

0

Share this post


Link to post
Share on other sites

Posted · Report post

It still baffles me as to why an Andriod reinstallation would work. It's not uncommon for me to switch kernels and modules 20-30 times a day if I am doing development, and still yet to encounter any gsm/wifi problems like you guys described. Anyway, good to know it works for you.

Is there a cache mechanism on Android. Maybe while booting up some values written somewhere

0

Share this post


Link to post
Share on other sites

Posted · Report post

That means the command "getprop haret.kernel" return nothing. Check step 2 again. Note the setprop line must be placed before the line that reads "class_start default".

You find the solution (set prop was last line in miy init.rc, my mistake).

I saw you already modified main post, specifying setprop position.

Happy re-boot to everyone :-)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Is there a cache mechanism on Android. Maybe while booting up some values written somewhere

If there's anything to save across reboots, it's usually in the config files. That's why I was asking you all to try point 4 of this post - to reset the config file. But somehow none of you tried - or at least none reported trying. Hmmm...

You find the solution (set prop was last line in miy init.rc, my mistake).

I saw you already modified main post, specifying setprop position.

Happy re-boot to everyone :-)

Finally someone succeeded. Nice.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ipaq3870 hello, hard, I use 4.0 kernel and module, the second, the third and all have flash screen phenomenon, only the first won't appear flash screen. Excuse me, is how to return a responsibility? Like crash phenomenon than 3.0 times more!!!

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hey guys, I have a quick question. Sry beforehand if this has been asked before but I searched this thread and wasn't able to find the answer.

How do I install this new version? Is it just downloading and installing the latest update from the "official" site (http://o2droid.phj.hu/index_en.php) and then just following the instructions on the first post of this thread?

Thanks much!

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hey guys, I have a quick question. Sry beforehand if this has been asked before but I searched this thread and wasn't able to find the answer.

How do I install this new version? Is it just downloading and installing the latest update from the "official" site (http://o2droid.phj.hu/index_en.php) and then just following the instructions on the first post of this thread?

Thanks much!

Isnt a "new version", it's the same system/version with a new TEST kernel that bring fixes and improvements, make sure you are aware of this quote right there on the first page:

Please note these are not for beginners and would require some knowledge and skills to properly set it up. More importantly, although unlikely, it may brick your phone and render it completely wasted. It comes with absolutely no guarantee and no warranty whatsoever. I am not responsible for any damages done. For those who is willing to take the risk, proceed below.

Anyway, install instructions is also on the first post of this topic. It's like you said, try it and then post where you are stuck so we can help you.

Edited by rom_omnia2
0

Share this post


Link to post
Share on other sites

Posted · Report post

Dude, don't want to sound harsh but if I havent read the whole thread I wouldn't be posting the question I made... The first post doesn't say anything about downloading and installing the "original" CM2 beta from the site I mention and THEN following the instructions. Or if I need to install the original CM2 beta plus all the other updates made to it and mixed in the old thread and THEN follow the instructions to install this.

That's all I want to know, so instead of trying to lecture me I would really appreciate a simple and clear response to the question.

Thanks.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Ok, it was as I thought, I did a clean install using the latest version downloaded from the "official site", then copied over the modules and zImage from this thread and everything is working, even wifi!

Tomorrow morning I'll try installing kexec and if that works it's bye bye WM!

Thank you very much Mr. Ipaq3870 for your hard work and this great release :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

So much work, so little time!

I'll be offline until Jul real soon. The code is already in place, I'm just not sure if I have time to release a 5.0 build. Tentative changelog:

  • Screen calibration: can calibrate and adjust to one's own device - see special instructions.
  • Switch off touch panel on screen blanks - phone no longer wakes up twice when pressing hold button.
  • Also "screen turned off delay" of the lockscreen can now be set to anything - it was having accidental wakeup problems.
  • 24bpp framebuffer now reports itself as 32bpp as expected by Android, though the hardware is still 24bpp.
  • Screenshot apps such as AndroSS, and console apps such as Live Logcat now work properly in 24bpp.
  • Vibrator now vibrates at 175Hz (strong) and is independent of CPU or AHB frequencies
  • User selectable vibrator strength via sysfs file: /sys/class/timed_output/vibrator/freq

0

Share this post


Link to post
Share on other sites

Posted · Report post

Oh, how nice. Waiting for new versions.

0

Share this post


Link to post
Share on other sites

Posted · Report post

i am still using the market provided in the cmb2 package

suddenly only a few apps can be searched

also the market in the computer don't recognize my phone

is it time to update our market to google play?

0

Share this post


Link to post
Share on other sites

Posted · Report post

i am still using the market provided in the cmb2 package

suddenly only a few apps can be searched

also the market in the computer don't recognize my phone

is it time to update our market to google play?

Change phone ui language to english.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Could someone tell me if KEXEC friendly with fast boot (services file)?

I replaced services.jar and fast boot is OK.

Then i install KEXEC (restarted Droid under OS, win boot skipped, i got boot logo - loading android on omnia II, got Lock Screen) and my Droid stall at lockscreen.

And onemore: if i shoot down the phone and restart Android under win mob i lost reboot option in Android ?

Edited by Antoxa1998
0

Share this post


Link to post
Share on other sites

Posted · Report post

Hello Ipaq3870.

First of all thanks for your kernels, they make my omnia usable as never before.

It's possible to have versions of your kernels with iptables included?

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

Oh, how nice. Waiting for new versions.

Arrgghhh... there's a bad show-stopper bug cropped up - video like youtube and camera preview don't work with the changed 32bpp.... and the release will be delayed until I am back.

i am still using the market provided in the cmb2 package

suddenly only a few apps can be searched

Try clean the data of talk, market, market updater, android framework, and the like.

Then i install KEXEC (restarted Droid under OS, win boot skipped, i got boot logo - loading android on omnia II, got Lock Screen) and my Droid stall at lockscreen.

So, it won't turn off when pressing the power/hold button? And the screen stays powered on indefinitely? Does it respond to other button presses? Can you stay use the "voldown+back+menu" kill combo to reboot the phone? And is this reproducible every time you do a reboot via kexec?

It's possible to have versions of your kernels with iptables included?

Perhaps in next version.

0

Share this post


Link to post
Share on other sites

Posted · Report post

i think the final goal is to use the linux 3.0 kernel and therefore we can use the new 3d 2d driver from spica

then our phone 's performance will be boosted to maximum

1

Share this post


Link to post
Share on other sites

Posted · Report post

how to fix the screen flicker at 24 bpp version? ?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.