H3ROS

[ROM][ZTE Skate - Android 2.3.5] H3 Blues (Official Dolby Audio)

1190 posts in this topic

WIFI tethering works fine now as i have moved to Atomic.......dont know why it was not working on this.

0

Share this post


Link to post
Share on other sites

@ dibbles

It's really weird. I've checked my changes against v1.2 and I can't see anything that would effect it, and the function itself is working. Maybe if you get 10 minutes you could backup your wifes ROM, flash the latest version and then try the app? You can roll back to the backup once you're done.

@ jtharmor

Are you using tether via WiFi or USB? I can connect fine via WiFi and I've not tried via USB, simply because if one works then so should the other. You just have to make sure the drivers on Windows are right and that you have USB debugging in order.

Can anyone else confirm that if they enable data on their phone and then enable tethering that their PC/laptop can connect to it wirelessly? Thanks.

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

@ dibbles

It's really weird. I've checked my changes against v1.2 and I can't see anything that would effect it, and the function itself is working. Maybe if you get 10 minutes you could backup your wifes ROM, flash the latest version and then try the app? You can roll back to the backup once you're done.

@ jtharmor

Are you using tether via WiFi or USB? I can connect fine via WiFi and I've not tried via USB, simply because if one works then so should the other. You just have to make sure the drivers on Windows are right and that you have USB debugging in order.

Can anyone else confirm that if they enable data on their phone and then enable tethering that their PC/laptop can connect to it wirelessly? Thanks.

Complete wipe of my wife's phone. Install the 1.3 ROM and setup her account etc. No apps installed at this point apart from that Greenpower application.

That app now behaves as it does on my phone, in other words it will indicate with a half moon icon that it is in night mode but can no longer invoke the airplane mode as it did previously when on the 1.2 ROM and her phone was full of apps and games..

I have limited time to test further with my wife's phone as she needs it. So I will continue to rebuild up her account and apps and then she can use it along with the Timeriffic app you told me about.

Edited by dibbles
0

Share this post


Link to post
Share on other sites

And if you flash back v1.2 onto yours or hers, does it work again? If it does I'd probably need to give you patches little by little until it stops working again.

I'll PM you a download link.

0

Share this post


Link to post
Share on other sites

I have already got a copy of 1.2 so thanks for that :)

Let me have a think of what I can do...

Since you linked me the timeriffic application that works really well for what we need. It is both simple and light and does what it states on the tin. It puts the phone in airplane mode late at night and then turns it off, that is all we needed. Thanks for that.

So I could nandroid up my working 1.3 ROM and then install my saved version of your 1.2 ROM. That would at least demonstrate if I can repeat the same issue of it then working on my phone. If it doesn't then it would require work by yourself (very much appreciated) and me to get me to where I am already with the timeriffic application.

Whilst there seemed to be a forming pattern, which might have suggested something between the 1.3 ROM and that one application, there could be a lot of work involved with very little purpose as the other app works fine and it does seem to be far more intuitive at doing it.!.

Let me know what you think, and thanks for your help :)

0

Share this post


Link to post
Share on other sites

Well we know Timeriffic works but if somethings "broke" between 1.2 to 1.3 then I'd like to at least try to fix it. It'd be easier if I could get the application working on my own phone as it'd make patch testing quicker, so my question there is do you use the full version of the application or the free version? If you use the free version then how do you setup the times to activate airplane mode? If the settings easy to find then you can probaby describe it, but if its somewhat hidden then a screenshot would be helpful :)

If the ROM is at fault then I would guess the issue is coming from one of the build.prop values I've set.

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

When I had my San Fran I bought the full version, it was on offer I think.

The full version offers...

PREMIUM version specific features:

- Bluetooth support

- Widget

- NIGHT (premium) mode fully configurable, Airplane mode...

- Tasker & Locale Plug-in

- Apps whitelist

- No ads

- The good feeling to support an independent developer

So Alas it is not going to be in the free version.

I understand your concerns with the ROM development and I as a user must play a part in that with helping.

I will nandroind my working version and then reinstall just 1.2 with no apps and see if it will work on my phone. If it does then there will look to be an issue with the ROM. If it doesn't then it will be an hobmomoly with something other than the ROM.

Give me a while though to sort things out and I'll post back my findings.

Edited by dibbles
0

Share this post


Link to post
Share on other sites

I downloaded an iffy copy of the application and installed it, just for testing purposes. I setup the times so that it went into sleep mode at 8pm and woke up again at 8:20pm, everything worked perfectly here :unsure:

Enable night mode = checked

Night start time = 20:00

Night end time = 20:20

All OFF at night = checked

Airplane mode = checked

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

Did you actually see it use the airplane mode though..? So within that 5 minute window if you turned the phone off standby it would show the airplane icon and thus no data or phone signal being activated.

If it did work as it should for you, and it seems to do so, then something is happening at my end.

Edited by dibbles
0

Share this post


Link to post
Share on other sites

Yep, I checked and it was off. I knew when it come back on as the back button flashed red a few times too.

0

Share this post


Link to post
Share on other sites

ok well I do thank you ever so much with what testing you have been able to do.

I will do all the wipes and start again with build 1.3.

Did you update the version of Go Launcher EX to the latest 3.03 - as I did, but I'm sure that could not cause an issue...?

FWIW - the app is quite good with many settings, if they are useful to the user of course.

Edited by dibbles
0

Share this post


Link to post
Share on other sites

I've stuck with the modded launcher as I prefer the height of the dock row and how the running and recent applications are displayed. The modded version I created also removes all advertisements and blocks their status tracking.

0

Share this post


Link to post
Share on other sites

Apart from what you write the only other difference that I like about the 3.03 version is that when you look at the running apps you long press on one and they will all start wobbling with a "no entry" type symbol on them. This allows you to end each app individually rather than clean all the memory.

0

Share this post


Link to post
Share on other sites

On the modded version you can click the app and then select to close it, lock it, go to it or bring up info on it. I like it that way :P

0

Share this post


Link to post
Share on other sites

mmm I must be a sucker for fluffy useless eyecandy then :P

Edited by dibbles
0

Share this post


Link to post
Share on other sites

Going to hang my head now in embarrassment.......

Not sure why but on a wiped fresh install of your 1.3 ROM I installed the Greenpower app after creating my Google account and setup the market and it worked.!

I would like to say why it worked, perhaps more important is to why it did not work before. That I can't answer, if it was due to an error that I was doing, not sure how as I have used either Juice Defender or Greenpower for quite a while now, then I would note it here.

Next I need to get hold of my wife's phone as she is using the timeriffic application. Albeit that it failed to work last time I will try it again but I'm at a lost with understanding what I write in that it is not being consistent.

Thanks very much with your testing and with the modifications you have done with that Go Launcher EX I will go back to that one :)

Do you happen to use the Go SMS Pro for your text messages...? Just wondering if you did do you need to do any "magic" wizardry on that to optimise its use, as you did with the launcher..?

0

Share this post


Link to post
Share on other sites

Normally I either use the stock client or Pansi SMS. Am I to guess that Go SMS has adverts in it?

0

Share this post


Link to post
Share on other sites

no doubt, the best ROM ! Excellent battery life, fast, smooth, very stable, overclockable, I am running My Skate on 1038MHz for almost a week without any lockup or spontanous reboot, nice work H3ROS ... gratz !

0

Share this post


Link to post
Share on other sites

Hi H3ROS, this is my first post in here and first of all I would like to say thank you and congratulations for your great work with this ROM.

I am still using 1.2 version and is working fine for me. I would like to comment some issues I have seen and could be solved for next updates (maybe they are not so important, but at least they worked with the original ROM):

-During a phone call, you cannot scroll down the notifications bar to see for example if you have just received a new text message or whatsapp. You need to end the phone call and then see what you have.

-You cannot select a ringtone for a specific contact (my wife for example). The only option given is to put that ringtone for all the calls.

Excuse anyway my english and I hope this will be useful to improve that excellent ROM. Thanks in advance!

0

Share this post


Link to post
Share on other sites

@ thoronx

Thank you :)

@ jlcb78

Do you mean you can't access the notification bar or that if you've got notifications listed and you can't scroll through them? I would bet that if you simply can't scroll through a list that it's due to the swipe notifications mod. I'll look into it once you confirm.

As for your second issue, I've answered it before here #5 :)

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

@ jlcb78

Do you mean you can't access the notification bar or that if you've got notifications listed and you can't scroll through them? I would bet that if you simply can't scroll through a list that it's due to the swipe notifications mod. I'll look into it once you confirm.

Thank you for your answer. I can see the notification bar but I cannot scroll down to see for example who sent me the whatsup or what's the message text about. I remember I made it with the original rom.

0

Share this post


Link to post
Share on other sites

As for your second issue, I've answered it before here #5

I can see that option, but I can use only phone ringtones, I cannot use for example a mp3 file from sd card. Normally from the mp3 file if you press on it one of the options is something like "Use as contact ringtone".This is what I mean, sorry.

Edited by jlcb78
0

Share this post


Link to post
Share on other sites

I face one problem with this rom. If I have kept the WIFI on and the phone goes to sleep, then i have to press the power button several times to wake it up.Also the same problem with Atomicmod

0

Share this post


Link to post
Share on other sites

You should only have to press it once and then wait at least 5 seconds. The phones in deep sleep and is sometimes a little slow to wake up.

I will update this ROM in a week or two if all goes well. Currently I've received an Xperia Mini which is an awesome little phone and outperforms the Skate in just about every way, apart from the screen size. The battery is better, the camera is better, its much faster, it has ICS officially and it's ARMv7 so I can run applications such as Chrome, Firefox and Temple Run without modifying anything. The Skate is very laggy in comparison. However, I'm giving it to my girlfriend once I'm done creating a ROM for it and I'll look into getting something like a ZTE Mimosa X later in the year.

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

You should only have to press it once and then wait at least 5 seconds. The phones in deep sleep and is sometimes a little slow to wake up.

But why does it happen only when WIFI is enabled, when wifi is switched off, there is no delay

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.