Sign in to follow this  
XMasterNinni

[Tool][Linux] ZTE Porting Tool

Recommended Posts

robt77    34

Have been playing with this porting tool for last couple of days and still only one successful Rom. I tried to compare the scripts and files between the successful and unsuccessful ones but to be honest I didn't know what I was looking for. I then used dsixda's kitchen as advised on this thread and it did find problems with the updater script, it said it was fixing it and I built the rom using the kitchen. When i flashed the rom it installed but when I rebooted it stuck on the boot screen (green android logo) I tried to use adb logcat however it just hung on waiting for devices and gave no errors

Even though I am not having much success, I am enjoying messing around with all these tools and no doubt will be posting more novice questions over the next week as I try and work it out.

Edited by robt77

Share this post


Link to post
Share on other sites
robt77    34

Success have managed to successfully port a Rom. I have[ported the zte skate ROM Android 2.3.5] H3 Blues (Dolby + Bravia) which was posted by H3ROS It all seems to work except the wifi. I have got the adb logcat file. If anyone could have a look I would appreciate it. thanks

Edit it is more broken than I thought.

When I connect to camera it uses the front camera, been on ICS so long forgot it had a front camera

Even though Super user was installed after flashing the Rom I had to flash it again in recovery to get root access

Fibnally after flashing the Rom the phone did not recognise my phone number and said it was disvconnected from mobile network/

But on the plus side it did boot up which is a start/

Edited by robt77

Share this post


Link to post
Share on other sites
surfungus    7

Hey rob, well done on your success! bet you were well chuffed when it booted. Hopefully one of the guys who knows what they're on about will point you in the right direction.

What did you change to get it to boot? I'll have another play when I get some time...

cheers surf

Share this post


Link to post
Share on other sites
robt77    34

Hi Surf,

Thanks, I have a feeling it was a bit of dumb luck and trial and error that got it to work. I decided to change the base port and used the FishNChiops Rom and used option B on the porting tool rather than Option A. It still didn't work and I got the write image error and I did some researc on here and some googling and it was to do with the update script. I then chanced upon dsixda's Android Kitchen tool and after a couple of hours iof playing around with that I finally got a Rom to Boot. Still not quite sure why it worked though.

Share this post


Link to post
Share on other sites
XMasterNinni    110

This are good news! :D

@ robt77

I will have a look in dsixda's scripts to know what the kitchen is doing with the updater script. (And maybe add it to my tool)

Just paste the logcat on pastebin and post the link here, we will try to help you.

@All

Feedback is much appreciated, as I don't own a Crescent.

Please post how you fixed stuff in here!

Thanks!

Share this post


Link to post
Share on other sites
robt77    34

Hi XMasterNinni

have uploaded the logcat to paste bin, here is the link http://pastebin.com/TAEnmKnv

Edit feedback on your porting tool.

Whenever I use method A to port a Rom this is when flashing it I get the can't write raw image error mentioned earlier in the thread. If I use the kitchen tool and use the updater script there I get a successfully installed Rom but then I am stuck on the android logo.

If I use method b on your porting tool and use FishNchips as the base Rom, the Rom created can be flashed and boots, but the phone does not recognize my phone number and said it was disconnected from mobile network. On the phone name it said it was the Blade S. However if I use the standard de-branded 2.3.5 you use on method A on method B, when I flash the Rom I still get the can't write raw image error even I use the kitchen tool and use the updater script

I can successfully flash the branded 2.3.5 Rom without any porting.I will look at 2.3.7 a different day

Thanks for your help

Rob

Edited by robt77

Share this post


Link to post
Share on other sites
Dazzozo    3,318

Daz is the Boss!

I'm currently on a trip with my classmates, so no update this week..

Thanks

That (should) fix any remaining Wi-Fi issues that people may be having. That's what fixed rymate1234's BladeWiz port. It has the Wi-Fi module arguments hard-coded in to it from compile time.

Edited by Dazzozo

Share this post


Link to post
Share on other sites
Dazzozo    3,318

Ah, this makes sense!

Will try to push it via gh4a on my mobile.

Gh4a died for me and doesn't work anymore so I switched to Hubroid. It's currently pretty limited on functionality, though. Looks nicer, I guess. :P

Edited by Dazzozo

Share this post


Link to post
Share on other sites
Dazzozo    3,318

Are you planning on adding a 4.0.4 option? I wouldn't mind contributing to it.

Share this post


Link to post
Share on other sites
XMasterNinni    110

@Daz

You've got a server, do you?

Would it be possible to upload the base_roms for Method A onto it, as my Dropbox is pretty much used...

Share this post


Link to post
Share on other sites
Dazzozo    3,318

@Daz

You've got a server, do you?

Would it be possible to upload the base_roms for Method A onto it, as my Dropbox is pretty much used...

Yeah, sounds good.

Share this post


Link to post
Share on other sites
XMasterNinni    110

Cheers! :D

I'll take Skate and Blade for 4.0.4 support, alright? You can upload lalit's ColdFusionX builds, as I'll use them. Can you take the Crescent?

Furthermore, I'm looking into supporting armv7 devices too. G300? :D

Edited by XMasterNinni

Share this post


Link to post
Share on other sites

Hello,

I want to use this tool to port a Skate rom to Crescent but; Ubuntu won't dual boot on my laptop (I just get the purple screen of death followed by a blank black screen and I can't access any menus of any type, all I do is reboot back to Windows 7) and I am completely lost with Cygwin so I gave up.

Can you tell me what to do step by step?

Thanks

Share this post


Link to post
Share on other sites
surfungus    7

Hi Curtis, So do you have cygwin installed? how did these instructions go?

1) Install "Cygwin". Visit the xda page of dsixda's Android Kitchen to get more info on that. Mine is at C:\cygwin

2) Extract the portingtool archive to Cygwin/home/your_user_name.

3) Start Cygwin

4) Type "cd portingtool" without the ""! (or whatever the portingtool folder you extracted was called,i just change it to 'portingtool' for ease)

5) Type "./portingtool.sh" without the ""! (The .sh was missing fom one of the readme, maybe you have that one, i know i did :blink: )

Now you should be in the porting tool.

Choose option 1-menu, then method A, now choose our device C, now choose A (android2,3,5, same as skatie).

Now we have to extract the ROM we want to port into the port rom folder (C:\cygwin\home\yourname\portingtool\port_rom).

Now hit 'a' to start downloading the base rom.

That should be it. It should say your zip is here /portrom/port.zip. Unfortunately i get an error and it doesnt download when i use cygwin but when i use ubuntu it works fine..

now you just have to be brave and flash it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.