PaulOBrien

MCR - MoDaCo.one for the HTC One S (Sense + Vanilla) new: WiFi Calling support

83 posts in this topic

Jesus Filefactory is slow unless you have an account, was this hosting a recent change as I'm sure it used to come from elsewhere and a lot faster?

0

Share this post


Link to post
Share on other sites

Yes, it's temporarily at FileFactory as I had problems with the existing host. I'll switch back shortly.

P

0

Share this post


Link to post
Share on other sites

Thank god! Thought you may have been trying out a new incentive to register :)

0

Share this post


Link to post
Share on other sites

I added a new kitchen option for 'system optimisations', the first of which is improved MinFree values. I've been running them with good success, if feedback is positive i'll update the prebake over the weekend to include it!

I also added a no-boot-up-sound option.

P

0

Share this post


Link to post
Share on other sites

One issue I have just noticed with my almost totally vanilla ROM is that contacts dont get joined together. I dont have the HTC contacts stuff. I also cannot manually join contacts, it crashes the contacts app.

0

Share this post


Link to post
Share on other sites

Vanilla link fixed.

P

0

Share this post


Link to post
Share on other sites

I'll post them here shortly (I don't have the phone to hand), they're the same as the Galaxy S 3 values. ;)

I've got a mod ready to upload that reverts the 4G icon to 3G / H, selectable in kitchen and i'll make it default for all but the 'with wifi calling' prebake...?

P

0

Share this post


Link to post
Share on other sites

OK, so I seem to be able to join contacts now I added friendstream and the HTC dialler and contacts app back into my baked ROM. Friend stream seems to be the answer.

But, in the ROM I just baked, the minfree values arent being set and also I am still getting the boot sound even though I am selecting the options correctly in the kitchen. Is something wrong there Paul?

0

Share this post


Link to post
Share on other sites
OK, so I seem to be able to join contacts now I added friendstream and the HTC dialler and contacts app back into my baked ROM. Friend stream seems to be the answer.

But, in the ROM I just baked, the minfree values arent being set and also I am still getting the boot sound even though I am selecting the options correctly in the kitchen. Is something wrong there Paul?

Hmm, ill check it. The minfree script should be in /system/etc/init.d named 50minfree.1GB?

P

0

Share this post


Link to post
Share on other sites

Hmm, ill check it. The minfree script should be in /system/etc/init.d named 50minfree.1GB?

P

I dont see it there. Just 99complete.

The boot sound is also playing even though I have chosen the option for silent startup. Could be a related issue.

Thanks

0

Share this post


Link to post
Share on other sites

I dont see it there. Just 99complete.

The boot sound is also playing even though I have chosen the option for silent startup. Could be a related issue.

Thanks

Kk, i'll double check!

P

0

Share this post


Link to post
Share on other sites

I dont see it there. Just 99complete.

The boot sound is also playing even though I have chosen the option for silent startup. Could be a related issue.

Thanks

I just fixed a replication error on kitchen server 'Ainsley' which would have caused this issue.

Rebake to resolve!

P

0

Share this post


Link to post
Share on other sites

The script is there now, but it doesn't run, so the minfree values dont get updated. If I run the script manually in root explorer, then the values get updated.

0

Share this post


Link to post
Share on other sites
The script is there now, but it doesn't run, so the minfree values dont get updated. If I run the script manually in root explorer, then the values get updated.

From a bake? Very odd. Will look into it, permissions should be set on zip flash.

P

0

Share this post


Link to post
Share on other sites

From a bake? Very odd. Will look into it, permissions should be set on zip flash.

P

Thanks for working on this. The permissions look ok on the file, I dont have the phone to hand, but from memory, it has execute permissions. As an FYI, I tried another init.d script and that didn't execute on boot either.

0

Share this post


Link to post
Share on other sites

Thanks for working on this. The permissions look ok on the file, I dont have the phone to hand, but from memory, it has execute permissions. As an FYI, I tried another init.d script and that didn't execute on boot either.

Did you fastboot flash the MCR's boot image?

I need to make it more explicit in instructions and when applying the update zip that that is necessary if S-ON. I'm S-OFF so I forget! :-)

P

0

Share this post


Link to post
Share on other sites

Did you fastboot flash the MCR's boot image?

I need to make it more explicit in instructions and when applying the update zip that that is necessary if S-ON. I'm S-OFF so I forget! :-)

P

I have tried that and I am using TWRP which supposedly doesn't need that step, but I still do it anyway.

0

Share this post


Link to post
Share on other sites

So, I tried wiping and reflashing. I used CWM just to be sure and I flashed the boot.img in fastboot as well. Same result, the script does not get executed.

0

Share this post


Link to post
Share on other sites
So, I tried wiping and reflashing. I used CWM just to be sure and I flashed the boot.img in fastboot as well. Same result, the script does not get executed.

OK, will check the boot images tomorrow.

P

0

Share this post


Link to post
Share on other sites

I added a 3G/H icon to the kitchen. I'll be updating the prebakes shortly, with 3G/H icon default for Sense and Vanilla and 4G icon for the version with WiFi Calling.

P

0

Share this post


Link to post
Share on other sites

Should be sorted now!

P

0

Share this post


Link to post
Share on other sites

Awasome work as usual Paul :)

I've noticed one issue so far. If using stock ICS lockscreen and stock ICS dialer screen is not unlocked on incoming call (both cellular and sip).

Could someone confirm it?

Also dialer hangs on answering incomming sip call (this also happened on stock afair).

I also have the issue with the stock ICS screen not being unlocked during when I receive an incoming call. One possibly related issue I have is that if I start playing a song in the Play Music app the lock screen only displays the very first song. In other words, the first song played will show up on the lock screen but any when playing subsequent songs the lock screen still displays the album art and the title of the first song.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.