• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

MCR - MoDaCo.one for the HTC One S (Sense + Vanilla) new: WiFi Calling support

83 posts in this topic

Posted · Report post

Jesus Filefactory is slow unless you have an account, was this hosting a recent change as I'm sure it used to come from elsewhere and a lot faster?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, it's temporarily at FileFactory as I had problems with the existing host. I'll switch back shortly.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thank god! Thought you may have been trying out a new incentive to register :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

I added a new kitchen option for 'system optimisations', the first of which is improved MinFree values. I've been running them with good success, if feedback is positive i'll update the prebake over the weekend to include it!

I also added a no-boot-up-sound option.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

One issue I have just noticed with my almost totally vanilla ROM is that contacts dont get joined together. I dont have the HTC contacts stuff. I also cannot manually join contacts, it crashes the contacts app.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Vanilla link fixed.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I'll post them here shortly (I don't have the phone to hand), they're the same as the Galaxy S 3 values. ;)

I've got a mod ready to upload that reverts the 4G icon to 3G / H, selectable in kitchen and i'll make it default for all but the 'with wifi calling' prebake...?

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

OK, so I seem to be able to join contacts now I added friendstream and the HTC dialler and contacts app back into my baked ROM. Friend stream seems to be the answer.

But, in the ROM I just baked, the minfree values arent being set and also I am still getting the boot sound even though I am selecting the options correctly in the kitchen. Is something wrong there Paul?

0

Share this post


Link to post
Share on other sites

Posted · Report post

OK, so I seem to be able to join contacts now I added friendstream and the HTC dialler and contacts app back into my baked ROM. Friend stream seems to be the answer.

But, in the ROM I just baked, the minfree values arent being set and also I am still getting the boot sound even though I am selecting the options correctly in the kitchen. Is something wrong there Paul?

Hmm, ill check it. The minfree script should be in /system/etc/init.d named 50minfree.1GB?

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hmm, ill check it. The minfree script should be in /system/etc/init.d named 50minfree.1GB?

P

I dont see it there. Just 99complete.

The boot sound is also playing even though I have chosen the option for silent startup. Could be a related issue.

Thanks

0

Share this post


Link to post
Share on other sites

Posted · Report post

I dont see it there. Just 99complete.

The boot sound is also playing even though I have chosen the option for silent startup. Could be a related issue.

Thanks

Kk, i'll double check!

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I dont see it there. Just 99complete.

The boot sound is also playing even though I have chosen the option for silent startup. Could be a related issue.

Thanks

I just fixed a replication error on kitchen server 'Ainsley' which would have caused this issue.

Rebake to resolve!

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

The script is there now, but it doesn't run, so the minfree values dont get updated. If I run the script manually in root explorer, then the values get updated.

0

Share this post


Link to post
Share on other sites

Posted · Report post

The script is there now, but it doesn't run, so the minfree values dont get updated. If I run the script manually in root explorer, then the values get updated.

From a bake? Very odd. Will look into it, permissions should be set on zip flash.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

From a bake? Very odd. Will look into it, permissions should be set on zip flash.

P

Thanks for working on this. The permissions look ok on the file, I dont have the phone to hand, but from memory, it has execute permissions. As an FYI, I tried another init.d script and that didn't execute on boot either.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks for working on this. The permissions look ok on the file, I dont have the phone to hand, but from memory, it has execute permissions. As an FYI, I tried another init.d script and that didn't execute on boot either.

Did you fastboot flash the MCR's boot image?

I need to make it more explicit in instructions and when applying the update zip that that is necessary if S-ON. I'm S-OFF so I forget! :-)

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Did you fastboot flash the MCR's boot image?

I need to make it more explicit in instructions and when applying the update zip that that is necessary if S-ON. I'm S-OFF so I forget! :-)

P

I have tried that and I am using TWRP which supposedly doesn't need that step, but I still do it anyway.

0

Share this post


Link to post
Share on other sites

Posted · Report post

So, I tried wiping and reflashing. I used CWM just to be sure and I flashed the boot.img in fastboot as well. Same result, the script does not get executed.

0

Share this post


Link to post
Share on other sites

Posted · Report post

So, I tried wiping and reflashing. I used CWM just to be sure and I flashed the boot.img in fastboot as well. Same result, the script does not get executed.

OK, will check the boot images tomorrow.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I added a 3G/H icon to the kitchen. I'll be updating the prebakes shortly, with 3G/H icon default for Sense and Vanilla and 4G icon for the version with WiFi Calling.

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have been waiting half an hour for the kitchen to bake, does it usually take this long?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Should be sorted now!

P

0

Share this post


Link to post
Share on other sites

Posted · Report post

Awasome work as usual Paul :)

I've noticed one issue so far. If using stock ICS lockscreen and stock ICS dialer screen is not unlocked on incoming call (both cellular and sip).

Could someone confirm it?

Also dialer hangs on answering incomming sip call (this also happened on stock afair).

I also have the issue with the stock ICS screen not being unlocked during when I receive an incoming call. One possibly related issue I have is that if I start playing a song in the Play Music app the lock screen only displays the very first song. In other words, the first song played will show up on the lock screen but any when playing subsequent songs the lock screen still displays the album art and the title of the first song.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Strange...

P

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.