• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

XMOD: Region / Device / Root patched Google Wallet

763 posts in this topic

Posted

I did that.

well there is not too much to it. It seems that you have done everything right but you haven't provided much information...

so, if I had to guess, you are in canada with a canadian carrier.

there have been several reports of users in canada having the app "disappear". why? idk

0

Share this post


Link to post
Share on other sites

Posted (edited)

well there is not too much to it. It seems that you have done everything right but you haven't provided much information...

so, if I had to guess, you are in canada with a canadian carrier.

there have been several reports of users in canada having the app "disappear". why? idk

The funny thing is that i live in Holland. Alright, so i put the apk in /system/app via root explorer and changed the permissions rw-r-r Afterwards i rebooted and immediately got the message that wallet has stopped working. When i click away the notification i can't find the app in the app tray. I am unlocked and rooted. Is there any other way to install this. I read something about via cwm?

Edited by tobitronics
0

Share this post


Link to post
Share on other sites

Posted

well there is not too much to it. It seems that you have done everything right but you haven't provided much information...

so, if I had to guess, you are in canada with a canadian carrier.

there have been several reports of users in canada having the app "disappear". why? idk

It's not just Canadian's that are having this problem. I'm from Australia and had the same disappearing problem. The only way I was able to get it back was to backup the app in Titanium Backup then remove all the data and the app completely off the phone. Then after a reset I put the Wallet apk back into the system/app folder and restored the data through Titanium Backup. This made Google Wallet stick around for long enough to be able to go into it and clear the data correctly but after that it just disappeared again. Hopefully this problem is fixed soon.

0

Share this post


Link to post
Share on other sites

Posted

The funny thing is that i live in Holland. Alright, so i put the apk in /system/app via root explorer and changed the permissions rw-r-r Afterwards i rebooted and immediately got the message that wallet has stopped working. When i click away the notification i can't find the app in the app tray. I am unlocked and rooted. Is there any other way to install this. I read something about via cwm?

rw-r--r-- not rw-r-r

Anyways, flashable wallet here http://forum.xda-developers.com/showthread.php?t=1769083

0

Share this post


Link to post
Share on other sites

Posted

Did anyone ever end up finding a fix for the Galaxy Note? Travelling to the US next week and would love to try it out..

0

Share this post


Link to post
Share on other sites

Posted

Tried the flashable zip, still the app does not appear, although I do not get the message that wallet has stopped working...

0

Share this post


Link to post
Share on other sites

Posted (edited)

Is there any chance to, setup my debit card and make payments outside the USA? I've got already registered my card in Google Play, and this card is visible in Wallet, but it says "setup required" but I'm living in Poland, and I can't fill the State information.

Edited by Proove
0

Share this post


Link to post
Share on other sites

Posted

IF YOUR APPS ARENT SHOWING UP. JUST SIMPLY TRY A DIFFERENT ROM!... some roms works and some roms doesnt. had to try about 5 different roms and finally i went for AOKP jelly bean for it to show up with no errors!.. just keep trying guys!..

0

Share this post


Link to post
Share on other sites

Posted

Tried the flashable zip, still the app does not appear, although I do not get the message that wallet has stopped working...

You likely need to unfreeze it using Titanium Backup as it there, just not showing.

0

Share this post


Link to post
Share on other sites

Posted

E/PackageManager( 1946): Package com.google.android.apps.walletnfcrel requires unavailable shared library com.android.nfc_extras; failing!

Found that in logcat after trying to install this on a Galaxy S2 (Yes, I'm aware it's unsupported). Anyone know how to go about building that?

0

Share this post


Link to post
Share on other sites

Posted

so there's a new update to google wallet (1.5 R79-V5)

0

Share this post


Link to post
Share on other sites

Posted

so there's a new update to google wallet (1.5 R79-V5)

Yeah, and damned Market auto updated mine, breaking it of course. I thought I had that feature turned off.

Tried uninstalling updates, which wiped out my data as well...didn't think it would do that.

Guess setting up fresh is safer than restoring from TBU at this point.

0

Share this post


Link to post
Share on other sites

Posted

with the new update my nexus 7 is not supported anymore and with the galaxy nexus the same 1000 error :( wtf!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Without editing the prop.build file the phone is stuck on Adding your account... When the screen times out and I wake it the Adding your account is back to Get Started. UPDATE: Just ran a logcat and it's reporting Secure Elements 0. I have not had this issue in the longest time. Is it time to find the Sprint NFC libs? -- UPDATE: Confirmed that the NFC libs were needed in the rom I just started using. Also confirmed thanks to Pauls 3 way patch I did NOT have to edit the prop.build file at all. Nice. Oh HOLD ON - I just got an error/timeout adding the pre pay. I might have to edit the prop.build after all. Report back in a while. UPDATE: I did have to edit the prop.build to get the card to load. I just tried to us my GW at a store and nothing happend at all. I had GW open held back of phone against paypass terminal and nothing. The little vibe and tone did not do it's thing. The balance updated and the account number was there. ???

Edited by Hammermann
0

Share this post


Link to post
Share on other sites

Posted (edited)

Ugh, this is frustrating. Way too much time screwing around with this to be able to use my phone instead of the actual card at the precious few places that take Wallet to begin with.

Was working perfectly until as previously mentioned the damned market auto-updated the app.

Try to wipe and install again:


E/DeviceCapabilityManagerImpl( 6289): OperatorName=AT&T, Operator=310410, Product=htc_jewel, Model=htc_jewel not supported

Okay, change it to Galaxy Nexus, yakju and maguro per the SGS3 hack. Don't get the "not supported" any more, but perpetually stuck at "adding account".

Force stop, clear data, reboot several times. Repeat. Restore data only from TiBu (didn't work). Force stop, clear, reboot again. Finally, took a very long time, but appears to be installed again.

Edited by DistortedLoop
0

Share this post


Link to post
Share on other sites

Posted

@Paul- Your app on the Nexus or Galaxy S3 doesn't appear to be linked to the Market, but on the One X it is. One X is only phone that I have that keeps getting messages to update Wallet when a new version comes out. Any ideas why that would be?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Can't get this installed on my Xperia s. Just comes back with "application not installed".

Changes permissions, build prop, owner group, put in both system and data folders.

The stock Google wallet app installs but won't run (unsupported device as expected) but at least it installs.

Any suggestions or something obvious that i have missed.

Rooted Xperia S

Ics 6.1.A.245

Edited by borgsta
0

Share this post


Link to post
Share on other sites

Posted

@Paul- Your app on the Nexus or Galaxy S3 doesn't appear to be linked to the Market, but on the One X it is. One X is only phone that I have that keeps getting messages to update Wallet when a new version comes out. Any ideas why that would be?

Paul's latest patch does not require you to change the prop.build so I get the message from Market that the Phone is not compatible. This get around the auto update issue for sure. To bad i'm stuck on adding account.
0

Share this post


Link to post
Share on other sites

Posted

Paul's latest patch does not require you to change the prop.build so I get the message from Market that the Phone is not compatible. This get around the auto update issue for sure. To bad i'm stuck on adding account.

Ah, that's good to know. I'd asked Paul about this a while back, but didn't realize he'd fixed it.

That might explain why my HTC One X asks to update; it's using the original apk - and I used the same apk off my sdcard to reinstall. My SGS3 I downloaded a fresh copy to use to install. I'm not sure which version my VZW Galaxy Nexus has on it.

I'll probably wait to reinstall when the latest version gets hacked.

0

Share this post


Link to post
Share on other sites

Posted

Paul's latest patch does not require you to change the prop.build so I get the message from Market that the Phone is not compatible. This get around the auto update issue for sure. To bad i'm stuck on adding account.

with the market version the build.prop needs to be changed to "galaxy nexus" for the s3 and it will stop working if you go back to stock. best to turn off auto-updates and/or uninstall updates and wait for the patched version

0

Share this post


Link to post
Share on other sites

Posted

with the market version the build.prop needs to be changed to "galaxy nexus" for the s3 and it will stop working if you go back to stock. best to turn off auto-updates and/or uninstall updates and wait for the patched version

But Paul's version you can change back to proper device identifiers?

I've got issues with other apps not wanting to install because they think my device is not supported while using the Wallet-friendly build.prop

0

Share this post


Link to post
Share on other sites

Posted

But Paul's version you can change back to proper device identifiers?

I've got issues with other apps not wanting to install because they think my device is not supported while using the Wallet-friendly build.prop

yes, with paul's patched wallet and the sgs3 i had to change the build.prop to add cards, but after that I changed back with no problems

0

Share this post


Link to post
Share on other sites

Posted

Ah, that's good to know. I'd asked Paul about this a while back, but didn't realize he'd fixed it.

That might explain why my HTC One X asks to update; it's using the original apk - and I used the same apk off my sdcard to reinstall. My SGS3 I downloaded a fresh copy to use to install. I'm not sure which version my VZW Galaxy Nexus has on it.

I'll probably wait to reinstall when the latest version gets hacked.

Ya hang on for the next patch. As it turned out I did have to edit the prop.build to ad the card.
0

Share this post


Link to post
Share on other sites

Posted

paul, sorry a little of topic, but in regards to the Disabled Jelly Bean 'disable apps on boot' feature on your n7 rom...some users, specifically in canada (as well as others) are reporting that after an ota update from the carrier (still ics) the wallet app is "disappearing" even though it is still in system/app, is it possible that they have implemented this feature in ics? and can it be disabled after the fact?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.