PaulOBrien

XMOD: Region / Device / Root patched Google Wallet

763 posts in this topic

i switched phones to toeh Sprint HTC one, and still had the issue. but somehow, miraculously, i got it to work. I have no idea how or if its repeatable

Installed Xposed on phone, ran prog, hit install and rebooted

Installed This wallet - https://www.dropbox....1.6-R96-v16.apk but did not open the program

Installed the Modaco Wallet Module, enabled it in the Xposed program and rebooted

Installed the Modaco Pro Toolkit (free at the moment), enabled the module in exposed, and rebooted

Ran wallet and it set up instantly.

Give it a try and let me know

I followed these steps and got to the Setup page (the page saying it may take up to 5 minutes to set up Wallet). I let it sit for quite some time and after about 3-5 minutes, it force closes. I used both the single mod and the MoDaCo toolkit's mod, but Wallet still won't complete setup. I have an unlocked HTC One and I've tried build.prop edits, and other Xposed mods but this is the closest I've gotten to a working Wallet app. Any help would be greatly appreciated!

0

Share this post


Link to post
Share on other sites

I followed these steps and got to the Setup page (the page saying it may take up to 5 minutes to set up Wallet). I let it sit for quite some time and after about 3-5 minutes, it force closes.

I'm guessing you're on AT&T; there's a post in this thread that mentions that the AT&T roms do not have the "secure element" enabled. I think it's on page 37 or 38. At any rate, we're still hoping that one of the gurus figures out a workaround. I'm offering a bounty for whoever does :)

0

Share this post


Link to post
Share on other sites

I'm guessing you're on AT&T; there's a post in this thread that mentions that the AT&T roms do not have the "secure element" enabled. I think it's on page 37 or 38. At any rate, we're still hoping that one of the gurus figures out a workaround. I'm offering a bounty for whoever does :)

You can consider me on AT&T, but it's an unlocked version (bought through HTC), so it shouldn't matter that it's on AT&T's network. Definitely hope someone can figure this out though.

0

Share this post


Link to post
Share on other sites

Has anyone using an HTC One gotten this working yet? I'm also getting the "insufficient secure element..." error as well. Help!

0

Share this post


Link to post
Share on other sites

Every time I try install this on my phone it just say application not installed and doesn't work.

0

Share this post


Link to post
Share on other sites

Paul, first I'd like to thank you for your previous patched Wallet apks. It makes me upset that carrier politics hurt the consumer and it takes this level of work to get something so trivial working.

I have security concerns about the Xposed framework and don't want to install it on my devices. I've been working to patch the latest wallet version myself. I've looked at the smali generated by pulling apart your last patched wallet apk and also what you did in your xposed module. I think I have a patched apk together, but when attempting to sign it I get an error telling me that I have insufficient privileges and that there are insufficient secure element privileges for this system (test-keys). I think I'm signing the apk wrong.

Would you be able to pass along how you signed the wallet apk so that it would run? Thanks!

EDIT: Here's the post with a screencap of the issue and apks that I generated http://forum.xda-developers.com/showpost.php?p=41294245&postcount=160

Paul, I am getting the same error on my rooted xperia z (C6606.. the t-mobile version). The xposed framework allowed me to install the app, bit that was it. I have edited the build.prop to show NFC to use the secure element. Can you help?

Edited by master of mayhem
0

Share this post


Link to post
Share on other sites

Has anyone using an HTC One gotten this working yet? I'm also getting the "insufficient secure element..." error as well. Help!

Is it safe to say that at this point, Wallet is not being supported if you are on a network other than Sprint?

0

Share this post


Link to post
Share on other sites

Hey guys,

So here's what I tried. I have an international HTC One X (Tegra 3 version) and I tried the Xposed framework mod for Google Wallet. I edited the build.prop file to show as if I was using a Galaxy Nexus, rebooted and all went well, Wallet opened and I could use it just fine.

The problem came when I reverted the build.prop changes and rebooted. Here I got in 2 sticky situations:

1. The first time, the phone rebooted, showed the spalsh screen and the bootanimation and got into the home screen, however, the wallpaper was all messed up and after about 10 seconds it would reboot by itself. It did this repeatedly;

2. The second time, the phone rebooted and would stay on the main HTC splash screen, but it would not go to the bootanimation and boot up Android.

I am using CM10.1.2 and fortunately I made a Nandroid Backup so I was able to revert the changes.

Does anyone know why these 2 errors occured? I really want to use GW but, unfortunately, it's not available in my country.

0

Share this post


Link to post
Share on other sites

So, I'm running the latest version of the N4 ROM and Wallet just got an update.

Being something I've been frustrated with for a while (along with most outside the US) I've not played with it for a while however after the update I opened it & my UK cards are listed there.

Will this work in M&S?

post-764110-13796414527806_thumb.jpg

0

Share this post


Link to post
Share on other sites

So, I'm running the latest version of the N4 ROM and Wallet just got an update.

Being something I've been frustrated with for a while (along with most outside the US) I've not played with it for a while however after the update I opened it & my UK cards are listed there.

Will this work in M&S?

No. No UK cards work. Tried it today and said international transactions are not supported.

0

Share this post


Link to post
Share on other sites

No you don't.

Hi w4qq4s, do you know if Google Wallet work in Dell streak mini 5 running Gingerbread 2.3.3?....my Dell Streak mini 5 do not work anyway with Wallet apk from this forum....... :wacko:......thanks in advance  :) 

0

Share this post


Link to post
Share on other sites

Hiya,

 

was wondering if you could help.

 

i have downloaded and installed Wallet 2.0-R133-v9.apk

 

installed xposed framework, added the wallet module and restarted my phone but its still saying im in the wrong region. also does tap to pay work yet in the uk ?

 

Rich

0

Share this post


Link to post
Share on other sites

Hiya,

 

was wondering if you could help.

 

i have downloaded and installed Wallet 2.0-R133-v9.apk

 

installed xposed framework, added the wallet module and restarted my phone but its still saying im in the wrong region. also does tap to pay work yet in the uk ?

 

Rich

I had a similar problem.

Solved by uninstalling the system app (when I tried to install the version linked above it failed), and then installing that version.

Problem is now is that I get error: Update Wallet: This version of the Google Wallet app is no longer supported. Please download the latest version from Google Play.

The latest version seems incompatible with the Xposed mod, however

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.