• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

XMOD: Region / Device / Root patched Google Wallet

763 posts in this topic

Posted

Does anyone know why google wallet keeps getting stuck at activating account after i click "I Agree" on my galaxy s2 skyrocket on at&t running cm9

post-984822-0-54278900-1340911381_thumb.

0

Share this post


Link to post
Share on other sites

Posted

Matt to I have the same issue - activating account.

Can any one help. I have a OneX and this was working for me, I put on a new rom (reset wallet before) and now when I load the app I get activating account.

Is anyone else having this issue now when it was working before?

0

Share this post


Link to post
Share on other sites

Posted

Matt to I have the same issue - activating account.

Can any one help. I have a OneX and this was working for me, I put on a new rom (reset wallet before) and now when I load the app I get activating account.

Is anyone else having this issue now when it was working before?

0

Share this post


Link to post
Share on other sites

Posted

A lot of devices aren't supported yet.

A new build is in the Galaxy Nexus JB release, 1.1-r67-v5 which i've already patched and will upload today, but it doesn't resolve this issue.

P

0

Share this post


Link to post
Share on other sites

Posted

The download has now been updated to 1.1-R67-v5 (as released with Galaxy Nexus Jelly Bean).

This doesn't seem to help with devices where the SMX element isn't detected (i.e. hanging on 'Activating').

P

1

Share this post


Link to post
Share on other sites

Posted

OK, had it running fine on my GN in ICS

just upgraded to Modaco's Jelly Bean ROM, added the new patched apk as I did before (in to system/app using root explorer)

restarted phone

nothing appearing in my app drawer

went back in, removed the apk already in there that said it was modified in 08, left the patched one, rebooted, still nothing

any ideas?

0

Share this post


Link to post
Share on other sites

Posted (edited)

The download has now been updated to 1.1-R67-v5 (as released with Galaxy Nexus Jelly Bean).

This doesn't seem to help with devices where the SMX element isn't detected (i.e. hanging on 'Activating').

P

hey paul, doing a bit of research. this was a similar problem with gingerbread (although not with google wallet) but same thing...

anyways the SMX has to be enabled in the config headers in the "external/libnfc-nxp library"

this obviously can't be done after the fact...unless there is a way to edit an lib .so file???

sooo, there is no source for samsung tw roms right?

maybe a leaked build with SMX enabled might be the only hope?

Edited by ogdobber
0

Share this post


Link to post
Share on other sites

Posted (edited)

Hey, Hey, Paul...

Your latest JB release works peachy here in the US on VZW....had to swipe it twice at McD's, but it worked!

Thank you SO much for making this usable again.

Cheers!

Edit: Goog Pre-pay is what I use..

Edited by skeeter1
0

Share this post


Link to post
Share on other sites

Posted

Hey, Hey, Paul...

Your latest JB release works peachy here in the US on VZW....had to swipe it twice at McD's, but it worked!

Thank you SO much for making this usable again.

Cheers!

Edit: Goog Pre-pay is what I use..

You're welcome!

P

0

Share this post


Link to post
Share on other sites

Posted

OK, had it running fine on my GN in ICS

just upgraded to Modaco's Jelly Bean ROM, added the new patched apk as I did before (in to system/app using root explorer)

restarted phone

nothing appearing in my app drawer

went back in, removed the apk already in there that said it was modified in 08, left the patched one, rebooted, still nothing

any ideas?

Same here. Any help appreciated!

0

Share this post


Link to post
Share on other sites

Posted

Rooted my 2 day old One X last night.

Everything went well with wallet but it fails on the adding card part when I try to add Google payment card.

It simply tells me to try again later.

Tried on wifi and 3g. Running Android Revolution 7.

Any ideas ?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, i had patched google wallet v4 working, confirmed by buying a slushie at 7/11 :) (SGS3 running CM9 in Australia) however, i had to reload cm9 because some core features (sms/mms) were not working, but i didn't know to reset google wallet data before doing this! (first android phone). Now on the new rom, my wallet gets stuck on activating account, while on the version where it was working ( made sure to back up this one incase) it gets stuck on Initializing. If i could past Initializing on the old version, i could reset it and that would hopefully fix the problem on the working cm9 rom, anyone have any ideas on how to get past Initializing?

Edited by Honeymunchz
0

Share this post


Link to post
Share on other sites

Posted

Version on Play Store was updated to v12 today. Any chance we can get the new version patched as well?

I can upload the APK, if it would help.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Version on Play Store was updated to v12 today. Any chance we can get the new version patched as well?

I can upload the APK, if it would help.

Any idea of the changes? V5 to V12 seems a little odd?

Play Store says

What's New

What's in this version:* Support for new device form factors

* Prepaid topup improvements

* Security enhancements

Edited by Northern-Loop
0

Share this post


Link to post
Share on other sites

Posted

Any idea of the changes? V5 to V12 seems a little odd?

Play Store says

What's New

What's in this version:* Support for new device form factors

* Prepaid topup improvements

* Security enhancements

I actually don't, because allowing the Play Store to update this version causes Wallet to cease functioning. Thus the need for the updated version to be patched.

0

Share this post


Link to post
Share on other sites

Posted

Hi, i had patched google wallet v4 working, confirmed by buying a slushie at 7/11 :) (SGS3 running CM9 in Australia) however, i had to reload cm9 because some core features (sms/mms) were not working, but i didn't know to reset google wallet data before doing this! (first android phone). Now on the new rom, my wallet gets stuck on activating account, while on the version where it was working ( made sure to back up this one incase) it gets stuck on Initializing. If i could past Initializing on the old version, i could reset it and that would hopefully fix the problem on the working cm9 rom, anyone have any ideas on how to get past Initializing?

I have the same problem on my One x, any help or guidance how to fix appreciated..

0

Share this post


Link to post
Share on other sites

Posted

Hey Paul,

What tool are you using to decompile and recompile? I've tried using apktool which decompiles successfully but fails to compile. Tried a few framework apks and making sure I have the latest platform-tools but no luck.

I'm 99% of the way there but must be missing a critical apk or similar.

Thanks for your hard work!

0

Share this post


Link to post
Share on other sites

Posted (edited)

I am having trouble getting wallet to even load.

Getting message Unfortunately unsupported device/carrier.

I have tried Hacked APK , tried market enabler None of them worked.

I am using HTC one x (Vodafone australia) Stock Rom - Rooted. Re-locked Bootloader, system recovery.

Android 4.03

When i copy hacked apk to system/app and set permission and reboot phone there is no GW apk present in system/app folder the one i copied before and can't find app on in the app list.

And the one from us - T mobile GW after using market enabler getting

unsupported device/carrier message.

Please help.

I tried copying with ADB push but after reboot app not available in drawer or system/app folder

already set correct permission rw-r--r-- with root explorer and chmod 644

Unable to get app icon with root explorer.

Manage to get icon with ES explorer but after reboot app is gone from the system/app folder and also not available in app drawer.

Changed owner to root

What is wrong ?Do i need corresponding .odex file for it as it is stocked rom ?

And if i need one where can i find it for your hacked GW.apk ?

Edited by chris1104
0

Share this post


Link to post
Share on other sites

Posted

Fix for stuck on "Activating Account" problem:

Reset Google Wallet through the settings page (this might take a minute or two).

Connect your phone to your computer and issue the following command through ADB:

./adb shell am broadcast -a android.intent.action.MASTER_CLEAR_NOTIFICATION[/CODE]

[/background][/font][/color]

[font=Roboto, helvetica, arial, sans-serif][color=#282828]That's it - this completely clears the secure element in the phone, which frankly is something that the app should do anyway when it resets itself. [/color][/font]

[color=#282828][font=Roboto, helvetica, arial, sans-serif][Note - you can't do this to activated numerous Google accounts to get multiple free $10 credits, so not worth the effort of potentially knackering the secure element in your phone. The free $10 is tied to the secure element ID, so this is why if you buy a second hand phone you might not always get the $10 credit.][/font][/color]

0

Share this post


Link to post
Share on other sites

Posted

Perhaps I did it wrong, but the fix didn't work for me

Was running older version fine and decided to upgrade

New version - stuck on activating account

Reverted to old version - stuck on initializing

And yes - did select reset account, in between upgrade

Got new version (R5) and still stuck on activating

HTC One X running LeeDroid v6.4

0

Share this post


Link to post
Share on other sites

Posted

The download has now been updated to 1.1-R67-v12 (latest play store release).

This doesn't seem to help with devices where the SMX element isn't detected (i.e. hanging on 'Activating').

P

1

Share this post


Link to post
Share on other sites

Posted (edited)

Since running your Jelly Bean I haven't managed to get Wallet working, looked in logs and I see this though, seems bad

Unknown permission com.android.nfc.permission.NFCEE_ADMIN in package com.google.android.apps.walletnfcrel

Dunno what info might help but it was Stock 4.0.4 Galaxy Nexus and I did a full wipe to your lovely Jr1

Edited by DaveTudou
0

Share this post


Link to post
Share on other sites

Posted

Running OK on JR1 here...!

P

0

Share this post


Link to post
Share on other sites

Posted

Running OK on JR1 here...!

P

OK My bad I think, I dont' remember pressing Freeze in Titanium, but there was a Defrost button. That worked. Though for ages I was getting permission denied to /data/system/packages.xml :S anywy I have my prepaid back, thanks Paul for the Wallet :)

0

Share this post


Link to post
Share on other sites

Posted

Tried running the fix at the top of this page but get the following :-

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd C:\Program Files (x86)\Android\android-sdk\platform-tools

C:\Program Files (x86)\Android\android-sdk\platform-tools>adb devices

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

List of devices attached

4df101d957514f9f device

C:\Program Files (x86)\Android\android-sdk\platform-tools>./adb shell am broadca

st -a android.intent.action.MASTER_CLEAR_NOTIFICATION

'.' is not recognized as an internal or external command,

operable program or batch file.

C:\Program Files (x86)\Android\android-sdk\platform-tools>

Anyone explain what I'm doing wrong.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.