• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Showing incorrect battery charge status

10 posts in this topic

Posted · Report post

Hi people, I could use some of your valueable insights here.

I'm running Android 2.3.5, kernel 2.6.32.9-perf and cyanogenmod 7-08212011-NIGHTLY-Blade.

Since a few days where I haven't had access to my own charger (I've been dependent on USB charging from my laptop), my phone has been reporting its battery charge incorrectly and wouldn't display a charge over 75% anymore regardless of how long it charged. I haven't upgraded my OS anytime recent (anytime at all, really) and battery status has been reported OK for months until this issue developed. In fact, when I tried a battery recalibrate, this made things worse. (Obviously I couldn't start the calibrate from "100%" though, because the phone never claims to reach that).

After a proper, full battery calibrate (i.e. full decharge followed by overnight recharge) my phone now claims to have a battery charge of 20% now even though I know the battery is fully charged. Obviously the battery *is* being fully charged, as it will last as long as a full charge. I know it's not a battery problem because I've already replaced the battery. It's just irritating to see the battery status show yellow or red when it's on a full charge.

In other words, I'm pretty sure this is a software issue. If I *know* my phone is really fully charged but it's displaying the charge at 20%, how do I tell it that it's mistaken and actually fully charged?

Thanks in advance,

Marc

0

Share this post


Link to post
Share on other sites

Posted · Report post

If you believe it is full battery then you could reboot into recovery & wipe battery stats.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Actually this advice has just made things worse. I'm now at a point where unplugging the phone from the charger at any time will make it buzz saying "connect your charger". Right now the phone states "current charge: 14%, 3780 mV. The latter is perfectly fine for a full battery. Of course when trying to charge the phone, it will never go higher than a full charge so the charge never reaches higher than the last percentage displayed at a full charge. That is, it's the former bit (14%) that the phone seems to hang on to which I need to reset.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I guess what I really want to know is, what are the following:

/sys/devices/platform/msm-battery/power_supply/battery/capacity

/sys/devices/platform/msm-battery/power_supply/battery/voltage_max_design

/sys/devices/platform/msm-battery/power_supply/battery/voltage_min_design

/sys/devices/platform/msm-battery/power_supply/battery/voltage_now

and is there any way to have influence over the values in there?

Edited by kleinebre
0

Share this post


Link to post
Share on other sites

Posted · Report post

:mellow: ah shiz soz about that... just a setting I used in recovery I did when installing CM7, did me no harm. Sounds to me like bad battery, maybe some of it is still charging but not all of it? Might wanna try another to verify if it's the battery or something in the phone / rom.

You didn't go crazy with the undervolting in the cpu settings in recovery?

0

Share this post


Link to post
Share on other sites

Posted · Report post

No worries. No, didn't do any fancy stuff in recovery. Also, as mentioned, I had already ruled out it to be a battery issue (already replaced it).

I've just had it charging all night (with the phone switched off to make sure no software could be eating up CPU) and in the morning it claimed

to be charged to 9%. I hook it off, and have my breakfast.

But here's the funny bit.

I just plugged in the charger in and unplug it, immediately it claims to be charged up to 11%. So I got curious...

Plugged the charger in again unplug it, immediately it claims to be charged up to 12%.

... repeated this a few times, and in under a minute it claims to be charged 18% (unfortunately it stopped doing that from that point on).

Battery app says the current charge is 3783 mV (18%). It's a ZTE blade by the way (though I doubt that that makes a difference).

Am I really supposed to believe that under 1 minute's worth of charging has a greater effect than charging overnight?

Of course I'm not interested in going through a plug in/unplug ritual that wears out the usb port 10 times as fast as usual.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Using the fast several times charger unplug-replug trick, battery charge is now being reported as 3800 mV (30%). Will report back in a few days.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Current charge: 17%, 3694 mV. You can see how this is inconsistent with a charge of 14%, 3780 mV.

I'm getting really fed up with this by now. Nominal battery voltage should be 3.7 volts for a full charge. So after a night on the charger, in effect, you can see it *is* fully charged.

Anyone?

0

Share this post


Link to post
Share on other sites

Posted · Report post

As my opinion the battery may not be calibrated correctly. You can download the Battery Calibration application off the market for free. It can be charge your phone to 100%, open the application, click the calibrate button, then unplug from the charger. After that let your battery drain completely until your phone shuts off then charge without a break back up to 100%, and your battery should be accurate.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I did have that app, but there was one problem... charge never reaching 100% in the first place. As a result, whenever I tried, it seemed to have the opposite effect and make things worse instead of better.

But in the end I've cracked it. It was a problem with the micro usb cable. A different cable and all problems disappeared just like that.

Apparently, Androids can charge over USB either via the power lines or the data lines. Charging via power lines is fast; charging over data lines is painfully slow, but will keep the phone going if the power lines are dodgy. In other words, as the phone was still charging, I ruled out a hardware issue, but I ruled it out too soon, forgetting that the charger cable is hardware too. I just never thought that a broken cable would still allow one to charge the phone.

All is well that ends well. Thanks for all the good intentions, even if they didn't lead to the solution. Hopefully someone with the same problem will run into this thread and save some time by simply replacing the data cable.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.