• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

screen response problem with root

71 posts in this topic

Posted · Report post

Hi Guys

I have a ZTE Skate (SFR starradict from France)

I was happy with it but as I suppost most of us unsatisfied with the small memory available

So, I have decided to root the mobile and then install Link2ds to move application to the SD

So, my mobile is under gingerbread 2.3.5 then I have applied the Android2.3.5_root patch

Everything has worked without problem and now I can move as I want programs to the SD (except some small bugs for some of the programs that doesn't like to be moved to the SD but that's not the actual issue)

The issue is that, since the root procedure, the touchscreen is not working properly.

The 1cm left border does not respond anymore then, I can't type some letter as A or Q (french keyboard).

First, I thought it was an hardware issue but then, I applied back the original rom to find back the original mobile and then, the screen worked back correctly...finally, I have reinstall the 2.3.5_root patch and the the screen problem is back

if some of you could help...

thanks a lot

Angelo

ps: sorry for my poor English but i'm french and since I did not find any solution in our french forum, I'm now here :-)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

me too, I have the same problems with atomic mod , cm9 or cm7 on Staraddict of SFR.

Sorry for english

Edited by spide
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

@angelo

After doing root just flash back the original boot.img from non-rooted stock rom. This will maintain root and probably solve your screen issues.

Edited by C3C0
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Thanks for your time C3C0

what do you mean by "the original boot.img" ?

I did a backup of the original rom with ClockworkMod...is this what you mean ? just restoring this rom via ClockworkMod menu ?

Angelo

Edited by angelo50
0

Share this post


Link to post
Share on other sites

Posted · Report post

Don't restore the whole rom. Just boot.img. This means... while in clockworkmod, go for: Backup & restore / Advanced Restore / Restore boot

0

Share this post


Link to post
Share on other sites

Posted · Report post

Wonderfull, you are are GREAT!!!!

I effectively restored the boot rom my non flashed backup and it works

The keaboard is ok and the mobile is still rooted...then I can use link2sd

Thanks you very very much

I will now communicate this solution to severals user in France who have the same issue

Thanks again

Angelo.

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

and for an custom roms? please

Edited by spide
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

You can use the same method for custom roms. But be aware that by using the stock boot you loose overclocking feature because

stock boot.img is not overclockable.

Yes and I forgot. CM7 and CM9 won't boot with stock boot at all.

This method can be applied to 2.3.4/2.3.5 stock based custom roms (e.g. Atomic)

It would be nice to have the stock boot.img for SFR. The one where screen works OK so I can take a look at it

what't under the hood that makes it different to those that we normally use with custom roms.

Edited by C3C0
0

Share this post


Link to post
Share on other sites

Posted · Report post

thanks I use Atomic r13 with your method : keyboard : OK but WIFI : NO

0

Share this post


Link to post
Share on other sites

Posted · Report post

Taking the files from /system/lib/modules of stock rom and placing them into same location on atomic should fix it.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Where are the files of stocks roms?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Inside system.img of your backup.

If you could upload the complete backup I could make a flashable zip containing boot.img and all the necessary files.

Edited by C3C0
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

ok and what do you want ?

sorry for english

backup origins roms with clockworkmod?

Edited by spide
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yes. Backup stock rom, zip it and upload it somewhere so I can download it. I'll take a look at it tomorrow possibly. Boot.img and system.img is all I need

Edited by C3C0
0

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks. Will look into it. And possibly make an overclockable kernel without touchscreen issues (at least I hope)

0

Share this post


Link to post
Share on other sites

Posted · Report post

OK. So I extracted kernel config from stock boot.img and it looks like your model of Skate uses newer touchscreen (TOUCHSCREEN_MXT224_P743F)

So I updated drivers in my S2 kernel to support this kind of touchscreen and compiled new boot.img.

Please note, I couldn't test it myself since I don't have this model. So backup before applying this update because might happen it wont't even boot...

This one is for non-Cyanogenmod ROMs (Atomic, Skatie, H3, ......).

If it works as expected then I will also make the S3 version for CM7 and CM9.

Download: http://tinyw.in/InZc

MD5 sum: d35e4953d1bae8dc355f3116f34f8160

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Keyboard OK but WIFI : NO (Error) with Atomic 13

Edited by spide
0

Share this post


Link to post
Share on other sites

Posted · Report post

@ angelo

Can you try new kernel posted in my previous post with stock rom?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Keyboard OK but WIFI : NO (Error) with Atomic 13

Did you flash the whole ZIP via clockworkmod?

Send me the boot.img from Atomic13 so I can take a look at it.

Also logcat would be helpful

Edited by C3C0
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yes with Clockworkmod.

Wait I go try Skaties

It's the same with skatie : NO WIFI (error)

Edited by spide
0

Share this post


Link to post
Share on other sites

Posted · Report post

Atomic R13 but no update : WIFI : YES but keyboard : NO

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Yes with Clockworkmod.

Wait I go try Skaties

It's the same with skatie : NO WIFI (error)

This definitely should work on Skatie since it is the same kernel the Skatie's S2 is based on.

Looks like that apart from touchscreen also wifi hardware module is different.

Can you post me a boot.img from Atomic13?

What about bluetooth? Does it work?

I am going to take a look inside the system files of stock rom you posted maybe I'll find some hints on wifi there

Edited by C3C0
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

ok and bluetooth it's ok

Edited by spide
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.