• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

MokeeOS Metal *Link Up*

121 posts in this topic

Posted (edited)

The torch does work, it's just the shortcut in the status bar doesn't work.

Is there a torch app on that rom? If yes disassemble it and find a line at values/bools.xml, something like:

<use_Camera_interface>false</>

and change false to true. In most cases it does its trick. In miui I had to change line that checks device name in build.prop and provides a set of functions(one of these was support a camera interface instead of torch device itself), so I just changed that line(as it was in plain quotes) to a4 and it worked.

for su there should be a su binary which belongs to mokee, also busybox and toolbox from this rom, not ours.

Edited by Lens_flare
0

Share this post


Link to post
Share on other sites

Posted (edited)

Is there a torch app on that rom?

Oh. That's probably the problem. Thanks for that btw, Ill post the logcat and see if you know anything

Edited by Mtman1
2

Share this post


Link to post
Share on other sites

Posted

Oh. That's probably the problem

what? you don't have it?

I'm curious how it works without proper implementation?

0

Share this post


Link to post
Share on other sites

Posted

Here it is. I can't find any app called com.mokeetec.flash (or whatever its called)

alogcat.2012-06-24-15-26-08+0100.txt

2

Share this post


Link to post
Share on other sites

Posted

can't find any app called com.mokeetec.flash (or whatever its called)

that's exactly what logcat tells to you :D

android.content.ActivityNotFoundException: Unable to find explicit activity class {com.mokeetek.flash2/com.mokeetek.flash2.MainActivity}; have you declared this activity in your AndroidManifest.xml?[/CODE]

It also couldn't find such app, have you deleted it?

0

Share this post


Link to post
Share on other sites

Posted

nope, haven't deleted anything. I've porteed this from the zte skate/blade (a mixture) and I don't think either of them have a torch :( so that might be why.

2

Share this post


Link to post
Share on other sites

Posted

YESSSSS

I've fixed the torch in status bar :):):)

@ lens I found a port for the desire, and that had a torch. I placed that in system/app, rebooted and it worked

CWM zip tomorrow maybe

2

Share this post


Link to post
Share on other sites

Posted

I'm on a roll!! Fixed both superuser and overclock! What else?

2

Share this post


Link to post
Share on other sites

Posted

Nice work! Waiting for the v4! And you will can remove the zte blade settings, are not use in our phone.

0

Share this post


Link to post
Share on other sites

Posted (edited)

That will leave a force close I think (and i dont like forse closes). I'm not sure -_- Ill have a look

Edit: yep it makes it fc. I might make an addon, but you can just use titanium backup too delete blade parts/skate parts.

Edited by Mtman1
2

Share this post


Link to post
Share on other sites

Posted

I'm on a roll!! Fixed both superuser and overclock!

busybox,toolbox and su? :D

share share share :P

0

Share this post


Link to post
Share on other sites

Posted

Su: put a su app in it + binery+busybox :P

Overclock: replaced the settings with another phone's settings that had overclock and added no frills cpu

2

Share this post


Link to post
Share on other sites

Posted

how much free spaces in internal memory is there, in this rom? thank's for your work!!waiting v4

0

Share this post


Link to post
Share on other sites

Posted

Hey why i don't see statusbar and have a big bugs???

0

Share this post


Link to post
Share on other sites

Posted

how much free spaces in internal memory is there, in this rom? thank's for your work!!waiting v4

Now, in v3 with the new apps, I have 142 MB free. I use Link2sd, of course :P

0

Share this post


Link to post
Share on other sites

Posted (edited)

Nice!

Edited by Samsung S3
0

Share this post


Link to post
Share on other sites

Posted

Hey why i don't see statusbar and have a big bugs???

Ummm.... try rebooting the phone... what big bugs?

2

Share this post


Link to post
Share on other sites

Posted

New and (maybe) final version out, check 1st post

1

Share this post


Link to post
Share on other sites

Posted

All working now! #v4

Thank you for all @Mtman1!

0

Share this post


Link to post
Share on other sites

Posted

Glad to hear :) If you can see any problems, please tell me

2

Share this post


Link to post
Share on other sites

Posted

We have a problem: it is impossible activate the led notifications!! :unsure:

In the older CyanogenSettings app, this path exist: -- Setting -- CyanogenMod settings -- Interface -- LED notification, but in the "multilanguage" version not exist.

0

Share this post


Link to post
Share on other sites

Posted

Oh.... That's not so good.... Ill have a look at it now :)

2

Share this post


Link to post
Share on other sites

Posted

So, I haven't found a fix yet. Was this function ever available in any of my builds of mokee? If so which one?

2

Share this post


Link to post
Share on other sites

Posted

check out have_intrusive_led = true at cmparts.apk.

0

Share this post


Link to post
Share on other sites

Posted

Oh that was easy.... I just replaced the cmparts.apk (cmsettings) with lens_flares cm7 apk. :) I will post the zip tomorrow

2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.