• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

LG E400 kernel source

64 posts in this topic

Posted (edited) · Report post

did you build it for stock gingerbread? i thought people has a problem with CM9 roms...

maybe you have to port it in CM's kernel...

Yes, this is kernel to stock firmware 2.3.6. Some users have had problems with the screen, if install the kernel, compiled from source v10c.

Edited by kgdhost
0

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, this is kernel to stock firmware 2.3.6. Some users have had problems with the screen, if install the kernel, compiled from source v10c.

okay then, it's great one... :)

so, when we try to port it to CM kernel? i haven't enough time for now, it's 03:10AM in here. i have to sleep for working at morning.

we'll waiting for your another great expansion... ;)

cheers....

0

Share this post


Link to post
Share on other sites

Posted · Report post

okay then, it's great one... :)

so, when we try to port it to CM kernel? i haven't enough time for now, it's 03:10AM in here. i have to sleep for working at morning.

we'll waiting for your another great expansion... ;)

cheers....

I'll try. But I can not promise... :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

did you build it for stock gingerbread? i thought people has a problem with CM9 roms...

maybe you have to port it in CM's kernel...

I heard that the problem also occured on gingerbread by some people so both should be tested i think

0

Share this post


Link to post
Share on other sites

Posted · Report post

absolutely right :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Many many thanks for the compiled kernel :D it works without problems with the news screen! :D very good job!

I tried to merge it with the CM9 kernel, but the compiler had some issue... can i ask you how to fix the missing files problem?

Anyway, i noticed that changes from v10c and v10q are only a few changes...so should be very simple merging this sources with the CM one... give it a try ;)

bye :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

wip

Edited by Suxsem
0

Share this post


Link to post
Share on other sites

Posted · Report post

v10b/v10c

# CONFIG_HIGHMEM is not set
CONFIG_HW_PERF_EVENTS=y
CONFIG_VMALLOC_RESERVE=0x08000000[/code]
[code]# CONFIG_MSM_KGSL_DISABLE_SHADOW_WRITES is not set
v10q
CONFIG_LGE_SILENCE_RESET=y
CONFIG_HIGHMEM=y
CONFIG_HW_PERF_EVENTS=y
CONFIG_VMALLOC_RESERVE=0x1C000000[/code]
[code]CONFIG_MSM_KGSL_DISABLE_SHADOW_WRITES=y
and those are the differences between the kernel source configs... files that are different between the two sources:
e0eu-perf_defconfig
board_lge.h
board-e0eu-camera.c
board-e0eu-input.c
board-e0eu-mmc.c
board-e0eu-sound.c
board-e0eu-usb.c
Kconfig
acpuclock-7201.c
devices-msm7x27a.c
memory.c
smd.c
mmu.c
adreno.c
adreno_postmortem.c
adreno_ringbuffer.c
kgsl_mmu.c
kgsl_pwrctrl.c
gp2ap002.c
mcs8000_ts_mms128.c }
mms100_ISC_download.h } all three found in touchscreen
mms100_firmware_binary.c }
radio-tavarua.c
hi351_reg.c
msm_camera.c
msm_io_msm7x27a.c
msm_battery.c
lge_gpio_switch.c
ebi2_tovis.c
mdp_ppp_v20.c
super.c
base.c
fs.h
earlysuspend.c
sys.c
hci_event.c[/code]

and that's it for changed files.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Many many thanks for the compiled kernel :D it works without problems with the news screen! :D very good job!

I tried to merge it with the CM9 kernel, but the compiler had some issue... can i ask you how to fix the missing files problem?

Anyway, i noticed that changes from v10c and v10q are only a few changes...so should be very simple merging this sources with the CM one... give it a try ;)

bye :)

I do not remember exactly how I did it . Rather, I simply add the missing files from v10c code.

Now, I uploaded the code with a few changes on github. Maybe it will be helpful to someone:


github.com/kgdhost/kernel-lge-e400-stock.git

0

Share this post


Link to post
Share on other sites

Posted · Report post

thanks :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

was able to installed it perfectly but my Wifi is not working :( ,.

any help appreciated thanks.

im using V10n eu

Edited by sharkeater02
0

Share this post


Link to post
Share on other sites

Posted · Report post

Sorry for noob question but is it possible to side load more governors as module using insmod command?

0

Share this post


Link to post
Share on other sites

Posted · Report post

wifi n wifi hotspot not working after flashing dis stock kernel.. v10j :(

0

Share this post


Link to post
Share on other sites

Posted · Report post

wifi n wifi hotspot not working after flashing dis stock kernel.. v10j :(

wifi n wifi hotspot not working after flashing dis stock kernel.. v10j :(

same here..had to reflash stock rom using KDZ

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.