• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[ICS] [CM9] [4.0.4] CyanogenMod 9 for the Huawei Ascend G300 [ROM]

814 posts in this topic

Posted

Camera is far off. I want to sort out display first. I don't think people are interested in CM9 anymore when work could be instead focused on CM10 being Android 4.1 and all.

I'd settle for a working cm7 port to hold us over for the couple of months development of cm10 will take. I think a lot of us feel like this and it seems that you and tillaz are prolly the only people who could easily make that happen.

How would you feel about doing something like that for us?

1

Share this post


Link to post
Share on other sites

Posted (edited)

I'd settle for a working cm7 port to hold us over for the couple of months development of cm10 will take. I think a lot of us feel like this and it seems that you and tillaz are prolly the only people who could easily make that happen.

How would you feel about doing something like that for us?

+1 to that. I would prefer CM9/CM10 but as you say, a CM7 build would be very welcome, although I guess we would be in the same situation with the RIL as we are with CM10.

Edited by Cyda
2

Share this post


Link to post
Share on other sites

Posted

I just got my G300 this week, updgraded from a Blade with CM7. I'd love to see CM7 on the G300 if CM9/10 are going to be problematic. Fingers crossed Qiwu will share eventually.

0

Share this post


Link to post
Share on other sites

Posted

I just got my G300 this week, updgraded from a Blade with CM7. I'd love to see CM7 on the G300 if CM9/10 are going to be problematic. Fingers crossed Qiwu will share eventually.

We may need Batman to do another Chinese kidnapping if it keeps up at this rate.

0

Share this post


Link to post
Share on other sites

Posted (edited)

duplicate post deleted.

Edited by skobywan
0

Share this post


Link to post
Share on other sites

Posted

So I've been working on this stuff for about 8 hours combined now (kernel and device) and I've got Jelly Bean running on a 3.0 kernel, and almost as smooth as CM9 was.

All connectivity is dead, I need to re-de-huaweify the kernel (wow what a word) and fix logging properly before I can debug and fix everything else.

Anyone interested in a build? I'll stress again, all connectivity dead for now, I was only really concerned in getting the 3.0 kernel running here and took the opportunity to sort out display a bit too.

6

Share this post


Link to post
Share on other sites

Posted

I'm interested in a build to try it out.

You could open a new thread dedicated to your CM10 efforts ;)

0

Share this post


Link to post
Share on other sites

Posted

Fire away dazz, it'll keep me from watching eastenders! :D

0

Share this post


Link to post
Share on other sites

Posted

I'll bet you get someone pleading "cannot connect to internet . .plzzzz fix" tho. :P

Will give it a whirl when I get in from work.

0

Share this post


Link to post
Share on other sites

Posted

It's actually currently built using my "ics-b8xx" props and the 109808 RIL implementation, so if anyone is on B8xx the RIL might actually work.

Probably not though. :P

3

Share this post


Link to post
Share on other sites

Posted

great news thanks , do you think you could make or hack the UI acceleration in cm10? it would be much smoother i think

0

Share this post


Link to post
Share on other sites

Posted

Would we need to downgrade first or will it be ok to test with the newer baseband ?

0

Share this post


Link to post
Share on other sites

Posted

great news thanks , do you think you could make or hack the UI acceleration in cm10? it would be much smoother i think

It's not just a "it's not done, now it is" kind of thing. Jelly Bean is complicated. You don't need to educate me about the benefits of UI acceleration.

Would we need to downgrade first or will it be ok to test with the newer baseband ?

Either way it probably won't work.

Or are you under the assumption that the baseband version has a larger effect outside of RIL tasks? It doesn't.

--

Edit: adding CPU governors now.

1

Share this post


Link to post
Share on other sites

Posted (edited)

Sounds like progress! Thanks for your hard work Dazzozo I will have a play when I'm back in England!

Edit: I'm guessing no point telling you about bugs as it's such a young build..?

Edited by timfimjim
0

Share this post


Link to post
Share on other sites

Posted

Not unless you can do your own investigation in to the problem. There's a lot to be done and practically everything will have to be looked at at some point.

Edit: for example, someone will report audio isn't working. I know, I intentionally disabled it as it's currently not compiling and needs to be redone.

Edit 2: CPU governors are working. Pushing it to github in a sec

Edit 3: https://github.com/Dazzozo/android_kernel_huawei_u8818/commit/1ba654616816f089fcac56c787a30898ee92c1d4 done, I should write a diary or something

4

Share this post


Link to post
Share on other sites

Posted

I couldn't boot with your jelly-bean build. It keeps forever with the Huawei logo...

did factory reset and wiped cache

0

Share this post


Link to post
Share on other sites

Posted

Boots up fine,i`d say it was a tad quicker than CM9 just now. :)

0

Share this post


Link to post
Share on other sites

Posted

Keep your diary here :)

0

Share this post


Link to post
Share on other sites

Posted

I couldn't boot with your jelly-bean build. It keeps forever with the Huawei logo...

did factory reset and wiped cache

Wipe -> reboot -> flash.

Recovery is a bit buggered for some reason and doesn't flash properly after a wipe.

2

Share this post


Link to post
Share on other sites

Posted

Wipe -> reboot -> flash.

Recovery is a bit buggered for some reason and doesn't flash properly after a wipe.

Is there anything in particular you need tested? I know my way around Linux a bit, I have a bag of smoke and a night to kill. More than willing to offer my help if there's any grunt work you need doing.

3

Share this post


Link to post
Share on other sites

Posted

It's a little hard to have a play around considering USB is completely dead besides charging, but I'm going to be trying to implement overclocking in a mo. I could share that for testing if it's successful.

4

Share this post


Link to post
Share on other sites

Posted

Finally some good news :) thanks daz

0

Share this post


Link to post
Share on other sites

Posted

This is surprisingly a pretty rare SoC. MSM7x27 was used to death in loads of devices, but the 7x27A I can only actually spot in another device that actually has custom ROMs and such, which is the GT-S7500.

I tried their overclock method and got the same results they have. It apparently works, though you can't really tell. I do seem to crash occasionally at around 1.4GHz and they did too - they ultimately locked the max at 1.2GHz.

Strange. I wouldn't be surprised if this phone doesn't ever really gain much from overclocking. Not that it would need it if we had a ROM which fully works but anyway.

I'm going to try it on 1.2GHz and see what happens, might be worth talking to the GT-S7500 guys. The majority of phones with 7x27As are unreleased or Windows Phone. :P

Next priority is actually making USB useful. It can only charge from it at the moment. I have no idea how something like that broke but it's really, really hard trying to fix things or get any information out of the device at all with no logs. :wacko:

Edit: I think I fixed the logging mess that Huawei insist on causing. I can't test right now as USB is completely dead obviously. :P Now, if you'll excuse me, It's 3:46am and I need to "hibernate". :ph34r:

7

Share this post


Link to post
Share on other sites

Posted

thanks for your efforts daz

0

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.