• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[CM7] [gen1/gen2] Latest CM7 2.3.7 ROMs

326 posts in this topic

Posted (edited)

equiliym, which repositories do you use to build cm7?

I tried to build cm7 for my ZTE Carl which is based on mooncake board too with GuyOverThere's guide, compiled fine but hangs on bootanimation, logcat shows errors about netd.

Then I installed cm-7-20120819-NIGHTLY-mooncake.zip. Working: GSM and data connection, Calls, SMS, Microphone, Speaker, FM radio, GPS, pretty much everything except Wifi, Camera and Accelerometer

Edited by mikeioannina
0

Share this post


Link to post
Share on other sites

Posted

sorry guys, i was on a business trip.. i stopped building cm7 from sources, i can port from blade and other phones if you want.. i used deadlinks github to get mooncake files, used alot of prebuilt drivers

0

Share this post


Link to post
Share on other sites

Posted

I have the latest version installed and usually put half a dozen contacts with individual touches, but does not always work and see the calls with the touch overall.

Anyone know how to solve this?

thank you

0

Share this post


Link to post
Share on other sites

Posted

sorry guys, i was on a business trip.. i stopped building cm7 from sources, i can port from blade and other phones if you want.. i used deadlinks github to get mooncake files, used alot of prebuilt drivers
equiliym plz update the roms anyhow..
0

Share this post


Link to post
Share on other sites

Posted

I have the latest version installed and usually put half a dozen contacts with individual touches, but does not always work and see the calls with the touch overall.

Anyone know how to solve this?

thank you

what?

equiliym plz update the roms anyhow..

well okay but that will mean hdpi framework and possible graphic glitches like big buttons or something.. will port latest blade release in my free time

0

Share this post


Link to post
Share on other sites

Posted

just downloaded cm-7-20120819-NIGHTLY-mooncake every thing is working fine, except one problem...... Rotation animation....... when applying rotation animation the screen turns green for very few seconds while changing the rotation....... another is unable to add google account, for that going to try Gapps pack: gapps-gb-20110828-minimal ... it should be fine then......... touch is working perfect except sometime just opening of app instead of upward or downward movement of screen also while typing using android keyboard sometimes digits are pressed twice.......... should i try deadlink gen1/gen2 kernel ........ if yes can i rollback to previous kernel if i want without deleting data....?? also i want lights on my hard buttons is it possible........... earlier someone has reported problem that by using racer_parts.zip lights does not goes off when screen turns off..........so please help...... otherwise thanks a lot.............. :))

0

Share this post


Link to post
Share on other sites

Posted

just downloaded cm-7-20120819-NIGHTLY-mooncake every thing is working fine, except one problem...... Rotation animation....... when applying rotation animation the screen turns green for very few seconds while changing the rotation....... another is unable to add google account, for that going to try Gapps pack:gapps-gb-20110828-minimal ... it should be fine then......... touch is working perfect except sometime just opening of app instead of upward or downward movement of screen also while typing using android keyboard sometimes digits are pressed twice.......... should i try deadlink gen1/gen2 kernel ........ if yes can i rollback to previous kernel if i want without deleting data....?? also i want lights on my hard buttons is it possible........... earlier someone has reported problem that by using racer_parts.zip lights does not goes off when screen turns off..........so please help...... otherwise thanks a lot.............. :))

For green artifact go to settings -> Cyanogenmod Settings -> Display Settings and uncheck Rotation Animation and reboot

For the google thing well good luck with gapps minimal though I've never had problems to add my google account with normal gapps

For kernel, yes, you can change kernels without deleting any data, just flash the kernel and that's it, didn't like it? flash the other one and that's it.

For hard buttons lights, RacerParts works more or less but as you've read it does tend to stay there... lighting.... xD you can however uncheck Buttons Backlight from Settings -> Device Settings, however the lights won't be totally deactivated, they'll turn on/off in very key moments (while loading the rom for example), so is kinda two extremes with RacerParts, either lights almost always or lights almost never :-\

0

Share this post


Link to post
Share on other sites

Posted

droidlover i can give you one of my older builds thats quite stable, works somewhat flawlessly, might just need a little edit since there is an error with video recording but on that rom even lights work.. need to find where i uploaded it tho, cant really remember lol

0

Share this post


Link to post
Share on other sites

Posted

yeah for some odd reason, when i resize Phone.apk to mdpi screens it appears either broken or the mic doesnt work so its an old bug regarding overlaping buttons..

for battery, you might want to try wiping battery stats in recovery, might fix your issues, then charge it 100% properly with phone turned off over night for example, my battery lasts for 2-3 days..

i also edited first post, added old market for those (if any) who prefer old one instead of google play (like myself) and swap info so you dont have to scroll through pages to see how to enable it

0

Share this post


Link to post
Share on other sites

Posted (edited)

yeah for some odd reason, when i resize Phone.apk to mdpi screens it appears either broken or the mic doesnt work so its an old bug regarding overlaping buttons..

for battery, you might want to try wiping battery stats in recovery, might fix your issues, then charge it 100% properly with phone turned off over night for example, my battery lasts for 2-3 days..

i also edited first post, added old market for those (if any) who prefer old one instead of google play (like myself) and swap info so you dont have to scroll through pages to see how to enable it

actually first row buttons are little big add call, end and dial pad........

and can you please tell me how to wipe battery stats.......... and how to enable what.....??? i ddnt get wat you told about android market........ and lastly wat about the screen scrolling up and down issues......?????

Edited by droidlover
0

Share this post


Link to post
Share on other sites

Posted

im not really sure about your scrolling issues, you might want to try different kernel due to sensitivity i guess..

you can wipe battery stats when you enter recovery/clockworkmod and go to advanced i think and there wipe battery stats

added a small tut on how to enable swap, its like virtual memory in windows, it makes a 100mb file on your sdcard and uses it as additional ram

0

Share this post


Link to post
Share on other sites

Posted

Hello equiliym

name='equiliym' timestamp='1346527370' post='2015219']

0624 is hybrid but stable, i use it even before i released it.. as for other stable releases, its just not worth my time since there are like 10 of us using racer

I know you already said this, but would you be so gentle and tell me please what's the most stable not-crashing games or apps to use in the Racer? i'm trying Lewa ROM right now, but noted only improved performance on Angry Birds Space :P

PD: Would 06-24 work with Deadlinks Kernel?, i'm having the camera driver issue as it seems to be fixed with that kernel.

0

Share this post


Link to post
Share on other sites

Posted

Hello equiliym

I know you already said this, but would you be so gentle and tell me please what's the most stable not-crashing games or apps to use in the Racer? i'm trying Lewa ROM right now, but noted only improved performance on Angry Birds Space :P

PD: Would 06-24 work with Deadlinks Kernel?, i'm having the camera driver issue as it seems to be fixed with that kernel.

i think i forgot to include and that i uploaded somewhere haptic support for deadlink kernel, but yeah, his kernel will work on 0624.. for games, i have no idea, i play those on computer when i have free time.. for apps, it totally depends what kind of apps.. i use few social and few news like apps and thats pretty much all..

0

Share this post


Link to post
Share on other sites

Posted

hey all i have found one thing......... actually i wanna edit the boot image (to show my editing skills :P) so i just copied it from system -> media then unzipped it in my pc, edited part 2 of boot image then zipped it and then moved it back to system -> media and deleted the previous bootimage.zip file when i rebooted the phone i didnt found the boot image on starting up of instead i found a black screen, but i found 1 thing that it took very less time as compared to earlier to boot.... then i flashed it via recovery then again i was unable to use the bootanimation. so 1 thing i wanna know y i m unable to use the bootanimation........ secondly y is it taking less time in booting up when there is no boot image.......????

0

Share this post


Link to post
Share on other sites

Posted

bootanimation.zip has to be compressed on storage level in winzip/winrar etc, not casual compression, thats why it doesnt work.. as for booting, if its big/long animation, it might boot longer until it finishes it.. other than that, until it executes all scripts in init.d..

0

Share this post


Link to post
Share on other sites

Posted

Guys i'm starting to be suspicious, i let my phone with Lewa ROM until today cause my PC was damaged (stupid cheap thermal paste) and now i tried to use 20120624 and the same eternal loop at booting happens, so i guess it's not ROMs problems, something it's weird with my stuff. I would be glad if someone can helpme anyway.

0

Share this post


Link to post
Share on other sites

Posted

Hi guys,

I am new to this and I need a specific functionality to be enabled on my ZTE Racer.

I need the USB Accessory mode to work for connection the mobile to the Arduino Mega ADK for Android. I am not sure if this is possible on this particular device, but my simplistic vision of it is that if there is a USB port, then it should be available to be controlled in any way you need.

So the USB Accessory is introduced in API 10 as a special library com.android.future.usb.accessory.jar. That library is present in the cm-7-20120819-NIGHTLY-mooncake rom that I installed today, but it was not found when I tried to put a simple demo app on the phone, giving error that library is not found. I already had this problem with the previous rom that I tried (cm7_2.3.7_Racer_full-257) and I solved it by putting the permissions definition file android.hardware.usb.accessory.xml at /system/etc/permissions/ as suggested in many forums (on the previous rom I had to put the jar too). This is how the application was successfully installed.

Unfortunately the application is not working as expected. It should start when USB is connected, but it doesn't. Even if I start it manually, it doesn't see that there is a device connected (the method mUsbManager.getAccessoryList() returns null). In the same time the phone green light is on, showing (I think) that it has USB connection or at least a charger.

From the Arduino side I see that it detects USB connection and tries to start communication, but gets some error 5 - protocol not supported - which usually means that the other side (the phone) is not reacting correctly as USB device. Log:

Device addressed... Requesting device descriptor.

found possible device. swithcing to serial mode

Data packet error: 5could not read device protocol version

So my question is can you compile next rom to support USB Accessory? I also read in forums that the compilation needs 'CONFIG_USB_ANDROID_ACCESSORY=y' in the '/proc/config.gz' but I don't really know if this is enough and what is its meaning.

Please respond if I can expect this feature or not, so I can decide what my next steps will be...

Thanks in advance!

0

Share this post


Link to post
Share on other sites

Posted (edited)

Guys, could you please, please, please help me? i'm having a real break through with my phone.

I made a recovery before installing all new ROMS on it and now it's just useless, the recovery made by my ClockWorkMod does not read itself, i mean if you make a recovery and then try to install it, it doesn't work show the message "Empty file".

Now i just have equiliym 20120829 wich works awesome, except for the camera as i intended, i would be very appreciate if you can work on the camera because i like the ROM and it's completely useful, but i often use my camera phone and now can't have it.

In fact the real problem it's i'm giving the phone to my sister and the camera it's broken and now the original ROM appears as "empty file" in wich the camera works perfectly,

Thanks for reading this and replies.

Edited by senupe
0

Share this post


Link to post
Share on other sites

Posted

Guys anyone here? Please guys would be very helpful to someone please guiding me about getting to stock ROM again, please i really need help.

Sincerely: Sebastián Núñez Peña (Senupe).

0

Share this post


Link to post
Share on other sites

Posted

sorry, i dont have a pc anymore so i cant reply much, using friends laptop.. you can download stock rom from stock roms thread and just flash it as any custom one, it will overwrite cwm recovery with FTM one and give you 2.1-update1 rom again

0

Share this post


Link to post
Share on other sites

Posted

My touch is not working can someone help

0

Share this post


Link to post
Share on other sites

Posted

Hi,i`m new in this forum.I have a zte racer2 v2.2.2 root.Well, i try and instal the last rom (cm-7-20120805-NIGHTLY-mooncake.zip) well done with all guidance but the phone not boot.The screen show me by turns robot android-logo zte and not open.If you tell me what i do wrong?Thanks.

Sorry for my bad english.

0

Share this post


Link to post
Share on other sites

Posted

For some reason, i cannot see the first post...has this ROM been discontinued?

0

Share this post


Link to post
Share on other sites

Posted

ics display driver have any one

0

Share this post


Link to post
Share on other sites

Posted (edited)

for ics

Edited by alex39
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.