• Announcements

    • PaulOBrien

      Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • PaulOBrien

      Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Gary_J_Wright

[GUIDE] Change to ANY G300/U8815/U8818 ROM via Boot loader version bypass [HACK]

231 posts in this topic

2 possible causes either you haven't restored your imei as this removes chinese splash or

I think what ever splash screen you have when you make imei backup is replaced when you restore > so if you make a imei backup on b926 chinese version your restore chinese splash screens

You are right. I tried to go back from ICS to GB but just using CWM backup (not .zip) directly. It worked but instead IMEI=0, mine was just "Unknow". I restored my IMEI backup done in GB before update, and once rebooted the logo was changed (Yoigo Spain) even the IMEI wasn't restored (still "unknow"). Then I went back to ICS using the CWM backup, the boot image still Yoigo and the IMEI was there without need to restore.

Regards.

Edited by elperroderoke
0

Share this post


Link to post
Share on other sites

That's because of the new baseband. Everything should work if you flash a B8xx ROM to B926 other than the mobile network (and vice versa for a B926 ROM flashed to B8xx).

0

Share this post


Link to post
Share on other sites

I knew that to go back to GB I needed to flash the update.app, but I do not really need to do that (by now), just playing if the boot image was changed or not. By now I do not need or want to trick the bootloader, but now I have a question in mind:

What happen if once you have downgraded and fix the Imei, you reflash the same update.app (B882, for instance). Will this rewrite the boot loader with a new one, so you do not have to "trik" again to change Rom?

Regards.

Edited by elperroderoke
0

Share this post


Link to post
Share on other sites

I knew that to go back to GB I needed to flash the update.app, but I do not really need to do that (by now), just playing if the boot image was changed or not. By now I do not need or want to trick the bootloader, but now I have a question in mind:

What happen if once you have downgraded and fix the Imei, you reflash the same update.app (B882, for instance). Will this rewrite the boot loader with a new one, so you do not have to "trik" again to change Rom?

Regards.

no once you have ics bootloader its for good, but it wont hurt to try flash update.app(b882) again but i think it will fail

if at b926 when a newer rom (i.e b928 ) comes out no more need to bypass bootloader version i.d i hope.

Edited by Gary_J_Wright
0

Share this post


Link to post
Share on other sites

I knew that to go back to GB I needed to flash the update.app, but I do not really need to do that (by now), just playing if the boot image was changed or not. By now I do not need or want to trick the bootloader, but now I have a question in mind:

What happen if once you have downgraded and fix the Imei, you reflash the same update.app (B882, for instance). Will this rewrite the boot loader with a new one, so you do not have to "trik" again to change Rom?

Regards.

cwm should not be used with this method at all..... its fine to use before or after to make back up (only to be used with cwm) , but cant be used with the downgrade/upgrade method to restore anything

also cwm will only work ics to ics or gb to gb

not gb to ics or ics to gb

0

Share this post


Link to post
Share on other sites

also cwm will only work ics to ics or gb to gb

not gb to ics or ics to gb

Wrong, CM9. ;)

0

Share this post


Link to post
Share on other sites

no once you have ics bootloader its for good, but it wont hurt to try flash update.app(b882) again but i think it will fail

if at b926 when a newer rom (i.e b928 ) comes out no more need to bypass bootloader version i.d i hope.

I'm more or less understanding how it works (coming from Motorola Defy+, so diferent way).

Not knowing if an incoming realase will "repair" the boot loader, is the reason I won´t try unless it would be necessary, and right now I don´t see the point to go back to GB unless I have to sent the phone to be repaired on warranty, and even do, by the time maybe there will be an official Yoigo Spain ICS to be flashed (I assume everybody hope or think it would be posible the update from Unicom ICS just flashing the update.app)

Thank you for all the explanations.

Regards.

0

Share this post


Link to post
Share on other sites

Wrong, CM9. ;)

l

lol ok cm9 i meant official huawei ..... :P

0

Share this post


Link to post
Share on other sites

I screwed up the ordering on this I think, What I've done because the official chinese ICS 4.0.3 install wouldn't work using the dload method I used this to backup and change my IMEI. Then I flashed a custom ICS rom *before* restoring the IMEI (but after getting root and reinstalling clockwork). Now i've restored my IMEI in the custom rom and it shows up fine in the settings or when I dial *#06# but I can't get any carrier signal (every now and then i get a 2g signal for a minute and it drops, weird).

I'm going to dload the offical update again and try restore the IMEI in there and hope that fixes it - any better suggestions?

0

Share this post


Link to post
Share on other sites

Are you on O2? Sounds like the problems they're having right now

0

Share this post


Link to post
Share on other sites

Are you on O2? Sounds like the problems they're having right now

No Vodafone AU - I've got another handset here and my SIM is fine in that one, I've definitely messed up the radio/baseband on this G300 somewhere during this process

I don't seem to be able to undo whatever damage it is I've done here. I just put the stock gingerbread rom back on, changed the IMEI to one from the zip on this thread, then ran the official ICS update again. Then restored my original IMEI (after having used unlockbootloader.exe to root again)

Now I'm official ICS with my original IMEI back, root is working and I can verify the IMEI in the settings or using *#06# but still have no signal with a working SIM

Edit: I fixed this by flashing the official ICS, restoreing the IMEI then rebooting and allowing the cache to wipe etc. Scared to flash another custom ICS now but it's worth the risk so here I go...

Edited by apopberz
0

Share this post


Link to post
Share on other sites

Edit: I fixed this by flashing the official ICS, restoreing the IMEI then rebooting and allowing the cache to wipe etc. Scared to flash another custom ICS now but it's worth the risk so here I go...

So it's fixed? Or have I read that out of context?

0

Share this post


Link to post
Share on other sites

No Vodafone AU - I've got another handset here and my SIM is fine in that one, I've definitely messed up the radio/baseband on this G300 somewhere during this process

I don't seem to be able to undo whatever damage it is I've done here. I just put the stock gingerbread rom back on, changed the IMEI to one from the zip on this thread, then ran the official ICS update again. Then restored my original IMEI (after having used unlockbootloader.exe to root again)

Now I'm official ICS with my original IMEI back, root is working and I can verify the IMEI in the settings or using *#06# but still have no signal with a working SIM

Edit: I fixed this by flashing the official ICS, restoreing the IMEI then rebooting and allowing the cache to wipe etc. Scared to flash another custom ICS now but it's worth the risk so here I go...

As corrected by Dazzozo. you somehow have the wrong baseband / firmware @ a guess

The original update.app is ALWAYS official ICS we cant alter the update.app, This is B926 based with ICS basebands / firmware

Next flashable zips (CWM)

There are Two types of ICS modified ROM versions those that have ICS basebands, B926 based. they will come as a zip

some like cm9 and ligux are ICS modded ROM versions made to run on GB basebands /firmware again a zip

Edited by Gary_J_Wright
0

Share this post


Link to post
Share on other sites

The partitions have absolutely nothing to do with the operating system that runs on it. We could get the old B8xx Gingerbread ROMs running on B926 if we were so bothered.

The key difference is the radio firmware change. There are two basebands, and two sets of firmware. A ROM with the firmware for the other baseband will result in you having no mobile network.

If your modified ICS is built for B8xx with B8xx firmware, RIL won't work on your B926 device, and vice versa.

"ICS partition layouts" is a bit redundant, the only thing that really changed in B926 was the system partition becoming ext4, which has nothing to do with radio problems.

0

Share this post


Link to post
Share on other sites

The partitions have absolutely nothing to do with the operating system that runs on it. We could get the old B8xx Gingerbread ROMs running on B926 if we were so bothered.

The key difference is the radio firmware change. There are two basebands, and two sets of firmware. A ROM with the firmware for the other baseband will result in you having no mobile network.

If your modified ICS is built for B8xx with B8xx firmware, RIL won't work on your B926 device, and vice versa.

"ICS partition layouts" is a bit redundant, the only thing that really changed in B926 was the system partition becoming ext4, which has nothing to do with radio problems.

cool think we need a guide of what works and how (Like the gen1 / gen2 blade) etc Really could do with a F A Q

0

Share this post


Link to post
Share on other sites

So it's fixed? Or have I read that out of context?

That's correct. I had to do this to fix it:

1) Install stock gingerbread

2) Flash this downgrade (false IMEI)

3) Install official chinese ICS update again

4) Root again (unlockbootloader.exe)

5) Restore my IMEI *before* changing roms to a custom ICS rom

So basically repeating the whole process detailed here again. I tried restoring my IMEI while having numerous custom roms (both gingerbread and ICS) and none allowed me to get a carrier connection. I would suggest adding to the guide the original IMEI should be restored as soon as possible (ie. right after chinese ICS and root are done, possibly even before bootloader unlocking) as this one really f***ed me up and took me about ~8 hours of flashing to resolve.

0

Share this post


Link to post
Share on other sites

Nice one :)

Would never have thought that the imei restore wouldn't have worked on custom roms so definitely worthy of note.

0

Share this post


Link to post
Share on other sites

How to delete after downgrade ICS...China logo "3G WO"...I want Huawei logo :)

0

Share this post


Link to post
Share on other sites

Hi all, I am trying to upgrade Huawei official ICS ontop of Vodafone UK 882 without luck.

Have anyone been able to make it work? Any suggestion?

thank you

sonicaaaa

0

Share this post


Link to post
Share on other sites

First off don't

get the 885 ota update first for audio fixes

0

Share this post


Link to post
Share on other sites

Hi all, I am trying to upgrade Huawei official ICS ontop of Vodafone UK 882 without luck.

Have anyone been able to make it work? Any suggestion?

thank you

sonicaaaa

ota 885 then official ICS you DONT need this hack

Edited by Gary_J_Wright
0

Share this post


Link to post
Share on other sites

I'm currently running ICS, have flashed the modaco ICS rom that Paul put together. Of course I went through the Chinese ICS update first then flashed the rom. I want to go back to GB, the guide in this thread would work for what I want to do?

Thanks.

0

Share this post


Link to post
Share on other sites

ota 885 then official ICS you DONT need this hack

You can just go from 882 to 926...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.