• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

Cyanogenmod 7.2 Kang for Optimus L3

107 posts in this topic

Posted

Got to go through init rc and couple of other bits

1

Share this post


Link to post
Share on other sites

Posted

I have data connection issues on cm9, wud i have the same issues on cm7.2 wen its able to boot properly?

0

Share this post


Link to post
Share on other sites

Posted

gah got no kernels that will work at present, the cm9 kernel needs all the ics changes removing, and the stock kernel seems broke

0

Share this post


Link to post
Share on other sites

Posted

some update?

0

Share this post


Link to post
Share on other sites

Posted

Waiting the CM7 out.. I Hope it not stuck in LG Logo

0

Share this post


Link to post
Share on other sites

Posted

Any update??? if this are done, maybe a blurred screen problem when install any ICS ROM (CM9 or MIUI) could be solved? or it's just the same? thanks :)

0

Share this post


Link to post
Share on other sites

Posted

Waiting the CM7 out.. I Hope it not stuck in LG Logo

yeaa... we hope so Ayam :P

0

Share this post


Link to post
Share on other sites

Posted

yeaa... we hope so Ayam :P

Ayam... :wacko:

0

Share this post


Link to post
Share on other sites

Posted (edited)

No update yet??? :(

or you can give me certainty when it's available to test of your project?

Edited by yayakuya
0

Share this post


Link to post
Share on other sites

Posted

gah got no kernels that will work at present, the cm9 kernel needs all the ics changes removing, and the stock kernel seems broke

so, how's your project master? i still waiting for this one :)

0

Share this post


Link to post
Share on other sites

Posted

currently checking caf for:

hardware/qcom/media/mm-core/omxcore/Android.mk:47: *** Unsupported target platform msm7x27a. Stop.

0

Share this post


Link to post
Share on other sites

Posted

currently checking caf for:

hardware/qcom/media/mm-core/omxcore/Android.mk:47: *** Unsupported target platform msm7x27a. Stop.

i see, how about another sources? or this is a best available one ported to L3? i just try to change zimage from CM9's kernel into this, and i thought that's works because it pass a LG logo (not stuck)... but LOL, it's bootloop and screen goes to 4bit layer :D

is the problem on boot image? would you tell me which one (ramdisk root) i have to change???

i'm sorry if you feel pushed by this, but i can't install CM9 properly (blurred screen problem) and stock rom make me so borred even has any tweaks. i still not satisfied.... :unsure:

please, make it real......

0

Share this post


Link to post
Share on other sites

Posted

i see, how about another sources? or this is a best available one ported to L3? i just try to change zimage from CM9's kernel into this, and i thought that's works because it pass a LG logo (not stuck)... but LOL, it's bootloop and screen goes to 4bit layer :D

is the problem on boot image? would you tell me which one (ramdisk root) i have to change???

i'm sorry if you feel pushed by this, but i can't install CM9 properly (blurred screen problem) and stock rom make me so borred even has any tweaks. i still not satisfied.... :unsure:

please, make it real......

Make sure you have:

    Ubuntu 12.04 (Precise Pangolin) 64-bit
    Your computer has at least 4GB RAM
    Good Internet connection

install dependencies:

$ sudo apt-get install git-core gnupg flex bison gperf build-essential \
zip curl zlib1g-dev zlib1g-dev:i386 libc6-dev lib32ncurses5-dev \
ia32-libs x11proto-core-dev libx11-dev:i386 libreadline6-dev:i386 \
lib32z-dev libgl1-mesa-glx:i386 libgl1-mesa-dev g++-multilib mingw32 \
tofrodos python-markdown libxml2-utils xsltproc readline-common \
libreadline6-dev libreadline6 lib32readline-gplv2-dev libncurses5-dev \
lib32readline5 lib32readline6 libreadline-dev libreadline6-dev:i386 \
libreadline6:i386 bzip2 libbz2-dev libbz2-1.0 libghc-bzlib-dev lib32bz2-dev \
libsdl1.2-dev libesd0-dev squashfs-tools pngcrush schedtool libwxgtk2.6-dev
$ sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib/i386-linux-gnu/libGL.so[/code] Configure USB:
[code]$ gksudo gedit /etc/udev/rules.d/51-android.rules
add this to the above:
#Garmin-Asus SUBSYSTEM==usb", ATTR{idVendor}==091E", MODE=0666" #Google SUBSYSTEM==usb", ATTR{idVendor}==18d1", MODE=0666" #HTC SUBSYSTEM==usb", ATTR{idVendor}==0bb4", MODE=0666" #Huawei SUBSYSTEM==usb", ATTR{idVendor}==12d1", MODE=0666" #K-Touch SUBSYSTEM==usb", ATTR{idVendor}==24e3", MODE=0666" #KT Tech SUBSYSTEM==usb", ATTR{idVendor}==2116", MODE=0666" #Kyocera SUBSYSTEM==usb", ATTR{idVendor}==0482", MODE=0666" #Lenovo SUBSYSTEM==usb", ATTR{idVendor}==17EF", MODE=0666" #LG SUBSYSTEM==usb", ATTR{idVendor}==1004", MODE=0666" #Motorola SUBSYSTEM==usb", ATTR{idVendor}==22b8", MODE=0666" #NEC SUBSYSTEM==usb", ATTR{idVendor}==0409", MODE=0666" #Nook SUBSYSTEM==usb", ATTR{idVendor}==2080", MODE=0666" #Nvidia SUBSYSTEM==usb", ATTR{idVendor}==0955", MODE=0666" #OTGV SUBSYSTEM==usb", ATTR{idVendor}==2257", MODE=0666" #Pantech SUBSYSTEM==usb", ATTR{idVendor}==10A9", MODE=0666" #Philips SUBSYSTEM==usb", ATTR{idVendor}==0471", MODE=0666" #PMC-Sierra SUBSYSTEM==usb", ATTR{idVendor}==04da", MODE=0666" #Qualcomm SUBSYSTEM==usb", ATTR{idVendor}==05c6", MODE=0666" #SK Telesys SUBSYSTEM==usb", ATTR{idVendor}==1f53", MODE=0666" #Samsung SUBSYSTEM==usb", ATTR{idVendor}==04e8", MODE=0666" #Sharp SUBSYSTEM==usb", ATTR{idVendor}==04dd", MODE=0666" #Sony Ericsson SUBSYSTEM==usb", ATTR{idVendor}==0fce", MODE=0666" #Toshiba SUBSYSTEM==usb", ATTR{idVendor}==0930", MODE=0666" #ZTE SUBSYSTEM==usb", ATTR{idVendor}==19D2", MODE=0666"
Set proper permissions:
$ sudo chmod a+r /etc/udev/rules.d/51-android.rules
JAVA JDK Installation: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-downloads-1637591.html
$ sudo apt-get purge openjdk-\* icedtea-\* icedtea6-\*
install Java JDK:
$ sudo mkdir -p /opt/java/64/
$ sudo cp jdk-6u34-linux-x64.bin /opt/java/64
$ sudo su -
$ cd /opt/java/64
$ chmod +x jdk-6u34-linux-x64.bin
$ ./jdk-6u34-linux-x64.bin
$ exit[/code] Add JDK PATH to .bashrc:
[code]$ gksudo gedit ~/.bashrc
Add these lines:
# Java PATHs
export JAVA_HOME=/opt/java/64/jdk1.6.0_34
export PATH=$PATH:$JAVA_HOME/bin[/code] Android SDK: Download the SDK here: http://developer.android.com/sdk/index.html Extract the SDK and place it in your home directory. Add AndroidSDK PATH to .bashrc:
[code]$ gksudo gedit .bashrc
Add the following lines:
# Android tools
export PATH=${PATH}:~/android-sdk/tools
export PATH=${PATH}:~/android-sdk/platform-tools
export PATH=${PATH}:~/bin[/code] Add PATH to .profile:
[code]$ gksudo gedit .profile
Add these lines:
PATH=$HOME/android-sdk/tools:$HOME/android-sdk/platform-tools:$PATH"
To use the ADB Update software (or to verify a working adb path), use the following command:
$ android
Install the Repo:
$ mkdir ~/bin
$ PATH=~/bin:$PATH
$ curl https://dl-ssl.google.com/dl/googlesource/git-repo/repo ] ~/bin/repo
$ chmod a+x ~/bin/repo[/code] Initialize the CyanogenMOD 9 Repo:
[code]$ mkdir android
$ cd android
$ mkdir system
$ cd system
$ repo init -u git://github.com/CyanogenMod/android.git -b gingerbread
Finally:
$ repo sync -j16

borrowed and adapted from Compile ParanoidAndroid

0

Share this post


Link to post
Share on other sites

Posted

next

~/android/system/vendor/cyanogen/get-rommanager
then
cd ~/android/system
. build/envsetup.sh
breakfast p350
breakfast mimmi
breakfast robyn
breakfast tass[/code]

or any other qvga device, there is no e400 device tree for cm7.2 so you have options of grabbing the e400 device tree from cm9 and dropping it into /devices/lge or modifying an existing device tree.

if you drop cm9 e400 device tree in, you will need to change all wpa supplicant 8 lib references to wpa supplicant 6 lib.

[b]edit[/b] [u]alternatively just delete it:[/u]

Package complete: /home/hecatae/cm7.2/out/target/product/e400/cm-7-20121227-UNOFFICIAL-e400.zip

5b840ab733f432f8a0152260b9e38369 cm-7-20121227-UNOFFICIAL-e400.zip

http://www.multiupload.nl/MMLRI3O6UI

testers welcome

0

Share this post


Link to post
Share on other sites

Posted

next

~/android/system/vendor/cyanogen/get-rommanager
then
cd ~/android/system

. build/envsetup.sh

breakfast p350

breakfast mimmi

breakfast robyn

breakfast tass

or any other qvga device, there is no e400 device tree for cm7.2 so you have options of grabbing the e400 device tree from cm9 and dropping it into /devices/lge or modifying an existing device tree.

if you drop cm9 e400 device tree in, you will need to change all wpa supplicant 8 lib references to wpa supplicant 6 lib.

edit alternatively just delete it:

Package complete: /home/hecatae/cm7.2/out/target/product/e400/cm-7-20121227-UNOFFICIAL-e400.zip

5b840ab733f432f8a0152260b9e38369 cm-7-20121227-UNOFFICIAL-e400.zip

http://www.multiupload.nl/MMLRI3O6UI

testers welcome

I'm so appreciate it master, i glad that you disposed to keep this work. but i was broke my Ubuntu couple months ago...

now i just have win xp with dsixda kitchen installed. i was try to port cm7 based on p350 last night, but nothing... same problem with your last update (it won't boot) . i think i'll try this one and i'll let you now if it works...

once again i'd like to say, thanks...

0

Share this post


Link to post
Share on other sites

Posted

no changing.... it still won't boot :(

0

Share this post


Link to post
Share on other sites

Posted

no changing.... it still won't boot :(

same problem here, thinking vmheap was set too high 76mb, so changed to 32mb, I wonder if we can get adb logcat out of it,

new one, ics adreno drivers replaced with gingerbread ones, vmheap set to 32mb

03b8f7c533ad77615ee9c98a3dedf80e cm-7-20121227-UNOFFICIAL-e400.zip

http://www.multiupload.nl/2ETLQQ7AB3

next job is to disable genlock, as I think only ics needs that and it maybe screwing up the boot of cm7

0

Share this post


Link to post
Share on other sites

Posted

it's same result....

but hey dude, you know what... keep that works and i'll be here for tested any update you done....

0

Share this post


Link to post
Share on other sites

Posted

Package complete: /home/hecatae/CyanogenMOD/out/target/product/e400/cm-7-20121230-UNOFFICIAL-e400.zip

e6a30becb58cf9d9dcc9bba099299dcc cm-7-20121230-UNOFFICIAL-e400.zip

http://www.multiupload.nl/LOJSEPFFB9

0

Share this post


Link to post
Share on other sites

Posted

Package complete: /home/hecatae/CyanogenMOD/out/target/product/e400/cm-7-20121230-UNOFFICIAL-e400.zip

e6a30becb58cf9d9dcc9bba099299dcc cm-7-20121230-UNOFFICIAL-e400.zip

http://www.multiupload.nl/LOJSEPFFB9

sry, doesn't boot

0

Share this post


Link to post
Share on other sites

Posted

same in here.....

keep rocks!!! :D

0

Share this post


Link to post
Share on other sites

Posted

Package complete: /home/hecatae/CyanogenMOD/out/target/product/e400/cm-7-20121230-UNOFFICIAL-e400.zip

18de9bc32808b318087f6bb19d5b1997 cm-7-20121230-UNOFFICIAL-e400.zip

http://www.multiupload.nl/COR3837RHC

0

Share this post


Link to post
Share on other sites

Posted

LG Logo... doesn't boot

0

Share this post


Link to post
Share on other sites

Posted

same result.....

0

Share this post


Link to post
Share on other sites

Posted

plz. work fast! I can't wait for this rom. I love it

luck for the work and thanks for it.

Happy new year :)

(I'm Spanish, please excuse me for my poor English)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.