• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[JB] [CM10] [4.1.1] CyanogenMod 10 for the ZTE Crescent [ROM] [Last updated: 01/09]

780 posts in this topic

Posted

If anyone's interested in removing multiple files from the zip file in one stretch (eg:- remove RomManager, VideoEditor etc from the ROM :P), I have made a linux shell script.

Open it and add/remove the files you want to delete

https://dl.dropbox.com/u/38622080/zip_trimmer.sh

0

Share this post


Link to post
Share on other sites

Posted (edited)

What should I do? I have my Windows fixed again, and my Ubuntu is finally working flawlessly.

-Ninjeh.

tried the chown thingy that fixed mine?

Edited by MadEye Moody
0

Share this post


Link to post
Share on other sites

Posted

Know any way of integrating the CM, gapps and a2sd zip files into one flashable zip?

0

Share this post


Link to post
Share on other sites

Posted

I would've released builds today but my internet was kinda dead. I had to tether through my phone to get a reliable (but bad) connection.

Edit: However... surfaceflinger is working again.

I would release this but there's no point as it's already stale, I'll do fresh builds tomorrow.

0

Share this post


Link to post
Share on other sites

Posted

Will this fit the 200/40/200 tpt

0

Share this post


Link to post
Share on other sites

Posted

No, Jelly Bean has totaled that. I'm running a 220 system and have to trim to get the gapps to even fit with 4mb spare.

Edit: That's trimmed gapps too.

Edit 2: telephony patch now sitting on gerrit http://review.cyanogenmod.com/#/c/19984/

0

Share this post


Link to post
Share on other sites

Posted

So how would I go about getting a tpt for jellybean on tmv. Tpt helper won't let me choose make my own and even if it did I wouldn't know what sizes I'd need

Thx in advance

0

Share this post


Link to post
Share on other sites

Posted

TPT Helper seems a little buggered. Not working on the SF2 either.

I'm planning on creating similar TPTs to what is recommended right now for CM10 in the Skate forum. I'll work on it after I've migrated to the goo.im buildbot.

0

Share this post


Link to post
Share on other sites

Posted

Cheers mate.do you ever sleep eat etc!

0

Share this post


Link to post
Share on other sites

Posted

I do, just very quickly. :P

1

Share this post


Link to post
Share on other sites

Posted

Tried to compile with changes in the doc. It gave me something about system image being too large. I'll get home and post the actual error.

0

Share this post


Link to post
Share on other sites

Posted

Yeah, you're right at the end. Did you grab this change? https://github.com/D...d13bda23e58dfd6

If yes it's probably overflown again... *sigh*

0

Share this post


Link to post
Share on other sites

Posted

Yeah, you're right at the end. Did you grab this change? https://github.com/D...d13bda23e58dfd6

If yes it's probably overflown again... *sigh*

I synced just before making the changes, so that should have been pulled.

I think I have


commit 06ef1d1095d545d4c13a997d0d13bda23e58dfd6

Author: Daz Jones <[s][email protected][/s]>

Date:   Sat Jul 21 20:46:37 2012 +0100

    lol did we seriously just overflow system

While compiling, I noticed it was compiling extra/v8 . Is this for ARMv8? can we omit it?

0

Share this post


Link to post
Share on other sites

Posted

ARMv8 pretty much doesn't exist yet.

I'm assuming you mean external/v8. V8 is the JavaScript engine.

0

Share this post


Link to post
Share on other sites

Posted

222MB doesn't seem to be enough

Error:

Install system fs image: out/target/product/blade2/system.img

out/target/product/blade2/system.img+out/target/product/blade2/obj/PACKAGING/recovery_patch_intermediates/recovery_from_boot.p maxsize=237625344 blocksize=135168 total=249505490 reserve=2433024

error: out/target/product/blade2/system.img+out/target/product/blade2/obj/PACKAGING/recovery_patch_intermediates/recovery_from_boot.p too large (249505490 > [240058368 - 2433024])

make: *** [out/target/product/blade2/system.img] Error 1

make: *** Deleting file `out/target/product/blade2/system.img'

0

Share this post


Link to post
Share on other sites

Posted

ARMv8 pretty much doesn't exist yet.

I'm assuming you mean external/v8. V8 is the JavaScript engine.

sorry, my bad :(

0

Share this post


Link to post
Share on other sites

Posted

222MB doesn't seem to be enough

Error:

Install system fs image: out/target/product/blade2/system.img
out/target/product/blade2/system.img+out/target/product/blade2/obj/PACKAGING/recovery_patch_intermediates/recovery_from_boot.p maxsize=237625344 blocksize=135168 total=249505490 reserve=2433024
error: out/target/product/blade2/system.img+out/target/product/blade2/obj/PACKAGING/recovery_patch_intermediates/recovery_from_boot.p too large (249505490 > [240058368 - 2433024])
make: *** [out/target/product/blade2/system.img] Error 1
make: *** Deleting file `out/target/product/blade2/system.img'
[/CODE]

Bump the system image size in BoardConfig.mk in the same way I did and it'll be satisfied.

0

Share this post


Link to post
Share on other sites

Posted

Bump the system image size in BoardConfig.mk in the same way I did and it'll be satisfied.

Yup made it F0 = 240

Will delete the apps that are not used.

0

Share this post


Link to post
Share on other sites

Posted

Running releasetool...

/home/renjith/android/source/cm10/out/target/product/blade2/cm_blade2-ota-user.renjith.zip doesn't exist!

make: *** [bacon] Error 1

There is a

/home/renjith/android/source/cm10/out/target/product/blade2/cm_blade2-ota-eng.renjith.zip which has a 234MB system

Is this file ready to be flashed?

0

Share this post


Link to post
Share on other sites

Posted

Running releasetool...
/home/renjith/android/source/cm10/out/target/product/blade2/cm_blade2-ota-user.renjith.zip doesn't exist!
make: *** [bacon] Error 1
[/CODE]

There is a

[i]/home/renjith/android/source/cm10/out/target/product/blade2/cm_blade2-ota-[/i][u][b]eng[/b][/u][i].renjith.zip[/i] which has a 234MB system

Is this file ready to be flashed?

What build variant are you trying to build for?

0

Share this post


Link to post
Share on other sites

Posted

What build variant are you trying to build for?

eh... user

$ brunch cm_blade2-user

Yesterday I got a lot more errors for userdebug, thats why I went for user. Will try with userdebug

0

Share this post


Link to post
Share on other sites

Posted

eh... user

$ brunch cm_blade2-user

Yesterday I got a lot more errors for userdebug, thats why I went for user. Will try with userdebug

I actually suggest eng at the moment as CM10 is early, hence engineering. If you get a boot loop you have an insecure boot.img with root, etc.

0

Share this post


Link to post
Share on other sites

Posted

Sorry for the confusion.

compiled in userdebug with 191.2MB system in the zip. So there is not an issue with the size

0

Share this post


Link to post
Share on other sites

Posted (edited)

The build that i compiles earlier is not booting. The boot animation won't end. Any troubleshooting tips?

Tried formatting system,boot,cache,sdext, etc.. no use

Edited by MadEye Moody
0

Share this post


Link to post
Share on other sites

Posted

logcat.

:P

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.