• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

3135 posts in this topic

Posted

Thanks. I think the phone is already rooted as it has a Modaco ROM on it, with SU preinstalled.

What will the TPT Helper do? Create a file on the SD card to boot from to format the phone in the right sizes? Have I got that right? WIll that get rid of CWM?

If CWM remains then after formatting it's just a matter of installing this ROM through CWM?

Sorry about all the questions. :)

I'd recommend a 160MB system TPT partition for this rom, with the Google apps (gapps) package from the first post. It fits perfectly. The larger system partition you have, the less space in the data partition you end up with, meaning you won't be able to install as many apps.

0

Share this post


Link to post
Share on other sites

Posted (edited)

H\W+ will never work on our device.

Why others doesnt play I dont know. May be KonstaT uses old proprietaries... You can compare libs with my from here: https://github.com/a...proprietary/lib

PCM audio dont supported by our extractor. You can enable software audio in MX Player for it.

I managed to fix the playing issues in MX Player (not in VLC, but I assume it's because it's beta)! Now it plays with S\W decoder for audio as you said - 10x. :) I never imagined that such basic standard as PCM, could be a problem for any device. :blink: Still, videos with B-frames are not played correctly (as you also warned me), so the benefit of H\W decoding is mostly for streaming or personally converted files. Nevertheless, great work! :)

Edited by elrond_bs
0

Share this post


Link to post
Share on other sites

Posted (edited)

This is now the final CM10 release - for real this time. ;)

cm-10-20130108-KonstaKANG-blade.zip

http://www.mediafire...428z9l44e6rf66i

md5:9a696d776d0dae0ea0d9800b60e55bf3

-fixed charger mode detection

-fake vsync events

-set correct permissions for boostpulse (now it actually works :P)

-enabled divx and wma hw decoding (again)

-switched back to jellybean camera (again) & fixed preview glitches

-Allow purging of asset bitmaps (1)

Can you do a self-build package with a image.bin that does all the partitions and installation of the Recovery ?

It would be helpful since im running an 2.2 Stock ROM . Since this is the Final Release you could do that like the CM9 Version

Edited by WiiSky70
0

Share this post


Link to post
Share on other sites

Posted

Hey, KonstaT i noticed that in cm7/9 FLAC (audio) is supported but in CM10 it isn't, is it CM Bug or our device doesn't have support??

0

Share this post


Link to post
Share on other sites

Posted

May i suggest, KonstaT, since all users have different needs, to provide two versions of the ROM, one with the hardware decoding and one without. That way everyone can select whichever works best for them.

No need to do that. Now that user related issues are resolved, everything seems to work for everyone. Also the reason why reverted it once before is now sorted.

Can you do a self-build package with a image.bin that does all the partitions and installation of the Recovery ?

It would be helpful since im running an 2.2 Stock ROM . Since this is the Final Release you could do that like the CM9 Version

No, because I don't have device that can flash image.bin style TPTs. I think it's one of the default layouts in TPT helper, so there's no need for me to make one.

Hey, KonstaT i noticed that in cm7/9 FLAC (audio) is supported but in CM10 it isn't, is it CM Bug or our device doesn't have support??

Android has native flac support since honeycomb. It works fine in CM10.1 and I have no reason to believe it doesn't work here (can't be bothered to test).

1

Share this post


Link to post
Share on other sites

Posted

I'd recommend a 160MB system TPT partition for this rom, with the Google apps (gapps) package from the first post. It fits perfectly. The larger system partition you have, the less space in the data partition you end up with, meaning you won't be able to install as many apps.

Thanks for this. Is there any way to return to the Gen1 layout with TPT Helper? Would there ever be any reason to do so? Does the Gen1 layout have any advantages at all?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks for this. Is there any way to return to the Gen1 layout with TPT Helper? Would there ever be any reason to do so? Does the Gen1 layout have any advantages at all?

Think of it basically as different size partitions on one disk. System + cache + data = whole disk. Different roms / versions of android require different size system partition in order to fit all the files.

Don't worry about the gen1, gen2 etc. All you need to know is that if your phone is gen1 you always have to use 'gen1 to gen2' TPT files. Regardless of what your current partition layout is - many people don't get this and think that after using gen1 to gen2 they think they need to use gen2 TPT files, when instead it is always gen1 to gen2

You want to choose a TPT size that gives you the most data space while ensuring it has enough system space. For this rom Konstat recommended 160MB system. Which, with a 2MB cache, leaves something like 294MB data.

Once you go to CM9, 10 or 10.1 you won't want to go back so don't worry about that ( it is easy though)

Edited by 99x
0

Share this post


Link to post
Share on other sites

Posted

Think of it basically as different size partitions on one disk. System + cache + data = whole disk. Different roms / versions of android require different size system partition in order to fit all the files.

Don't worry about the gen1, gen2 etc. All you need to know is that if your phone is gen1 you always have to use 'gen1 to gen2' TPT files. Regardless of what your current partition layout is - many people don't get this and think that after using gen1 to gen2 they think they need to use gen2 TPT files, when instead it is always gen1 to gen2

You want to choose a TPT size that gives you the most data space while ensuring it has enough system space. For this rom Konstat recommended 160MB system. Which, with a 2MB cache, leaves something like 294MB data.

Once you go to CM9, 10 or 10.1 you won't want to go back so don't worry about that ( it is easy though)

Thanks again, that's quite clear :) But what confuses me are threads like this one, which seems to indicate a complete change occurs, and that only Gen 2 ROMs can be used after the conversion. Or is that thread now obsolete?

And I am right to assume my AMOLED UK SF is Gen 1, right?

0

Share this post


Link to post
Share on other sites

Posted

Thanks again, that's quite clear :) But what confuses me are threads like this one, which seems to indicate a complete change occurs, and that only Gen 2 ROMs can be used after the conversion. Or is that thread now obsolete?

And I am right to assume my AMOLED UK SF is Gen 1, right?

It is all kind if of a mess really. In any case, you phone is GEN 1 (You can check with https://play.google.com/store/apps/details?id=com.amphoras.bladechecker) and therefore you simply need to run a GEN 1 -> GEN 2 TPT to get everything sorted.

0

Share this post


Link to post
Share on other sites

Posted

hey KonstaT im trying to compile cm10 on another device with the same cpu of the skate (msm7227 turbo or something like that) and physicall keyboard, what did you change in the kernel source for it to work on jelly bean/ics/4.2?

0

Share this post


Link to post
Share on other sites

Posted

It is all kind if of a mess really. In any case, you phone is GEN 1 (You can check with https://play.google....as.bladechecker) and therefore you simply need to run a GEN 1 -> GEN 2 TPT to get everything sorted.

Just out of interest, what is the standard (stock) system partition size? And by a "GEN 1 -> GEN 2 TPT" you mean something like TPT Helper provides?

0

Share this post


Link to post
Share on other sites

Posted

I'm using the Dec 27th version:

I have set my wi-fi sleep policy to turn : Never turn off when plugged in (I also tried : Turn off when screen is off with 5 minute delay).

Nevertheless according to the battery usage graph my wi-fi stays on for long periods of time.

Anyone else notice this?

The battery usage is not too bad by the way, it's only the fact that the graph says my wi-fi is on for hours is what is interesting.

0

Share this post


Link to post
Share on other sites

Posted

Just out of interest, what is the standard (stock) system partition size? And by a "GEN 1 -> GEN 2 TPT" you mean something like TPT Helper provides?

Yes,I am referring to TPT Helper. Stock is different on different Blade gens. For instance, GEN 3 (which can't run a TPT to something better :( ) has a massive 60 mb wasted cache partition, a huge 200 mb system, and a tiny 160 mb data...

0

Share this post


Link to post
Share on other sites

Posted

Is it possible that compiling the ROM in release mode instead of userdebug can give some minor performance improvements?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Is it only with me that play store opens and closes instantly with last release?

Also, doesn't show the name of the contacts in the messages app, only their numbers :(

Edited by crazzy_boy
0

Share this post


Link to post
Share on other sites

Posted

It's only you, apparently. Wipe everything and install again.

1

Share this post


Link to post
Share on other sites

Posted

How about OC in this rom? How much can you squeeze out of your blades?

0

Share this post


Link to post
Share on other sites

Posted

How about OC in this rom? How much can you squeeze out of your blades?

The amount of oc doesn't depend only on the Rom but also on the hardware itself.;)

1

Share this post


Link to post
Share on other sites

Posted

How about OC in this rom? How much can you squeeze out of your blades?

Have used in several modded ROMs 748MHz for over two year now. :)

0

Share this post


Link to post
Share on other sites

Posted

Means nothing, because my phone (as well as many others) was never stable above 690Mhz.

1

Share this post


Link to post
Share on other sites

Posted

Well, on cm7 i've never got under 710mhz but now i can't even touch the cpu governor or otherwise it becomes unstable.

0

Share this post


Link to post
Share on other sites

Posted

I'd just like to say thanks a lot, KonstaT. You've prolonged the life of the Blade far longer than I could have hoped for. Mines going into retirement now, but I really appreciate your efforts!

0

Share this post


Link to post
Share on other sites

Posted

once again thanks konstat for another update

i updated to 8.1 without full wipe from the 27.12 rom and was working fine, then i decided to wipe my sd card because it was full of leftover data but after this the ext partition stopped being recognised so since i was fully backed up with titanium i repartitioned the card in cwm (6.0.2.7) again and full wipe and reinstalled the 8.1 but now it still won't recognise the ext partition, in partition info it just says unavailable and it's greyed out in s2e

so whats wrong?

i've also tried using minitool partition to get 4ext but that doesn't work either

has anyone got any suggestions

i've seen on other forums that people have to activate a2sd in the terminal with

su

a2sd install

y

n

y

but i assume it's something different for s2e

if anyone can help it would be really appreciated

0

Share this post


Link to post
Share on other sites

Posted

once again thanks konstat for another update

i updated to 8.1 without full wipe from the 27.12 rom and was working fine, then i decided to wipe my sd card because it was full of leftover data but after this the ext partition stopped being recognised so since i was fully backed up with titanium i repartitioned the card in cwm (6.0.2.7) again and full wipe and reinstalled the 8.1 but now it still won't recognise the ext partition, in partition info it just says unavailable and it's greyed out in s2e

so whats wrong?

i've also tried using minitool partition to get 4ext but that doesn't work either

has anyone got any suggestions

i've seen on other forums that people have to activate a2sd in the terminal with

su

a2sd install

y

n

y

but i assume it's something different for s2e

if anyone can help it would be really appreciated

i dont know if thr is any advantages of s2e over link2sd.

But I too had problems with s2e. So i started using link2sd and its been working without any problems.

0

Share this post


Link to post
Share on other sites

Posted

once again thanks konstat for another update

i updated to 8.1 without full wipe from the 27.12 rom and was working fine, then i decided to wipe my sd card because it was full of leftover data but after this the ext partition stopped being recognised so since i was fully backed up with titanium i repartitioned the card in cwm (6.0.2.7) again and full wipe and reinstalled the 8.1 but now it still won't recognise the ext partition, in partition info it just says unavailable and it's greyed out in s2e

so whats wrong?

i've also tried using minitool partition to get 4ext but that doesn't work either

has anyone got any suggestions

i've seen on other forums that people have to activate a2sd in the terminal with

su

a2sd install

y

n

y

but i assume it's something different for s2e

if anyone can help it would be really appreciated

Did this some time ago when changed my 16GB to 32GB before upgrading to 4.2.1.

Backed up with TB.

Partitioned SD-card with minitool partition wizard to Fat32/ext4/swap.

Flashed S2E 8.1 in CWM.

Restored with TB.

Everything went fine. :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.