• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

3135 posts in this topic

Posted

After a while one CM9 KANG (old build from early July), whose stability was really astonishing, I finally decided to move to JB yesterday evening.

I expected some issues, but all went so smoothly it was almost disappointing :D

I could even fit it into my 140Mb /system partition :P with the LatinIME hack Konsta recently provided and a (hardly) modified gapps package.

So once again thanks to the community and especially to all the committed developers who give so much time and efforts to create and fix beautiful roms like this one and then provide them to us for free.

Can anyone confirm if Link2SD is working? specifically Link2SD, S2E doesn't allow you to pick and choose which apps you link which is terrible.

I confirm Link2SD works flawlessly, I could restore all my apps via TB and the link was systematically created as expected.

1

Share this post


Link to post
Share on other sites

Posted

I'm totally excited. I just flashed CM10 for the 1st time and first thing I can say: the camera - preview included - works! Thank you KonstaT and the other devs who have contributed to that success!

To any interested user: I used the v10a TPT (160 MB system) and stripped successfully some content from the ROM, namely: All unneeded languages from LatinIME apk (system/app/LatinIME.apk/res/raw), some other apks (eg Live Wallpaper picker and Email) and most of the audio files. Don't know how much deleting would have been necessary to fit into 160 MB system but in my case it worked. I stripped the ROM zip from 90 to 79 MB.

1

Share this post


Link to post
Share on other sites

Posted

I'm using Kang CM9 but now i wanna try CM10 because camera seems to be working and i use it a lot.

So can i flash this like CM9? Do a full wipe then install cm10? Or do i have to do what's in second post?

0

Share this post


Link to post
Share on other sites

Posted

This is not in the change list of 08.21 version, but fixes my issue. Now i continue to using this ROM, not downgrade to SSRLS7. Thank you Konstat!

0

Share this post


Link to post
Share on other sites

Posted

I'm using Kang CM9 but now i wanna try CM10 because camera seems to be working and i use it a lot.

So can i flash this like CM9? Do a full wipe then install cm10? Or do i have to do what's in second post?

You can just take the zip from post no.1 and flash it as every ROM. The second post ist something else that you don't need.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Yes, 21/8 version works fine.

Camera works now including preview on legacy apps on my sf oled blade.

Only youtube playback broke again (coming from 8/8 version), mx player on s/w works fine

When youtube will work, we've got an almost perfect cm10 :)

cm10 bootanimation is great, best cm animation ever!!

Edited by birdibird
0

Share this post


Link to post
Share on other sites

Posted

I'm using Kang CM9 but now i wanna try CM10 because camera seems to be working and i use it a lot.

So can i flash this like CM9? Do a full wipe then install cm10? Or do i have to do what's in second post?

Dude, check your system sieze before flahing anything. Read the posts on this and the last four pages and it will be clear what you need to do.

- This is not a "for-daily-use" ROM, thats why the dev has a tag in the post-name [dev].

Also, always do nandroid backups before flashing anything. Always. aaaalways.

0

Share this post


Link to post
Share on other sites

Posted

You can just take the zip from post no.1 and flash it as every ROM. The second post ist something else that you don't need.

Thanks!

Dude, check your system sieze before flahing anything. Read the posts on this and the last four pages and it will be clear what you need to do.

- This is not a "for-daily-use" ROM, thats why the dev has a tag in the post-name [dev].

Also, always do nandroid backups before flashing anything. Always. aaaalways.

Yeah i know i'll need to do a new tpt as i was using a smaller system size for cm9. Thanks for the heads up i allways do backups!

0

Share this post


Link to post
Share on other sites

Posted

@KonstaT

The new EGL patch doesn't seem to work for me too..


simon@simon-HP-Pavilion-dv6-Notebook-PC:~/paranoid_jb$ cd frameworks/native

simon@simon-HP-Pavilion-dv6-Notebook-PC:~/paranoid_jb/frameworks/native$ git am *.patch

Applying: graphics: Add directives for compatibility with older EGL blobs (2/2)

error: patch failed: libs/ui/GraphicBufferMapper.cpp:75

error: libs/ui/GraphicBufferMapper.cpp: patch does not apply

error: patch failed: opengl/include/GLES/glext.h:71

error: opengl/include/GLES/glext.h: patch does not apply

error: patch failed: opengl/include/GLES2/gl2ext.h:60

error: opengl/include/GLES2/gl2ext.h: patch does not apply

error: patch failed: opengl/libagl/state.cpp:192

error: opengl/libagl/state.cpp: patch does not apply

error: patch failed: services/surfaceflinger/DisplayHardware/DisplayHardware.cpp:247

error: services/surfaceflinger/DisplayHardware/DisplayHardware.cpp: patch does not apply

error: patch failed: services/surfaceflinger/Layer.cpp:784

error: services/surfaceflinger/Layer.cpp: patch does not apply

Patch failed at 0001 graphics: Add directives for compatibility with older EGL blobs (2/2)

When you have resolved this problem run "git am --resolved".

If you would prefer to skip this patch, instead run "git am --skip".

To restore the original branch and stop patching run "git am --abort".

simon@simon-HP-Pavilion-dv6-Notebook-PC:~/paranoid_jb/frameworks/native$ git am --abort

simon@simon-HP-Pavilion-dv6-Notebook-PC:~/paranoid_jb/frameworks/native$ ^C

0

Share this post


Link to post
Share on other sites

Posted

hi guys, i was just wondering about the amout of system partition is required by this rom. Will it fit in 160 mb?Thanks in advance

0

Share this post


Link to post
Share on other sites

Posted (edited)

hi guys, i was just wondering about the amout of system partition is required by this rom. Will it fit in 160 mb?Thanks in advance

Read page 35 and 36.

Edited by staud
0

Share this post


Link to post
Share on other sites

Posted

Read page 35 and 36.

LOL i've serched using "partition size" in the topic but i didn't find anything.... and the answer was in the last page...xD

But i got another question.... how can i get the system partition to be 180/200 MB with TPT?

0

Share this post


Link to post
Share on other sites

Posted (edited)

ive got blade checker it says ive got european blade atpt upgraded gen 2 phone use gen 1 style tpts so im confused how to put this rom on my blade and which tpt to use off tpt helper could you direct me please thankyou.

TPT helper should tell what to choose. My impression is that you can use any of the "Gen 1 to Gen 2" TPTs, however I am not entirely certain.

LOL i've serched using "partition size" in the topic but i didn't find anything.... and the answer was in the last page...xD

But i got another question.... how can i get the system partition to be 180/200 MB with TPT?

Download blade checker from Play store. If it says you have a GEN1 or GEN2 Blade, proceed with the app TPT helper. If your phone is a stock GEN2 you might want to create your own custom TPT with a lot of space for data, and just the right amount for system.

Edited by TehStalker
0

Share this post


Link to post
Share on other sites

Posted

LOL i've serched using "partition size" in the topic but i didn't find anything.... and the answer was in the last page...xD

But i got another question.... how can i get the system partition to be 180/200 MB with TPT?

Use tpt helper from market. You can create a 'manual' TPT whit the partition size that you want.

0

Share this post


Link to post
Share on other sites

Posted

LOL i've serched using "partition size" in the topic but i didn't find anything.... and the answer was in the last page...xD

But i got another question.... how can i get the system partition to be 180/200 MB with TPT?

CHECK OUT:http://amphoras.co.uk/index.php/downloads/blade-tpts

ITS HELPED ME

0

Share this post


Link to post
Share on other sites

Posted

play shows device not compatible for s2E. Can any body provide the apk, please?

0

Share this post


Link to post
Share on other sites

Posted (edited)

Download simple2ext-v6-jb.zip from:

https://docs.google....m4tejhQaFU/edit

and flash it on each update.

I've patched the s2e app to work with api levl 16.

Edited by XeS0r
1

Share this post


Link to post
Share on other sites

Posted

Konstat, thanks alot for your work but what about TPT for optimised partition layout?

Not quite there yet. I'm still not aiming for any specific partition size. Would probably prevent this thread turning into a 'how to do a TPT?' thread though. :P

s2e working?

Yeah, S2E works perfect, just not the app from the play shop. ;) I have *grhhhm* hacked the app to work in jelly bean. I'm not sure how polite it would be distribute it. There's obviously some (unknown) reason why the developer hasn't updated his app.

Can anyone confirm if Link2SD is working? specifically Link2SD, S2E doesn't allow you to pick and choose which apps you link which is terrible.

I think there's an issue if you move dalvik executables to your ext partition (what you shouldn't do in the first place anyway). I also suggest that you move the link2sd script from /system/init.d/ to /data/local/userinit.d/ where it is preserved during ROM updates. Link2SD has a bad habit of borking the links on updates, this should prevent that.

I personally prefer S2E/Darktremor over Link2SD. They're more robust and reliable. And I don't see it as a bad thing that they limit what dumb user is allowed to move around. :P

My screen is kinda flickering... in notification bar when a msg comes and it rolls upwards it looks like ghosting. Is everyone havin this prob or is it just me?

Yes, everyone.

@KonstaT

The new EGL patch doesn't seem to work for me too..

You already have something else applied. Reset your HEAD to match CM10 upstream.

It's this patch here anyway. You can always cherry-pick it and resolve the conflicts yourself.

I've patched the s2e app to work with api levl 16.

Me too. ;)

1

Share this post


Link to post
Share on other sites

Posted

@KonstaT

Ok thanks! ;) git reset --hard github/jellybean did the job!

0

Share this post


Link to post
Share on other sites

Posted

Ah right. BTW I've put up the fixes for streaming with the EGL hack.

Yeah, I've had that other part but it causes an issue for me. If I rotate my screen while watching youtube I get a soft reboot. Local videos work fine. Any ideas on that?

0

Share this post


Link to post
Share on other sites

Posted

System size for ROM + gapps from the first post seems to be ~161mb. You need to have system size larger than that or do some trimming on the ROM - simple as that.

And a quick reminder.

Updating from some other ROM:

  1. boot to clockworkmod
  2. mounts & storage -> format system
  3. wipe data & factory reset
  4. install zip from sdcard -> cm-10-xxxxxxxx-KonstaKANG-blade.zip
  5. install zip from sdcard -> gapps-jb-xxxxxxxx-KonstaKANG.zip
  6. reboot now

Updating from previous version of this ROM:

  1. boot to clockworkmod
  2. install zip from sdcard -> cm-10-xxxxxxxx-KonstaKANG-blade.zip
  3. reboot now

If you have installed some other gapps package:

  1. boot to clockworkmod
  2. mounts & storage -> format system
  3. install zip from sdcard -> cm-10-xxxxxxxx-KonstaKANG-blade.zip
  4. install zip from sdcard -> gapps-jb-xxxxxxxx-KonstaKANG.zip
  5. reboot now

2

Share this post


Link to post
Share on other sites

Posted

Anyone tried burstlams new jb release?

0

Share this post


Link to post
Share on other sites

Posted

oh thanx for the info... ;) which partition-set do you think is better?

0

Share this post


Link to post
Share on other sites

Posted

Download simple2ext-v6-jb.zip from:

https://docs.google....m4tejhQaFU/edit

and flash it on each update.

I've patched the s2e app to work with api levl 16.

Thanks!! worked well.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.