• Announcements

    • PaulOBrien

      Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance) CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission) ROMs must give full credit to the original author ISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • PaulOBrien

      Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
KonstaT

[DEV][ROM][8.1.] CyanogenMod 10 (Android 4.1.2)

3135 posts in this topic

Thanks, KonstaT. I kanged some things from your kernel and data usage seems to be working :)

0

Share this post


Link to post
Share on other sites

No its not a stupid question, how do i create the ext4 partition on the sd-card. Knew i was missing something

M havin the same problem! S2E works in Paranoid but I cant install it in THIS version. Play store says its not compatible with my version of android! WTF?

0

Share this post


Link to post
Share on other sites

I cannot, for the love of Jesus, get the proximity sensor to work!

I've tried the default calibrator, various other apps, on different luminous intensities...

The issue persists with the clean flashing ov various other ROMs, mainly Swedish Snow, CM7, CM9 and CM10.

Can someone please give me a hand here :(

0

Share this post


Link to post
Share on other sites

Hacked S2E for jelly bean available here.

Partitioned using latest CWM, followed the instructions above and everything's working fine.

0

Share this post


Link to post
Share on other sites

Great ROM. Amazing what can be done with a device like this.

Using 2012-10-10 release, used the 09-27 before (before that Swedish Snow).

I had some strange problems initially (notifications not working, many applications crashing etc). This was due to I had a 160 MiB = 167 MB /system partition. The partition had like 300 KB free still after installing gapps. Increasing the partition (first to 210 MiB, then to 170 MiB) solved the problem. Still 10,3 MB free, but there may be some additional temp space needed?

I did not see a specific recommendation other than 160 MB (really 160 MiB), is that working for someone? If not the recommendations on the first page should probably be updated.

Edit: I wrote this before updating to 10-10 release. Now I have 22MB free, so 160MB should fit after all. Confirmed by others.

Some hints on S2E: I had problem accessing the SD card at all after taking the first backup before upgrading, using KonstaT's CWM 6.0.1.2 (probably coincidence problem occurred then). I had reformat in Linux, to get it working in the Blade again (Windows OK). Using Snap.IT's CWM Touch 6.0.1.1 now. I have moved apps and app-data to sd-ext. dalvik-cache slows down app startup some. Actually, I would like to use data on flash, my sdcard is a little slow (test CrystalDiskMark 4K Write, should be > 1 MB/s, 0,005 MB/s is painful. Class 2/4 SanDisk cards seem to have best reputation).

I miss the FM Radio. If KonstaT posts his hints I may take a look (but do not expect so much, no Android experience).

The only issue that currently puzzles me is that CM10 seem to activate lockscreen when closing notifications and reactivates lockscreen when deactivated (I use Llama to deactivate it when I am home).

Edited by gerhardo
0

Share this post


Link to post
Share on other sites

Hi.

I hope I'm not duplicating any question here...

I've updated first to the 27/9 (which was quite fine, a few bugs exception) and now to 10/10. Or at least trying to.

I've formated the /system partition, wyped dalvik cache and then did the upgrade.

It booted up to the point where it optimized a few apps (55, if I'm not mistaken) and now it has been +-1h it says "Android is being updated" and "Starting apps" (or so I think these are the texts, as mine says this in Portuguese).

What to do now? Any help is appreciated, or I'll have to restore the nandroid backup...

Thanks!

Ricardo

Update: it has rebooted; I didn't notice if something else happened, but now the little green man is on the screen...

Edited by Ricardo Mota
0

Share this post


Link to post
Share on other sites

I was wondering, is there a Car Panel in this release like in CM7.1 and if so, how do I access it? (Google apps are installed as instructed.) I seem to have misplaced it :P

Edited by Camacha
0

Share this post


Link to post
Share on other sites

I was wondering, is there a Car Panel in this release like in CM7.1 and if so, how do I access it? (Google apps are installed as instructed.) I seem to have misplaced it

Mmm is this what you're refering to?

As it's available on Play, there's no point in having it in the rom or in the gapps.

Edited by Ogami Itto
0

Share this post


Link to post
Share on other sites

Hi.

I hope I'm not duplicating any question here...

I've updated first to the 27/9 (which was quite fine, a few bugs exception) and now to 10/10. Or at least trying to.

I've formated the /system partition, wyped dalvik cache and then did the upgrade.

It booted up to the point where it optimized a few apps (55, if I'm not mistaken) and now it has been +-1h it says "Android is being updated" and "Starting apps" (or so I think these are the texts, as mine says this in Portuguese).

What to do now? Any help is appreciated, or I'll have to restore the nandroid backup...

Thanks!

Ricardo

Update: it has rebooted; I didn't notice if something else happened, but now the little green man is on the screen...

What exactly is the issue here? Are you stuck at the reboot phase? Try installing again from scratch, that solves the problem sometimes, I never had this problem.. hope you have a nandroid backup lying around :)

I was wondering, is there a Car Panel in this release like in CM7.1 and if so, how do I access it? (Google apps are installed as instructed.) I seem to have misplaced it

Nope, its not included, as you can download it from play store, but for some reason, it shows most devices are incompatible with it, so just google "car home.apk " and download it separately

Great ROM. Amazing what can be done with a device like this.

Using 2012-10-10 release, used the 09-27 before (before that Swedish Snow).

I had some strange problems initially (notifications not working, many applications crashing etc). This was due to I had a 160 MiB = 167 MB /system partition. The partition had like 300 KB free still after installing gapps. Increasing the partition (first to 210 MiB, then to 170 MiB) solved the problem. Still 10,3 MB free, but there may be some additional temp space needed?

I did not see a specific recommendation other than 160 MB (really 160 MiB), is that working for someone? If not the recommendations on the first page should probably be updated.

Some hints on S2E: I had problem accessing the SD card at all after taking the first backup before upgrading, using KonstaT's CWM 6.0.1.2 (probably coincidence problem occurred then). I had reformat in Linux, to get it working in the Blade again (Windows OK). Using Snap.IT's CWM Touch 6.0.1.1 now. I have moved apps and app-data to sd-ext. dalvik-cache slows down app startup some. Actually, I would like to use data on flash, my sdcard is a little slow (test CrystalDiskMark 4K Write, should be > 1 MB/s, 0,005 MB/s is painful. Class 2/4 SanDisk cards seem to have best reputation).

I miss the FM Radio. If KonstaT posts his hints I may take a look (but do not expect so much, no Android experience).

The only issue that currently puzzles me is that CM10 seem to activate lockscreen when closing notifications and reactivates lockscreen when deactivated (I use Llama to deactivate it when I am home).

I have an exact 160 MB system partition and it works perfectly :)

M havin the same problem! S2E works in Paranoid but I cant install it in THIS version. Play store says its not compatible with my version of android! WTF?

Refer to the first post in the thread, KonstaT has given the link to the hacked version of S2E that works on JB.. Don't try using the one on the playstore. :P

No its not a stupid question, how do i create the ext4 partition on the sd-card. Knew i was missing something

Use CWM, boot into recovery, n partition the SD card, remember, don't use the ROM manager to do this. Choose the Swap size as 0 and the ext size according to your preference. Dont use too big a value because you'll reduce the space on the SD card and you wont be utilizing that big an ext partition anyway. ;)

Or you can download Minitool Partition Wizard (google it) , connect your phone to the PC in the mass storage mode and create an ext partition separately.

TAKE A BACKUP OF ALL THE DATA ON THE SD CARD BEFORE YOU PARTITION IT, BECAUSE IT WILL BE FORMATTED!

then reboot, start up s2e and wait for it 2 detect your ext partition :)

2

Share this post


Link to post
Share on other sites

What to do now? Any help is appreciated, or I'll have to restore the nandroid backup...

Update: it has rebooted; I didn't notice if something else happened, but now the little green man is on the screen...

Hi,

It might be that the last build is bigger than the previous one, hence 160Mb is not enough... Didn't seem to, however, as the zip was smaller iirc, but as per gerhardo's message above, it might be the issue.

Now you can:

1. Reboot just to check.

2. If it stays on the green droid, restore your backup and flash again

3a. It still fails, you can change your partition size to 170Mb and reflash

3b. Alternatively, you can remove stuff you don't use from the zip before flashing with your current partition.

Additional languages in LatinIME.apk would be an easy way to gain a few Mb, although KonstaT already cleaned it a bit.

Of course, this is relevant only if the issue is linked to partition size...

Edit: well, with Moonvalley11's message, the partition issue starts moving away :D Steps 1 and 2 still apply, though, and tailoring the zip doesn't cost much, if you fancy giving it a try :P

Edited by Ogami Itto
0

Share this post


Link to post
Share on other sites

I had some strange problems initially (notifications not working, many applications crashing etc). This was due to I had a 160 MiB = 167 MB /system partition. The partition had like 300 KB free still after installing gapps. Increasing the partition (first to 210 MiB, then to 170 MiB) solved the problem. Still 10,3 MB free, but there may be some additional temp space needed?

I did not see a specific recommendation other than 160 MB (really 160 MiB), is that working for someone? If not the recommendations on the first page should probably be updated.

Hi,

It might be that the last build is bigger than the previous one, hence 160Mb is not enough... Didn't seem to, however, as the zip was smaller iirc, but as per gerhardo's message above, it might be the issue.

Now you can:

1. Reboot just to check.

2. If it stays on the green droid, restore your backup and flash again

3a. It still fails, you can change your partition size to 170Mb and reflash

3b. Alternatively, you can remove stuff you don't use from the zip before flashing with your current partition.

Additional languages in LatinIME.apk would be an easy way to gain a few Mb, although KonstaT already cleaned it a bit.

Of course, this is relevant only if the issue is linked to partition size...

Edit: well, with Moonvalley11's message, the partition issue starts moving away Steps 1 and 2 still apply, though, and tailoring the zip doesn't cost much, if you fancy giving it a try

It's only gotten smaller lately. System size for the ROM & gapps in the first post is ~150mb. There's absolutely no trouble fitting it to 160b system.

2

Share this post


Link to post
Share on other sites

Here is quick summary of my FM radio experiment. These are the commits that I had (with some minor adjustments to get everything compiled).

Framework:

https://www.codeaurora.org/gitweb/quic/la/?p=platform/frameworks/base.git;a=commit;h=b1e3fd5f3fc043c62f4d672be3fc359317f72ee9

https://www.codeaurora.org/gitweb/quic/la/?p=platform/frameworks/base.git;a=commit;h=72fc98929460513f7da1d6d23594631624efe7e6

https://www.codeaurora.org/gitweb/quic/la/?p=platform/frameworks/base.git;a=commit;h=9136b0abd71d968c96a969e310440552628cd431

si4708 driver from CM7:

https://github.com/CyanogenMod/android_frameworks_base/blob/gingerbread/core/jni/android_hardware_fm_si4708.cpp

FM radio app from CAF:

https://www.codeaurora.org/gitweb/quic/la/?p=platform/packages/apps/FM.git;a=shortlog;h=refs/heads/jb_rel

These are already merged in CM10:

https://www.codeaurora.org/gitweb/quic/la/?p=platform/hardware/libhardware_legacy.git;a=commit;h=3ec47968387b8f139a50daedc33e20f70dadb33d

https://www.codeaurora.org/gitweb/quic/la/?p=platform/frameworks/av.git;a=commit;h=fd7e6bc3c99afecce6e25c1c4b0cc0ebbb004edf

FM radio is switched on in kernel but then gets stuck in for loop in framework. Nothing happening in the audio system. Any volunteers to add FM support? ;) Any ideas what I'm missing here?

In logcat:


D/FMRadio ( 1716): Load preferences
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Country :1
D/FMRadio ( 1716): RadioBand :4
D/FMRadio ( 1716): Emphasis :1
D/FMRadio ( 1716): ChSpacing :1
D/FMRadio ( 1716): RdsStd :1
D/FMRadio ( 1716): LowerLimit :87500
D/FMRadio ( 1716): UpperLimit :108000
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): onCreate - Height : 800 - Width : 480
E/FMRadio ( 1716): bindToService: Context with serviceconnection callback
D/FMRadio ( 1716): onCreate: Start Service completed successfully
D/FMRadio ( 1716): FMRadio: onstart
D/FMRadio ( 1716): FMRadio: onresume
D/FMRadio ( 1716): Load preferences
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Country :1
D/FMRadio ( 1716): RadioBand :4
D/FMRadio ( 1716): Emphasis :1
D/FMRadio ( 1716): ChSpacing :1
D/FMRadio ( 1716): RdsStd :1
D/FMRadio ( 1716): LowerLimit :87500
D/FMRadio ( 1716): UpperLimit :108000
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Load preferences
D/FMRadio ( 1716): =====================================================
D/FMRadio ( 1716): Country :1
D/FMRadio ( 1716): RadioBand :4
D/FMRadio ( 1716): Emphasis :1
D/FMRadio ( 1716): ChSpacing :1
D/FMRadio ( 1716): RdsStd :1
D/FMRadio ( 1716): LowerLimit :87500
D/FMRadio ( 1716): UpperLimit :108000
D/FMRadio ( 1716): =====================================================
D/FMService( 1716): is A2DP device Supported In HALfalse
D/FMService( 1716): onstart
D/FMService( 1716): onBind
D/FMService( 1716): onCallStateChanged: State - 0
D/FMService( 1716): onCallStateChanged: incomingNumber -
D/FMService( 1716): onDataActivity - 0
D/FMService( 1716): ACTION_HEADSET_PLUG Intent received
D/FMService( 1716): mReceiver: ACTION_HEADSET_PLUG
D/FMService( 1716): ==> intent: Intent { act=android.intent.action.HEADSET_PLUG flg=0x40000010 (has extras) }
D/FMService( 1716): state: 1
D/FMService( 1716): name: Headset
E/FMRadio ( 1716): onServiceConnected: mCallback
E/FMRadio ( 1716): ServiceConnection: onServiceConnected:
D/FMService( 1716): fmOn: RadioBand :4
D/FMService( 1716): fmOn: Emphasis :1
D/FMService( 1716): fmOn: ChSpacing :1
D/FMService( 1716): fmOn: RdsStd :1
D/FMService( 1716): fmOn: LowerLimit :87500
D/FMService( 1716): fmOn: UpperLimit :108000
V/FMRadio ( 1716): enable: CURRENT-STATE : FMOff ---> NEW-STATE : FMRxStarting
D/FmTransceiver( 1716): Opened 40
D/FmTransceiver( 1716): turning on 1
D/fmradio_si4708( 1716): FMRadio on
D/FmTransceiver( 1716): Calling fmConfigure
V/FmConfig( 1716): In fmConfigure
V/FmConfig( 1716): fmConfigure() : FM Srch Alg : OLD
D/FMService( 1716): Analog Path is not supported
D/FMRadio ( 1716): Starting listener 40
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
V/FMRadio ( 1716): RxEvtList: CURRENT-STATE : FMRxStarting ---> NEW-STATE : FMRxOn
D/FMService( 1716): FmRxEvEnableReceiver
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): mReceiver.enable done, Status :true
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMService( 1716): setLowPowerMode: false
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): setLowPowerMode done, Status :true
D/FMRadio ( 1716): Got READY_EVENT
D/FMService( 1716): mAudioManager.setFmRadioOn = true
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): In startFM
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
I/AudioService( 386): AudioFocus requestAudioFocus() from [email protected]vice$13@40fe2640
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMService( 1716): FM registering for registerMediaButtonEventReceiver
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
I/AudioService( 386): Remote Control registerMediaButtonIntent() for PendingIntent{4106d350: PendingIntentRecord{4124c8f0 com.quicinc.fmradio broadcastIntent}}
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): FMRadio: sending the intent
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
V/AudioService( 386): FM Intent received
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): mAudioManager.setFmRadioOn done
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FmRxRdsData( 1716): In rdsOn: RDS is true
D/FMRadio ( 1716): Received <0>
D/FmRxRdsData( 1716): In rdsOptions: rdsMask: 23
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMService( 1716): registerRdsGroupProcessing done, Status :true
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMService( 1716): enableAutoAF: true
D/FMRadio ( 1716): Received event. Count: 1
D/FmRxRdsData( 1716): In rdsOn: RDS is true
D/FMRadio ( 1716): Received <0>
D/FmRxRdsData( 1716): In enableAFjump: AFenable : true
D/FMRadio ( 1716): Got READY_EVENT
D/FmRxRdsData( 1716): Currently set rds_group_mask : 0
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FmRxRdsData( 1716): After enabling the rds_group_mask is : 0
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMService( 1716): enableAutoAF done, Status :true
D/FMService( 1716): setInternalAntenna done, Status :true
D/FMRadio ( 1716): Got READY_EVENT
D/FMService( 1716): getInternalAntenna: false
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>
D/FMRadio ( 1716): Got READY_EVENT
D/FMRadio ( 1716): Received event. Count: 1
D/FMRadio ( 1716): Received <0>[/CODE] In dmesg:
[CODE]
<6>[10-06 10:08:49.369999] [1716: quicinc.fmradio]snd_hph_amp_ctl:0
<6>[10-06 10:08:49.649999] [1716: quicinc.fmradio]snd_hph_amp_ctl:1

2

Share this post


Link to post
Share on other sites

i was thinking that any one could add permission manager and privacy guard? It would be awesome.

0

Share this post


Link to post
Share on other sites

Here is quick summary of my FM radio experiment. These are the commits that I had (with some minor adjustments to get everything compiled).

Framework:

https://www.codeauro...3fc359317f72ee9

https://www.codeauro...594631624efe7e6

https://www.codeauro...0440552628cd431

si4708 driver from CM7:

https://github.com/C...e_fm_si4708.cpp

FM radio app from CAF:

https://www.codeauro...fs/heads/jb_rel

These are already merged in CM10:

https://www.codeauro...33e20f70dadb33d

https://www.codeauro...b0cc0ebbb004edf

FM radio is switched on in kernel but then gets stuck in for loop in framework. Nothing happening in the audio system. Any volunteers to add FM support? Any ideas what I'm missing here?

In logcat:


D/FMRadio ( 1716): Load preferences

....

D/FmRxRdsData( 1716): After enabling the rds_group_mask is : 0

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMService( 1716): enableAutoAF done, Status :true

D/FMService( 1716): setInternalAntenna done, Status :true

D/FMRadio ( 1716): Got READY_EVENT

D/FMService( 1716): getInternalAntenna: false

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>

D/FMRadio ( 1716): Got READY_EVENT

D/FMRadio ( 1716): Received event. Count: 1

D/FMRadio ( 1716): Received <0>
In dmesg:

<6>[10-06 10:08:49.369999] [1716: quicinc.fmradio]snd_hph_amp_ctl:0

<6>[10-06 10:08:49.649999] [1716: quicinc.fmradio]snd_hph_amp_ctl:1

Hi, i am glad that someone takes his time for FM radio!

I am not an Andriod dev but was thinkinj about how to narrow down the problem.

If you could compare the log with working fm log (running fm radio on CM7) you will see what would be the next step after the antenna task and so narrow down the problem in the FM radio source by adding there some debug info (or in some used fm radio util source / framework source).

Maybe the problem isnt to hard to find then.

0

Share this post


Link to post
Share on other sites

Hi,

It might be that the last build is bigger than the previous one, hence 160Mb is not enough... Didn't seem to, however, as the zip was smaller iirc, but as per gerhardo's message above, it might be the issue.

Now you can:

1. Reboot just to check.

2. If it stays on the green droid, restore your backup and flash again

3a. It still fails, you can change your partition size to 170Mb and reflash

3b. Alternatively, you can remove stuff you don't use from the zip before flashing with your current partition.

Additional languages in LatinIME.apk would be an easy way to gain a few Mb, although KonstaT already cleaned it a bit.

Of course, this is relevant only if the issue is linked to partition size...

Edit: well, with Moonvalley11's message, the partition issue starts moving away Steps 1 and 2 still apply, though, and tailoring the zip doesn't cost much, if you fancy giving it a try

I did 1 and 2, but the result was the same. I think it could be some corruption on the zip file. I've downloaded it again, so I'm gaining courage to repeat the process...

Thanks

Ricardo

Edited by Ricardo Mota
0

Share this post


Link to post
Share on other sites

Canvas element in Browser hangs Up (browser is ok) on simple animations.

Example: html5canvas.tk - worked fine on Your rom 2 months ago.

Great ROM Konstat!

0

Share this post


Link to post
Share on other sites

Having problems building on Mac OS X Snow Leopard. Followed instructions up until build, I added proprietary_vendor_zte, android_device_zte_blade, and zte-kernel-msm7x27 then ran repo sync, which picked them up and seemed to work ok, then I applied the frameworks/av and frameworks/native patches, which again seemed to work fine.

When I launch 'lunch cm_blade-userdebug' it give me a 'Dependencies file not found, bailing out.' message, and when when I try 'make bacon -j8' I get this:

============================================

PLATFORM_VERSION_CODENAME=REL

PLATFORM_VERSION=4.1.2

TARGET_PRODUCT=cm_blade

TARGET_BUILD_VARIANT=userdebug

TARGET_BUILD_TYPE=release

TARGET_BUILD_APPS=

TARGET_ARCH=arm

TARGET_ARCH_VARIANT=armv6-vfp

HOST_ARCH=x86

HOST_OS=darwin

HOST_OS_EXTRA=Darwin-10.8.0-x86_64-i386-64bit

HOST_BUILD_TYPE=release

BUILD_ID=JZO54K

OUT_DIR=/Volumes/android/out

============================================

Checking build tools versions...

build/core/base_rules.mk:171: *** device/zte/blade/BladeParts: MODULE.TARGET.APPS.BladeParts already defined by KonstaT/android_device_zte_blade/BladeParts. Stop.

Its probably something obvious, but does anyone have any idea what the problem is?

Thanks,

James

0

Share this post


Link to post
Share on other sites

I can't see my music in the music App. What can i do?

0

Share this post


Link to post
Share on other sites

Wow just only one reboot in 2 days! stable like the ICS one! 1UP! :D

0

Share this post


Link to post
Share on other sites

Is everyone's speakerphone super quiet? It's so low I thought it was broken at first.

0

Share this post


Link to post
Share on other sites

I can't see my music in the music App. What can i do?

Install Scan Media from play store

0

Share this post


Link to post
Share on other sites

Someone else can't use music app in background?

0

Share this post


Link to post
Share on other sites

today i read the miui v4 jellybean thread and someone says that camcorder works well. how is possible? can use that fix in this rom?

Edited by Loki86
0

Share this post


Link to post
Share on other sites

i'm having a delay till keyboard appears

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.