hypnose95

Bricked Huawei 4.0.3 official ROM

20 posts in this topic

Hi Guys,

I am new here and I need a little help. I had 4.0.4 installed on my G300 but because it wasn't stable I decided to go back to 4.0.3 (official one from Huawei).

I have followed the guide to downgrade, changing the IMEI and using the bootloader to go to the latest offical version. Everything was fine, all went really smooth.

I have used my phone for 2 days, did all the restore (including the IMEI of course) for my apps and data.

However, I have restarted my phone and it's stuck on Huawei logo screen, I can't do anything with it, could someone please help :-( ?

Thanks

0

Share this post


Link to post
Share on other sites

That's far away from bricked phone.If you have recovery, then flash rom.zip with it.If you don't have it, put dload folder on root of your SD card and then power up your phone while holding volume up+volume down (hold all buttons on phone while powering).You should use the same rom that you booted succesfully on (judging by your post, thats 4.0.3).And you need external sd card, not the internal one.

0

Share this post


Link to post
Share on other sites

Thanks for your answer Aport, as it's the official ROM I don't have access anymore to the recovery mode. I forgot that I have deleted the UPDATE.APP file from the dload folder, it's now reinstalling.

However, it's normally ok to delete the dload folder from the sdcard no?

0

Share this post


Link to post
Share on other sites

OK now I am having a different issue, I put the dload folder on the SD card, press VolUP+DOWN, and it starts loading the new rom BUT it's stuck at around 30/35%. I have tried with the official ROM 4.0.3 and 2.3.6 it does the same, any idea anyone? I need my phone back :-( please

0

Share this post


Link to post
Share on other sites

Install the "middle package" update then retry

0

Share this post


Link to post
Share on other sites

Still not working, I am about to take it back to Vodafone :-( if I don't find a solution quickly

0

Share this post


Link to post
Share on other sites

just run the clockwork stuff again and you will get it working again .

0

Share this post


Link to post
Share on other sites

Thanks Aport and wrtease, but I don't have CWM anymore as the last one that ran on my phone is the official 4.0.3 it must have deleted CWM I can't go to recovery mode anymore. I am going to try 4.0.4 and see what it does.

0

Share this post


Link to post
Share on other sites

can you force clockwork mod on.just get your mobile to the waitng for device and then pull usb out then hold volume down and plug back in it should work.

0

Share this post


Link to post
Share on other sites

I have tried this already, can't go into recovery but when I plug it in I can hear the USB sound on my PC, the bootloader can't boot on a non-UPDATE.APP file, is there any way we can convert the 4.0.4 files into an UPDATE.APP?

0

Share this post


Link to post
Share on other sites

what operating system do you have .well its the other way then you the middle downgrade dload folder .then delete it. then run the dload ics folder b926 .then see what happens .

0

Share this post


Link to post
Share on other sites

I have Windows 7. The middle downgraded did not work too :-( it gets stuck (I want to hit my head on a wall :-s) where can I get the dload for b926?

0

Share this post


Link to post
Share on other sites

Downloaded it and tried it, still the same gets stuck during the pink bar :-(

0

Share this post


Link to post
Share on other sites

Just checked the content of my dload folder and I have a log file called sd_update.log there is the content:

filename = /mmc1/dload/update.app

dload_sd_chk_file_data->f_read-if failed!

dload_sd_chk_file_data failed!

filename = /mmc1/dload/update.app

dload_sd_chk_file_data->f_read-if failed!

dload_sd_chk_file_data failed!

filename = /mmc1/dload/update.app

dload_sd_chk_file_data->f_read-if failed!

dload_sd_chk_file_data failed!

0

Share this post


Link to post
Share on other sites

Now trying with the official rom 4.0.3 and I get in that log:

filename = /mmc1/dload/update.app

call RCV_MODULE_END_EVENT failed,module = CRC

CMD=0xf,moduleaddr = 0xe8000000, len_tmp=0x1b

I can't find anything in goodle about these entries.

0

Share this post


Link to post
Share on other sites

Could you try it with another SD card? It looks like that your SD card is kinda faulty (CRC errors or read failed => faulty SD card)

0

Share this post


Link to post
Share on other sites

I have tried with 2 different one :-( still the same

0

Share this post


Link to post
Share on other sites

did you ever find a solution to your problem ? I'm having a similar issue, will give the middle package a try and see what happens

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.