• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[APP] FusionX Multiboot [MULTIBOOT]

34 posts in this topic

Posted

That's weird. I've checked mokee and it worked for me. Could you try another rom and see if it works.

0

Share this post


Link to post
Share on other sites

Posted

hi!..

in first place, Congratulations for this amazing work!..

got it to work smoothly with mokee on my blade, but i had t flash it twice as you suggested!

Thanks for the great work!

0

Share this post


Link to post
Share on other sites

Posted

Just tried it but I am not sure if I got it right.

I have Paranoid JB as my main ROM and I wanted to dualboot with Mokee for the ocasional radio listening. The app creates Mokee rom in loop rom folder and everything is ok. But after that I am not sure how to proceed. I have rebooted to recovery and there I don't know what to flash. I have option to flash the zip in Boot-images folder or the zip in Loop-roms folder. I tried to flash the loop roms zip and after succesfull install message, the phone stuck with the android logo for 30 minutes, had to pull battery and restore backup . Tried to flash the boot image zip and the same happened. I have created the mokee with 250 mb system and 1 gb data.

Please advise on the required steps after FusionXMultiboot does its magic.

0

Share this post


Link to post
Share on other sites

Posted (edited)

ok, tried it on ROM:

-SKatie by Ceco - Android 2.3.5 version 2.4

-[androidarmv6] [4.2] ColdFusionX 3 [CM10.1] [updated - 06/01]

tried it with ROM:

-[androidarmv6] [4.2] ColdFusionX 3 [CM10.1] [updated - 06/01]

-[ROM][ZTE Skate] MoKeeOS v1.10 - CM7.2 - Android 2.3.7 (06/08/2012)

tried it with APP:

FusionX Multiboot V2.5

FusionX Multiboot V4.1

FusionX Multiboot V4.2

and no luck.

remark:

folder

-/sdcard/multiboot/boot-images => 0.8-2MB for 1 file

-/sdcard/multiboot/loop-roms => 85MB for 1 file

do not always show *.zip file or is corrupt in recovery.

in *.zip file boot.img (sometimes) missing!

ZTE Skate: 150MB system, 35MB cache and 255MB data

Multiboot: 300MB system, ??MB cache and 500MB data

on which ROM worked this?

ad 201301152250 logcat error?

D/FusionXMultiboot( 1993): zip error: Nothing to do! (try: zip -r -q /mnt/sdcard/multiboot/loop-roms/ZTESkate_ROM_MoKeeOS_v1.10_20120806-loopinstall.zip . -i *)

D/FusionXMultiboot( 1993): zip error: Nothing to do! (try: zip -r -q /mnt/sdcard/multiboot/loop-roms/ZTESkate_ROM_MoKeeOS_v1.10_20120806-loopinstall.zip . -i *)

D/FusionXMultiboot( 1993): cp /mnt/sdcard/tempMultiboot/ZTESkate_ROM_MoKeeOS_v1.10_20120806/boot.img /mnt/sdcard/tempMultiboot/tempFlashBoot/boot.img

D/FusionXMultiboot( 1993): cp /mnt/sdcard/tempMultiboot/ZTESkate_ROM_MoKeeOS_v1.10_20120806/boot.img /mnt/sdcard/tempMultiboot/tempFlashBoot/boot.img

ad 201301162317 logcat File

ad 201301202130 info of SKatie by Ceco - Android 2.3.5 version 2.4

BusyBox.apk is potential causing issues.

will do a fresh install of [ROM][ZTE Skate] MoKeeOS v1.10 - CM7.2 - Android 2.3.7 (06/08/2012) as Host.

multiboot.txt

Edited by SimonDeBacker
0

Share this post


Link to post
Share on other sites

Posted

CommonMultibootBase.java

line 73


protected void editInitRc() {

if (findTextInFile(romExtractionDir + "system/build.prop",

"ro.build.version.release=4.1"))

externalDir = "/storage/sdcard0";

else

[ 01-16 22:55:57.980 2780:0xadc D/su ]10161 com.fusionx.tilal6991.multiboot executing 0 /system/bin/sh using shell /system/bin/sh : sh

[ 01-16 22:55:57.980 2780:0xadc D/su ]10161 com.fusionx.tilal6991.multiboot executing 0 /system/bin/sh using shell /system/bin/sh : sh

[ 01-16 22:55:58.010 2500:0xa10 W/System.err ]java.io.FileNotFoundException: /mnt/sdcard/tempMultiboot/ZTESkate_ROM_MoKeeOS_v1.10_20120806/system/build.prop (No such file or directory)

[ 01-16 22:55:58.010 2500:0xa10 W/System.err ]java.io.FileNotFoundException: /mnt/sdcard/tempMultiboot/ZTESkate_ROM_MoKeeOS_v1.10_20120806/system/build.prop (No such file or directory)


romExtractionDir="/mnt/sdcard/tempMultiboot/ZTESkate_ROM_MoKeeOS_v1.10_20120806/"; // aka is ok=> build error at start?

problem starts soner CreateRom.java line 148

private void remakeBootImage() {

publishProgress("Moving boot image");

moveBootImage();


publishProgress("Getting boot.img parameters");

getBootImageParameters();


publishProgress("Extracting kernel");

extractKernel();


publishProgress("Extracting ramdisk");

extractRamdisk();


publishProgress("Editing init.rc");

editInitRc(); // => fault detect

CreateOther.java line 20

protected Void doInBackground(final Bundle... params) {

bundle = params[0];

inputFile = Environment.getExternalStorageDirectory()

.getAbsolutePath() + "/" + bundle.getString("filename");

romName = bundle.getString("filename").replace(".zip", "");

romExtractionDir = tempSdCardDir + romName + "/";


preClean();


publishProgress("Making directories");

makeDirectories();


publishProgress("Getting data from wizard");

systemImageName = bundle.getString("systemimagename");


extractRom();

publishProgress("Editing updater script");

fixUpdaterScript();

packUpAndFinish();

cleanup();

return null;

}

[ 01-16 22:55:56.440 2755:0xac3 D/su ]10161 com.fusionx.tilal6991.multiboot executing 0 /system/bin/sh using shell /system/bin/sh : sh

[ 01-16 22:55:56.440 2755:0xac3 D/su ]10161 com.fusionx.tilal6991.multiboot executing 0 /system/bin/sh using shell /system/bin/sh : sh

[ 01-16 22:55:56.580 176:0xc8 W/ProcessStats ]Skipping unknown process pid 2755

[ 01-16 22:55:56.660 2500:0xa10 D/FusionXMultiboot ]/data/data/com.fusionx.tilal6991.multiboot/files/busybox unzip -q /mnt/sdcard/ZTESkate_ROM_MoKeeOS_v1.10_20120806.zip -d /mnt/sdcard/tempMultiboot/ZTESkate_ROM_MoKeeOS_v1.10_20120806/

[ 01-16 22:55:56.660 2500:0xa10 D/FusionXMultiboot ]/data/data/com.fusionx.tilal6991.multiboot/files/busybox unzip -q /mnt/sdcard/ZTESkate_ROM_MoKeeOS_v1.10_20120806.zip -d /mnt/sdcard/tempMultiboot/ZTESkate_ROM_MoKeeOS_v1.10_20120806/

busybox unzip fault?

0

Share this post


Link to post
Share on other sites

Posted

tilal6991 mmm this app is working? or doesn,t work? mmm I'm interested in a dual-boot for our phone. ^_^ TY

0

Share this post


Link to post
Share on other sites

Posted

Guys i want to make dual boot for thia phone but dont know how and anything about it .is thia dual boot work full.

0

Share this post


Link to post
Share on other sites

Posted

Hi, sorry to bother you, but i was hoping you can send me, if you still have it, an earlier version of your multibbot app, the version 4.1 dosen't work on my blade, but the 2.1 or something, worked very well, unfortunatly lost the apk.

would apreciate it!

thanks in advance.

0

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, sorry to bother you, but i was hoping you can send me, if you still have it, an earlier version of your multibbot app, the version 4.1 dosen't work on my blade, but the 2.1 or something, worked very well, unfortunatly lost the apk.

would apreciate it!

thanks in advance.

github.com


https://github.com/tilal6991/FusionXMultiboot


https://github.com/tilal6991/FusionXMultiboot/FusionXMultiboot-v2.5.0.apk/qr_code

edit : bron Google "FusionXMultiboot V2.1"

Edited by SimonDeBacker
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.