Sign in to follow this  
xgt001

Xolo not going into Deep Sleep mode

Recommended Posts

BlueMoonRising    162

Why would the gallery be using an audio_in process? Also, when I listened to music earlier on my OSD a new process appeared as Audio_out under com.intel.android.gallery.media.social gallery and it ran for 10s more. Its probably irrelavent I'm just wondering why a gallery app would be using audio in/out.

I'm using Quickpics but Social Gallery can play Video files can it not? That would explain the audio link.

Although I believe it's fixed now I came across this from within betterbatterystats regarding a bug in Chrome posted back in July :-

http://forum.xda-developers.com/showthread.php?p=28676218

"I found that using Chrome for Android would, at times, drain my battery in the background substantially, to the point where it would be the first or second highest "reason" listed for battery drain, even when I hadn't opened the app all day.

Thanks to Badass Battery Monitor, I found that Chrome was using the Gyroscope in the background. This doesn't make any sense, so I assume it's a bug.

Here are the steps I used to resolve it:

1. Open up Chrome

2. Go to Settings

3. Select "Developer tools"

4. Uncheck "Enable Tilt Scrolling"

5. Reboot the phone"

So battery draining reasons might not be soo simple as it first appears.

Share this post


Link to post
Share on other sites
BlueMoonRising    162

Which stat should we be concentrating on within betterbatterystats for wakelocks? Count, Wake Count or Expire Count? I'm presuming Wake Count.

Share this post


Link to post
Share on other sites
Gibson.1    1

I'm using Quickpics but Social Gallery can play Video files can it not? That would explain the audio link.

Yeah but it was under my pillow for an hour or two when it was using audio_in, I would presume its just a bug, I'll disable and install stock ICS gallery and let everyone know what battery is like today.

Share this post


Link to post
Share on other sites
Simon O    396

I did it the hard way be deleting social gallery from the /system folder (which needs root & unsecure adb) but disabling social gallery from the Settings > Apps control panel then installing GalleryICS will work just as well.

Share this post


Link to post
Share on other sites
Gibson.1    1

I did it the hard way be deleting social gallery from the /system folder (which needs root & unsecure adb) but disabling social gallery from the Settings > Apps control panel then installing GalleryICS will work just as well.

BetterBatteryStats is still showing *overflow* and audio_out under com.intel.android.gallery.media.Social Gallery

despite having force stopped then disabled Social Gallery. Why would it still have anything happening? I just find it slightly strange that for a gallery app its using audio in/out while I'm not using my phone and after disabling it still has processes going on.

Share this post


Link to post
Share on other sites
Gibson.1    1

Did you reboot the phone after disabling social gallery?

Ahh, it appears I've made a newbie error lol. I'll reboot and keep an eye out to see if it goes away then. I'd imagine it will though.

Edit: just rebooted and *overflow* is at the top of the wakelock list since boot.

Edited by Gibson.1

Share this post


Link to post
Share on other sites
BlueMoonRising    162

BetterBatteryStats is still showing *overflow* and audio_out under com.intel.android.gallery.media.Social Gallery

despite having force stopped then disabled Social Gallery. Why would it still have anything happening? I just find it slightly strange that for a gallery app its using audio in/out while I'm not using my phone and after disabling it still has processes going on.

OK, I am a newbie and obviously missing something obvious to you guys. I've got the same entries after rebooting yesterday despite disabling the app, why does rebooting put them back in BetterBatteryStats list?

Share this post


Link to post
Share on other sites
Gibson.1    1

OK, I am a newbie and obviously missing something obvious to you guys. I've got the same entries after rebooting yesterday despite disabling the app, why does rebooting put them back in BetterBatteryStats list?

I've rebooted twice and they're still there, first reboot just left two, second reboot and after a sleep I all of a sudden have all of the wakelocks back.

I think that the social gallery process actually deals with other parts of the system, specifically audio, and that's why its not going away. I'm pretty new to this stuff, maybe the android gallery process does deal with audio etc. And its well known, but I just assumed gallery meant pics/video.

Share this post


Link to post
Share on other sites
jikobutsu    312

Social Gallery is a strange one, I noticed that even after freezing it still shows in stats.....then I uninstalled it and now its history :)

Share this post


Link to post
Share on other sites
Simon O    396

Just delete it manually and replace it with GalleryICS or something. Job done. You'll need to set the system as read/write. Easiest way is to install the unsecure adb app from the market and enable this, then on your computer open up the command prompt/terminal and do

adb remount

adb shell rm /system/app/SocialGal*

and boom - it's gone :D

Share this post


Link to post
Share on other sites
xgt001    0

Hi

Confirmed that Social Gallery is a major battery sucker.... can anyone report any major difference in battery life after removing it? I have just disablied it yet, not completely removed it....

Share this post


Link to post
Share on other sites
xgt001    0

okay, thankfully looks like it is successfully going into deep sleep... I had to remove Viber and turn off data as I have wifi...Will test it again with Juice Defender on. Also removed some annoying games which "might" be waking up the device with notification ads, and as discussed at length in this thread, Social Gallery is a culprit too... will report once I get rid of it completely

lKtoQ.png

Share this post


Link to post
Share on other sites
codroid    12

I have tried everything to get this device to sleep but I always wake up with a loss of around half what I had before I went to sleep. I am familiar with android and have never had sleep problems, I have no auto sync, data/wifi is always off when screen off, CPU spy always shows the device spending 70% of the time at 600Mhz. Even from a clean install I have the problem and, that is with xolo apps removed and social gallery, I even remove YouTube as it depends on Google play services a well known wake app. I also have deep sleep battery doctor set to slumber so that there is always deep sleep with screen off, ontop of that I have greenify with all user apps selected for sleep at screen off.

Edited by codroid

Share this post


Link to post
Share on other sites
BlueMoonRising    162

I have tried everything to get this device to sleep but I always wake up with a loss of around half what I had before I went to sleep. I am familiar with android and have never had sleep problems, I have no auto sync, data/wifi is always off when screen off, CPU spy always shows the device spending 70% of the time at 600Mhz. Even from a clean install I have the problem and, that is with xolo apps removed and social gallery, I even remove YouTube as it depends on Google play services a well known wake app. I also have deep sleep battery doctor set to slumber so that there is always deep sleep with screen off, ontop of that I have greenify with all user apps selected for sleep at screen off.

And what does https://play.google....HRlcnlzdGF0cyJd say? Presuming you've got it installed(or similar).

I would start with removing deep sleep battery doctor perhaps and working your way through the apps to find the culprit.

Edit:- it may be that something that works on ARM just doesn't like the X86 architecture.

Edited by BlueMoonRising

Share this post


Link to post
Share on other sites
codroid    12

I have found what keeps the device awake at night but have no idea what it is, this matches with what CPU spy says, I reset CPU spy before bed and on wake it shows 6 hours at 600Mhz.

Anyone have an idea what the top two processes are causing kernel wake ?

post-1007375-0-68860600-1361958072_thumb

Share this post


Link to post
Share on other sites
BlueMoonRising    162

You have to check the Partial Wakelocks screen.

Edit :- A useful short piece if you're new to wakelocks is here - http://android.stackexchange.com/questions/34969/how-to-deal-with-orphaned-wakelocks

Edited by BlueMoonRising

Share this post


Link to post
Share on other sites
codroid    12

I did check partial wake and there was no problems so I looked elsewhere and found the problem is at kernel level. I done a little google search on suspend backoff and found some talk of chrome, which is not installed, I use stock ics browser which is far more reliable and faster than any browser. So no idea what the problem is but, I do love a good challenge so I will solve it :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.