• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

[MOD][ICS/JB] AC!D Audio Engine (Update 11/29) (TESTERS NEEDED!)

64 posts in this topic

Posted

I use v5 universal on 19nov2012 Cfx2 with Noozxoide addon. I had to replace libdownmix.so and libcyanogen-dsp.so from original cfx2 soundfx libs. Edit build.prop, wipe dalvik, delete DSP manager are needed as well. It's booting and I can hear effects, change EQ etc

Thanks for your report.

So we should edit the flashable zip a little to make it work?

What did you add in build.prop?

0

Share this post


Link to post
Share on other sites

Posted

Considering a build.prop is different for each version of each ROM, unless you offer a guide, you'll have to add various zips for each ROM users want it on

0

Share this post


Link to post
Share on other sites

Posted (edited)

Considering a build.prop is different for each version of each ROM, unless you offer a guide, you'll have to add various zips for each ROM users want it on

You probably know more about this than me, but I think you only add new lines at the end to make all the audio mods work.

The thread isn't finished, I will try the mod on my device now on different ROMs and I'll talk to Thunderdigital about the build.prop change.

Also my PC is ****** up, the cursor keeps moving when I'm typing.

EDIT: Tried the build.prop lines from Xperia 2011 thread, can't really see any different, will remove the mod I think, doesn't really change sound quality and it's too complicated for me to keep it up.

Edited by oscar-mark
0

Share this post


Link to post
Share on other sites

Posted

You probably know more about this than me, but I think you only add new lines at the end to make all the audio mods work.

The thread isn't finished, I will try the mod on my device now on different ROMs and I'll talk to Thunderdigital about the build.prop change.

Also my PC is ****** up, the cursor keeps moving when I'm typing.

EDIT: Tried the build.prop lines from Xperia 2011 thread, can't really see any different, will remove the mod I think, doesn't really change sound quality and it's too complicated for me to keep it up.

Here is my whole story. First of all I installed v5 universal. Step by step tutorial in first post here: http://forum.xda-dev...d.php?t=2002367

I had to paste build.prop lines like in §10.

But I needed eq, so flashed Noozxoide addon - than stayed in bootloop.

I replaced the two lib files in the zip (system/lib/soundfx) from original cfx2 as I wrote above.

( I don't remeber exacly that used or not, but once I changed lines in system/etc/audio_effects.conf that uuid match to cfx2's libs - tomorrow i can compare files on my working PC.)

Wiped my dalvik.

Flashed modified addon.

It boots and works now.

1

Share this post


Link to post
Share on other sites

Posted

That will be it for today! Night!

0

Share this post


Link to post
Share on other sites

Posted

Here is my whole story. First of all I installed v5 universal. Step by step tutorial in first post here: http://forum.xda-dev...d.php?t=2002367

I had to paste build.prop lines like in §10.

But I needed eq, so flashed Noozxoide addon - than stayed in bootloop.

I replaced the two lib files in the zip (system/lib/soundfx) from original cfx2 as I wrote above.

( I don't remeber exacly that used or not, but once I changed lines in system/etc/audio_effects.conf that uuid match to cfx2's libs - tomorrow i can compare files on my working PC.)

Wiped my dalvik.

Flashed modified addon.

It boots and works now.

The audio_effects.conf is unchanged. Same as in Noozxoide addon's zip.

1

Share this post


Link to post
Share on other sites

Posted (edited)

Does v5 work On my PA ICs ?

Edited by Omar korom
0

Share this post


Link to post
Share on other sites

Posted

I tested it.It doesn't work on c3c0's ICS PA(10/28build).It will break the rom.Don't know if it work or not on later biulds.

0

Share this post


Link to post
Share on other sites

Posted

I will only test this MOD when another update is released by ACID Team , it doesn't work properly on PA 1.6A - ICS

0

Share this post


Link to post
Share on other sites

Posted

any updates ?

0

Share this post


Link to post
Share on other sites

Posted

The phone doesn't boot after Addingthose lines , Tested on Pa 1.6 ( ICS ) and Coldfusion X2 (JB) :

###AC!D Sound Tweaks by R-ikfoot###

#Sony Xloud & Clearbass +

ro.semc.sound_effects_enabled=true

ro.semc.xloud.supported=true

persist.service.xloud.enable=1

ro.semc.enhance.supported=true

persist.service.enhance.enable=1

ro.semc.clearaudio.supported=true

persist.service.clearaudio.enable=1

ro.somc.dmnorm.supported=true

persist.service.dmnorm.enable=1

ro.sony.walkman.logger=1

ro.somc.clearphase.supported=true

persist.service.clearphase.enable=1

#Resampling

af.resampler.quality=255

persist.af.resampler.quality=255

#Beats Engine

htc.audio.swalt.enable=1

htc.audio.swalt.mingain=14512

0

Share this post


Link to post
Share on other sites

Posted (edited)

any updates ?

Check the original XDA thread or the Facebook group for more info.

EDIT: Looks like v6 is out for Xperia 2012 phones, universal version should come soon.

Edited by oscar-mark
0

Share this post


Link to post
Share on other sites

Posted

V5 is working on a clean cfx3(20130106)

The sound is just awsome!

And I would like to make one thing sure,It still have all the things that made by sony even I didn't have walker right?

0

Share this post


Link to post
Share on other sites

Posted

V5 is working on a clean cfx3(20130106)

The sound is just awsome!

And I would like to make one thing sure,It still have all the things that made by sony even I didn't have walker right?

Mostly I think, ClearBass is for Xperia only, but the rest are software only and have been ported.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.