MoDaCo is undergoing planned maintenance. Site functionality may be reduced - follow @modaco or @paulobrien on Twitter for updates.

  • Announcements

    • Reminder - MoDaCo position on illegal content

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such software
      Nintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)


      CUSTOM ROMS

      You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not be hosted directly in topic via the MoDaCo attachment system
      ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)
      ROMs must give full credit to the original author
      This decision has been taken in light of the huge amount of interest in this area of device customisation within the community, and member feedback! Please note that custom ROM discussion should be kept in specific device sub-areas, (e.g. Kaiser.MoDaCo.com for Kaiser based devices). ISSUES If you have any issues with this policy, please contact me directly via PM. P
    • Support MoDaCo by signing up to a MoDaCo Silver or Gold membership

      To sign up to an annual MoDaCo Silver subscription which will eliminate all ads from the site (as well as giving you access to the MoDaCo Online Kitchens for Android) for only £9.99 using PayPal, Credit or Debit Card, ensure you are logged in to the site, and then click the link below, which will take you directly to the subscription store! You can also sign up to an annual MoDaCo Gold subscription for £29.99, which adds the benefits listed below! PURCHASE A MODACO SUBSCRIPTION - FREE Titanium Backup Mobile for Android worth $5.99! - FREE 1 year PrivateInternetAccess.com worth $39.95! - FREE 1 year LastPass Premium worth $12! - FREE CalcConvert for Pocket PC from Binaryfish worth $17.95! - FREE Calendar Bar for Pocket PC from OmegaOne worth $9.99! - FREE CamerAware for Pocket PC and Smartphone from MoDaCo worth £19.99 / $30! - FREE Chronos for Pocket PC from ActiveKitten worth $14.95! - FREE CodeWallet Pro for Smartphone and Pocket PC from DeveloperOne worth up to $24.95! - FREE Concentrix for Pocket PC from eSoft Interactive worth $9.95! - FREE FlexMail for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE FTouchSL for Pocket PC from Vekoff s.r.o. worth 10 euro / $12.50! - FREE Jewel Challenge for Pocket PC from eSoft Interactive worth $9.95! - FREE John Cody's Alerts Pro for Smartphone from Omnisoft worth $14.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Dutch for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> French for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> German for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Italian for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Talking Dictionary 2008 English <-> Spanish for Pocket PC from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Dutch for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> French for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> German for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Russian for Smartphone from Lingvosoft worth $49.95! - FREE LingvoSoft Dictionary English <-> Turkish for Smartphone from Lingvosoft worth $49.95! - FREE Note2Self for Pocket PC and Smartphone from WebIS worth up to $19.90! - FREE Opera 8.60 for Pocket PC and Smartphone from Opera Software worth up to $48! - FREE Pocket Informant for Pocket PC and Smartphone from WebIS worth up to $59.90! - FREE Pocket Launcher for Pocket PC and Smartphone from Conduits worth $9.95! - FREE PTab for Pocket PC and Smartphone from z4soft worth up to $60! - FREE Resco Explorer for Pocket PC and Smartphone from Resco worth up to $49.90! - FREE Safemode for Pocket PC from monocube worth $12.95 - FREE SplashPhoto for Pocket PC and Smartphone from SplashData worth up to $59.90! - FREE Sprite Backup for Pocket PC and Smartphone from Sprite Software worth $29.95! - FREE Teksoft Glyphs UI for Pocket PC and Smartphone from Teksoft €9.95! - FREE Teksoft HeadsetRemote for Pocket PC and Smartphone from Teksoft €4.95! - FREE Traffic Jam for Pocket PC from eSoft Interactive worth $9.95! - FREE unlock (1 per year) from imei-check.co.uk - DISCOUNT of 10% at MoDaCo FairDeal - DISCOUNT of 10% at Semsons.com - FORUM - AD FREE SITE - FORUM - custom rank / title - FORUM - double competition entries - FORUM - double post attachment space - FORUM - no search flood control - FORUM - priority event registration - FORUM - triple PM space
    • Reminder: Selling items on the forum directly is not allowed

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspensions / ban.

[DEV][ROM] RacerMod 1.7 [19/04/2013] CyanogenMod 7.2 port with 2.6.35.7 kernel & CWM Recovery 5.0.2.8

389 posts in this topic

Posted · Report post

[quote name='noobzone' timestamp='1351461155' post='2044711']
you really have a phone witch accepts everything. I can't even boot with the one you posted there o.O ics v5 and copybit. same thing as before. I have all the roms in a folder in my pc but it was the RC2(no updates so rc2.0) from the first release [url="http://www.modaco.com/topic/353398-rom-miui-patchrom-rc2/"]http://www.modaco.co...i-patchrom-rc2/[/url] this one if I'm not mistaken.

could you upload an zipped backup of the rom + kernel just to see if that works? I really don't know what the hell is wrong. even tested gen 2 (just covering all the options) and still nothing. o.O
[/quote]

Wow... while zte has slight differences between same model phones this is ridiculous, uploading a zipped clockworkmod backup of equilyim's 0624 with .35.7 kernel, gonna take a while (slow connection in my country :( ). Could it be a different copybit you're using? the one I'm using is the same I posted with the kernels t3 and t4.

Thanks for mui link, I'll test that after have it downloaded
0

Share this post


Link to post
Share on other sites

Posted · Report post

this was my protocol
1)got the ICSv5 rom
2)got the kernel (gen1)
3)got the copybit from the same post
4)flashed rom and made 1st boot
5)adb'ed the copybit to /system/lib/hw/
6)flashed the kernel
7)didn't boot

slight variances? a different camera is a small variance. now this is something completely different o.O
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Built again with my device folder with slight modifications and boots fine too.
I used these files from GuyOverThere: prebuilt netd, vold and gralloc.mooncake.so

Only difference is that camera works now. I'm building again disabling options one by one to find what caused the bug.

EDIT: used some build.prop lines that were not present in mine too Edited by mikeioannina
1

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='noobzone' timestamp='1351462660' post='2044720']
this was my protocol
1)got the ICSv5 rom
2)got the kernel (gen1)
3)got the copybit from the same post
4)flashed rom and made 1st boot
5)adb'ed the copybit to /system/lib/hw/
6)flashed the kernel
7)didn't boot

slight variances? a different camera is a small variance. now this is something completely different o.O
[/quote]

Same protocol here, only point 7 change since it does boot and works. The variances as far as I know are very subtle, like two touchscreen from two racer P729 phones don't behave exactly the same, that's what I've read anyway but right now I'm as lost as you are.

If the mui rom works on mine then I can sell you my phone for like ... 700$ and then I can buy a galaxy s3! :D
0

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='GuyOverThere' timestamp='1351463430' post='2044724']
Same protocol here, only point 7 change since it does boot and works. The variances as far as I know are very subtle, like two touchscreen from two racer P729 phones don't behave exactly the same, that's what I've read anyway but right now I'm as lost as you are.

If the mui rom works on mine then I can sell you my phone for like ... 700$ and then I can buy a galaxy s3! :D
[/quote] it should work as the error is always the same. I got this program [url="https://play.google.com/store/apps/details?id=yly.android.app.droidinfo&feature=also_installed#?t=W251bGwsMSwxLDEwNCwieWx5LmFuZHJvaWQuYXBwLmRyb2lkaW5mbyJd"]https://play.google.com/store/apps/details?id=yly.android.app.droidinfo&feature=also_installed#?t=W251bGwsMSwxLDEwNCwieWx5LmFuZHJvaWQuYXBwLmRyb2lkaW5mbyJd[/url] to check my racer's details
I got an HTML full with every thing.
this:
[b]Configuration[/b]
[b][u]Font Scale[/u] : [/b][color=#000000][font='Times New Roman'][size=1]1.0[/size][/font][/color]
[b][u]Hard Keyboard Hidden[/u] : [/b][color=#000000][font='Times New Roman'][size=1]YES[/size][/font][/color]
[b][u]Keyboard[/u] : [/b][color=#000000][font='Times New Roman'][size=1]NOKEYS[/size][/font][/color]
[b][u]Keyboard Hidden[/u] : [/b][color=#000000][font='Times New Roman'][size=1]NO[/size][/font][/color]
[b][u]Locale[/u] : [/b][color=#000000][font='Times New Roman'][size=1]pt_PT[/size][/font][/color]
[b][u]MCC[/u] : [/b][color=#000000][font='Times New Roman'][size=1]268[/size][/font][/color]
[b][u]MNC[/u] : [/b][color=#000000][font='Times New Roman'][size=1]3[/size][/font][/color]
[b][u]Navigation[/u] : [/b][color=#000000][font='Times New Roman'][size=1]NONAV[/size][/font][/color]
[b][u]Navigation hidden[/u] : [/b][color=#000000][font='Times New Roman'][size=1]NO[/size][/font][/color]
[b][u]Orientation[/u] : [/b][color=#000000][font='Times New Roman'][size=1]PORTRAIT[/size][/font][/color]
[b][u]Screen Layout[/u] : [/b]
[color=#000000][font='Times New Roman'][size=1]LONG_NO[/size][/font][/color]
[color=#000000][font='Times New Roman'][size=1]SIZE_LARGE[/size][/font][/color]
[color=#000000][font='Times New Roman'][size=1]SIZE_NORMAL[/size][/font][/color]
[color=#000000][font='Times New Roman'][size=1]SIZE_SMALL[/size][/font][/color]
[b][u]Touchscreen[/u] : [/b][color=#000000][font='Times New Roman'][size=1]FINGER[/size][/font][/color]
[b][u]UI Mode[/u] : [/b]
[color=#000000][font='Times New Roman'][size=1]NIGHT_NO[/size][/font][/color]
[color=#000000][font='Times New Roman'][size=1]TYPE_NORMAL[/size][/font][/color]

[b]BuildInfos[/b]
[b][u]Android version[/u] : [/b][color=#000000][font='Times New Roman'][size=1]2.3.7[/size][/font][/color]
[b][u]Release Codename[/u] : [/b][color=#000000][font='Times New Roman'][size=1]REL[/size][/font][/color]
[b][u]API LEVEL[/u] : [/b][color=#000000][font='Times New Roman'][size=1]10[/size][/font][/color]
[b][u]CPU ABI[/u] : [/b][color=#000000][font='Times New Roman'][size=1]armeabi-v6l[/size][/font][/color]
[b][u]Manufacturer[/u] : [/b][color=#000000][font='Times New Roman'][size=1]ZTE[/size][/font][/color]
[b][u]Bootloader[/u] : [/b][color=#000000][font='Times New Roman'][size=1]unknown[/size][/font][/color]
[b][u]CPU ABI2[/u] : [/b][color=#000000][font='Times New Roman'][size=1]armeabi[/size][/font][/color]
[b][u]Hardware[/u] : [/b][color=#000000][font='Times New Roman'][size=1]mooncake[/size][/font][/color]
[b][u]Radio[/u] : [/b][color=#000000][font='Times New Roman'][size=1]unknown[/size][/font][/color]
[b][u]Board[/u] : [/b][color=#000000][font='Times New Roman'][size=1]mooncake[/size][/font][/color]
[b][u]Brand[/u] : [/b][color=#000000][font='Times New Roman'][size=1]zte[/size][/font][/color]
[b][u]Device[/u] : [/b][color=#000000][font='Times New Roman'][size=1]mooncake[/size][/font][/color]
[b][u]Display[/u] : [/b][color=#000000][font='Times New Roman'][size=1]GWK74[/size][/font][/color]
[b][u]Fingerprint[/u] : [/b][color=#000000][font='Times New Roman'][size=1]google/passion/passion:2.3.4/GRJ22/121341:user/release-keys[/size][/font][/color]
[b][u]Host[/u] : [/b][color=#000000][font='Times New Roman'][size=1]cyanogenmod[/size][/font][/color]
[b][u]ID[/u] : [/b][color=#000000][font='Times New Roman'][size=1]GRJ22[/size][/font][/color]
[b][u]Model[/u] : [/b][color=#000000][font='Times New Roman'][size=1]ZTE-RACER[/size][/font][/color]
[b][u]Product[/u] : [/b][color=#000000][font='Times New Roman'][size=1]cyanogen_mooncake[/size][/font][/color]
[b][u]Tags[/u] : [/b][color=#000000][font='Times New Roman'][size=1]test-keys[/size][/font][/color]
[b][u]Type[/u] : [/b][color=#000000][font='Times New Roman'][size=1]user[/size][/font][/color]
[b][u]User[/u] : [/b][color=#000000][font='Times New Roman'][size=1]otoha[/size][/font][/color]

[color=#000000][font='Times New Roman'][size=1]and this[/size][/font][/color]

[b][b]CPU[/b]
[b][u]Processor[/u][/b] ARMv6-compatible processor rev 5 (v6l)
[b][u]BogoMIPS[/u][/b] 599.65
[b][u]Features[/u][/b] swp half thumb fastmult vfp edsp java
[b][u]CPU implementer[/u][/b] 0x41
[b][u]CPU architecture[/u][/b] 6TEJ
[b][u]CPU variant[/u][/b] 0x1
[b][u]CPU part[/u][/b] 0xb36
[b][u]CPU revision[/u][/b] 5
[b][u]Hardware[/u][/b] mooncake ZTE handset
[b][u]Revision[/u][/b] 0000
[b][u]Serial[/u][/b] 0000000000000000
[b][u]Frequency range[/u]:[/b] 122.88 -> 806.4MHz
[b][u]Current Frequency[/u]:[/b] 604.8MHz[/b]
[b]are the only things I can think of messing the compatibility :/ if this kernel brings us one step closer to ICS then I'll be glad to help with everything I can. I come to the forum everyday so I'm always on the moment ;)[/b]
0

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='noobzone' timestamp='1351464734' post='2044732']
it should work as the error is always the same. I got this program [url="https://play.google.com/store/apps/details?id=yly.android.app.droidinfo&feature=also_installed#?t=W251bGwsMSwxLDEwNCwieWx5LmFuZHJvaWQuYXBwLmRyb2lkaW5mbyJd"]https://play.google....mRyb2lkaW5mbyJd[/url] to check my racer's details
[/quote]

What the crap???! it says is incompatible with my device... can't install it, perhaps mikeioannina can? someone?
0

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='noobzone' timestamp='1351464734' post='2044732']
are the only things I can think of messing the compatibility :/ if this kernel brings us one step closer to ICS then I'll be glad to help with everything I can. I come to the forum everyday so I'm always on the moment ;)
[/quote]

Well we have to get a fully working gb rom first and then maybe port ics/jb. It's difficult because a lot of things have changed from 2.3 to 4.0/4.1 and many modifications are required

[quote name='GuyOverThere' timestamp='1351465599' post='2044739']
What the crap???! it says is incompatible with my device... can't install it, perhaps mikeioannina can? someone?
[/quote]

It says incompatible with my device too :/
1

Share this post


Link to post
Share on other sites

Posted · Report post

Well, mui rom working in my phone, same as before update-35.7-t3.zip and copybit from blade:

[attachment=84059:2012.10.28-21.16.54.jpeg]

I... just don't know anymore...
0

Share this post


Link to post
Share on other sites

Posted · Report post

from my searching, somehow, I should be missing some libs. that's really odd since I did a fresh install every time o_O we have to go deeper... also the app not working. I kinda know what it is. my screen density is set to 95 instead of the default 120 LDPI. that makes the icons smaller thus I like it that way. the only problem is the market that gets that DPI and then doesn't allow me to download anything. so a cracked play store is needed. but I have it cracked to 120 DPI so I'm still WTH is going on here ._.
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

That app shows not compatible with even my racer. Probably noobzone tried some other version of it? I guess I'll try to download apk and install it through sd card.
https://play.google.com/store/apps/details?id=com.noser.droidinfo16&feature=also_installed
This version seem to be working. Edited by massacre^
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

[quote name='noobzone' timestamp='1351497109' post='2044808']
from my searching, somehow, I should be missing some libs. that's really odd since I did a fresh install every time o_O we have to go deeper... also the app not working. I kinda know what it is. my screen density is set to 95 instead of the default 120 LDPI. that makes the icons smaller thus I like it that way. the only problem is the market that gets that DPI and then doesn't allow me to download anything. so a cracked play store is needed. but I have it cracked to 120 DPI so I'm still WTH is going on here ._.
[/quote]

Missing libs... unlikely :-\ we're doing the same thing, full wipe -> flash rom -> first boot -> change copybit -> flash kernel -> done. Even the copybit could be skipped, granted with a flickering screen but it still boots all the way (in my phone at least, at think mikeioannina as well since I think he's building copybit from blade source).

The only libs that could be different is libril and some other I don't remember right now (libgc or something) but that's just in gen2 phones and yours is gen1 as mine, so I don't think is a libs thing but also don't know what is D:

If the rom works out of the box in your phone and if you don't change copybit (just flash the kernel) then we can say the kernel is the obvious cause, but what part of it? ... beats me, not enough info to know, could be anything, msm_ts driver, msm_ts_data or other structs, gpios, device registration on kernel subsystem, driver initialization, memory settings, some bad address for your particular model, i2c, pmem... god.....

[quote name='massacre^' timestamp='1351499170' post='2044815']
That app shows not compatible with even my racer. Probably noobzone tried some other version of it? I guess I'll try to download apk and install it through sd card.
[url="https://play.google.com/store/apps/details?id=com.noser.droidinfo16&feature=also_installed"]https://play.google....=also_installed[/url]
This version seem to be working.
[/quote]

Is it good? I mean, does it give lots of info to play with? :D

Edit;// right now testing Android system info from electricsheep (https://play.google.com/store/apps/details?id=com.electricsheep.asi&hl=en) seems good at the momment Edited by GuyOverThere
0

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='GuyOverThere' timestamp='1351517941' post='2044923']
Missing libs... unlikely :-\ we're doing the same thing, full wipe -> flash rom -> first boot -> change copybit -> flash kernel -> done. Even the copybit could be skipped, granted with a flickering screen but it still boots all the way (in my phone at least, at think mikeioannina as well since I think he's building copybit from blade source).

The only libs that could be different is libril and some other I don't remember right now (libgc or something) but that's just in gen2 phones and yours is gen1 as mine, so I don't think is a libs thing but also don't know what is D:

If the rom works out of the box in your phone and if you don't change copybit (just flash the kernel) then we can say the kernel is the obvious cause, but what part of it? ... beats me, not enough info to know, could be anything, msm_ts driver, msm_ts_data or other structs, gpios, device registration on kernel subsystem, driver initialization, memory settings, some bad address for your particular model, i2c, pmem... god.....



Is it good? I mean, does it give lots of info to play with? :D
[/quote]

The problems start right after kernel flash if that's what you mean. the worst part is that it is the first time anyone has encountered this specific error :o now detecting what causes the error is like finding a needle in a haystack :/
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Well, android system info gives the same info (same format even) of what you posted, only difference is that I have Screen Layout: LONG_NO and SIZE_SMALL only, but that's a rom config, nothing that affects the kernel.

Does your phone works the same with vamshi and deadlink kernels? I mean, is something that change in behaviour with any one of those?, although .32 and .35 have some important differences it might tell something about your phone, also, where is your model from? do you happen to know the signature of the stock rom that came with your device? (like 3UK_P726GV1.0.0B05 , ECLR_P726CUV1.0.0B06, etc...)

mikeioannina is going to update the first post of this thread to add his compiled rom and kernels later I think, perhaps there's better luck there :| Edited by GuyOverThere
0

Share this post


Link to post
Share on other sites

Posted · Report post

[color=#4E565E][font=Verdana, Tahoma, Arial, 'Trebuchet MS', sans-serif, Georgia, Courier, 'Times New Roman', serif][b]TMN (Portugal): TMN Soft Stone[/b][/font][/color]
[b]ECLR_P726NV1.0.0B09[/b]

[color=#000000]ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]version[/color][color=#666600].[/color][color=#000000]release[/color][color=#666600]=[/color][color=#006666]2.1[/color][color=#666600]-[/color][color=#000000]update1
ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]date[/color][color=#666600]=[/color][color=#660066]Thu[/color][color=#000000] [/color][color=#660066]Jun[/color][color=#000000] [/color][color=#006666]3[/color][color=#000000] [/color][color=#006666]19[/color][color=#666600]:[/color][color=#006666]45[/color][color=#666600]:[/color][color=#006666]34[/color][color=#000000] CST [/color][color=#006666]2010[/color]
[color=#000000]ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]sw_internal_version[/color][color=#666600]=[/color][color=#000000]ECLR_P726NV1[/color][color=#666600].[/color][color=#006666]0.0B09[/color]
[color=#000000]ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]display[/color][color=#666600].[/color][color=#000000]id[/color][color=#666600]=[/color][color=#000000]ECLR_P726NV1[/color][color=#666600].[/color][color=#006666]0.0B03[/color]
[color=#000000]ro[/color][color=#666600].[/color][color=#000000]com[/color][color=#666600].[/color][color=#000000]google[/color][color=#666600].[/color][color=#000000]gmsversion[/color][color=#666600]=[/color][color=#006666]2.1[/color][color=#000000]_r4
[/color]

[color=#000000]That's the original rom of my zte[/color]
[color=#000000]and yes it works the sam[size=4]e w[/size][/color][size=4]ith[font=Verdana, Tahoma, Arial, 'Trebuchet MS', sans-serif, Georgia, Courier, 'Times New Roman', serif] vamshi and deadlink kernels but vamishi was the one with the best calibration so I stick with it to all roms (even if I install an older one I update the kernel)[/font][/size]
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

[quote name='noobzone' timestamp='1351520176' post='2044931']
[color=#4E565E][font=Verdana, Tahoma, Arial, 'Trebuchet MS', sans-serif, Georgia, Courier, 'Times New Roman', serif][b]TMN (Portugal): TMN Soft Stone[/b][/font][/color]
[b]ECLR_P726NV1.0.0B09[/b]

[color=#000000]ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]version[/color][color=#666600].[/color][color=#000000]release[/color][color=#666600]=[/color][color=#006666]2.1[/color][color=#666600]-[/color][color=#000000]update1
ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]date[/color][color=#666600]=[/color][color=#660066]Thu[/color][color=#000000] [/color][color=#660066]Jun[/color][color=#000000] [/color][color=#006666]3[/color][color=#000000] [/color][color=#006666]19[/color][color=#666600]:[/color][color=#006666]45[/color][color=#666600]:[/color][color=#006666]34[/color][color=#000000] CST [/color][color=#006666]2010[/color]
[color=#000000]ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]sw_internal_version[/color][color=#666600]=[/color][color=#000000]ECLR_P726NV1[/color][color=#666600].[/color][color=#006666]0.0B09[/color]
[color=#000000]ro[/color][color=#666600].[/color][color=#000000]build[/color][color=#666600].[/color][color=#000000]display[/color][color=#666600].[/color][color=#000000]id[/color][color=#666600]=[/color][color=#000000]ECLR_P726NV1[/color][color=#666600].[/color][color=#006666]0.0B03[/color]
[color=#000000]ro[/color][color=#666600].[/color][color=#000000]com[/color][color=#666600].[/color][color=#000000]google[/color][color=#666600].[/color][color=#000000]gmsversion[/color][color=#666600]=[/color][color=#006666]2.1[/color][color=#000000]_r4[/color]


[color=#000000]That's the original rom of my zte[/color]
[color=#000000]and yes it works the same w[/color]ith[font=Verdana, Tahoma, Arial, 'Trebuchet MS', sans-serif, Georgia, Courier, 'Times New Roman', serif] vamshi and deadlink kernels but vamishi was the one with the best calibration so I stick with it to all roms (even if I install an older one I update the kernel)[/font]
[/quote]

Good, then tonight I'm going to check a diff between deadlink's and .35 kernel, and since your device is expecting something from fb area I'll concentrate on that and see if I can pinpoint what's happening, why would you need something I don't is beyond me but it's the only starting point I have right now =(

Edit:// Checked the configs, one thing that might be responsable is the lack of samsung qvga fb, deadlink has it, vamshi I'm not sure (never got the config of his #68 kernel), so by default, known .32 sources had 3 lcd framebuffers: lead qvga, himax qvga and samsung qvga, himax is the one that Racer "needs" as in it seems to be the principal chip support, lead qvga has to be compiled because it's a dependency of himax (setting himax without setting lead will stop himax compilation) and samsung ... no idea =/

I'm at work now but I'm gonna try to compile a gen1 kernel with only the samsung fb added to see if it works with your phone. Edited by GuyOverThere
0

Share this post


Link to post
Share on other sites

Posted · Report post

I found out that I still need the prebuilt gralloc.mooncake.so, when I built it from sources the phone was stuck in the ZTE logo. But using prebuilt gralloc & debug.sf.hw=0 in build.prop, we don't have hardware acceleration so rotation animation & screen on/off animations don't work...
1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Found this on xda-developers:
[code]
debug.sf.hw=1
debug.composition.type=gpu
windowsmgr.max_events_per_sec=150
video.accelerate.hw=1
debug.performance.tuning=1
[/code]

Gonna see if I can try it in my phone and report

Edit://

Well this is rich... it seems to work, boot ok, screen working ok... and I haven't changed copybit yet (unless I've forgotten to revert and I'm still using copybit from blade lol) o: !!!!! mikeioannina, can you test?

Edit2: //

Forgot to add, I used rom toolbox which reported video.accelerate.hw=1 already, couldn't add windowsmgr.max_events_per_sec, after setting the property name the activity grew beyond my LCD size and the "add" button wasn't touchable, by default is [b]35[/b], 150 was used by some atrix phone, so I was thinking more about using a number between 45 and 60 just to test. Is possible that debug.* are just for testing and not needed for hw accel and animations to work (with the exception of debug.sf.hw=0 that needs to exist in build.prop to avoid screen bugs) Edited by GuyOverThere
0

Share this post


Link to post
Share on other sites

Posted · Report post

well I'll be waiting then. gonna study some mathish thing (test tomorow and study=0 x) just as usual xD )
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

[quote name='noobzone' timestamp='1351528306' post='2044978']
well I'll be waiting then. gonna study some mathish thing (test tomorow and study=0 x) just as usual xD )
[/quote]

try this (same as before, change copybit and flash): [url="http://www.mediafire.com/?5dlsq2d0bkxt9ww"]http://www.mediafire...5dlsq2d0bkxt9ww[/url]

The only change I made was to add samsung qvga, let's hope this is what your phone is needing :|

Be warned, I had to ssh'd the only linux server we have, had to use ndk, made last minute install of several i686 libs, ndk's gcc was complaining during mooncake_keypad compilation about array index boundaries... so yeah, this kernel might be more problematic xD Edited by GuyOverThere
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

[quote name='GuyOverThere' timestamp='1351531963' post='2045033']
try this (same as before, change copybit and flash): [url="http://www.mediafire.com/?5dlsq2d0bkxt9ww"]http://www.mediafire...5dlsq2d0bkxt9ww[/url]

The only change I made was to add samsung qvga, let's hope this is what your phone is needing :|

Be warned, I had to ssh'd the only linux server we have, had to use ndk, made last minute install of several i686 libs, ndk's gcc was complaining during mooncake_keypad compilation about array index boundaries... so yeah, this kernel might be more problematic xD
[/quote]
Well well well let's see if it boots. if it does hurray :D then we'll trouble shoot the rest. if it does not... D:

EDIT: Clean installed cm-7 rom. ADB'ed the copybit. SUCCESS. rom booted and rebooted and its A ok even received a call right after so I can tell you that the call quality is good. hardware buttons not working though. not sure if they had not loaded yet or if kernel problem but still IT BOOTED :D
1 step closer :D
EDIT2: forget the hw buttons part. only send button not working. all others operational. sensors "offline" and calibration is a little bit ghosty. oh well still happy it booted anyway :D Edited by noobzone
0

Share this post


Link to post
Share on other sites

Posted · Report post

I'm preparing to upload the first nightly & kernel & recovery for Racer... stay tuned and check the first post
1

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='noobzone' timestamp='1351533965' post='2045059']
Well well well let's see if it boots. if it does hurray :D then we'll trouble shoot the rest. if it does not... D:

EDIT: Clean installed cm-7 rom. ADB'ed the copybit. SUCCESS. rom booted and rebooted and its A ok even received a call right after so I can tell you that the call quality is good. hardware buttons not working though. not sure if they had not loaded yet or if kernel problem but still IT BOOTED :D
1 step closer :D
[/quote]

As I said, ndk gcc complained about mooncake_keypad driver compilation so I had to cheat for it to be compiled. Buttons not working it is something I expected in this case, now if I get home, re-compile there with qvga samsung and still buttons aren't working then I'll be worried (there's no need to cheat keypad driver with my development box). Since mikeioannina is going to upload soon, let's hope he still had samsung qvga enabled in his defconfig :P

Why zte...why.... why require samsung code for your devices...why!!!? :'(
0

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='mikeioannina' timestamp='1351534853' post='2045071']
I'm preparing to upload the first nightly & kernel & recovery for Racer... stay tuned and check the first post
[/quote]

Were you able to test the build.prop thing?
0

Share this post


Link to post
Share on other sites

Posted · Report post

[quote name='GuyOverThere' timestamp='1351535417' post='2045077']
Since mikeioannina is going to upload soon, let's hope he still had samsung qvga enabled in his defconfig :P
[/quote]
I think I always had it enabled...

I need some help, I compiled the rom for gen2, is it possible to use it on gen1 by changing some files only? I want to avoid rebuilding the whole source again :/

[quote name='GuyOverThere' timestamp='1351535440' post='2045078']
Were you able to test the build.prop thing?
[/quote]
Didn't test that yet
1

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

[quote name='mikeioannina' timestamp='1351535789' post='2045082']
I think I always had it enabled...

I need some help, I compiled the rom for gen2, is it possible to use it on gen1 by changing some files only? I want to avoid rebuilding the whole source again :/
[/quote]

The rom doesn't care about the gen, during cm building you can had either gen1 or gen2 address in boardconfig.mk (or whatever that's put) but that only affects kernel installation, thus, if you built with gen2 addresses, gen1 people will only need a gen1 kernel and done, the rom will still work as intended

Edit://

Crap, forgot the libs xD libcm.so and libril-qc-1.so need to be changed, sending to you, sorry, work affects my mind Edited by GuyOverThere
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.