Sign in to follow this  
Followers 0
fieldmar

proximity sensor issue

14 posts in this topic

Hi,

I have had a g300 for a couple of months or so now and have been very happy with it, it's currently running the 936 NZ rom, and was unlocked via a code purchased on ebay. The problem is that it seems to have developed the proximity sensor issue that a few others have also reported, ie the phone blanks it's screen when close to your face, but fails to turn back on when removed. I've installed an app called 'proximity sensor finder' which show it reads 9cm when away from face, drops to 0 when moved closer but fails to reset to 9 when moved away, squeezing the top right hand corner of the phone front to back cause the sensor to trigger and read 9 cm again. So as I see it this is a hardware issue which would need a return to hauwei to fix (I bought it in a Tesco store). By unlocking via ebay have I blown my guarantee? If not, do I need to reflash a different firmware, i've read the NZ rom is md5 identical to the recently released UK OTA update so can i just leave the NZ rom on there?

Any suggestions gratefully received.

0

Share this post


Link to post
Share on other sites

I would flash the u.k vodafone version first and leave it unrooted e.t.c . Then take it back , others have successfully done this with mic problems e.t.c and got a new phone or there's repaired.

0

Share this post


Link to post
Share on other sites

Ok, so if i want to flash the UK version, where can i get an update.app from? At the moment if I try an online update it tells me I'm already on the latest version. I've looked though the forum but can't see any links to this versions update.app

Edited by fieldmar
0

Share this post


Link to post
Share on other sites

I have the proximity problem as well, and I would love it if someone would post the international gb version for the g300 it doesn't mater which b8xx it is just as it's a stock international version so I can take it to a service center.

Btw, I'm on Infusion now so I'd have to revert back to gb, and if someone could link me a guide as well that would be great.

Here's a temporary fix for the call screen going black: settings ----> acessibility----> "Power button ends call"

Edited by MrDjibrilo
0

Share this post


Link to post
Share on other sites

Hello,

i had the same problem with screen gong black after making a call. I found out, what was causing this issue. there was dust inside covering the small hole. i removed the dust and everything is now working fine. I think dust in the inside is a general issue.

moerph

1

Share this post


Link to post
Share on other sites
Ok, so if i want to flash the UK version, where can i get an update.app from? At the moment if I try an online update it tells me I'm already on the latest version. I've looked though the forum but can't see any links to this versions update.app

You can just go to the official U.K Huawei site and download it from there, and force the update by powering on with volume -/+ , thats if they haven't pulled it ?.

I don't use the NZ version but if it is identical you would probably get away with it ,depending on network and apn settings on the phone ,

If its the same in the U.K and N.Z for vodafone then you should be o.k.

Check the post about crap coverage of the sensor first. It might be that easy.

0

Share this post


Link to post
Share on other sites

Hello,

i had the same problem with screen gong black after making a call. I found out, what was causing this issue. there was dust inside covering the small hole. i removed the dust and everything is now working fine. I think dust in the inside is a general issue.

moerph

Did you have to take the whole phone apart to remove the dust?

0

Share this post


Link to post
Share on other sites

Hello,

i had the same problem with screen gong black after making a call. I found out, what was causing this issue. there was dust inside covering the small hole. i removed the dust and everything is now working fine. I think dust in the inside is a general issue.

moerph

Hi guys, a couple days ago my G300 also started suffering from the dodgy proximity sensor. I tried this after reading the above post, and it seems to work (for now anyway).

I first removed the back cover, battery, sim card and memory card. Then with a vacuum cleaner, I tried sucking out dust from around the front speaker grille, and around any holes that could introduce dust - like the headphone socket, and all over the exposed back of the phone. After, I tried making calls to my landline, and the proximity sensor is working again!

This is a good quick fix, and seems to support moerph's theory of dust blocking the sensor being the cause of the problem. It's definitely not a permanent solution; dust will eventually work its way back in, but if you don't want to risk disassembling your phone (like me), then give it a go.

0

Share this post


Link to post
Share on other sites

Resolved for me - I installed Daz's CM10 and it now works perfectly (it didn't on any other ROM)

0

Share this post


Link to post
Share on other sites

I was on B944 before going to CM9, then a OTA update to CM10

Edit - After re-flashing CM10 via CWM and performing all the wipes it has gone back to the black screen issue :angry2:

Edited by nsmacd1
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.